Winzige Schriftarten unter Suse 10.1

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Thorin, 02.06.2006.

  1. #1 Thorin, 02.06.2006
    Zuletzt bearbeitet: 02.06.2006
    Thorin

    Thorin Grünschnabel

    Dabei seit:
    02.06.2006
    Beiträge:
    9
    Zustimmungen:
    0
    Hallo,

    habe über die Suche nichts Adäquates gefunden, daher ein neuer Post:
    Habe folgendes Problem: nach Einbinden des Nvidia-Treibers werden sämtliche Schriften in Schriftgröße 3 oder sowas angezeigt - also absolut nicht mehr lesbar. Auf Runlevel 3 ist alles in Ordnung, im Terminal-Fenster (bash, xterm) auch.

    Habe schon ein bißchen gewühlt und gegoogelt und das ganze mal im Textmodus versucht. Als Root eingeloggt, die xorg.conf aufgerufen, Schrift steht bei 35x27 DPI, ist also völlig verwurstet. Nun habe ich leider keine Ahnung, wie ich das im Textmodus editieren kann (bin ein ziemlicher n00b auf Linux). Also flugs "startx" und das System gibt mir den Gnome-Desktop, was eigentlich gar nicht gewünscht war. Da sind nun aber sämtliche Schriftarten so, wie sie sein sollen. Ob das beim direkten Switch auf Runlevel 5 auch der Fall ist, habe ich nicht überprüft - also, ob Gnome grundsätzlich gescheite Schriften anzeigt.

    Wie oder wo editiere ich nun die Schriftgröße in xorg.conf? Die Bildschirmverhältnisse stimmen soweit, also ausgemessener Bildschirm stimmt mit den angegebenen Zahlen überein. Nur die Schriftgröße ist kaputt.

    Kann mir da wer einen Tipp geben?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Ich würde im Runlevel 3 nochmals sax2 durchlaufen lassen ... (nachdem du die Nvidia treiber installierst hast) ... dann sollte es doch klappen ;)
     
  4. #3 Thorin, 02.06.2006
    Zuletzt bearbeitet: 02.06.2006
    Thorin

    Thorin Grünschnabel

    Dabei seit:
    02.06.2006
    Beiträge:
    9
    Zustimmungen:
    0
    Habe ich bereits mehrfach getan - also nach Anweisung: sax2 -m 0=nvidia
    Unter Runlevel 3 hat er allerdings nichts gemacht - er wollte irgendwie einen XServer. Also habe ich das Ganze unter XServer im Terminalfenster nochmal (mehrfach) ausgeführt. Er hat jedes Mal was getan, aber getan hat sich leider nix. ;)

    Btw, ich bin ja lernwillig und die Grundlagen von Linux werden sich nicht so wahnsinnig schnell verändern. Weiß jemand ein gutes downloadbares Grundlagenkompendium? Am Bildschirm lesen macht nicht so viel Spaß.
     
  5. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
  6. #5 Thorin, 02.06.2006
    Zuletzt bearbeitet: 02.06.2006
    Thorin

    Thorin Grünschnabel

    Dabei seit:
    02.06.2006
    Beiträge:
    9
    Zustimmungen:
    0
    Der sagt: 38x24 dots per inch.

    Zur Info: habe Auflösung 1280x1024 eingestellt.

    Der Nvidia-Thread sagt da was von 85x86 dots per inch, die eingestellt sein müssten. Wie stelle ich das jetzt um?
     
  7. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
  8. Thorin

    Thorin Grünschnabel

    Dabei seit:
    02.06.2006
    Beiträge:
    9
    Zustimmungen:
    0
    Ich habe das jetzt alles gelesen, bin aber leider immer noch nicht weiter. Die xorg.conf finde ich und kann sie dank Konqueror im Systemverwaltungmodus auch editieren. Aber die DPI-Angabe finde ich nicht. eine x86config läuft mir im X11-Ordner auch nicht über den Weg. Die Screen-Resolution habe ich nach längerem Suchen zwar gefunden, kann dort aber nur einfache Sachen einstellen, wie man sieht. Wo genau finde ich die Einstellung der Schriftart? Die Größe des Monitors ist mit 340 x 270 mm absolut korrekt erfasst.
     

    Anhänge:

  9. #8 tuxlover, 02.06.2006
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    Ort:
    berlin
    falls du kde benutzt. es gibt irgendwo im kontrollzentrum (glaube unter arbeistplatz oder erscheinungbild) die möglichkeit die schriften für das aussehen unter kde zu vergrößern. versuchs mal damit.

    sonnig warme grüße von tuxlover
     
  10. Thorin

    Thorin Grünschnabel

    Dabei seit:
    02.06.2006
    Beiträge:
    9
    Zustimmungen:
    0
    KDE heißt aktuell "Blindflug". Das Phänomen beschränkt sich auch nur auf Anmeldeebene und KDE. Gnome ist tadellos.

    Ich bin gerade unter Gnome angemeldet. Logge mich gerade mal um und mache einen Screenie, damit die Situation klar wird.
     
  11. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Dann wäre es vielleicht noch ne Option in der kdmrc diese Einstellung zu testen ;)

    http://wiki2.archlinux.org/index.php/KDE#Changing_DPI_settings_for_KDM:

    kdmrc sollte in /etc/opt/kde3/share/config/kdm/kdmrc liegen ;)
     
  12. #11 Thorin, 02.06.2006
    Zuletzt bearbeitet: 02.06.2006
    Thorin

    Thorin Grünschnabel

    Dabei seit:
    02.06.2006
    Beiträge:
    9
    Zustimmungen:
    0
    So, hier ist der Screenie. Das andere probier ich direkt mal aus.

    EDIT: Habe beides probiert. Hat nichts geholfen. Zur Sicherheit habe ich noch einige andere Windowmanager ausprobiert. KDE ist nicht der einzige mit den kleinen Schriftarten. Aktuell kann ich nur unter Gnome arbeiten. Alle anderen scheinen sich die Schriftgrößen aus X zu ziehen.
     

    Anhänge:

  13. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Schaut übel aus ...
     
  14. Thorin

    Thorin Grünschnabel

    Dabei seit:
    02.06.2006
    Beiträge:
    9
    Zustimmungen:
    0
    Danke. Wie erwähnt: man sieht NIX mehr. :(
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Hastes durchprobiert?
     
  17. Thorin

    Thorin Grünschnabel

    Dabei seit:
    02.06.2006
    Beiträge:
    9
    Zustimmungen:
    0
    Habe sämtliche GUIs einmal durch. Bei allen, außer bei Gnome, das gleiche Bild.

    Ich glaube, es hat doch was mit xorg.conf zu tun. Nur finde ich da keine Möglichkeit, die DPI einzustellen. Vielleicht bin ich auch nur zu schusselig. Meine xorg.conf sieht aktuell so aus:

    # /.../
    # SaX generated X11 config file
    # Created on: 2006-06-02T16:03:01+0200.
    #
    # Version: 7.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (7.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "Files"
    FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/local"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/URW"
    FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
    FontPath "/usr/X11R6/lib/X11/fonts/PEX"
    FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
    FontPath "/usr/X11R6/lib/X11/fonts/truetype"
    FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/CID"
    FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    EndSection

    Section "Module"
    Load "v4l"
    Load "dbe"
    Load "glx"
    Load "type1"
    Load "freetype"
    Load "extmod"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "de"
    Option "XkbModel" "pc105"
    Option "XkbRules" "xfree86"
    Option "XkbVariant" "nodeadkeys"
    EndSection


    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "7"
    Option "Device" "/dev/input/mice"
    Option "Name" "ImExPS/2 Generic Explorer Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 340 270
    HorizSync 30-83
    Identifier "Monitor[0]"
    ModelName "MD30217PG"
    Option "DPMS"
    VendorName "MED"
    VertRefresh 43-76
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    EndSection


    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "Device"
    BoardName "GeForce4 MX 420"
    BusID "1:0:0"
    Driver "nvidia"
    Identifier "Device[0]"
    Screen 0
    VendorName "NVidia"
    EndSection


    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection


    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    EndSection

    Kann mir jemand sagen, wo ich da was einstellen soll? Die Monitoreinstellungen sind, soweit ich das beurteilen kann, richtig. Oder hilft es vielleicht, den Treiber einmal neu einzubinden und die Auto-Konfiguration nochmal durchtickern zu lassen?
     
Thema:

Winzige Schriftarten unter Suse 10.1

Die Seite wird geladen...

Winzige Schriftarten unter Suse 10.1 - Ähnliche Themen

  1. winzige Schrift nach nvidia Install bei Suse 10.1

    winzige Schrift nach nvidia Install bei Suse 10.1: Hallo, bin kurz vorm verzweifeln, habe gestern Suse Linux 10.1 installiert, und anschliessend dann den nvidia Treiber (8762) für meine...
  2. Möglichkeit: Liste mit Schriftartenvorschau erstellen

    Möglichkeit: Liste mit Schriftartenvorschau erstellen: Hallo, ich suche nach einer Möglichkeit (kleines Programm oder ähnliches) mit dem eine Tabelle (Name | Vorschau der Schriftart) erstellt und...
  3. Schriftarten in Website einbinden

    Schriftarten in Website einbinden: wie kann ich mit font-face eine schriftart in meine website einbinden, damit sie nicht nur von internet explorer sondern auch von firefox...
  4. Schriftarten unter Linux

    Schriftarten unter Linux: hallo ich habe mir ein homepage unter Windows angefangen zu bauen jetzt habe ich zu linux opensuse 10.2 gewechselt und habe gemerkt das die Seite...
  5. schriftarten bei suse10.1

    schriftarten bei suse10.1: Hi @ll ich suche schon nach ner ganzen weile schriftarten für suse 10.1. Hat einer von euch vllt ne idee wo ich n paar schriftarten her bekomm?...