Windows Freigaben mounten mit Samba

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von mike7000, 08.07.2008.

  1. #1 mike7000, 08.07.2008
    mike7000

    mike7000 Jungspund

    Dabei seit:
    18.02.2007
    Beiträge:
    19
    Zustimmungen:
    0
    Hallo,

    lansam bin ich verzweifelt :( Ich versuche seit ein paar Tagen eine Windows Freigabe unter Ubuntu 8.4 zu mounten. Leider Fehlanzeige..nicht hinzubekommen.

    Ich möchte die Freigabe wie ein Windows Netzlaufwerk benutzen. Ich denke dann komme ich um das mounten nicht herum.

    Ich habe zwei Rechner mit Windows XP Prof und zwei Rechner mfit Ubuntu 8.4 im Netzwerk. Ich kann alle Freigaben sehen und ich kann auf alle Freigaben von Ubuntu und XP gegenseitig prima zugreifen.

    Nur leider klappt das mounten nicht. Ich habe viel probiert und hab´s zu letzt mit diesem Befehl probiert:

    sudo mount -t smbfs -o Win nusername=otto,Win password=geheim,uid=1000,gid=1000 //server/share /mnt/win

    Die uid und gid habe ich über das Terminal mit id benutzer herausbekommen wenn das richtig ist?

    Leider hat das auch nicht geklappt - was kann ich noch machen? Bitte um Hilfe :think:

    MFG Mike
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. towo

    towo Haudegen

    Dabei seit:
    16.05.2003
    Beiträge:
    649
    Zustimmungen:
    1
    Ort:
    Pößneck
    Naja, "hat nicht geklappt" is ja 'ne sehr tolle Fehlerbeschreibung!
    Code:
    mount -t cifs //server/share /Pfad/zum/Mountpoint -o username=username,password=password,uid=linuxusername
    Das sollte funktionieren.
    Wenn nicht, dann poste die Fehlermeldung, aber nicht "geht nicht"!
     
  4. NoXqs

    NoXqs Routinier

    Dabei seit:
    07.05.2007
    Beiträge:
    420
    Zustimmungen:
    0
    Ort:
    Bremen
    Das ist keine vernünftige Fehlerbeschreibung!

    Die Fehlermeldung oder syslog-Einträge lesen oder posten.

    Gern geschehen.
     
  5. Dizzy

    Dizzy Brain Damage

    Dabei seit:
    02.05.2007
    Beiträge:
    857
    Zustimmungen:
    0
    Ort:
    Graz
    Hi,

    ich hab's so gemountet (/etc/fstab Eintrag):

    Code:
    //SERVIERER/FREIGABE  /mnt/ORDNER smbfs user=USER%PASSWORD 0 0
     
  6. towo

    towo Haudegen

    Dabei seit:
    16.05.2003
    Beiträge:
    649
    Zustimmungen:
    1
    Ort:
    Pößneck
    Nur gibt es 2 Gründe, smbfs nicht zu benutzen:

    1. smbfs is deprecated
    2. smbfs kann von haus aus nix mit Dateien >2 GB anfangen, ohne daß man lfs als mountoption mitgibt.
    (3.) cifs ist etwas performanter als smbfs.

    Na gut, waren 3 Gründe.
     
  7. #6 mike7000, 08.07.2008
    Zuletzt bearbeitet: 08.07.2008
    mike7000

    mike7000 Jungspund

    Dabei seit:
    18.02.2007
    Beiträge:
    19
    Zustimmungen:
    0
    Was würdest Du denn benutzen ausser smbfs bzw. cifs?
    Sorry Linux Neueinsteiger
     
  8. towo

    towo Haudegen

    Dabei seit:
    16.05.2003
    Beiträge:
    649
    Zustimmungen:
    1
    Ort:
    Pößneck
    Habe ich irgendwo geschrieben, cifs nicht zu benutzen?
     
  9. NoXqs

    NoXqs Routinier

    Dabei seit:
    07.05.2007
    Beiträge:
    420
    Zustimmungen:
    0
    Ort:
    Bremen
    Hast du den ersten Post von towo gelesen und den Vorschlag mal probiert?
     
  10. #9 mike7000, 08.07.2008
    Zuletzt bearbeitet: 08.07.2008
    mike7000

    mike7000 Jungspund

    Dabei seit:
    18.02.2007
    Beiträge:
    19
    Zustimmungen:
    0
    Hallo,

    danke vorerst an alle. Ich poste die Fehlermeldung sobald ich zuhause am Rechner sitze.

    MFG
     
  11. #10 kostjaXP, 08.07.2008
    Zuletzt bearbeitet: 08.07.2008
    kostjaXP

    kostjaXP =[KT]=SUpOrt GUnNer=[KT]=

    Dabei seit:
    09.02.2007
    Beiträge:
    388
    Zustimmungen:
    0
    Ort:
    /home
    Manchmal kann es auch helfen die zeile in die fstab einzutragen mit der option noauto

    Außerdem musst du dich versichern, dass die Freigabe unter derselben SUBNET-address firmiert
    Beispiel: Host-IP: 192.168.0.1 Subnet: 255.255.255.0
    Freigabe-IP: 192.168.0.2 Subnet: 255.255.255.255
    --> klappt net, weil die Subnet net stimmt!

    Also wenn das in der fstab steht, sollte auf dem Desktop ein Symbol erscheinen mit der Freigabe..wenn der Befehl gestimmt hat.

    Wichtig ist außerdem, dass der Zielordner /mnt/win existiert!
    Wenn nicht muss er natürlich erstellt werden!

    Mehr kann man so ohne Fehlermeldung und weitere Infos nicht sagen.

    Meine zeile in der fstab:
    Code:
    [B]//IP-Adresse/Ordner	/mnt/Ordner	cifs	defaults,noauto,user=xyz,pass=xyz	0	0[/B]
     
  12. towo

    towo Haudegen

    Dabei seit:
    16.05.2003
    Beiträge:
    649
    Zustimmungen:
    1
    Ort:
    Pößneck
    Na geht's noch?
    Aber bei solchen Antworten bleib halt mit Deinem Problem alleine!
     
  13. #12 mike7000, 08.07.2008
    Zuletzt bearbeitet: 08.07.2008
    mike7000

    mike7000 Jungspund

    Dabei seit:
    18.02.2007
    Beiträge:
    19
    Zustimmungen:
    0
    Hallo,

    vielen Dank für die rege Beteiligung, leider hat bisher nichts geklappt!

    Mit diesem Befehl:

    mount -t cifs //windows server/share /mnt/windows -o username=windows user am windowsrechner,password=windowspasswort am windows Rechner,uid=ubuntu user der die share mounten möchte

    Fehlermeldung:
    mount error: could not find target server. TCP name erna/Freig_erna not found
    No ip address specified and hostname not found

    Der zweite Vorschlag:

    //SERVIERER/FREIGABE /mnt/ORDNER smbfs user=USER%PASSWORD 0 0

    Fehlermeldung:
    bash: //erna/Freig_erna: No such file or directory
    root@moni:/home/ubuntu10#



    MFG
     
  14. Dizzy

    Dizzy Brain Damage

    Dabei seit:
    02.05.2007
    Beiträge:
    857
    Zustimmungen:
    0
    Ort:
    Graz
    Hi,

    hast du dir die Fehlermeldung selbst durchgelesen?
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 mike7000, 08.07.2008
    mike7000

    mike7000 Jungspund

    Dabei seit:
    18.02.2007
    Beiträge:
    19
    Zustimmungen:
    0
    Joh - soll heissen?
     
  17. Rvg

    Rvg Doppel-As

    Dabei seit:
    11.07.2004
    Beiträge:
    141
    Zustimmungen:
    0
Thema:

Windows Freigaben mounten mit Samba

Die Seite wird geladen...

Windows Freigaben mounten mit Samba - Ähnliche Themen

  1. Problem beim Zugriff auf Windows 7 - Freigaben mit Solaris 11

    Problem beim Zugriff auf Windows 7 - Freigaben mit Solaris 11: Ich möchte mit Solaris 11 auf meine Windows 7 - freigaben zugreifen. Ich werde normal nach Benutzername und Passwort gefragt, aber wenn ich es...
  2. windows und samba freigaben. neuling

    windows und samba freigaben. neuling: hallo, ich habe samba auf meiner nslu2 unter debian laufen. einstellungen nehme ich mit swat vor. es hängt an der nslu2 nur eine festplatte dran....
  3. Alte Freigaben unter Windows XP

    Alte Freigaben unter Windows XP: Hallo, ich habe Samba auf meinem Linux Rechner (Ubuntu) eingerichtet und es funktioniert eigentlich wunderbar. Jetzt habe ich aber ein problem...
  4. kein Zugriff von Windows auf Samba freigaben

    kein Zugriff von Windows auf Samba freigaben: Hi Leute, das Problem liegt darin, dass nicht auf meinen Drucker und meine Ordner zugegriffen werden kann. Ich habe schon recherchiert und die...
  5. Windows Freigaben beim Booten automatisch mounten geht nicht

    Windows Freigaben beim Booten automatisch mounten geht nicht: Hallo, ich habe openSuSE mit allen aktuellen Paketen. Über den Eintrag in /etc/samba/smbfstab versuche ich 2 Freigaben aus dem Windows Netzwerk...