Wie spielt man ein Video von smb-Server ab

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Atum, 04.10.2006.

  1. Atum

    Atum Foren As

    Dabei seit:
    03.09.2006
    Beiträge:
    76
    Zustimmungen:
    0
    Hallo,
    ich bins mal wieder... mit etwas, das unter Windows problemlos geht und ich unter Linux leider verzweifel :/

    Ich habe Video- und Musikdateien auf einem Windowsrechner liegen. Ich möchte nun unter Kubuntu mit den mitgelieferten Programmen (Kaffeine und Amarok) diese Dateien abspielen.
    Ich weiß, daß diverse Codecs nachinstalliert werden müssen.
    Mittlerweile habe ich

    libxine-extracodecs
    w32codecs
    kibarts1-mpeglib
    libarts1-xine
    libakode2-mpeg

    und noch einige andere, die ich mittlerweile schon vergessen habe, installiert.
    Lokal auf dem Kubunturechner liegende Dateien werden auch brav abgespielt. Aber über das Netzwerk bekomme ich dann Meldungen wie:

    "Kein Plugin gefunden um diese Quelle zu handhaben (smb://.....)
    xine: cannot find inputplugin for MRL"

    Irgendwie hängt es also nun an diesem "MRL" aber ich weiß nicht, wie ich das beheben kann.

    Kann mir jemand helfen?
    Thx schonmal.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Mounte dir die Netzwerk-Laufwerke einfach lokal (man mount) und spiele die Dateien dann wie lokale Dateien ab. Xine unterstuetzt nunmal kein Samba-Protokoll.
     
  4. heady

    heady Routinier

    Dabei seit:
    13.12.2005
    Beiträge:
    424
    Zustimmungen:
    0
    Ort:
    im Herzen Europas
    Also in meinem Gentoo kann ich die Unterstützung für Samba einstellen, wenn ich xine compiliere...
    Also schätze wenn er das Ubuntu-Paket löscht und sich xine mit Samba kompiliert, müsste das funktionieren.
    Ansonsten bleibt die Alternative, mit dem smb-Filessytem zu mounten.

    Müsse so gehen:

    mount -t smb[fs] -o username=user,password=pwd //xxx.xxx.xxx.xxx/pfad /wohin/du/mounten/willst
     
  5. #4 Goodspeed, 04.10.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Gibts bei Dir die Datei
    Code:
    /usr/lib/xine/plugins/1.0.1/xineplug_inp_smb.so
    
    Sollte im Paket libxine1 sein ... zumindest ist es bei Debian so ...
     
  6. Atum

    Atum Foren As

    Dabei seit:
    03.09.2006
    Beiträge:
    76
    Zustimmungen:
    0
    @Goodspeed:
    bis darauf, daß ich das Paket 1.1.1 habe, ja. Ich habe diese Datei.

    @heady:
    das habe ich ja schon versucht. Aber anscheinend bin ich als Neuling nicht in der lage, einen einfachen Befehl bei Linux auszuführen ;)

    sudo mount -t smb -o username=bla,password=bla //192.168.100.3/Movies /filme

    ergibt bei mir die Fehlermeldung:

    Coult not resolve mount point /filme
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Existiert bei dir der Ordner /filme ueberhaupt?
     
  9. #7 Atum, 04.10.2006
    Zuletzt bearbeitet: 04.10.2006
    Atum

    Atum Foren As

    Dabei seit:
    03.09.2006
    Beiträge:
    76
    Zustimmungen:
    0
    Also auf dem Linuxrechner nein. Vielleicht habe ich das ja falsch verstanden. Ich war immer der Meinung, daß ich mit mount einen Ordner in meinen Verzeichnisbaum einbinden kann und diesen dann entsprechend benennen kann, wie ich will. Daß ich diesen Ordner schon vorher erzeugen muß, war mir bisher nicht klar ;)
    Gut. Das Problem hätten wir behoben, bleibt noch immer die Fehlermeldung:

    6476: session setup failed: ERRDOS -ERRnoaccess (Access denied.)
    SMB connection failed


    obwohl ich mit gleichem user und password über den Konquerorbrowser beim smb-Browsen auf diesen Ordner Zugang erhalte.

    OK, vergesst es. Ich bin zu doof (oder zu müde). Ich hatte einen Vertipper im Befehl gehabt ...

    Jetzt geht es. Vielen Dank!!!
     
Thema: Wie spielt man ein Video von smb-Server ab
Besucher kamen mit folgenden Suchen
  1. freebsd amarok mount smb

Die Seite wird geladen...

Wie spielt man ein Video von smb-Server ab - Ähnliche Themen

  1. Sony Digital Media Player NWZ-S544 spielt keine Videos

    Sony Digital Media Player NWZ-S544 spielt keine Videos: Hallo, ich würde gern mein Lieblingsvideo http://www.youtube.com/watch?v=y3l_f7NrY-I auf den o.g. Player...
  2. Firefox 3 schliesst automatisch und Videos können nicht abgespielt werden

    Firefox 3 schliesst automatisch und Videos können nicht abgespielt werden: Hallo zusammen Ich habe mehrere Probleme mit Firefox 3 unter Kubuntu. Videos konnte ich schon seit ich Kubuntu installiert habe mit allen...
  3. Videos werden unsynchron und mit Clipping abgespielt

    Videos werden unsynchron und mit Clipping abgespielt: Ich habe unter Ubuntu 8.04 64bit Probleme Videos synchron abzuspielen (Ton ist schneller als das Bild). Außerdem ist das Clipping auch noch stark...
  4. VLC spielt kein Video mehr ab

    VLC spielt kein Video mehr ab: Hallo, seit einem -Upgrade all- in Smart spielt VLC keine *.avi mehr ab, nur noch den Ton. Ich habe schon VLC de- und neuinstalliert, ohne...
  5. gmplayer spielt keine videos mehr ab

    gmplayer spielt keine videos mehr ab: hallo. ich habe aus versehen 2 videos gleichzeitig abgespielt (mit gmplayer). als das 2. video geladen wurde, kam nur der fehler Error...