Welches shell-script ist ausführbar?

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von B-52, 10.12.2011.

  1. B-52

    B-52 Routinier

    Dabei seit:
    08.08.2011
    Beiträge:
    270
    Zustimmungen:
    0
    Ort:
    Bern (CH)
    Hallo Community,
    Dies ist mehr eine Verständnisfrage, weil ich ich nicht ganz Durchblicke!
    Ich habe Google Earth via einem *.deb Paket installiert. Leider wurde nicht automatisch ein Start-Icon erstellt.

    Die Ausgabe:
    Code:
    yuna@bulloz:/opt/google/earth/free$ dir
    ergab:
    Code:
    drivers.ini		    libcurl.so.4	    libIGOpt.so		       libsgutil.so
    googleearth		    libevll.so		    libIGSg.so		       libspatial.so
    google-earth		    libflightsim.so	    libIGUtils.so	       libviewsync.so
    googleearth-bin		    libfusioncommon.so	    libinput_plugin.so	       libwebbrowser.so
    google-earth.desktop	    libgdal.so.1	    liblayer.so		       libwmsbase.so
    gpl.txt			    libgdata.so		    liblayout.so	       libxsltransform.so
    gpsbabel		    libge_net.so	    libmath.so		       PCOptimizations.ini
    ImporterGlobalSettings.ini  libgeobase.so	    libmeasure.so	       plugins
    ImporterUISettings.ini	    libgeobaseutils.so	    libmoduleframework.so      product_logo_128.png
    kh20			    libGLU.so.1		    libnavigate.so	       product_logo_16.png
    lang			    libgoogleapi.so	    libnss_mdns4_minimal.so.2  product_logo_22.png
    libalchemyext.so	    libgoogleearth_free.so  libport.so		       product_logo_24.png
    libapiloader.so		    libgooglesearch.so	    libprofile.so	       product_logo_256.png
    libauth.so		    libgps.so		    libproj.so.0	       product_logo_32.png
    libbase.so		    libgtest.so		    libQtCore.so.4	       product_logo_32.xpm
    libbasicingest.so	    libicudata.so.38	    libQtGui.so.4	       product_logo_48.png
    libcollada.so		    libicuuc.so.38	    libQtNetwork.so.4	       product_logo_64.png
    libcommon_gui.so	    libIGAttrs.so	    libQtWebKit.so.4	       qt.conf
    libcommon_platform.so	    libIGCore.so	    librender.so	       resources
    libcommon.so		    libIGExportCommon.so    libreporting.so	       shaders
    libcommon_webbrowser.so     libIGGfx.so		    libsearchmodule.so	       xdg-mime
    libcomponentframework.so    libIGMath.so	    libsearch.so	       xdg-settings
    
    Woran genau erkenne ich jetzt, welche Datei ich dem Starter hinzufügen muss. Wie sehe ich als Dummy, dass nur google-earth im Terminal ausgeführt tatsächlich funktioniert? Und warum ist es nicht googleearth, google-earth.desktop, googleearth-bin
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. glako

    glako Eala Frya Fresena!

    Dabei seit:
    27.05.2007
    Beiträge:
    161
    Zustimmungen:
    0
    Ort:
    umme Ecke
    Code:
    ls -l
    hilft
     
  4. amöbe

    amöbe Tripel-As

    Dabei seit:
    21.01.2007
    Beiträge:
    188
    Zustimmungen:
    0
    Die .desktop-Datei ist anklickbar.
    Außerdem kann man sie mit vim etc. öffnen und dann findet man eine Zeile mit Exec=..., an der man sieht, welcher Befehl ausgeführt wird. (http://standards.freedesktop.org/menu-spec/menu-spec-1.0.html)
    Wenn man ls mit Farben hat sind oft die ausführbaren Dateien grün o.ä.
     
  5. #4 B-52, 10.12.2011
    Zuletzt bearbeitet: 10.12.2011
    B-52

    B-52 Routinier

    Dabei seit:
    08.08.2011
    Beiträge:
    270
    Zustimmungen:
    0
    Ort:
    Bern (CH)
    @glako + amöbe
    Genau das, was ich wollte. Die ausführbare Datei ist somit "hellblau" oder wie wir diese Farbe auch nennen wollen - Danke!

    ls-l.jpg
     
  6. #5 xbeduine, 10.12.2011
    xbeduine

    xbeduine ausgesperrt

    Dabei seit:
    09.09.2007
    Beiträge:
    142
    Zustimmungen:
    0
    Wenn du mal ein Terminal ohne Farben hast -> die Datei die das Executable gesetzt hat ist ausführbar. Erkennst du am x bei ls -l
     
  7. Rimu

    Rimu Tripel-As

    Dabei seit:
    29.12.2003
    Beiträge:
    208
    Zustimmungen:
    0
    Ort:
    Nirvana
    ist auch ganz nett
     
  8. amöbe

    amöbe Tripel-As

    Dabei seit:
    21.01.2007
    Beiträge:
    188
    Zustimmungen:
    0
    Code:
    find . -maxdepth 1 -perm -700 -type f ! -name '.*'
    :)
     
  9. #8 Goodspeed, 11.12.2011
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Nö ... die hellblaue ist erstmal nur n Softlink. Die grünen sind entsprechende ihrer Rechte (x-Flag) ausführbar ...
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 B-52, 11.12.2011
    Zuletzt bearbeitet: 11.12.2011
    B-52

    B-52 Routinier

    Dabei seit:
    08.08.2011
    Beiträge:
    270
    Zustimmungen:
    0
    Ort:
    Bern (CH)
    Danke, jetzt bin ich echt verwirrt...

    Jedenfalls hat's funktioniert und
    Code:
    /opt/google/earth/free/google-earth
    im Starter eingegeben funktioniert.

    google-earth ist hier als ls -l aufgerufen hellblau und für mich "ausführbar" :-)

    Gruss B-52

    PS: aber vielen Dank für die Richtigstellung. Hab noch viel zu lernen...
     
  12. #10 Goodspeed, 12.12.2011
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Dann solltest Du nochmal nachschlagen, was ein Softlink ist.
    Nicht google-earth ist ausführbar, sondern dessen Ziel (das Du im Übrigen auch bei ls -l angezeigt bekommst).
     
Thema:

Welches shell-script ist ausführbar?

Die Seite wird geladen...

Welches shell-script ist ausführbar? - Ähnliche Themen

  1. suche 32-Bit Kompatibilitaetsbibliothek für Debian Wheezy amd64 -- Welches Paket?

    suche 32-Bit Kompatibilitaetsbibliothek für Debian Wheezy amd64 -- Welches Paket?: Hallo Community, möchte eigentlich xampp auf meinem System [3.2.0-4-amd64 #1 SMP Debian 3.2.39-2 GNU/Linux] installieren. Leider bekomme ich...
  2. Lenovo Thinkpad T500 - welches Linux passt?

    Lenovo Thinkpad T500 - welches Linux passt?: Servus Leute, ich muss jetzt doch endlich mal wechseln. Habe mir das Lenovo ThinkPad T500 gebraucht gekauft (...
  3. welches Medium für Datensicherung

    welches Medium für Datensicherung: Hi, ich würde gerne in regelmäßigen Abständen eine Datensicherung durchführen. Ich habe mir dazu duplicity eingerichtet, das funktioniert auch...
  4. Welches ist euer Liebling Konsolen Editor?

    Welches ist euer Liebling Konsolen Editor?: Also ich habe mich klar für nano entschieden, wobei mir die Syntax Highlight bei mcedit gefällt. Kann sein das ich mcedit zunehmend mehr nutzen werde.
  5. Welches Notebook???

    Welches Notebook???: hallo ich möchte mir ein neues notebook kaufen. das segment ist aber so unüberschaubar das ich mir überhaupt nicht mehr sicher bin was ich...