was ist falsch an meiner /etc/fstab ?

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von KoRny, 29.04.2007.

  1. KoRny

    KoRny Narrenkönig

    Dabei seit:
    01.08.2006
    Beiträge:
    11
    Zustimmungen:
    0
    hi
    ich poste mal hier meine /etc/fstab.
    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/sda7       /               ext3    defaults,errors=remount-ro 0       1
    /dev/sda1       none            swap    sw              0       0
    /dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
    /dev/sdc1       /media/keyfile_usb vfat ro              0       0
    
    Eigentlich sieht sie ja ganz ok aus, aber der letzte Eintrag wird beim booten nicht gemounted.
    Was hab ich falsch gemacht oder wo kann ich nach einer Fehlermeldung suchen?

    MFG
    KoRny
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. buli

    buli Debianator

    Dabei seit:
    16.09.2006
    Beiträge:
    789
    Zustimmungen:
    0
    Ort:
    Essen/Ruhrgebiet
    /dev/sdc1 /media/keyfile_usb vfat ro,user,auto 0 0

    Würd ich ganz spontan sagen
     
  4. Ogion

    Ogion FOSS-Fan

    Dabei seit:
    29.04.2007
    Beiträge:
    93
    Zustimmungen:
    0
    Und wenn du auf die Partition auch schreiben willst, dann solltest du aus dem ro ein rw machen...
    Ansonsten stimme ich da meinem Vorposter zu. Der Eintrag auto bewirkt, dass die Partition beim booten gemountet wird. Der Eintrag user bewirkt, dass nicht nur root Rechte auf der Partition hat.

    Ogion
     
  5. #4 saeckereier, 30.04.2007
    Zuletzt bearbeitet: 30.04.2007
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Nö nö, die Frage war doch wir bewirke ich dass meine Partition beim Booten gemountet wird. Auto ist Bestandteil von defaults und genau das was gewollt ist. noauto... NICHT beim Booten.

    Nee, überhaupt nicht. User hat nichts damit zu tun ob User Rechte auf der Partition haben, es bewirkt dass User dieses Gerät mounten können. Da es bereits beim Booten gemountet werden soll auch nicht relevant. ;) Thema verfehlt, setzen 6 ;)
    (Die Smileys kennzeichnen hierbei dass es ein Scherz ist)

    Aus deiner fstab Angabe schliesse ich dass es sich wohl um einen USB Stick handeln wird. Da das mounten der Dateisysteme eine der ersten Aktionen ist, ist es rel. wahrscheinlich, dass zum Zeitpunkt des Mountes noch gar kein /dev/sdc1 existiert. Vorraussetzungen wären dass der Support für SCSI HDDs und USB Wechseldatenträger fest im Kernel einkompiliert ist. Ausserdem sollte dein Kernel das vfat Dateisystem fest einkompiliert haben. Darübehinaus solltest du dir Gedanken machen diesen USB Stick mittels udev Regeln immer eine spezielle Gerätedatei zuweisen zu lassen, sonst kann es dir u. U. passieren dass du mehrere USB Sticks hast und die Buchstaben sich unterscheiden. Bitte klär uns auf ob es sich um einen USB Stick handelt...

    EDIT: Und bevor nachher die Frage nach den Rechten des gemounteten Devices kommt, besonders weil ich mal schätze dass das nur root lesen können soll, man mount -> "Mount options for fat" suchen
     
  6. buli

    buli Debianator

    Dabei seit:
    16.09.2006
    Beiträge:
    789
    Zustimmungen:
    0
    Ort:
    Essen/Ruhrgebiet
    Ja, auto. Sag ich doch.
     
  7. #6 saeckereier, 30.04.2007
    Zuletzt bearbeitet: 30.04.2007
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    stimmt.

    (Okay, habs übersehen vor lauter noautos, autos und was auch immer. Was ich eigentlich sagen wollte ist das man auto nicht explizit erwähnen muss, da es bestandteil von defaults ist..)
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Und sehe jetzt gerade das defaults nicht angegeben ist. Also ich würde dass nehmen was buli gesagt hat, bzw. defaults,ro anstatt nur ro..
     
  8. buli

    buli Debianator

    Dabei seit:
    16.09.2006
    Beiträge:
    789
    Zustimmungen:
    0
    Ort:
    Essen/Ruhrgebiet
    Ahso.
    Muss man dann aber nicht zumindest defaults angeben? Der Kollege hat nämlich garkeine weiteren Optionen gesetzt (ausser ro)

    /edit:
    @ saeckereier
    Jetzt hab ich grad deinen edit gesehen. Also kannst meine Frage vergessen ;)
     
  9. #8 saeckereier, 30.04.2007
    Zuletzt bearbeitet: 30.04.2007
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Alles klar. Ja war alles ein bisschen durcheinander.. Im Endeffekt hatte mich nur die user Option gestört, denn so wie der Mountpoint und alles andere sich anhört (!) ist es eher wahrscheinlich dass User von dem Ding die Finger zu lassen haben, ich denke mal das wird ein USB Stick mit Key für eine verschlüsselte Partition sein, un da wäre es evtl. unangenehm wenn die User sich den einfach ziehen kann, bzw. jedes Skript/Virus das/den der User ausführt. Also zusammengefasst, wie von buli bereits treffend formuliert:
    Code:
    /dev/sdc1 /media/keyfile_usb vfat ro,user,auto 0 0
    oder so: (grosse Unterschiede gibt es da nicht)
    Code:
    /dev/sdc1 /media/keyfile_usb vfat ro,defaults 0 0
    Ob du user mit einbaust oder nicht hängt dann nur noch davon ab, was du eigentlich willst, und wie die Berechtigungen gewünscht sind. Wenn nur root lesen können soll, wird wahrscheinlich auch noch ne Verwendung von umask und/oder dmask in den Optionen nötig..
     
  10. KoRny

    KoRny Narrenkönig

    Dabei seit:
    01.08.2006
    Beiträge:
    11
    Zustimmungen:
    0
    Sehr gut überlegt ^^
    Es ist tatsächlich ein USB-Stick mit Keyfile. Allerdings bin ich der einzige Nutzer und möchte als normaler Nutzer lesend drauf zugreifen können (da truecrypt über sudo angesprochen werden darf).

    Wie buli es gesagt hat funktioniert es tatsächlich (oh Wunder ^^). Dass der USB-Stick beim booten nicht gemounted wird, weil die ganzen Module noch nicht da sind ist auch logisch, aber dann würd mich dennoch interessieren wo ich die Fehlermeldung finde.

    In meiner mtab finde ich nun nachdem ich die Zeile von buli übernommen habe folgenden Eintrag:
    Code:
    /dev/sdc1 /media/keyfile_usb vfat ro,noexec,nosuid,nodev 0 0
    Alles OK soweit :T

    Wenn ich als normaler User versuche den USBstick zu-umounten bekomme ich
    Code:
    umount: only root can unmount /dev/sdc1 from /media/keyfile_usb
    Also kann ich ihn nur mit root-rechten im rw Modus wieder mounten (oder nicht? ich ann ihn ja nicht umounten als user).

    Vielen Dank soweit für die schnelle tolle Aufklärung.

    MFG
    KoRny
     
  11. buli

    buli Debianator

    Dabei seit:
    16.09.2006
    Beiträge:
    789
    Zustimmungen:
    0
    Ort:
    Essen/Ruhrgebiet
    Diese Anspielung habe ich einfach mal überlesen. 8)
    Code:
    dmesg | grep -i usb
    
    Oder:
    Code:
    grep -i usb /var/log/messages
     
  12. #11 saeckereier, 30.04.2007
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    *kratz* *kratz*
    Klappt das mounten beim Booten denn jetzt oder nicht? Wenn es klappt, gab es vorher sicherlich keine Fehlermeldung, denn schliesslich hat dein System auch nicht versucht den USB Speicher beim Booten einzubinden.

    Ansonsten sieht es mit Fehlermeldungen in dem Moment etwas schlecht aus. Warum? Nun, vor dem Mounten der Dateisysteme ist i.d.R. noch kein schreibbares Dateisystem da, also läuft auch noch kein syslog bzw. klog mit dem Effekt, dass Logmeldungen direkt auf den Bildschirm laufen. Da hilft also höchstens ein schnelles Blinzeln...

    Dein anderer Punkt:
    liesse sich mit dem oben beschriebenen user erreichen oder auch über sudo. Unter Linux darf ein User nur dann Medien einbinden oder entfernen WENN in der fstab der Parameter user vorhanden ist und auch dann NUR wenn dieser User das Medium eingebunden hat. Sprich nach automatischem Einbinden beim Start dürfte nur root das wieder entfernen können.

    Ich mag mich jetzt irren, da ich truecrypt nur unter Windows kenne (unter Linux eher ein Fan von dm-crypt und luks) aber wenn ich dich richtig verstehe rufst du truecrypt per sudo auf. Dann läuft truecrypt unter dem root-account und eben deshalb muss dieser Key nicht von normalen Usern gelesen werden können. Es wäre also evtl. wirklich sinnvoll die Rechte entsprechend einzuschränken. Vielleicht wäre es auch hilfreich wenn du uns einmal aufklärst wie und von wem in welchen Szenarien auf diesen USB Stick zugegriffen wird, noch raten wir eher etwas rum..
     
  13. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  14. #12 KoRny, 30.04.2007
    Zuletzt bearbeitet: 30.04.2007
    KoRny

    KoRny Narrenkönig

    Dabei seit:
    01.08.2006
    Beiträge:
    11
    Zustimmungen:
    0
    also auf den USB-stick kann eigentlich nur ich hardwaremäsig zugreifen. Und auch sonst hab ich ein Debian-Desktop System auf dem ich der einzige Nutzer bin und keine Serverdienste (nur im lan) laufen. Ich sehe eigentlich kein Problem mit der Keyfile, zumal auf dem USB-Stick nur die verschlüsselte keyfile liegt.
    Da Truecrypt aber wirklich als root läuft, sollte ich wohl eher die entschlüsselte keyfile nicht lesbar für normale User aufbewahren.

    Btw: Die keyfile mounte ich mit
    Code:
    sudo truecrypt -r /media/keyfile_usb/{keyfile} $tr_keyfile
    /media/keyfile_usb/ ist der gemountete USB-Stick

    Danke für die detailreiche Hilfe =)


    edit an buli:
    Was war ernst gemeint von mir. Vor allem eine superschnelle, genaue, funktionierende, problembetreffende Antwort ist in den meisten Foren doch immer noch ein Wunder.

    MFG
    KoRny
     
  15. #13 saeckereier, 30.04.2007
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Der Gedanke ist einfach eine so wichtige Datei (theoretisch) zu schützen z.B. auch damit kein Virus oder ähnliches Skript sie klauen könnte. Die Wahrscheinlichkeit ist zwar sehr klein, aber schaden tut es auch nicht.. Ist halt derselbe Grund weshalb man sich nichts als root in KDE anmeldet oder generell als root arbeitet.
    Dafür müsstest du übrigens diese Änderung hinzufügen:
    Code:
    /dev/sdc1 /media/keyfile_usb vfat ro,defaults,umask=077 0 0
    glaube ich..
     
Thema:

was ist falsch an meiner /etc/fstab ?

Die Seite wird geladen...

was ist falsch an meiner /etc/fstab ? - Ähnliche Themen

  1. CentOS 7: Falsche Metric bei regelbasiertem Routing nach Server-Reboot

    CentOS 7: Falsche Metric bei regelbasiertem Routing nach Server-Reboot: Hallo zusammen Ich möchte unseren existierenden SFTP Server durch einen neuen Server mit CentOS 7 ersetzen. Da der Server einerseits direkt via...
  2. Was mache ich falsch? Tiniywm und Mate Install unter OpenBSD

    Was mache ich falsch? Tiniywm und Mate Install unter OpenBSD: Hallo, # make tiny make: don't know how to make tiny Stop in /root/Downloads/tiny/tinywm-1.3 # make tinywm cc -O2 -pipe -o tinywm tinywm.c...
  3. Chrome und Firefox sperren gefälschte Server-Zertifikate

    Chrome und Firefox sperren gefälschte Server-Zertifikate: Seit Freitag waren offenbar gefälschte Server-Schlüssel von Google im Umlauf. Google reagierte darauf, indem es die betroffenen Schlüssel im...
  4. Per Samba falsche Angaben zum freien Speicherplatz übertragen

    Per Samba falsche Angaben zum freien Speicherplatz übertragen: Moin, ich habe ein altes Mainboard zu einem NAS umgebaut auf dem ein Ubuntu läuft. Ist kein spezielles NAS-System, es war halt nur drauf. An...
  5. Fehler in GCC kann falschen Kernel-Code erzeugen

    Fehler in GCC kann falschen Kernel-Code erzeugen: Linux-Kernel, die mit neueren Versionen von GCC erzeugt wurden, können sporadische Abstürze zeigen. Bisher dürften nur wenige Anwender betroffen...