W-Lan-Einrichtung Knoppix

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von smarti0101, 04.09.2007.

  1. #1 smarti0101, 04.09.2007
    Zuletzt bearbeitet: 04.09.2007
    smarti0101

    smarti0101 Jungspund

    Dabei seit:
    04.09.2007
    Beiträge:
    10
    Zustimmungen:
    0
    Hi Leute.... ich habe diesen Beitrag schon in einem anderen Bereich geschrieben, aber ich denke er ist hier besser aufgehoben.


    Also....

    nachdem die HD meines Lappis abgeraucht ist und ich auf die schnelle an keine WIN XP-CD kommen konnte, bin ich auf Knoppix umgestiegen. Knoppix aus dem Grund, weil man mit 700 mhz und 128Mb Ram nicht viel reißen kann.

    Ich habe also Knoppix fest installiert und versuche seit gestern Abend meine W-Lan-Karte (PCMCIA) zum laufen zu bekommen. Laut Infozentrum wird sie richtig als "Siemens Gigaset PC Card 11" erkannt. Aber ich bekomme diesen WPA Supplicant (oder wie das heißt) nicht zum laufen.

    Wenn ich auf das Knoppix-Menü gehe und dort auf "Funklan konfigurieren" kommt immer eine Fehlermeldung "SU hat einen Fehler gefunden" (oder so ähnlich)

    Ich habe ein ganz klein wenig nachgelesen und habe Knoppix dazu gebracht mir folgendes auszuspucken: "eth1: Atmel at76c50x Version 0.98"

    Auch habe ich gelesen, daß man für diese PCMCIA-Karte einen speziellen Treiber braucht. Diesen habe ich bereits runtergeladen habe aber absolut keinen Plan, wie man den installiert. Den Treiber habe ich von http://linuxwiki.de/LinuxWireless. Meine Karte ist die letzte der 11 MBit Karten.

    Wenn Ihr noch Infos braucht, sagt mir bitte, wie ich sie Knoppix entlocken kann....

    Gruß Philipp


    Edit:

    Die Power-LED an der Karte leuchtet, wie sie soll. Jedoch leuchtet auch die Activity-LED dauerhaft... was nicht sein sollte....



    Nach einem Tip mit "iwlist eth1 scan" wurde mein Netzwerk gefunden. Bei dem Versuch mit "kwlan" einzurichten bekomme ich immer die Fehlermeldung, daß der "WPA-Dingsda" nicht funzt. Auch wenn ich über das Knoppix-Menü gehe und dann auf "Funklan konfigurieren" bekomme ich nur folgende Fehlermeldung
    Ich benutze jetzt Knoppix den 2 Tag und bin ein dementsprechender DAU....
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 aokneufi, 10.09.2007
    Zuletzt bearbeitet: 10.09.2007
    aokneufi

    aokneufi Grünschnabel

    Dabei seit:
    10.09.2007
    Beiträge:
    7
    Zustimmungen:
    0
    Hi, du brauchst (wenn es ein 2.6er kernel ist)

    Wenn Du die Karte einsteckst und dann dmesg anguckst, fehlt sicher die
    Firmware.

    Die kriegste hier:
    http://rpmseek.com/rpm/atmel-firmware_1.3-2_all.html?hl=de&cx=2113:A:0:2362902:0:0:0

    speicherst es im home und dann als root

    dpkg -i atmel-firmware_1.3-2_all.deb

    (deinstallieren kannst mit dpkg -r atmel-firmware)


    Karte einstecken und mit dmesg gucken ob es geladen wurde. Mit iwconfig siehste auf welches Interfaces es gebunden wird. eth1 oder so ähnlich. Das musst dann unten anpassen in der interfaces liste. Ich hab mal eth1 genommen.



    Dann die /etc/network/interfaces (WPE)

    allow-hotplug eth1
    iface eth1 inet dhcp
    wireless_channel auto
    wireless_mode auto
    wireless_essid DeineESSID
    wireless_key DeinSchlüssel [1]
    #wireless_power off
    #wireless_sens -80
    #wireless_frag 512
    #wireless_txpower auto
    #wireless_rts 250

    [1] meint den ersten schlüssel von den vier verwenden
    mit power on oder gemäss [man] iwconfig, würdest die led auskriegen. Jedoch geht auch der saft dann weg, war bei mir schon immer dauernd an.

    oder mit WPA

    #allwo-hotplug eth1
    #iface eth1 inet dhcp
    #wpa-ssid DeinESSID
    #wpa-psk DeinPasswort

    Wobei mit WPA hab ich noch nie gemacht, da gibt es einfach wie hier bis kompliziert, am besten das hier zu WPA:
    http://svn.debian.org/wsvn/pkg-wpa/wpasupplicant/trunk/debian/README.modes?op=file&rev=0&sc=0


    Die Konfiguration neu einlesen mit dem Befehel:
    /etc/init.d/networking stop
    /etc/init.d/networking start

    Dann die Karte aus- und einschieben. Und hoffen das die Verbindung tut.
    ifconfig

    Bei mir macht die Karte aber probs, und bin nicht der einzige. Verliere immer den Kontakt wieder. Das linuxwiki.de mit dieser Karte hab ich mal geschrieben, das war noch im 2.4er da lief sie noch gut.

    by
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    smarti, ich hab ja noch probleme mit der Karte, das sie immer wieder den kontakt verliert.

    Mit einem Kernel der für i486er Code compiliert ist , geht es.

    Bei debian kriegt man den fertig vorgefertigt. Ich vermute bei Knoppix kannst den auch installieren.

    apt-get update
    apt-cache search linux-image (evt kernel-image bei knoppix)

    aus der liste solltest dir was nehmen wie
    linux-image-2.6.18-5-486

    apt-get install linux-image-2.6.18-5-486


    das installiert den bei Debian und auch gleich in den bootmanager

    cue

    (so leuft die wenigstens, wobei ich natürlich gern hätte wenn der Kernel schon die grossen CPU Befehle verwenden würde bei mir, aber mal gucken)
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    ah ja, wenn du WPE Modus machst, kannst fast alles auf Auto stellen.
    aus /etc/network/interfaces:

    allow-hotplug eth2
    iface eth2 inet dhcp
    wireless_channel auto
    wireless_mode auto
    wireless_essid DeinESSID
    wireless_enc WPE
    wireless_key DeinWPEschlüssel [1]
    wireless_power on
    wireless_sens auto

    ob es eth2 oder eth1 oder so ist, musst mit iwconfig schnell nachgucken und apassen, und power on startet das Powermanagment der Karte, die LED bleibt off bei Kontakt.
     
  4. #3 aokneufi, 12.09.2007
    aokneufi

    aokneufi Grünschnabel

    Dabei seit:
    10.09.2007
    Beiträge:
    7
    Zustimmungen:
    0
    Atmel PCMCIA 0.98

    Ich hab meine Erfahrungen wie früher im linuxwiki.de niedergeschrieben unter wireless.

    Diese atmel_cs geschichte hat es in sich.

    Debian etch 2.6.18-5-486 ist no probelm, works fine out

    2.6.22-2-486 with new libc6 broken my linksys dhcpservices, my linksys dhcpservices froze!

    crazzy

    http://linuxwiki.de/LinuxWireless?highlight=(wireless)#head-0e7243975f3ca26cde9941e30c513084a656a8bb


    mal gucken, den Debianer Maintainer angemailt von atmel_cs

    :oldman
     
Thema:

W-Lan-Einrichtung Knoppix

Die Seite wird geladen...

W-Lan-Einrichtung Knoppix - Ähnliche Themen

  1. Anfänger: Hilfe W-Lan-Einrichtung

    Anfänger: Hilfe W-Lan-Einrichtung: Hi Leute, nachdem die HD meines Lappis abgeraucht ist und ich auf die schnelle an keine WIN XP-CD kommen konnte, bin ich auf Knoppix umgestiegen....
  2. Knoppix 7.6 veröffentlicht

    Knoppix 7.6 veröffentlicht: Klaus Knopper hat die Version 7.6 der populären Linux-Live-Distribution Knoppix herausgegeben. Knoppix 7.6 enthält eine neue Version des...
  3. Knoppix 7.4 veröffentlicht

    Knoppix 7.4 veröffentlicht: Klaus Knopper hat die Version 7.4 der populären Linux-Live-Distribution Knoppix herausgegeben. Die neue Version enthält eine teilweise Integration...
  4. Knoppix 7.2 veröffentlicht

    Knoppix 7.2 veröffentlicht: Klaus Knopper hat die Version 7.2 der populären Linux-Live-Distribution Knoppix herausgegeben, die das anonyme Surfen mit Tor unterstützt....
  5. Knoppix auf Festplatte unsicher? Passwortabfrage

    Knoppix auf Festplatte unsicher? Passwortabfrage: Hallo allerseits Nachdem mich tgruene freundlicherweise ins Forum gelotst (bekommen) hat, möchte ich o.g. Thema noch einmal auf aktuellem Stand...