vsftpd

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von .mike., 20.01.2007.

  1. .mike.

    .mike. Doppel-As

    Dabei seit:
    27.08.2006
    Beiträge:
    207
    Zustimmungen:
    0
    hallo

    versuche gerade den vsftpd-server zum laufen zu bringen, d.h. er läuft eigentlich ganz gut.

    ich kann mich auch zu ihm verbinden, aber nur wenn den internen netzwerknamen bzw. die interne ip-adresse nehme.
    hab dann an meinem router ne portfreigabe eingerichtet aber wenn ich mich "von außen" zu ihm verbinden will, also über die "internet-ip" dann gehts nicht.

    es kommt auch kein fehler.

    kann mir jemand helfen?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    du musst neben der port freigabe (ich denke mal du hast 21 freigegebn) auch eine NAT auf deine netzwerk interne ip einrichten, also port 21 nach XXX.XXX.XXX.XXX, das müsstest du im router menu einstellen können
     
  4. .mike.

    .mike. Doppel-As

    Dabei seit:
    27.08.2006
    Beiträge:
    207
    Zustimmungen:
    0
    also der port 21 is auf 192.168.178.20:21 (der rechner mit dem vsftpd) freigegeben.

    ich weiß wirklich nicht weiter
    muss ich vielleicht in der /etc/vsftpd.conf was ändern?
     
  5. #4 supersucker, 20.01.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Kein Ding, das kriegen wir hin...

    1.

    Was ist die Ausgabe von

    Code:
    nmap deine_externe_ip
    2.

    Poste mal deine conf.

    3.

    Was steht in den logs von vsftp nach einem fehlgeschlagenen Verbindungsversuch?
     
  6. #5 flashlighter, 20.01.2007
    flashlighter

    flashlighter Foren As

    Dabei seit:
    07.01.2007
    Beiträge:
    93
    Zustimmungen:
    0
    hi,


    was für einen router hast du denn?

    beim speedport 500V funktioniert die portweiterleitung z.B gar nicht...

    habe das schon an mehreren 500V's probiert...

    grüße, michi
     
  7. #6 .mike., 20.01.2007
    Zuletzt bearbeitet: 20.01.2007
    .mike.

    .mike. Doppel-As

    Dabei seit:
    27.08.2006
    Beiträge:
    207
    Zustimmungen:
    0
    hab eine Fritz!Box

    nmap läuft gerade aber ich kann mal die conf posten:

    # Example config file /etc/vsftpd.conf
    #
    # The default compiled in settings are fairly paranoid. This sample file
    # loosens things up a bit, to make the ftp daemon more usable.
    # Please see vsftpd.conf.5 for all compiled in defaults.
    #
    # If you do not change anything here you will have a minimum setup for an
    # anonymus FTP server.
    #
    # READ THIS: This example file is NOT an exhaustive list of vsftpd options.
    # Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
    # capabilities.

    # General Settings
    #
    # Uncomment this to enable any form of FTP write command.
    #
    #write_enable=YES
    #
    # Activate directory messages - messages given to remote users when they
    # go into a certain directory.
    #
    dirmessage_enable=YES
    #
    # It is recommended that you define on your system a unique user which the
    # ftp server can use as a totally isolated and unprivileged user.
    #
    #nopriv_user=ftpsecure
    #
    # You may fully customise the login banner string:
    #
    #ftpd_banner="Welcome to FOOBAR FTP service."
    #
    # You may activate the "-R" option to the builtin ls. This is disabled by
    # default to avoid remote users being able to cause excessive I/O on large
    # sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
    # the presence of the "-R" option, so there is a strong case for enabling it.
    #
    #ls_recurse_enable=YES
    #
    # You may specify a file of disallowed anonymous e-mail addresses. Apparently
    # useful for combatting certain DoS attacks.
    #
    #deny_email_enable=YES
    #
    # (default follows)
    #
    #banned_email_file=/etc/vsftpd.banned_emails
    #
    # If enabled, all user and group information in
    # directory listings will be displayed as "ftp".
    #
    #hide_ids=YES

    # Local FTP user Settings
    #
    # Uncomment this to allow local users to log in.
    #
    #local_enable=YES
    #
    # Default umask for local users is 077. You may wish to change this to 022,
    # if your users expect that (022 is used by most other ftpd's)
    #
    #local_umask=022
    #
    # Uncomment to put local users in a chroot() jail in their home directory
    # after login.
    #
    #chroot_local_user=YES
    #
    # You may specify an explicit list of local users to chroot() to their home
    # directory. If chroot_local_user is YES, then this list becomes a list of
    # users to NOT chroot().
    #
    #chroot_list_enable=YES
    #
    # (default follows)
    #
    #chroot_list_file=/etc/vsftpd.chroot_list
    #
    # The maximum data transfer rate permitted, in bytes per second, for
    # local authenticated users. The default is 0 (unlimited).
    #
    #local_max_rate=7200


    # Anonymus FTP user Settings
    #
    # Allow anonymous FTP?
    #
    anonymous_enable=YES
    #
    # Anonymous users will only be allowed to download files which are
    # world readable.
    #
    anon_world_readable_only=YES
    #
    # Uncomment this to allow the anonymous FTP user to upload files. This only
    # has an effect if the above global write enable is activated. Also, you will
    # obviously need to create a directory writable by the FTP user.
    #
    #anon_upload_enable=YES
    #
    # Default umask for anonymus users is 077. You may wish to change this to 022,
    # if your users expect that (022 is used by most other ftpd's)
    #
    #anon_umask=022
    #
    # Uncomment this if you want the anonymous FTP user to be able to create
    # new directories.
    #
    #anon_mkdir_write_enable=YES
    #
    # Uncomment this to enable anonymus FTP users to perform other write operations
    # like deletion and renaming.
    #
    #anon_other_write_enable=YES
    #
    # If you want, you can arrange for uploaded anonymous files to be owned by
    # a different user. Note! Using "root" for uploaded files is not
    # recommended!
    #
    #chown_uploads=YES
    #chown_username=whoever
    #
    # The maximum data transfer rate permitted, in bytes per second, for anonymous
    # authenticated users. The default is 0 (unlimited).
    #
    #anon_max_rate=7200


    # Log Settings
    #
    # Log to the syslog daemon instead of using an logfile.
    #
    syslog_enable=YES
    #
    # Uncomment this to log all FTP requests and responses.
    #
    #log_ftp_protocol=YES
    #
    # Activate logging of uploads/downloads.
    #
    #xferlog_enable=YES
    #
    # You may override where the log file goes if you like. The default is shown
    # below.
    #
    #vsftpd_log_file=/var/log/vsftpd.log
    #
    # If you want, you can have your log file in standard ftpd xferlog format.
    # Note: This disables the normal logging unless you enable dual_log_enable below.
    #
    #xferlog_std_format=YES
    #
    # You may override where the log file goes if you like. The default is shown
    # below.
    #
    #xferlog_file=/var/log/xferlog
    #
    # Enable this to have booth logfiles. Standard xferlog and vsftpd's own style log.
    #
    #dual_log_enable=YES
    #
    # Uncomment this to enable session status information in the system process listing.
    #
    #setproctitle_enable=YES

    # Transfer Settings
    #
    # Make sure PORT transfer connections originate from port 20 (ftp-data).
    #
    connect_from_port_20=YES
    #
    # You may change the default value for timing out an idle session.
    #
    #idle_session_timeout=600
    #
    # You may change the default value for timing out a data connection.
    #
    #data_connection_timeout=120
    #
    # Enable this and the server will recognise asynchronous ABOR requests. Not
    # recommended for security (the code is non-trivial). Not enabling it,
    # however, may confuse older FTP clients.
    #
    #async_abor_enable=YES
    #
    # By default the server will pretend to allow ASCII mode but in fact ignore
    # the request. Turn on the below options to have the server actually do ASCII
    # mangling on files when in ASCII mode.
    # Beware that turning on ascii_download_enable enables malicious remote parties
    # to consume your I/O resources, by issuing the command "SIZE /big/file" in
    # ASCII mode.
    # These ASCII options are split into upload and download because you may wish
    # to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
    # without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
    # on the client anyway..
    #
    #ascii_upload_enable=YES
    #ascii_download_enable=YES
    #
    # Set to NO if you want to disallow the PASV method of obtaining a data
    # connection.
    #
    #pasv_enable=NO

    # PAM setting. Do NOT change this unless you know what you do!
    #
    pam_service_name=vsftpd

    # Set listen=YES if you want vsftpd to run standalone
    #
    listen=YES

    # Set to ssl_enable=YES if you want to enable SSL
    ssl_enable=NO



    die hab ich übrigens nicht verändert seit der installation

    /var/log/rcvsftp.log ist leer
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    komisch

    wenn ich
    Code:
    nmap localhost
    mache ist er in 0.432 sek fertig
    bei
    Code:
    nmap meine_internet_IP
    braucht er ewig und bringt keine ergebnisse... hab nach ner halben stunde abgebrochen

    mit dem apache auf port 80 hab ichs auch grad probiert und hab genau des gleiche problem (aufruf über localhost geht, 'von außen' nicht)

    muss wohl doch am router liegen, irgendwie reagiert der nicht.
     
  8. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    was gitb dir den ein browser aus wenn du versuchst

    ftp://<deineip>

    ?

    bei mir is das zb so, das wenn ich versuche von meinem netzwerk aus über meine externe ip zuzugreifen, dann geht das nicht, von leuten mit ner anderen öffentlichen ip allerdings schon ;)

    bin mir ziemlich sicher das das ein NAT problem ist, allerdings solltest das bei der fritzbox gehen, hab das shcon bei nem kumpel eingerichtet


    //edit: ich würde das mal von einem anderne pc aus testen, also zb zu deinen nachbarn gehen oder so und dann von da aus auf deine externe ip mal conencten
     
  9. .mike.

    .mike. Doppel-As

    Dabei seit:
    27.08.2006
    Beiträge:
    207
    Zustimmungen:
    0
    hab mal 2 (ausschnitte von) screenshots

    [​IMG]

    und

    [​IMG]

    ich denke die portfreigabe müsste richtig eingerichtet sein.

    ein "nmap externe_ip" sagt "Host seems down"

    und wenn ich http://externe_ip eingeb kommt (zumindest im konqueror) ein timeout-fehler (apache auf port 80 läuft)
    mit ftp auf port 21 auch timeout

    hat einer ne idee wo der haken is, weil vor meiner suseneuinstallation (auch scho n ne zeit lang her) hatte ich des ganze mal laufen... :think:

    danke für jede hilfe ! :)
     
  10. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    also erstmal würde ich testen was passiert wenn du es mit


    ftp://<deine INTERNE ip>

    versuchst,

    das bei nmap nichts kommt, liegt bestimmt daran das dein router oder eine firewall portscans automatisch killt. (das is sicherer ;) )
     
  11. .mike.

    .mike. Doppel-As

    Dabei seit:
    27.08.2006
    Beiträge:
    207
    Zustimmungen:
    0
    des geht

    nur
    Code:
    ftp://<externe IP>
    
    geht ned
    ich weiß wirklich ned warum weil der router müsste richtig eingestellt sein (siehe mein letzter post)
    hat einer ne idee was ich falsch mach?
     
  12. amöbe

    amöbe Tripel-As

    Dabei seit:
    21.01.2007
    Beiträge:
    188
    Zustimmungen:
    0
    Geh mal alle möglichen firewall-Einstelleungen sowohl vom router als auch von deiner mascheine durch. es kann sein, dass dein firewall Zugriffe von localhost, in einem vertrauenswürdigem Bereich also, erkennt und die durchlässt, anderes aber blockt. Auch manche Router blocken gerne von außen (was ja irgendiwe sinn macht)

    Schau dsich ein bisschen um, wenn du es dir erlauben kannst, schalt kurz alle firewalls aus und schau ob es danach läuft... (aber machs echt nur, wenn du nichts verlieren willst, ich will keine Haftung übernehmen für irgenwelche Angriffe etc.)
     
  13. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    das das mit der externen ip, würde ich nich von dem gleichenen rechner bzw von der selben ip versuchen, wenn ich das hier bei mir für meinen homeserver versuche, geht da auch nichts, aber wenn zb mein nachbarn das versucht geht das ohne probs, also einfach mal von ner anderen externen ip verscuhen, wenn das geht haste alles richtig gemacht
     
  14. #13 zwergnase, 31.01.2007
    zwergnase

    zwergnase Grünschnabel

    Dabei seit:
    09.12.2006
    Beiträge:
    1
    Zustimmungen:
    0
    Der Zugriff vom Intranet aus auf deine nach aussen freigegebenen Dienste über die öffentliche Adresse wird nicht klappen :-(
    Wenn du auf FTP zugreifen willst, probiere mal http://www.www2ftp.de/
    Alternativ, wenn du über ddns einen festen Domainname hast, kannst du ihn in der hosts eintragen mit der internen IP als ziel (extern.mydomain.de 192.168.1.3)

    Stefan
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 .mike., 31.01.2007
    Zuletzt bearbeitet: 31.01.2007
    .mike.

    .mike. Doppel-As

    Dabei seit:
    27.08.2006
    Beiträge:
    207
    Zustimmungen:
    0
    die firewall war tatsächlich des problem
    dass ich da ned drangedacht hab...

    der apache2 läuft jetzt und ich kann auch von außen auf ihn zugreifen, musste in den http-einstellungen den firewallport öffnen.

    nur mit dem ftp-server und der firewall hab ich noch probleme, weil ich da den port in der firewall ned öffnen kann bzw. ned über yast.
    weiß einer wie ? :hilfe2:

    #edit:
    wenn ich die firewall ausschalte kann ich über http und ftp zugreifen (<-- @ zwergnase)
    vom eigenen rechner über die externe IP
    wirkich
     
  17. amöbe

    amöbe Tripel-As

    Dabei seit:
    21.01.2007
    Beiträge:
    188
    Zustimmungen:
    0
    komisch, als wenn ich versuche über meine dyndns-Adresse von meinem Computer au meinen Computer zuzugreifen geht es auch nie... allerdings von anderen Maschinen im Intranet schon.

    Um beliebige Dienste in der Firewall freizugeben, geh (in Yast->Sicherheiut & Benutzer>firewall) unten auf erweitert und dann gib bei TCP-Ports "ftp" ein.
     
Thema:

vsftpd

Die Seite wird geladen...

vsftpd - Ähnliche Themen

  1. vsftpd-Fragen

    vsftpd-Fragen: Hallo Freunde! Ich besitze seit neuestem ein Raspberry Pi und habe Raspbian als OS laufen. Nun möchte ich das Gerät über das Netzwerk...
  2. vsftpd: internet explorer problem

    vsftpd: internet explorer problem: Moin, ich hab leider ein ziemlich bescheidenes Problem. Unser FTP Server müsste mal neu gemacht werden, die config vom alten ist nicht mehr...
  3. sftp mit vsftpd und mysql

    sftp mit vsftpd und mysql: Hallo zusammen, ich möchte den vsftpd auf meinem CentOS 6 dazu bewegen a) sftp und b) den mysql zwecks virtuellen Usern zu nutzen. Bisher...
  4. vsftpd deamon beim starten permission denied

    vsftpd deamon beim starten permission denied: Hallo zusammen Ich arbeite mit einer suse VM, auf welcher vsftp eingerichtet ist. Das ganze lief ohne Probleme, ich konnte mich per FTP mit...
  5. Sicherheitsfrage vsftpd und lighttpd

    Sicherheitsfrage vsftpd und lighttpd: Hallo, ich habe auf meinem vServer bei proplay.de Ubuntu Linux 9.10 (Kernel: 2.6.18) installiert. Nun habe ich einen FTP-Server (vsftpd) und...