vsftpd kann mit keinem user einloggen (Noob alarm ;;)

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von Dmulec, 06.11.2008.

  1. Dmulec

    Dmulec Jungspund

    Dabei seit:
    06.11.2008
    Beiträge:
    14
    Zustimmungen:
    0
    Hallo, ich habe gestern einen vsftpd user installiert aber aus welchem grund auch immer kann ich mit keinem user auf dem ftp via filezilla einloggen, es kommt ständig 530 login inkorrekt. Und ja ich habe die richtigen login daten :P

    Ich bin planlos, angeblich sind meine chroot settings nicht das problem.
    Destotrotz, dies sind meine settings:
    Ich hoffe Ihr könnt mir helfen denn ich bin schon langsam am verzweifeln :(
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    mal mit nem anderen clienten versucht ?

    auf meinem proftpd-server konnte sich gestern auch jemand nicht mit filezilla anmelden, mit anderen clienten kein problem ...
     
  4. Dmulec

    Dmulec Jungspund

    Dabei seit:
    06.11.2008
    Beiträge:
    14
    Zustimmungen:
    0
    Habs nun mit WSFTP LE und SmartFTP versucht, selber fehler :(
     
  5. #4 aspire_5652, 06.11.2008
    aspire_5652

    aspire_5652 Tripel-As

    Dabei seit:
    02.01.2008
    Beiträge:
    198
    Zustimmungen:
    0
    Standartmäßig macht vsftp nur anonymous FTP. Willst du dass sich lokale Nutzer anmelden dürfen, musst du die Option
    Code:
    local_enable=YES
    setzen.

    Am besten du deaktivierst anonymous FTP mit
    Code:
    anonymous_enable=NO
     
  6. #5 Dmulec, 06.11.2008
    Zuletzt bearbeitet: 06.11.2008
    Dmulec

    Dmulec Jungspund

    Dabei seit:
    06.11.2008
    Beiträge:
    14
    Zustimmungen:
    0
    Dies hatte ich schon erledigt, doch dann sagte mir gestern ein kollege es liegt am chroot das kein user zugriffsrechte hat, so habe ich gestern dann die chroot settings bearbeitet (siehe OP), aber leider geht es noch immer nicht.

    Edit: Trotzdem schonmal vielen Dank ^^
     
  7. #6 aspire_5652, 06.11.2008
    Zuletzt bearbeitet: 06.11.2008
    aspire_5652

    aspire_5652 Tripel-As

    Dabei seit:
    02.01.2008
    Beiträge:
    198
    Zustimmungen:
    0
    Unsinn, wenn ein User in sein Home-Vz gechrooted ist, darf er da zugreifen wie er will, doch soweit kommt er ja garnicht. Am chroot liegt es bestimmt nicht.

    Außerdem reicht für dein Nutzer-Login und Chroot ein:
    Code:
    local_enable=YES
    chroot_local_user=YES
    Ein
    Code:
    530 login inkorrekt
    klingt eher wie ein Login-, bzw Authentifizierungsproblem. Was sagt denn
    Code:
    tail -f /var/log/vsftpd.log
    beim gleichzeitigen Verbinden? Hat denn das verbinden schonmal ohne deine chroot-Schalter schonmal geklappt?

    btw wie wird sich verbunden? Aktives oder passives FTP?
     
  8. Dmulec

    Dmulec Jungspund

    Dabei seit:
    06.11.2008
    Beiträge:
    14
    Zustimmungen:
    0
    Uhm verbinden funktionierte nur als Anonymous aktiviert war, seit dem der aus ist kann man sich nicht mehr verbinden :S
    Sorry, ich bin so noob das ich es leider nicht sagen kann welches FTP gewählt wird, es ist die einstellung "Standard" bei FileZilla.

    Und uhm tail -f /var/log/vsftpd.log gibt folgendes aus
    Code:
    Thu Nov 6 12:19:14 2008 [pid 2503] CONNECT: Client "192.168.XX.XXX"
    Thu Nov 6 12:19:17 2008 [pid 2502] awesomeftp FAIL LOGIN: Client "192.168.XX.XXX"
    
    Und eine reihe weiterer dieser Fail login meldungen, der einzige unterschied ist die angegebene Zeit.

    EDIT: Nun habe ich die configs auf local_enable=YES und chroot_local_user=YES reduziert und nun kann man sich nichtmal zum Server verbinden. In den logs steht nichts darüber btw.
     
  9. #8 aspire_5652, 06.11.2008
    aspire_5652

    aspire_5652 Tripel-As

    Dabei seit:
    02.01.2008
    Beiträge:
    198
    Zustimmungen:
    0
    Du hast jetzt nicht wirklich nur diese 2 Zeilen in deiner Konfig stehen. Ich meinte dass für dein gewünschtes Verhalten: Lokale Nutzer zulassen und ein Chroot, genau diese 2 Schalter reichen.

    Passives und aktives FTP wird am Server eingestellt und nicht am Client:
    http://de.wikipedia.org/wiki/File_Transfer_Protocol#Verbindungsarten

    Poste mal deine gesamte Config.
     
  10. Dmulec

    Dmulec Jungspund

    Dabei seit:
    06.11.2008
    Beiträge:
    14
    Zustimmungen:
    0
    Leider weiss ich nicht wie ich von vi auf meinem ssh client copy paste auf die Windows umgebung übertragen kann, deswegen habe ich nun alle optionen in meiner config abgetippt.

    Vielen Dank ^^
     
  11. #10 aspire_5652, 06.11.2008
    Zuletzt bearbeitet: 06.11.2008
    aspire_5652

    aspire_5652 Tripel-As

    Dabei seit:
    02.01.2008
    Beiträge:
    198
    Zustimmungen:
    0
    hm, also Passives FTP hast du schonmal nicht explizit aktiviert, also läuft standartmäßig Aktives FTP. Das sorgt in einer Firwallumgebung immer für Schwierigkeiten, da der Client einen Port öffnen muss auf den sich der Server dann verbindet. Steht der Server in einem LAN oder im Internet? Wenn er im LAN steht dann müssten die Clients ihrer Firewall deaktiveren um sich mit FTP verbinden zu können. Besser wäre da passives FTP, dass der Server für die Datenleitung einen Port öffnet und bekannt gibt.

    Außerdem könnte es auch an dem Zertifikat liegen welches du mit angegeben hast. Möglicherweise gibt es ein Problem bei der Authentifizierung. Einfach mal die Zeile auskommentieren. Und
    Code:
    ssl_enable=NO
    setzen.

    Ich poste hier mal meine Config, nicht wundern mein vsftp wird über xinetd gestartet, deswegen steht bei LISTEN=NO

    Code:
    write_enable=YES
    dirmessage_enable=YES
    nopriv_user=ftpsecure
    ftpd_banner="Welcome to \"HEIMNETZ.ZONE\" FTP service."
    #ls_recurse_enable=YES
    #deny_email_enable=YES
    #banned_email_file=/etc/vsftpd.banned_emails
    #hide_ids=YES
    local_enable=YES
    #local_umask=022
    chroot_local_user=YES
    #chroot_list_enable=YES
    #chroot_list_file=/etc/vsftpd.chroot_list
    local_max_rate=0
    anonymous_enable=YES
    anon_world_readable_only=YES
    anon_upload_enable=NO
    #anon_umask=022
    anon_mkdir_write_enable=NO
    anon_other_write_enable=NO
    #chown_uploads=YES
    #chown_username=whoever
    #anon_max_rate=7200
    syslog_enable=NO
    log_ftp_protocol=YES
    xferlog_enable=YES
    vsftpd_log_file=/var/log/vsftpd.log
    xferlog_std_format=YES
    xferlog_file=/var/log/xferlog
    dual_log_enable=YES
    #setproctitle_enable=YES
    connect_from_port_20=YES
    #idle_session_timeout=600
    #data_connection_timeout=120
    #async_abor_enable=YES
    #ascii_upload_enable=YES
    #ascii_download_enable=YES
    pasv_enable=YES
    pasv_min_port=31245
    pasv_max_port=31255
    pam_service_name=vsftpd
    # Set listen=YES if you want vsftpd to run standalone
    listen=NO
    # Set to ssl_enable=YES if you want to enable SSL
    ssl_enable=NO
     
  12. Dmulec

    Dmulec Jungspund

    Dabei seit:
    06.11.2008
    Beiträge:
    14
    Zustimmungen:
    0
    Habe ssl auf NO gesetzt, funktioniert leider auch nicht.
    habe nun passive ftp auch aktiviert, aber trotzdessen kommt leider noch immer error 530.
     
  13. #12 aspire_5652, 06.11.2008
    aspire_5652

    aspire_5652 Tripel-As

    Dabei seit:
    02.01.2008
    Beiträge:
    198
    Zustimmungen:
    0
    Hast du auch einen Portrange für den Passive-Modus angegeben und werden diese Ports auch nach außen geöffnet (Firewall)?

    Steht der betreffende User, mit dem du dich einzuloggen versuchst vllt in der /etc/ftpusers? Da stehen alle User drin die sich nicht mit FTP verbinden dürfen.

    Ist möglicherweise das Passwort falsch? Ist denn ein Konsolenlogin möglich?

    Wenn garnix geht, dann nimm meine Config. Die geht auf jeden Fall.
     
  14. Dmulec

    Dmulec Jungspund

    Dabei seit:
    06.11.2008
    Beiträge:
    14
    Zustimmungen:
    0
    Passwort ist korrekt, jedoch shell ist deaktiviert (/bin/false) da er nur ftp zugriff haben soll, sonst nichts.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. JBR

    JBR Fichtenschonung

    Dabei seit:
    18.03.2007
    Beiträge:
    561
    Zustimmungen:
    0
    Ort:
    Nolop
    Hint: Um die config zu kopieren verwende entweder cat /pfad/zur/config und kopier die Ausgabe oder sftp (Du kannst dich damit wahrscheinlich nicht als root einloggen - das ist auch gut so - also vorher in ein entsprechendes Verzeichnis kopieren oder Berechtigungen ggf. anpassen)
     
  17. #15 aspire_5652, 06.11.2008
    aspire_5652

    aspire_5652 Tripel-As

    Dabei seit:
    02.01.2008
    Beiträge:
    198
    Zustimmungen:
    0
    Das mit "/bin/false" ist auf jeden Fall schonmal vernünftig. Was passiert wenn du nur zum testen mal eine Shell gibst?
     
Thema:

vsftpd kann mit keinem user einloggen (Noob alarm ;;)

Die Seite wird geladen...

vsftpd kann mit keinem user einloggen (Noob alarm ;;) - Ähnliche Themen

  1. vsftpd-Fragen

    vsftpd-Fragen: Hallo Freunde! Ich besitze seit neuestem ein Raspberry Pi und habe Raspbian als OS laufen. Nun möchte ich das Gerät über das Netzwerk...
  2. vsftpd: internet explorer problem

    vsftpd: internet explorer problem: Moin, ich hab leider ein ziemlich bescheidenes Problem. Unser FTP Server müsste mal neu gemacht werden, die config vom alten ist nicht mehr...
  3. sftp mit vsftpd und mysql

    sftp mit vsftpd und mysql: Hallo zusammen, ich möchte den vsftpd auf meinem CentOS 6 dazu bewegen a) sftp und b) den mysql zwecks virtuellen Usern zu nutzen. Bisher...
  4. vsftpd deamon beim starten permission denied

    vsftpd deamon beim starten permission denied: Hallo zusammen Ich arbeite mit einer suse VM, auf welcher vsftp eingerichtet ist. Das ganze lief ohne Probleme, ich konnte mich per FTP mit...
  5. Sicherheitsfrage vsftpd und lighttpd

    Sicherheitsfrage vsftpd und lighttpd: Hallo, ich habe auf meinem vServer bei proplay.de Ubuntu Linux 9.10 (Kernel: 2.6.18) installiert. Nun habe ich einen FTP-Server (vsftpd) und...