vsftpd eingerichtet! Beim FTP-Login ... Fehlermeldung ... Passwort falsch!

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von aeson, 25.04.2007.

  1. aeson

    aeson Foren As

    Dabei seit:
    25.04.2007
    Beiträge:
    86
    Zustimmungen:
    0
    Hallo,
    ich hoffe ich habe die richtige Abteilung getroffen und ich hoffe einer von euch kann mir schnell helfen.

    Ich haben auf meinem Server Debian Linux zu laufen und möchte mir einen FTP Server einrichten und verwende hierfür das Programm vsftpd. Um die Sache nicht all zu umständlich zu machen, für die Konfiguration habe ich folgende Anleitung verwendet und es hat auch alles perfekt funktioniert: http://archiv.debianhowto.de/de/vsftpd/installation_konfiguration.html

    Jetzt habe ich allerdings ein Problem an dem ich seid ca. 2 Tagen sitze. Wenn ich mich auf dem FTP mit dem eingegebenen Username und Passwort einloggen will, gibt er mir immer die Fehlermeldung raus das ich das falsche Passwort eingegeben habe. Darafhin habe ich versucht einen normalen Systembenutzer anzulegen, also nicht über den Befehl ./addftpuser sondern über den Befehl adduser aber auch das hat nicht geholfen. Daraufhin habe ich mir überlegt die LOG-Dateien von vsftpd zu enablen und hab mich noch einmal mit dem FTP connected, da ich gehofft habe das mir die LOG-Datei aufschluss über den Fehler geben kann aber auch das war ein Irrtum, denn sie sagt mir nur "FAIL LOGIN".

    Ich hoffe sehr das mir einer von euch helfen kann.
    Vielen Dank schonmal im vorraus!
    gruß aeson
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. karru

    karru OSX'ler

    Dabei seit:
    02.05.2006
    Beiträge:
    338
    Zustimmungen:
    0
    Hi,

    hast du den Benutzernamen, mit welchen du dich Verbinden möchtest, in die /etc/vsftpd.user_list eingetragen?

    gruß
     
  4. buli

    buli Debianator

    Dabei seit:
    16.09.2006
    Beiträge:
    789
    Zustimmungen:
    0
    Ort:
    Essen/Ruhrgebiet
    Editiere die /etc/passwd und entferne das "x" zwischen den beiden ": :".
    Dann solltest du dich ohne pw einloggen können.
    Dann ein neues pw setzen.

    (wobei "ftp-user" natürlich durch den Benutzernamen zu ersetzen ist)
     
  5. aeson

    aeson Foren As

    Dabei seit:
    25.04.2007
    Beiträge:
    86
    Zustimmungen:
    0
    @karru
    Ja ich habe den user unter user_list eingetragen bzw. er macht es ja eigentlich automatisch weil ich das Script auf der Seite wonach ich vsftpd eingerichtet habe benutzt habe. Aber ich hab auch nochmal nach geguckt und daran liegt es leider nicht. Der Username wird beim Login auf den FTP auch erkannt ... erst beim Passwort sagt er Access Denied

    @buli
    Das versuche ich nachher mal... muss jetzt zur Arbeit ich melde mich so gegen 21.00 Uhr nochmal hier. Wenn jemand anders noch einen Vorschlag hat dann immer gerne Posten :)

    gruß aeson
     
  6. brahma

    brahma Netzpirat

    Dabei seit:
    06.12.2005
    Beiträge:
    709
    Zustimmungen:
    0
    Ort:
    Münsterland
    Hat das Verzeichnis in das der FTP-User reinsoll, also rein /home, auch die entsprechenden Rechte? Gehört ihm das Verzeichnis nicht, sagt vsftpd nämlich auch das das Passwd falsch ist ;)
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. aeson

    aeson Foren As

    Dabei seit:
    25.04.2007
    Beiträge:
    86
    Zustimmungen:
    0
    @buli
    also das mit dem x rauslöschen funktioniert leider nicht. Ich hab nach wie vor das Problem das er mir die Fehlermeldung rausgibt. Wenn ich mich mit FlashFXP einloggen will gibt er mir folgenden text:

    [R] Connecting to XX.XX.XXX.XX -> IP=XX.XX.XXX.XX PORT=21
    [R] Connected to XX.XX.XXX.XX
    [R] 220 (vsFTPd 2.0.5)
    [R] USER mainpage
    [R] 331 Please specify the password.
    [R] PASS (hidden)
    [R] 530 Login incorrect.
    [R] Connection failed

    @brahma
    Wie meinst du das mit den enstprechenden rechten? meinst du ob die angelegten User im verzeichnis mainpage ausreichen rechte haben?
    ich habe den user mit folgendem parameter die rechte zugeteilt:
    chmod 1770 /home/$username

    gruß aeson
     
  9. #7 Kai-Behncke, 03.06.2007
    Kai-Behncke

    Kai-Behncke Grünschnabel

    Dabei seit:
    03.06.2007
    Beiträge:
    1
    Zustimmungen:
    0
    Ja, da hab ich mir auch fast die Zähne ausgebissen.

    Wenn man einen User anlegt und dann ein -s /bin/false dabei setzt,
    dann muss man den Eintrag /bin/false

    auch in der Datei /etc/shells eintragen.

    Anosnetn scheint das Login immer inkorrekt zu sein.

    Und dann muss man aufpassen, dass das jeweilige Home-Verzeichnis des Users auch definitiv genügend Rechte hat, zum Tesen ruhig mal ein 777 probieren.

    Siehe auch:
    http://www.debianforum.de/forum/viewtopic.php?t=84774
     
Thema:

vsftpd eingerichtet! Beim FTP-Login ... Fehlermeldung ... Passwort falsch!

Die Seite wird geladen...

vsftpd eingerichtet! Beim FTP-Login ... Fehlermeldung ... Passwort falsch! - Ähnliche Themen

  1. vsftpd-Fragen

    vsftpd-Fragen: Hallo Freunde! Ich besitze seit neuestem ein Raspberry Pi und habe Raspbian als OS laufen. Nun möchte ich das Gerät über das Netzwerk...
  2. vsftpd: internet explorer problem

    vsftpd: internet explorer problem: Moin, ich hab leider ein ziemlich bescheidenes Problem. Unser FTP Server müsste mal neu gemacht werden, die config vom alten ist nicht mehr...
  3. sftp mit vsftpd und mysql

    sftp mit vsftpd und mysql: Hallo zusammen, ich möchte den vsftpd auf meinem CentOS 6 dazu bewegen a) sftp und b) den mysql zwecks virtuellen Usern zu nutzen. Bisher...
  4. vsftpd deamon beim starten permission denied

    vsftpd deamon beim starten permission denied: Hallo zusammen Ich arbeite mit einer suse VM, auf welcher vsftp eingerichtet ist. Das ganze lief ohne Probleme, ich konnte mich per FTP mit...
  5. Sicherheitsfrage vsftpd und lighttpd

    Sicherheitsfrage vsftpd und lighttpd: Hallo, ich habe auf meinem vServer bei proplay.de Ubuntu Linux 9.10 (Kernel: 2.6.18) installiert. Nun habe ich einen FTP-Server (vsftpd) und...