VSFTP - Frage zu Usern

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von LordIcon, 16.04.2005.

  1. #1 LordIcon, 16.04.2005
    LordIcon

    LordIcon Eroberer

    Dabei seit:
    12.04.2005
    Beiträge:
    60
    Zustimmungen:
    0
    Hey und Hallo,

    nachdem ich das Problem mit meinem Samba Share gelöst habe, hab ich mich gleich an das nächste gemacht und zwar an die Einrichtung vom FTP-Server.

    Auf Basis von http://german.fedorausers.org//article.php...040609192749759 hab ich das auch hinbekommen und der Server funktioniert schonmal.

    Was mir da aber gerade irgendwie fehlt und ich suche ist folgendes.

    Wie lege ich einen Virtuellen User an, der nur auf das Verzeichnis /var/www/html (also das Root des Apachen) zugriff hat und dies quasie sein Homeverzeichnis ist. Das Tut von Habenix hier (http://www.fedoraforum.de/index.php?showtopic=284) hat mir da leider auch irgendwie nicht weitergeholfen bzw. ich bin mir irgendwie nicht wirklich sicher wie ich so einen Virtuellen User anlegen muss.

    Wie schaffe ich es eigentlich auf einfache Art und Weise, das alle Benutzer bis auf root die ich im System habe sich nicht per FTP anmelden können!? ALso das nur dieser zu erstellende Virtuelle User und der Root zur Sicherheit...
     
  2. Anzeige

    Schau dir mal diesen Ratgeber an. Viele Antworten inkl. passender Shell-Befehle!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Du legst nen user im system an und gibst als shell /bin/false an.

    Du kannst z.B. eine eigene Gruppe ftpuser anlegen - dann "useradd DEINUSER -G ftpuser -s /bin/false"

    Die Verzeichnisse sollten halt die entsprechenden rechte für die User haben ..


    Proftpd kann u.a. versch. Auth möglichkeiten nutzen, nicht nur die im System angelegten User....

    VSFTPD Howto -> http://de.wikibooks.org/wiki/Linux-Kompendium:_Linux_als_FTP-Server
     
  4. #3 LordIcon, 17.04.2005
    LordIcon

    LordIcon Eroberer

    Dabei seit:
    12.04.2005
    Beiträge:
    60
    Zustimmungen:
    0
    So, jetzt hab ich eine Gruppe und auch den User angelegt mittesl

    Code:
    groupadd ftpuser
    useradd -d /var/www/html/ -g ftpuser -s /sbin/false -p Passwort BenutzerName
    
    aber irgendie anmelden kann ich mich trotzdem nicht !? Bekomm da nen Fehler 530 Login Incorrect.

    Woran liegt das denn schon wieder !?
     
  5. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Hast du dir das HowTO angeschaut ?

    Notfalls mal deine Config von VSFTPD posten :)
     
  6. #5 LordIcon, 17.04.2005
    LordIcon

    LordIcon Eroberer

    Dabei seit:
    12.04.2005
    Beiträge:
    60
    Zustimmungen:
    0
    Jupp, dass hab ich mir angeschaut und danach auch eigentlich nicht wirklich einen Fehler gefunden...

    Wie gesagt, mit dem Benutzer maik funktioniert es, nur nicht mit den Virtuellen Usern maikftp ( useradd ... -s /sbin/nologin ... ) und maikftp2 ( useradd ... -s /sbin/false ... )

    Hier mal die betroffenen Dateinen für die Konfiguration...

    vsftpd.user_list
    Code:
    maik
    maikftp
    maikftp2
    

    vsftpd.ftpusers
    Code:
    root
    bin
    daemon
    adm
    lp
    sync
    shutdown
    halt
    mail
    news
    uucp
    operator
    games
    nobody
    

    vsftpd.chroot_list
    Code:
    maik
    maikftp
    maikftp2
    

    vsftpd.conf
    Code:
    anonymous_enable=YES
    local_enable=YES
    write_enable=YES
    local_umask=022
    #anon_upload_enable=YES
    #anon_mkdir_write_enable=YES
    dirmessage_enable=YES
    xferlog_enable=YES
    connect_from_port_20=YES
    #chown_uploads=YES
    #chown_username=whoever
    xferlog_file=/var/log/vsftpd.log
    xferlog_std_format=YES
    idle_session_timeout=600
    #data_connection_timeout=120
    #nopriv_user=ftpsecure
    #async_abor_enable=YES
    #ascii_upload_enable=YES
    #ascii_download_enable=YES
    ftpd_banner=Welcome to FTP service.
    #deny_email_enable=YES
    #banned_email_file=/etc/vsftpd.banned_emails
    chroot_list_enable=YES
    chroot_list_file=/etc/vsftpd.chroot_list
    #ls_recurse_enable=YES
    pam_service_name=vsftpd
    userlist_deny=NO
    userlist_enable=YES
    #enable for standalone mode
    listen=YES
    tcp_wrappers=YES
    
     
  7. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Hmmm .. hast den Serverdient restartet ?

    Kannst du mal ins log schauen ob es da eine detailiertere Fehlermeldung gibt ?
     
  8. #7 LordIcon, 17.04.2005
    LordIcon

    LordIcon Eroberer

    Dabei seit:
    12.04.2005
    Beiträge:
    60
    Zustimmungen:
    0
    Jupp, das habe ich gemacht..mehrfach mitlerweile ;-)

    Magst mir sagen, wo ich das log finde ?! vsftpd.log gibts irgendwie nicht auf meinem System, zumindestens liefert locate nichts ...
     
  9. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Schau mal in /var/log/messages ... vielleicht findest da etwas bzgl. der fehlerhaften Logins.
     
  10. #9 LordIcon, 17.04.2005
    LordIcon

    LordIcon Eroberer

    Dabei seit:
    12.04.2005
    Beiträge:
    60
    Zustimmungen:
    0
    Jupp, damt hast du Recht, in der messages finde ich folgendes:

    Code:
    Apr 17 16:21:27 localhost vsftpd(pam_unix)[4797]: authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=192.168.0.2  user=maikftp
    Aber meine Zugangsdaten die ich angegeben habe sind definitiv richtig.... ?!
     
  11. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Hmmm ... setz die passwörte doch nochmal mit "passwd USER" neu ...
     
  12. #11 LordIcon, 17.04.2005
    LordIcon

    LordIcon Eroberer

    Dabei seit:
    12.04.2005
    Beiträge:
    60
    Zustimmungen:
    0
    Mhh, jetzt versteh ich garnichts mehr :-?

    Also das mit den Passwörtern hatte ich mir so auch schon gedacht und auch über die GUI von Gnome die Passwörter bei den Usern neu gesetzt, was aber auch ncihts gebracht hat.

    Hab das jetzt einfach wie von dir geschrieben auf der Konsole gemacht und jetzt funktioniert das?! Aber wieso ist das jetzt, und wieso hat das scheinbar bei der GUI als auch beim anlegen des Benutzers nicht geklappt ?!
     
  13. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Tja, fehlersuchen kannst ja jetzt in Ruhe machen :)

    Solange es nun läuft ist es ja ok - ich erledige useradd & passwd immer nur in der konsole :)
     
  14. #13 LordIcon, 17.04.2005
    LordIcon

    LordIcon Eroberer

    Dabei seit:
    12.04.2005
    Beiträge:
    60
    Zustimmungen:
    0
    Also den benutzer hatte ich auch an der Konsole so eingerichtet, wie es im HowTo da von mir steht... ;-)

    Naja, jetzt läufts und das reicht mir für den Entwicklunsgserver vollkommen aus ;) Jetzt noch den eMail Realy einrichten und denn schauen wie weiß ich die Ports alle schließen und dicht machen muss...
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 muaddib2, 13.07.2005
    Zuletzt bearbeitet: 13.07.2005
    muaddib2

    muaddib2 Kommandozeilenenthusiast

    Dabei seit:
    17.02.2003
    Beiträge:
    15
    Zustimmungen:
    0
    Ort:
    Ostfriesland
    Jaja, der Thread ist alt und ich hab ihn über Google gefunden.
    Falls noch jemand darüber stolpert, hier die Lösung:

    Es werden von vsftp nur Benutzer akzeptiert, die sich am System einloggen können, also nicht als shell "/sbin/false" haben.

    Weiss jemand eine Lösung wie man gerade das vermeidet? Ich möchte nämlich nicht, dass die ftpuser sich am system anmelden können.

    Edit: Ich habs schon gefunden:
    In /etc/shells den Eintrag /bin/false nachtragen.
    Jetzt kann man dem User die Shell /bin/false zuweisen und vsftpd funzt.
     
  17. MHHV

    MHHV Grünschnabel

    Dabei seit:
    05.09.2005
    Beiträge:
    1
    Zustimmungen:
    0

    Ich greife jetzt auch noch einmal weit zurück.

    Also ich habe auch noch das gleiche Problem ( Debian Linux ). Erst wenn ich in der PASSWD auf /bin/sh änder kann ich mich einloggen. Vorher sagt er immer Login incorrect.

    Irgendwelche ideen ?
     
Thema:

VSFTP - Frage zu Usern

Die Seite wird geladen...

VSFTP - Frage zu Usern - Ähnliche Themen

  1. vsftpd-Fragen

    vsftpd-Fragen: Hallo Freunde! Ich besitze seit neuestem ein Raspberry Pi und habe Raspbian als OS laufen. Nun möchte ich das Gerät über das Netzwerk...
  2. Sicherheitsfrage vsftpd und lighttpd

    Sicherheitsfrage vsftpd und lighttpd: Hallo, ich habe auf meinem vServer bei proplay.de Ubuntu Linux 9.10 (Kernel: 2.6.18) installiert. Nun habe ich einen FTP-Server (vsftpd) und...
  3. vsftpd: internet explorer problem

    vsftpd: internet explorer problem: Moin, ich hab leider ein ziemlich bescheidenes Problem. Unser FTP Server müsste mal neu gemacht werden, die config vom alten ist nicht mehr...
  4. sftp mit vsftpd und mysql

    sftp mit vsftpd und mysql: Hallo zusammen, ich möchte den vsftpd auf meinem CentOS 6 dazu bewegen a) sftp und b) den mysql zwecks virtuellen Usern zu nutzen. Bisher...
  5. VSFTP Meldungen nach Besuch von googlebot

    VSFTP Meldungen nach Besuch von googlebot: Hallo, wir haben einen anonymen FTP Serverdienst. Jedesmal, wenn dieser Server angesprochen wird, stehen dann einige Einträge im Logfile. Oct...