[VM] Debian Lenny

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von seim, 02.06.2009.

  1. seim

    seim seim oder nicht seim?

    Dabei seit:
    08.09.2006
    Beiträge:
    909
    Zustimmungen:
    0
    Ort:
    /mnt/reallife
    Code:
    None of the pre-built vmmemctl modules for VMware Tools is suitable for your
    running kernel.  Do you want this program to try to build the vmmemctl module
    for your system (you need to have a C compiler installed on your system)?
    [yes]
    
    Using compiler \"/usr/bin/gcc\". Use environment variable CC to override.
    
    Your kernel was built with \"gcc\" version \"4.1.3\", while you are trying to use
    \"/usr/bin/gcc\" version \"4.3.2\". This configuration is not recommended and
    VMware Tools may crash if you\'ll continue. Please try to use exactly same
    compiler as one used for building your kernel. Do you want to go with compiler
    \"/usr/bin/gcc\" version \"4.3.2\" anyway? [no]
    Das ist mir beim Installieren der VMware Tools unter Debian 5 passiert.. Was soll ich davon halten?

    Ich mein ich hab erstmal weitergemacht ohne die Sachen wo aptitude wohl einen zu neuen gcc installiert hat, aber ohne die ganzen Maus Treiber uns sonstige Gimmicks ist ne VM recht nervig!
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. daboss

    daboss Keine Macht für niemand!

    Dabei seit:
    05.01.2007
    Beiträge:
    1.294
    Zustimmungen:
    0
    Ort:
    sydney.australia.world
    Kommt öfters vor, das man Kernelmodule mit demselben gcc kompilieren muss, mit dem auch der Kernel kompiliert wurde, zum Beispiel auch Truecrypt aus den Quellen (zumindest, wenn man 1:1 laut Tutorial vorgehen wollen würde). Warum's problematisch sein soll, weiß ich aber auch nicht so recht, hat/te mich aber auch nicht so interessiert. (Zumal der Punkt damals für mich eh unrelevant war, sonst hätt ich's nachgeguggt ;) )
     
  4. seim

    seim seim oder nicht seim?

    Dabei seit:
    08.09.2006
    Beiträge:
    909
    Zustimmungen:
    0
    Ort:
    /mnt/reallife
    Nur, das ich keine Ahnung hab wie ich genau diese Version installieren soll :hilfe2:

    Das .deb runterladen kann ich gleich ma versuchen, aber wahrscheinlich braucht der wieder 1000 >alte< Abhängigkeiten..
     
  5. #4 daboss, 02.06.2009
    Zuletzt bearbeitet: 02.06.2009
    daboss

    daboss Keine Macht für niemand!

    Dabei seit:
    05.01.2007
    Beiträge:
    1.294
    Zustimmungen:
    0
    Ort:
    sydney.australia.world
    4.1 ist schon noch in den Repos, sollte also kein Stress geben. (Dann halt einfach kurz die alte Version nach /usr/bin/gcc verlinken)

    /Edit: Wär aber schon interessant, mal zu erfahren, warum das manchmal problematisch ist/wäre, und manchmal nicht. Ich wollte eben mal fix danach suchen. Aber ich hab immer nur Beiträge gefunden, "das man das machen muss", aber nicht, warum...
     
  6. seim

    seim seim oder nicht seim?

    Dabei seit:
    08.09.2006
    Beiträge:
    909
    Zustimmungen:
    0
    Ort:
    /mnt/reallife
    Hab' mal wieder zu schnell bzw. zuwenig geguckt..

    Mit aptitude kann man direkt das Paket "gcc-4.1" runterladen. Aber gut, dass du mir sagst dass es in /usr/bin liegt ich wüsste nicht wie ich das rausbekommen soll so ganz ohne Google :D

    Naja ansonsten:

    Code:
    cd /usr/bin
    rm gcc
    ln -s gcc-4.1 gcc
    //-Linux Headers nicht vergessen zu installieren-//
    vmware-config-tools.pl
    //-Enter, Enter, Enter...-//
    rm gcc
    ls -l | grep gcc
    ln -s gcc-HÖCHSTE gcc
    
    Ende.
    Danke auf jedenfall!
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. daboss

    daboss Keine Macht für niemand!

    Dabei seit:
    05.01.2007
    Beiträge:
    1.294
    Zustimmungen:
    0
    Ort:
    sydney.australia.world
    Kein Ding :)

    A propos:
    Zum einen:
    Code:
    {-alex-|-asterix-} => [~]
    (13:14:53) [b][u]whereis[/u][/b] gcc
    gcc: /usr/bin/gcc /usr/lib/gcc /usr/share/man/man1/gcc.1.gz
    {-alex-|-asterix-} => [~]
    (13:15:38) [b][u]whereis[/u][/b] gcc-4.3
    gcc-4: /usr/bin/gcc-4.3
    
    Zum anderen... wo sucht man binaries zuerst...? ;)
     
  9. seim

    seim seim oder nicht seim?

    Dabei seit:
    08.09.2006
    Beiträge:
    909
    Zustimmungen:
    0
    Ort:
    /mnt/reallife
    Ich glaub' ich würde bei /bin anfangen ^.^

    Naja also die VMware-Tools gehen jetz zwar ".. loads perfectly into running Kernel", aber die Maus will sich trotzdem nicht selbst befreien.. warum auch immer :/

    Kann auch sein, dass die für das "neue" Debian nicht ganz ausgereift sind..
     
Thema:

[VM] Debian Lenny

Die Seite wird geladen...

[VM] Debian Lenny - Ähnliche Themen

  1. Wiederherstellen von überschriebenen Dokumenten auf debian samba

    Wiederherstellen von überschriebenen Dokumenten auf debian samba: Ich habe ein Problem. Vor Kurzem hat der Trojaner cryptologer einen Schaden eingerichtet. Glücklicherweise gab es eine Sicherung auf...
  2. Debian Samba 4.2.10+dfsg-0+deb8u3 Password wrong -Windows DC

    Debian Samba 4.2.10+dfsg-0+deb8u3 Password wrong -Windows DC: Hallo, ich habe einen debian Samba-Server mit share´s ohne Domäne aufgesetzt, d.h. "standalone". Wenn ich von Windows-Clients mit...
  3. Debian VM Klonen und parallel betreiben? Systemanpassungen

    Debian VM Klonen und parallel betreiben? Systemanpassungen: Hallo, ich habe vor eine Debian Maschine als Prototyp aufzusetzen... (als vSphere VM).... Diese Maschine will ich dann x-mal klonen und in div....
  4. LinuxDistribution: Bunsenlabs (Debian 8.2 mit Openbox)

    LinuxDistribution: Bunsenlabs (Debian 8.2 mit Openbox): Für alle die eine superschnelle minimalistische Distribution suchen, die auch auf schwachen Rechnern läuft, ich bin fündig geworden. Bin gestern...
  5. Update auf Apache >=2.4.12 unter Debian Jessie

    Update auf Apache >=2.4.12 unter Debian Jessie: Hi, aufgrund eines Bugs in Apache 2.4 benötige ich zum Deployment von Seafile unter Debian Jessie das Paket apache2 in der Version >= 2.4.12...