Verbinden auf Samba Shares nicht möglich

Dieses Thema im Forum "Samba" wurde erstellt von Mitzekotze, 19.03.2008.

  1. #1 Mitzekotze, 19.03.2008
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Servus zusammen,

    wenn ich versuche auf meine Samba Shares per smbclient zu zugreifen, bekomme ich nur diese Fehlermeldung:

    Code:
    smbclient //mitzekotze/freigaben
    Password: 
    Domain=[ARBEITSGRUPPE] OS=[Unix] Server=[Samba 3.0.28]
    Server not using user level security and no password supplied.
    tree connect failed: NT_STATUS_BAD_NETWORK_NAME
    
    Hier ist meine smb.conf:

    Code:
    [global]
    workgroup=Arbeitsgruppe
    netbios name=Mitzekotze
    server string=Mitzekotze[global]
    workgroup=Arbeitsgruppe
    netbios name=Mitzekotze
    server string=Mitzekotze
    security=share
    
    [Freigaben]
    path=/home/mitzekotze/Alles_Mögliche/Netzwerk
    guest only=yes
    guest okay=yes
    read only=no
    
    [CC Musik]
    path=/home/mitzekotze/Alles_Mögliche/Musik/CC Music
    guest only=yes
    guest okay=yes
    read only=yes
    security=share
    
    [Freigaben]
    path=/home/mitzekotze/Alles_Mögliche/Netzwerk
    guest only=yes
    guest okay=yes
    read only=no
    
    [CC Musik]
    path=/home/mitzekotze/Alles_Mögliche/Musik/CC Music
    guest only=yes
    guest okay=yes
    read only=yes
    Die erste Freigabe soll Lese und Schreibrechte für jeden ermöglichen, während die zweite Freigabe nur mit Lese Rechten versehen ist. Die oben bereits genannte Fehlermeldung erhalte ich beim Zugriff auf beide Freigaben.

    Hat jemand eine Idee wo die Fehlerquelle liegen könnte?

    Samba Version: 3.0.28A-1
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 20.03.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Ich vermute mal, dass dein Samba beim Starten einige Warnungen auswerfen dürfte, z.B., dass 'guest okay=yes' nicht korrekt ist, da es 'guest ok = yes' heissen müsste. Dadurch gibt es vermutlich Probleme bei der Authentifizierung. Per Default ist 'guest ok = no' und in diesem Fall fordert Samba ein Passwort an.
     
  4. #3 Mitzekotze, 20.03.2008
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Danke für den Hinweiß, ich habe den entsprechenden Eintrag sofort abgeändert. Leider erhalte ich noch immer die selbe Fehlermeldung wenn ich versuche auf die Freigaben zu zugreifen.
    In den Log Dateien des smbd Deamons habe ich aber folgendes gefunden:
    Code:
    [2008/03/20 08:41:08, 0] smbd/service.c:make_connection_snum(1003)
      '/home/mitzekotze/Alles_Mögliche/Netzwerk' does not exist or permission denied when connecting to [Freigaben] Error was Keine Berechtigung
    Der Ordner ist mit Lese, Schreib und Ausführ Rechten für alle drei Gruppen ausgestattet, daran kann es also nicht liegen.

    Hast du noch eine Idee woran es liegen könnte?
     
  5. #4 bitmuncher, 20.03.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Für welche 3 Gruppen? Offenbar kann der Samba-User nicht auf das Share zugreifen. Die Fehlermeldung ist da ja recht eindeutig. Da ein Umlaut im Ordnernamen ist, kann es auch sein, dass einfach der Ordnername nicht korrekt aufgelöst werden kann und der Ordner somit nicht gefunden wird. Umlaute in Datei- und Ordnernamen daher immer vermeiden, damit nicht ein falsches Encoding zu Problemen führt.
     
  6. #5 Mitzekotze, 20.03.2008
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Ich habe das ganze mal ohne einen Ordner mit Umlauten probiert und das Problem ist das selbe :/ .

    Das mit den drei Gruppen hab ich wohl ein wenig falsch ausgedrückt, ich meine damit die drei Rechte Kategorien: user, group und others.

    Ich werde mal in Richtung der Benutzerverwaltung von Samba nachschauen. Wahrscheinlich habe ich da einfach etwas nicht ganz verstanden.

    Was mich bloß wundert ist, das Samba die ganze Zeit ohne Probleme lief. Ich vermute dass, das Problem mit dem letzten Update zusammenhängt. Vielleicht hat sich ja die Syntax der smb.conf geändert.

    Na ja wie auch immer, ich melde mich falls ich etwas neues herausfinde.
     
  7. #6 Herr Nilsson, 21.03.2008
    Herr Nilsson

    Herr Nilsson Eroberer

    Dabei seit:
    21.03.2008
    Beiträge:
    62
    Zustimmungen:
    0
    Ort:
    Dortmund
    Gehen wir die Sache mal durch:

    1.) Unter Samba 3.0.28 gibt es den Befehl 'testparm'. Dieser untersucht die smb.conf-Datei und gibt nützliche Hinweise. Wie z.B. bitmuncher schon sagte, muß es 'guest ok = Yes' heißen.

    2.) testparm gibt zudem noch aus:
    Processing section "[CC Musik]"
    Global parameter security found in service section!

    Der security-Eintrag ist also global und hat in der 'service section' [CC Musik] nichts zu suchen.

    Was hast Du vor? Habe ich es richtig verstanden, daß Gäste Schreib/Lese-Rechte haben sollen, aber authentifizierte Benutzer nur lesen dürfen? Falls dem so ist, denk da lieber nochmal drüber nach!

    Falls Du beabsichtigen solltest, hier irgendwelche Fallunterscheidungen vorzunehmen, könntest Du es ohnehin nicht so machen, denn bei Samba werden sich doppelte Einträge, also auch zweimalige Einträge unter [CC Musik], verdrängen.

    Versuchen solltest Du in solchen Fällen etwas wie:
    Code:
    [global]
      config file = /etc/samba/smb.conf.%U
    
    %U wird durch den Anmeldenamen des Benutzers ersetzt. Falls dann z.B. der Benutzer 'Gast' wäre, würde Samba die Datei '/etc/samba/smb.conf.GAST' anstelle der aktuellen 'smb.conf' laden. Dort könnte eine eigenständige Konfiguration für 'Gast' vorliegen.

    Wird für einen anderen Benutzer keine passende Datei gefunden, wird wieder auf die Standard-smb.conf zurückgegriffen.

    Neben %U gibt es noch weitere Variablen, die vielleicht für dich interessanter sein könnten.
     
  8. #7 Mitzekotze, 21.03.2008
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Ich habe meine smb.conf schon mit testparm geprüft das Ergebnis davon sah folgendermaßen aus:
    Code:
    testparm /etc/samba/smb.conf
    Load smb config files from /etc/samba/smb.conf
    Processing section "[Freigaben]"
    Processing section "[CC Musik]"
    Loaded services file OK.
    Server role: ROLE_STANDALONE
    Press enter to see a dump of your service definitions
    
    [global]
            workgroup = ARBEITSGRUPPE
            server string = Mitzekotze
            security = SHARE
    
    [Freigaben]
            path = /home/mitzekotze/Alles_Moegliche/Netzwerk
            read only = No
            guest only = Yes
            guest ok = Yes
    
    [CC Musik]
            path = /home/mitzekotze/Alles_Moegliche/Musik/CC Music
            guest only = Yes
            guest ok = Yes
    Bei mir erscheint die Warnung überhaupt nicht. Kann das vielleicht an einem Versionen Unterschied liegen?

    Auf der Freigabe "Freigaben" sollte jeder im Ordner /home/mitzekotze/Alles_Moegliche/Netzwerk Schreib und Lese Rechte besitzen.
    Die Freigabe "CC Musik" sollte für jeden Benutzer Lesbar sein, aber nicht Schreibbar.
     
  9. #8 Herr Nilsson, 21.03.2008
    Zuletzt bearbeitet: 21.03.2008
    Herr Nilsson

    Herr Nilsson Eroberer

    Dabei seit:
    21.03.2008
    Beiträge:
    62
    Zustimmungen:
    0
    Ort:
    Dortmund
    Ich habe z.Z. leider keinen Zugang zu einem Samba-Server :(

    Im Blindflug wäre mein Vorschlag etwas analoges zu:
    Code:
    [global]
            workgroup = ARBEITSGRUPPE
            map to guest = bad user
            guest account = smbguest
    
    [cifs_rw]
            path = /home/cifs/rw_dir
            read only = No
            guest only = Yes
            guest ok = Yes
    
    [cifs_ro]
            path = /home/cifs/ro_dir
            guest only = Yes
            guest ok = Yes
    
    • 'map to guest = Bad User' sollte dafür sorgen, daß nur Benutzer mit ungültigem/unbekanntem Namen zum Gast werden.
    • 'guest account = smbguest' definiert den Unix-Namen für das Windows-Gastkonto. Dieser Benutzer sollte somit unter Linux bekannt sein.
    Nicht vergessen, die Linux-Verzeichnisse mit etwas wie chmod 1777 /home/cifs/rw_dir zugreifbar zu machen.

    Nebenbei: Was zeigt denn smbclient -L localhost -N an?
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    So, der Server läuft und die smb.conf scheint ok zu sein :)
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 Mitzekotze, 21.03.2008
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Code:
    map to guest = bad user
    guest account = mitzekotze
    Dank diesem Eintrag funktioniert die Freigabe nun wieder einwandfrei :) auch wenn mir die Tatsache das das Gastkonto nun unter meinem lokalem Benutzerkonto läuft ein wenig Kopfschmerzen bereitet.

    Aber auf jeden Fall erst einmal vielen Dank für deine Hilfe Nilsson :)

    (Dein Name bezieht sich nicht rein zufällig auf das Haustier eines Schwedischen Superstars? ^^ )
     
  12. #10 Herr Nilsson, 21.03.2008
    Herr Nilsson

    Herr Nilsson Eroberer

    Dabei seit:
    21.03.2008
    Beiträge:
    62
    Zustimmungen:
    0
    Ort:
    Dortmund
    Mich scheint auch jeder zu kennen :D
     
Thema:

Verbinden auf Samba Shares nicht möglich

Die Seite wird geladen...

Verbinden auf Samba Shares nicht möglich - Ähnliche Themen

  1. Domänen Computer können sich nicht mit dem Samba Share verbinden. Alle anderen schon.

    Domänen Computer können sich nicht mit dem Samba Share verbinden. Alle anderen schon.: Moin moin zusammen, ich hab da einen lustigen Effekt mit einem Samba Server als Mitgliedsserver in einer W2003 Domäne. Winbind ist konfiguriert...
  2. Arch Linux via Hamachi zu bestehendem VPN verbinden

    Arch Linux via Hamachi zu bestehendem VPN verbinden: Guten Tag zusammen! Ich betreibe zu Hause einen kleinen Server für Minecraft und samba file sharing und möchte diesen nun zu meinem bestehenden...
  3. Kontextmenü mit einem Skript verbinden

    Kontextmenü mit einem Skript verbinden: Abend, wenn ich z. B. eine simple Umwandlung eines Bildformates in ein anderes über das KDE-Kontextmenü (Servicemenü nennt es sich im KDE oder...
  4. CoreOS und Kubernetes verbinden sich zu Tectonic

    CoreOS und Kubernetes verbinden sich zu Tectonic: CoreOS Inc. will Googles Containerverwaltung Kubernetes in die Unternehmen bringen. Das Container-Betriebssystem, das stark auf Konzepten aus...
  5. debian 7.8 live mit ssh verbinden?

    debian 7.8 live mit ssh verbinden?: hallo zusammen kreige das einfach nicht hin, auf dem system ist aber der port 22 offen. weder putty noch "bitvise ssh client" können drauf...