Usb

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von pachydyptes, 15.10.2004.

  1. #1 pachydyptes, 15.10.2004
    pachydyptes

    pachydyptes Mitglied

    Dabei seit:
    08.06.2004
    Beiträge:
    46
    Zustimmungen:
    0
    Hallo,

    Ich habe das Problem, dass ich meine Digicam über USB anschließen möchte. Kann mir bitte jemand verraten, was ich wie konfigurieren muß, um die Bilder auszulesen?
    Danke
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Ohne weitere Daten kann dir keiner Helfen !
    (Digicam Typ, welche Distribution, ggf. Kernel Version, Desktop Environment (Gnome,KDE,etc) und und und )
     
  4. #3 damager, 15.10.2004
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    ....und in zukunft bitte einen "treffenderen" topic-titel wählen.

    schon mal einfach die kamera eingesteckt und /var/log/messages beobachtet? :D
     
  5. #4 pachydyptes, 15.10.2004
    pachydyptes

    pachydyptes Mitglied

    Dabei seit:
    08.06.2004
    Beiträge:
    46
    Zustimmungen:
    0
    sorry, hier die fehlenden Angaben:
    Minolta Dimage Z1, testing, 2.4er Kernel, KDE 3.2
     
  6. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Also die Cam sollte normal als Mass-Storage Device laufen ... also als USB-Laufwerk.

    Kannst du mal die Ausgabe von "dmesg" posten wenn du die Kamera ansteckst ?
     
  7. #6 pachydyptes, 15.10.2004
    pachydyptes

    pachydyptes Mitglied

    Dabei seit:
    08.06.2004
    Beiträge:
    46
    Zustimmungen:
    0
    hm, die Ausgabe von "dmesg" ist ziemlich lang, kann ich das eingrenzen?
    ich habe gerade usbview installiert, die Kamera wird angezeigt.
     
  8. #7 pachydyptes, 15.10.2004
    pachydyptes

    pachydyptes Mitglied

    Dabei seit:
    08.06.2004
    Beiträge:
    46
    Zustimmungen:
    0
    Linux version 2.4.26-1-k7 (horms@tabatha) (gcc version 3.2.3 (Debian)) #1 Tue Aug 24 14:08:24 JST 2004
    BIOS-provided physical RAM map:
    BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
    BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
    BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
    BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)
    BIOS-e820: 000000001fff0000 - 000000001fff3000 (ACPI NVS)
    BIOS-e820: 000000001fff3000 - 0000000020000000 (ACPI data)
    BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
    BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
    BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
    0MB HIGHMEM available.
    511MB LOWMEM available.
    found SMP MP-table at 000f4ae0
    hm, page 000f4000 reserved twice.
    hm, page 000f5000 reserved twice.
    hm, page 000f0000 reserved twice.
    hm, page 000f1000 reserved twice.
    On node 0 totalpages: 131056
    zone(0): 4096 pages.
    zone(1): 126960 pages.
    zone(2): 0 pages.
    ACPI: RSDP (v000 GBT ) @ 0x000f63b0
    ACPI: RSDT (v001 GBT AWRDACPI 0x42302e31 AWRD 0x01010101) @ 0x1fff3000
    ACPI: FADT (v001 GBT AWRDACPI 0x42302e31 AWRD 0x01010101) @ 0x1fff3040
    ACPI: MADT (v001 GBT AWRDACPI 0x42302e31 AWRD 0x01010101) @ 0x1fff6840
    ACPI: DSDT (v001 GBT AWRDACPI 0x00001000 MSFT 0x0100000c) @ 0x00000000
    ACPI: Local APIC address 0xfee00000
    ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
    Processor #0 Pentium(tm) Pro APIC version 16
    ACPI: LAPIC_NMI (acpi_id[0x00] dfl dfl lint[0x1])
    Using ACPI for processor (LAPIC) configuration information
    Intel MultiProcessor Specification v1.4
    Virtual Wire compatibility mode.
    OEM ID: OEM00000 Product ID: PROD00000000 APIC at: 0xFEE00000
    I/O APIC #2 Version 17 at 0xFEC00000.
    Enabling APIC mode: Flat. Using 1 I/O APICs
    Processors: 1
    Kernel command line: root=/dev/hdb1 ro
    Initializing CPU#0
    Detected 1540.488 MHz processor.
    Console: colour VGA+ 80x25
    Calibrating delay loop... 3073.63 BogoMIPS
    Memory: 511348k/524224k available (1234k kernel code, 12488k reserved, 461k data, 116k init, 0k highmem)
    Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
    Inode cache hash table entries: 32768 (order: 6, 262144 bytes)
    Mount cache hash table entries: 512 (order: 0, 4096 bytes)
    Buffer cache hash table entries: 32768 (order: 5, 131072 bytes)
    Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
    CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
    CPU: L2 Cache: 256K (64 bytes/line)
    Intel machine check architecture supported.
    Intel machine check reporting enabled on CPU#0.
    CPU: After generic, caps: 0383fbff c1c3fbff 00000000 00000000
    CPU: Common caps: 0383fbff c1c3fbff 00000000 00000000
    CPU: AMD Athlon(tm) XP 1800+ stepping 00
    Enabling fast FPU save and restore... done.
    Enabling unmasked SIMD FPU exception support... done.
    Checking 'hlt' instruction... OK.
    POSIX conformance testing by UNIFIX
    enabled ExtINT on CPU#0
    ESR value before enabling vector: 00000000
    ESR value after enabling vector: 00000000
    ENABLING IO-APIC IRQs
    Setting 2 in the phys_id_present_map
    ...changing IO-APIC physical APIC ID to 2 ... ok.
    init IO_APIC IRQs
    IO-APIC (apicid-pin) 2-0, 2-10, 2-11, 2-18, 2-20, 2-23 not connected.
    ..TIMER: vector=0x31 pin1=2 pin2=0
    number of MP IRQ sources: 24.
    number of IO-APIC #2 registers: 24.
    testing the IO APIC.......................

    IO APIC #2......
    .... register #00: 02000000
    ....... : physical APIC id: 02
    ....... : Delivery Type: 0
    ....... : LTS : 0
    .... register #01: 00178003
    ....... : max redirection entries: 0017
    ....... : PRQ implemented: 1
    ....... : IO APIC version: 0003
    .... IRQ redirection table:
    NR Log Phy Mask Trig IRR Pol Stat Dest Deli Vect:
    00 000 00 1 0 0 0 0 0 0 00
    01 001 01 0 0 0 0 0 1 1 39
    02 001 01 0 0 0 0 0 1 1 31
    03 001 01 0 0 0 0 0 1 1 41
    04 001 01 0 0 0 0 0 1 1 49
    05 001 01 0 0 0 0 0 1 1 51
    06 001 01 0 0 0 0 0 1 1 59
    07 001 01 0 0 0 0 0 1 1 61
    08 001 01 0 0 0 0 0 1 1 69
    09 001 01 0 0 0 0 0 1 1 71
    0a 000 00 1 0 0 0 0 0 0 00
    0b 000 00 1 0 0 0 0 0 0 00
    0c 001 01 0 0 0 0 0 1 1 79
    0d 001 01 0 0 0 0 0 1 1 81
    0e 001 01 0 0 0 0 0 1 1 89
    0f 001 01 0 0 0 0 0 1 1 91
    10 001 01 1 1 0 1 0 1 1 99
    11 001 01 1 1 0 1 0 1 1 A1
    12 000 00 1 0 0 0 0 0 0 00
    13 001 01 1 1 0 1 0 1 1 A9
    14 000 00 1 0 0 0 0 0 0 00
    15 001 01 1 1 0 1 0 1 1 B1
    16 001 01 1 1 0 1 0 1 1 B9
    17 000 00 1 0 0 0 0 0 0 00
    IRQ to pin mappings:
    IRQ0 -> 0:2
    IRQ1 -> 0:1
    IRQ3 -> 0:3
    IRQ4 -> 0:4
    IRQ5 -> 0:5
    IRQ6 -> 0:6
    IRQ7 -> 0:7
    IRQ8 -> 0:8
    IRQ9 -> 0:9
    IRQ12 -> 0:12
    IRQ13 -> 0:13
    IRQ14 -> 0:14
    IRQ15 -> 0:15
    IRQ16 -> 0:16
    IRQ17 -> 0:17
    IRQ19 -> 0:19
    IRQ21 -> 0:21
    IRQ22 -> 0:22
    .................................... done.
    Using local APIC timer interrupts.
    calibrating APIC timer ...
    ..... CPU clock speed is 1540.4622 MHz.
    ..... host bus clock speed is 267.9064 MHz.
    cpu: 0, clocks: 2679064, slice: 1339532
    CPU0<T0:2679056,T1:1339520,D:4,S:1339532,C:2679064>
    mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
    mtrr: detected mtrr type: Intel
    ACPI: Subsystem revision 20040326
    ACPI: Interpreter disabled.
    PCI: PCI BIOS revision 2.10 entry at 0xf9b50, last bus=1
    PCI: Using configuration type 1
    PCI: Probing PCI hardware
    PCI: ACPI tables contain no PCI IRQ routing entries
    PCI: Probing PCI hardware (bus 00)
    PCI: Using IRQ router default [1106/3189] at 00:00.0
    PCI->APIC IRQ transform: (B0,I11,P0) -> 19
    PCI->APIC IRQ transform: (B0,I12,P0) -> 16
    PCI->APIC IRQ transform: (B0,I13,P0) -> 17
    PCI->APIC IRQ transform: (B0,I13,P0) -> 17
    PCI->APIC IRQ transform: (B0,I16,P0) -> 21
    PCI->APIC IRQ transform: (B0,I16,P1) -> 21
    PCI->APIC IRQ transform: (B0,I16,P2) -> 21
    PCI->APIC IRQ transform: (B0,I16,P3) -> 19
    PCI->APIC IRQ transform: (B0,I17,P0) -> 22
    PCI->APIC IRQ transform: (B0,I17,P2) -> 22
    PCI->APIC IRQ transform: (B1,I0,P0) -> 16
    PCI: Via IRQ fixup for 00:10.0, from 10 to 5
    PCI: Via IRQ fixup for 00:10.1, from 11 to 5
    PCI: Via IRQ fixup for 00:10.2, from 10 to 5
    Linux NET4.0 for Linux 2.4
    Based upon Swansea University Computer Society NET3.039
    Initializing RT netlink socket
    Starting kswapd
    VFS: Disk quotas vdquot_6.5.1
    devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
    devfs: boot_options: 0x0
    pty: 256 Unix98 ptys configured
    Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI enabled
    ttyS00 at 0x03f8 (irq = 4) is a 16550A
    ttyS01 at 0x02f8 (irq = 3) is a 16550A
    COMX: driver version 0.85 (C) 1995-1999 ITConsult-Pro Co. <info@itc.hu>
    RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
    Initializing Cryptographic API
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP: routing cache hash table of 4096 buckets, 32Kbytes
    TCP: Hash tables configured (established 32768 bind 65536)
    Linux IP multicast router 0.06 plus PIM-SM
    RAMDISK: cramfs filesystem found at block 0
    RAMDISK: Loading 4196 blocks [1 disk] into ram disk... done.
    Freeing initrd memory: 4196k freed
    VFS: Mounted root (cramfs filesystem).
    Freeing unused kernel memory: 116k freed
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
    Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    ide: late registration of driver.
    VP_IDE: IDE controller at PCI slot 00:11.1
    VP_IDE: chipset revision 6
    VP_IDE: not 100% native mode: will probe irqs later
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    VP_IDE: VIA vt8235 (rev 00) IDE UDMA133 controller on pci00:11.1
    ide0: BM-DMA at 0xe400-0xe407, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xe408-0xe40f, BIOS settings: hdc:DMA, hdd:DMA
    hda: SAMSUNG SV0412H, ATA DISK drive
    hdb: FUJITSU MPC3064AT, ATA DISK drive
    blk: queue e082a500, I/O limit 4095Mb (mask 0xffffffff)
    blk: queue e082a63c, I/O limit 4095Mb (mask 0xffffffff)
    hdc: MATSHITADVD-ROM SR-8588, ATAPI CD/DVD-ROM drive
    hdd: HL-DT-ST DVDRAM GSA-4082B, ATAPI CD/DVD-ROM drive
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    ide1 at 0x170-0x177,0x376 on irq 15
    hda: attached ide-disk driver.
    hda: 78242976 sectors (40060 MB) w/2048KiB Cache, CHS=77622/16/63, UDMA(100)
    hdb: attached ide-disk driver.
    hdb: 12672450 sectors (6488 MB), CHS=13410/15/63, UDMA(33)
    Partition check:
    /dev/ide/host0/bus0/target0/lun0: [PTBL] [4870/255/63] p1 p2 p4
    /dev/ide/host0/bus0/target1/lun0: [PTBL] [788/255/63] p1
    Journalled Block Device driver loaded
    kjournald starting. Commit interval 5 seconds
    EXT3-fs: mounted filesystem with ordered data mode.
    kjournald starting. Commit interval 5 seconds
    EXT3-fs: mounted filesystem with ordered data mode.
    Adding Swap: 1036180k swap-space (priority -1)
    EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,65), internal journal
    Real Time Clock Driver v1.10f
    hdc: attached ide-cdrom driver.
    hdc: ATAPI 48X DVD-ROM drive, 256kB Cache, UDMA(33)
    Uniform CD-ROM driver Revision: 3.12
    hdd: attached ide-cdrom driver.
    hdd: ATAPI 32X DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB Cache, UDMA(33)
    kjournald starting. Commit interval 5 seconds
    EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,4), internal journal
    EXT3-fs: mounted filesystem with ordered data mode.
    irda_init()
    8139too Fast Ethernet driver 0.9.26
    eth0: RealTek RTL8139 at 0xc000, 00:50:fc:9f:b7:d4, IRQ 19
    eth0: Identified 8139 chip type 'RTL-8100B/8139D'
    SCSI subsystem driver Revision: 1.00
    scsi0 : SCSI host adapter emulation for IDE ATAPI devices
    solo1: version v0.20 time 14:13:15 Aug 24 2004
    solo1: joystick port at 0xd401
    solo1: ddma base address: 0xcc00
    Via 686a/8233/8235 audio driver 1.9.1-ac3
    via82cxxx: Six channel audio available
    PCI: Setting latency timer of device 00:11.5 to 64
    ac97_codec: AC97 Audio codec, id: ALG32 (ALC650)
    via82cxxx: board #1 at 0xE800, IRQ 22
    usb.c: registered new driver usbdevfs
    usb.c: registered new driver hub
    usb-uhci.c: $Revision: 1.275 $ time 14:12:43 Aug 24 2004
    usb-uhci.c: High bandwidth mode enabled
    usb-uhci.c: USB UHCI at I/O 0xd800, IRQ 21
    usb-uhci.c: Detected 2 ports
    usb.c: new USB bus registered, assigned bus number 1
    hub.c: USB hub found
    hub.c: 2 ports detected
    usb-uhci.c: USB UHCI at I/O 0xdc00, IRQ 21
    usb-uhci.c: Detected 2 ports
    usb.c: new USB bus registered, assigned bus number 2
    hub.c: USB hub found
    hub.c: 2 ports detected
    usb-uhci.c: USB UHCI at I/O 0xe000, IRQ 21
    usb-uhci.c: Detected 2 ports
    usb.c: new USB bus registered, assigned bus number 3
    hub.c: USB hub found
    hub.c: 2 ports detected
    usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
    hub.c: new USB device 00:10.0-2, assigned address 2
    usb.c: USB device 2 (vend/prod 0x400/0x1000) is not claimed by any active driver.
    ehci_hcd 00:10.3: VIA Technologies, Inc. USB 2.0
    ehci_hcd 00:10.3: irq 19, pci mem e0969000
    usb.c: new USB bus registered, assigned bus number 4
    ehci_hcd 00:10.3: USB 2.0 enabled, EHCI 1.00, driver 2003-Dec-29/2.4
    usb.c: USB disconnect on device 00:10.0-2 address 2
    hub.c: USB hub found
    hub.c: 6 ports detected
    hub.c: new USB device 00:10.0-2, assigned address 3
    usb.c: USB device 3 (vend/prod 0x400/0x1000) is not claimed by any active driver.
    irda_init()
    8139cp: 10/100 PCI Ethernet driver v1.1 (Aug 30, 2003)
    usb.c: registered new driver usbscanner
    scanner.c: USB scanner device (0x0400/0x1000) now attached to scanner0
    scanner.c: 0.4.16:USB Scanner Driver
    eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
    parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE]
    parport0: irq 7 detected
    lp0: using parport0 (polling).
    apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16)
    hub.c: new USB device 00:10.0-1, assigned address 4
    usb.c: USB device 4 (vend/prod 0x686/0x4018) is not claimed by any active driver.
    Initializing USB Mass Storage driver...
    usb.c: registered new driver usb-storage
    scsi1 : SCSI emulation for USB Mass Storage devices
    Vendor: MINOLTA Model: DiMAGE Z1 Rev: 1.00
    Type: Direct-Access ANSI SCSI revision: 02
    WARNING: USB Mass Storage data integrity not assured
    USB Mass Storage device found at 4
    USB Mass Storage support registered.
    usb.c: USB disconnect on device 00:10.0-1 address 4
    hub.c: new USB device 00:10.0-1, assigned address 5
    WARNING: USB Mass Storage data integrity not assured
    USB Mass Storage device found at 5
    usb.c: USB disconnect on device 00:10.0-1 address 5
    hub.c: new USB device 00:10.0-1, assigned address 6
    WARNING: USB Mass Storage data integrity not assured
    USB Mass Storage device found at 6
     
  9. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    USB-Mass-Storage einbinden

    Hi,

    also offenbar wird deine Kamera tatsaechlich als Mass-Storage-Device erkannt. Um nun herauszubekommen, welche Partition du mounten musst um auf deine Kamera zuzugreifen mache folgendes:

    fdisk -l

    Der Output sollte dann etwa so aussehen:
    Code:
    Disk /dev/hda: 30.0 GB, 30005821440 bytes
    255 heads, 63 sectors/track, 3648 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/hda1              32        3070    24410767+  83  Linux
    /dev/hda2   *        3071        3647     4634752+   c  W95 FAT32 (LBA)
    /dev/hda3               1          31      248976   82  Linux swap
    
    Partition table entries are not in disk order
    
    Disk /dev/sda: 123 MB, 123207680 bytes
    16 heads, 32 sectors/track, 470 cylinders
    Units = cylinders of 512 * 512 = 262144 bytes
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1               1         470      120304    b  W95 FAT32
    
    Disk /dev/sdb: 1 MB, 1474560 bytes
    1 heads, 3 sectors/track, 960 cylinders
    Units = cylinders of 3 * 512 = 1536 bytes
    
       Device Boot      Start         End      Blocks   Id  System
    
    
    Hier waere das USB-Device sda1 vom Typ FAT32 (vfat). Um dieses zu mounten muesstest du

    mount -t vfat /dev/sda1 /mnt/camera

    machen. Natuerlich musst du das Device, den Dateisystemtyp und den Mountpoint deinem Output von fdisk entsprechend anpassen.
     
  10. #9 pachydyptes, 15.10.2004
    pachydyptes

    pachydyptes Mitglied

    Dabei seit:
    08.06.2004
    Beiträge:
    46
    Zustimmungen:
    0
    mit fdisk hatte ich schonmal versucht, das device rauszufinden. Seltsamerweise bekomme ich keine Partitionstabelle eingelesen, sondern die Aufforderung, das entsprechende device anzugeben. Nur kenne ich das ja nicht. Bei fdisk -l passiert nix...

    zamecnik:/home/zamecnik# fdisk

    Usage: fdisk [-l] [-b SSZ] [-u] device
    E.g.: fdisk /dev/hda (for the first IDE disk)
    or: fdisk /dev/sdc (for the third SCSI disk)
    or: fdisk /dev/eda (for the first PS/2 ESDI drive)
    or: fdisk /dev/rd/c0d0 or: fdisk /dev/ida/c0d0 (for RAID devices)
    ...
    zamecnik:/home/zamecnik# fdisk -l
     
  11. #10 NiceDay, 16.10.2004
    NiceDay

    NiceDay Aushilfe

    Dabei seit:
    17.05.2003
    Beiträge:
    1.314
    Zustimmungen:
    0
    Ort:
    Elmshorn
    Auch als root probiert ja?
     
  12. #11 pachydyptes, 17.10.2004
    pachydyptes

    pachydyptes Mitglied

    Dabei seit:
    08.06.2004
    Beiträge:
    46
    Zustimmungen:
    0
    Ja, das ist die Ausgabe in der root-Konsole.
     
  13. #12 tuxlin, 18.10.2004
    Zuletzt bearbeitet: 18.10.2004
    tuxlin

    tuxlin Eroberer

    Dabei seit:
    23.12.2003
    Beiträge:
    74
    Zustimmungen:
    0
    USB-Kamera ganz easy

    1. USB-Tools installieren:
    apt-get update && apt-get install usbutils usbmgr uswbview
    Dann den USB-Manager laden mit /etc/init.d/usbmgr restart.
    Ich gehe davon aus dass die nötigen Kernelmodule bereits laufen und die Kamera den USB-Masstorage-Standard einhält.

    2. usbview starten. Wenn alles o.k. ist siehtst du hier deine Digitalkamera.
    Wenn nicht checken ob usbmgr läuft und die nötigen Kernelmodule geladen sind (lsmod | grep usb_storage). Bei Bedarf Kernelmodule installierenund laden.

    3. SCSI-Devices in/dev checken. Ist /dev/sda1 da? Falls ja, alles o.k., falls nicht da mite MAKEDEV sda1 anlegen.

    4. /etc/fstab anpassen und zwar ungefähr so:
    /dev/sda1 /mnt/sda1 vfat rw,user,noauto,sync,exec,nodev,umask=000 0 0

    5. Directory anlegen mit "mkdir /mnt/sda1". Damit alle das lesen können
    Rechte ändern mit "chmod a+r /mnt/sda1" .

    6. Nun beherzt die Kamera einstecken und mounten mit
    "mount /mnt/sda1" .

    7. Wenn nun alles geklappt hat siehst du das device mit dem Befehl
    "df -h" . Das mit fdisk lässt man lieber, wenn man was falsch macht kann das nach hinten losgehen.

    Bye
    tuxlin
     
  14. #13 Atomara, 18.10.2004
    Atomara

    Atomara Debrandeter User

    Dabei seit:
    06.03.2004
    Beiträge:
    1.255
    Zustimmungen:
    0
    Ort:
    Deutschland , Nrw , Münsterland
    kann jemand was mit der meldung timeout on ep0out was anfangen ?
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 pachydyptes, 21.10.2004
    Zuletzt bearbeitet: 21.10.2004
    pachydyptes

    pachydyptes Mitglied

    Dabei seit:
    08.06.2004
    Beiträge:
    46
    Zustimmungen:
    0
    Noch 'ne Frage:

    4. /etc/fstab anpassen und zwar ungefähr so:
    /dev/sda1 /mnt/sda1 vfat rw,user,noauto,sync,exec,nodev,umask=000 0 0

    weshalb sync?

    nach df -h kommt /dev/sda1 is not a valid block device
     
  17. #15 Atomara, 21.10.2004
    Atomara

    Atomara Debrandeter User

    Dabei seit:
    06.03.2004
    Beiträge:
    1.255
    Zustimmungen:
    0
    Ort:
    Deutschland , Nrw , Münsterland
    sync ist damit die daten auf den usbspeicher sofort geschrieben , sonst wird das erst nach einem umount gemacht
     
Thema:

Usb