usb-Verwaltung zerschossen? (device does not accept adress xy)

Dieses Thema im Forum "Laufwerke / Speichermedien" wurde erstellt von gs1100muc, 10.11.2004.

  1. #1 gs1100muc, 10.11.2004
    gs1100muc

    gs1100muc Grünschnabel

    Dabei seit:
    10.11.2004
    Beiträge:
    2
    Zustimmungen:
    0
    Ort:
    Muenchen
    Hallo Forum,

    hatte letzte Woche eine USB-Festplatte (200GB) gekauft, Suse9.1 hat sie auch sofort erkannt, dann habe ich einige Daten kopiert und nach ca. 30 Minuten schien sich Suse aufgehängt zu haben, habe die Platte rausgezogen, danach hat Suse auch den Memory-Stick nicht mehr erkannt (Stick blinkt zweimal und dann dunkel),

    dmesg: "device not accepting adress 3, error -32)

    Dann habe ich mit einer anderen Anleitung Hotplug deaktiviert und wollte den vorher einwandfrei funktionierenden USB-Stick manuell mounten ( mit fstab etc. auf dev/sda1 und /media/stick), Stick blinkt zweimal und bleibt dann dunkel, und ich bekomme

    jetzt aber die Meldung "device is not a valid block device".


    Nach langem surfen bin ich inzwischen etwas schlauer zu USB, es gibt 3 Arten, USB-Geräte anzubinden:
    Hotplug (usbfs), Automounter (wie CD-Rom, subfs) und eben manuell.
    unter /proc/bus/usb werden 3 Ordner angezeigt (habe zwei USB-Sticks und die USB-Festplatte), aber alle jeweils leer bzw. Dateien mit 0B Groesse.

    Dann habe ich noch ein älteres Laptop (650MHz), der hatte die USB-Platte zunächst erkannt, dann abgebrochen, dort habe ich dann nur hotplug deaktiviert; mit manuellen mount funktioniert usb-hdd dort einwandfrei; dann Einstellungen abgeglichen mit meinem Tower, aber Fehlanzeige am Tower)
    Der PC läuft ansonsten einwandfrei und absturzfrei, einzig USB versagt seinen Dienst.
    die Module usb-storage, scsi-support etc scheinen alle korrekt geladen zu sein, finde aber keine geräte-Infos mehr zum Kingston-Stick etc.

    Frage 1:
    Gibt es eine Möglichkeit, in der Liste der erkannten Hardware die USB-Geräte zu löschen und dann per neu-Erkennung korrekt einzubinden?

    Frage 2:
    Wer hat eine Anleitung, wie ich Hotplug (bzw. Automounter) so wiederherstellen kann, dass der urspr. Zustand wieder läuft?
    Ich habe schon 20 Foren abgegrast, dieses Problem haben einige User, aber nirgends eine Lösung gefunden.
    Besten Dank für Eure Hilfe!
    Peter
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. khs

    khs Routinier

    Dabei seit:
    19.08.2004
    Beiträge:
    408
    Zustimmungen:
    0
    Gestern hatte ich erstmals einen aehnlichen Fehler. Und weisst du, wie ich es geloest habe? Das billige Reichelt-Verlaengerungs-USB-Kabel einfach wieder rausgenommen und die USB-Platte direkt mit dem mitgelieferten Kabel an den USB-Controller angeschlossen. Und siehe da - es lief wieder auf Anhieb. Allerdings wurde bei mir als Grund fuer "device not accepting address" der Error -71 mitgeliefert.
    Was ich in dem Zusammenhang auch interessant fand, war, dass Kernel 2.6.9 einfach so von sich aus die Platte erkannt hat. Ohne usb-storage und ohne scsi-Emulation (!) stellt er direkt nach dem anstoepseln die Devices /dev/ubX[0-9] zur Verfuegung. Eigentlich war ich ja neugierig, warum das ohne usb-storage geht, aber dann hat schon wieder was anderes meine Neugier gefesselt und ich weiss immer noch nicht, wieso das so ist... ;)

    -khs
     
  4. #3 gs1100muc, 10.11.2004
    gs1100muc

    gs1100muc Grünschnabel

    Dabei seit:
    10.11.2004
    Beiträge:
    2
    Zustimmungen:
    0
    Ort:
    Muenchen
    Danke für den Tip, aber mein USB-Stick geht direkt in die Buchse; habe bisher auch noch nicht gefunden, was error -32 bedeutet, aber ich lasse mir in dem Fall gerne weiterhelfen...
    Peter
     
Thema:

usb-Verwaltung zerschossen? (device does not accept adress xy)

Die Seite wird geladen...

usb-Verwaltung zerschossen? (device does not accept adress xy) - Ähnliche Themen

  1. Internetverbindung nach BleechBit zerschossen.

    Internetverbindung nach BleechBit zerschossen.: Hallo! Habe ein seltsames Problem mit der Inetverbindung. Nachdem ich, wie gewohnt BleechBit drüber laufen ließ, kann ich mich nicht mehr mitm...
  2. Paketliste zerschossen

    Paketliste zerschossen: Hi, ich glaube mir hats etwas die Abhängigkeiten und/oder so zerschossen. Ich will mir nen Terminalserver installieren, aber: # apt-get install...
  3. KDE 4.2.4 nach Update zerschossen!

    KDE 4.2.4 nach Update zerschossen!: Hallo alle zusammen, Ich hatte mein KDE über Yast unbewust auf Version 4.2.90 aktualisiert. (Installationsquellen --> Rechte Maustaste --> Alle...
  4. Debian zerschossen!! apt-get ist kaputt

    Debian zerschossen!! apt-get ist kaputt: Hallo, Ich habe ausversehen mit folgenden commando: apt-get --purge remove usbutils libusb-0.1-4 hotplug mein debian 5 zerschossen, apt-get...
  5. K-menu (KDE4) zerschossen?

    K-menu (KDE4) zerschossen?: Hallo, seit ich meinen Kubuntu-Rechner vor ein paar Tagen nicht richtig runterfahren konnte, zeigt sich folgendes Problem: K-menu ist nicht...