usb probleme...

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von dennis_, 04.07.2006.

  1. #1 dennis_, 04.07.2006
    Zuletzt bearbeitet: 04.07.2006
    dennis_

    dennis_ Jungspund

    Dabei seit:
    04.07.2006
    Beiträge:
    17
    Zustimmungen:
    0
    ich habe 2 systeme auf meinem pc, windows auf der einen festplatte und linux auf der anderen
    ich habe ein 5m usb2 kabel mit repeater, ein usb2 hub, eine cherry usb tastatur und eine ms usb maus.

    die verkabelung wie sie im windows ohne probleme 1a super funktioniert
    computer -> "5m usb2 kabel mit repeater" -> "usb2hub" -> tastatur,maus

    im linux funktioniert das so nicht fehlerfrei, wenn ich
    computer -> "5m usb2 kabel mit repeater" -> "usb2hub" -> tastatur,maus
    benutze habe ich das problem das wenn ich tippe zufaellig irgendwann ein buchstabe den ich grade tippe unendlich viele male wiederholt wird bis ich eine, egal welche taste druecke, dann hoert er auf sich zuwiederholen
    ich habe festgestellt das wenn ich die tastatur direkt an das 5musb2repeater kabel anschliesse das problem fast weg ist, in den letzten 2 wochen ist es nur 3 mal aufgetretten

    hat linux eine andere vielleicht nicht so gute fehlerkorrektur fuer die daten die ueber usb kommen und gehen?
    gibt windows mehr strom auf die usb anschluesse? (das bios im mainboard hat keine optionen fuer stromeinstellungen auf die usb ports (abit ic7))

    es ist nervig so mit linux zuarbeiten, ich will auf keinen fall wieder windows benutzen muessen
    ich weiss nicht weiter woran es liegen koennte oder was ich noch versuchen koennte
    vielleicht hat ja hier jemmand ein paar ideen



    :edit
    Jul 4 10:23:24 erster kernel: drivers/usb/input/hid-core.c: input irq status -71 received
    Jul 4 10:36:31 erster kernel: drivers/usb/input/hid-core.c: ctrl urb status -71 received
    soetwas sehe ich sehr sehr oft im syslog, eigentlich sehe ich sowas nur im syslog
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Nemesis, 04.07.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    was sagt "lsusb" ?
     
  4. #3 dennis_, 04.07.2006
    dennis_

    dennis_ Jungspund

    Dabei seit:
    04.07.2006
    Beiträge:
    17
    Zustimmungen:
    0
    ui,wusste garnicht das es lsusb gibt

    Code:
    lsusb
    Bus 005 Device 029: ID 046a:0023 Cherry GmbH Cymotion Master Linux Keyboard
    Bus 005 Device 006: ID 045e:001e Microsoft Corp. IntelliMouse Explorer
    Bus 005 Device 005: ID 04b4:6560 Cypress Semiconductor Corp. CY7C65640 USB-2.0 "TetraHub"
    Bus 005 Device 003: ID 05e3:0605 Genesys Logic, Inc. USB 2.0 Hub [ednet]
    Bus 005 Device 002: ID 05e3:0605 Genesys Logic, Inc. USB 2.0 Hub [ednet]
    Bus 005 Device 001: ID 0000:0000
    Bus 004 Device 001: ID 0000:0000
    Bus 003 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    Bus 001 Device 001: ID 0000:0000
    
    
    
     
  5. #4 Nemesis, 04.07.2006
    Zuletzt bearbeitet: 04.07.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    naja, gegen "nichtwissen" habe ich das richtige mittel: >>Link<<

    was steht in der section "inputdevice" in deiner /etc/X11/xorg.conf?
     
  6. #5 dennis_, 04.07.2006
    dennis_

    dennis_ Jungspund

    Dabei seit:
    04.07.2006
    Beiträge:
    17
    Zustimmungen:
    0
    Code:
    Section "InputDevice"
            Identifier      "Generic Keyboard"
            Driver          "kbd"
            Option          "CoreKeyboard"
            Option          "XkbRules"      "xorg"
            Option          "XkbModel"      "pc105"
            Option          "XkbLayout"     "de"
            Option          "XkbVariant"    "nodeadkeys"
    EndSection
    
    steht bei mir in der xorg.conf
    aber das besagte problem ist schon nach einer frischen nackten debian installation ohne x da
     
  7. #6 damager, 04.07.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    ich denke einfach das die kabel-länge das problem ist... direkt an der maschine passiert das nicht oder?
    die maximal-länge ist ja schon bei 5m und dadurch etwas grenzwertig....

    evtl. hast du die möglichekeit dir eine usb-line-extender auszuleihen
    wie z.b unter http://www.usb-infos.de/USB-FAQ-09000.html gezeigt. damit sollte das IMHO besser laufen.
     
  8. #7 dennis_, 04.07.2006
    Zuletzt bearbeitet: 04.07.2006
    dennis_

    dennis_ Jungspund

    Dabei seit:
    04.07.2006
    Beiträge:
    17
    Zustimmungen:
    0
    ueber den kauf eines solches line-extenders habe ich schon nachgedacht
    was ich hier habe ist ein usb2 kabel das 5m lang ist, an einem ende ist ein kleines stueck elektronik drin was das signla verstaerken soll

    das es am kabel liegt glaube ich nicht, denn unter windows funktioniert alles 1a super und ohne das beschriebene problem mit den sich zufaellig beim tippen wiederholenden buchstaben
    daher schliese ich das es am linux liegen muss weil wie gesagt es unter windows 1a super und ohne probleme funktioniert
     
  9. #8 Nemesis, 04.07.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    steck doch ie tastatur mal direkt an und probiers, wenn dann der fehler nichtmehr auftaucht, weisst du an was es hängt.
     
  10. #9 damager, 04.07.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    kann tatsächlich sein das unter linux die anschlüsse anders gepowert wirt.... diese elektronik, hat sie ein eigenesnetzteil?

    trotzdem ein test direkt am rechner würde etwas aufschluss bringen ...denn wenn direkt am rechner funtzt ...dann kann es ja nur an dem "dazwischen" liegen :]
     
  11. #10 dennis_, 04.07.2006
    dennis_

    dennis_ Jungspund

    Dabei seit:
    04.07.2006
    Beiträge:
    17
    Zustimmungen:
    0
    direkt am rechner funktioniert es ohne probleme genauso gut wie im windows
    das kabel hat kein eigenes netzteil
     
  12. #11 Nemesis, 04.07.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    ahm, soweit ich weiss liegt am usb anschluss immer gleichviel strom an, egal welches OS läuft.
    das is das lange kabel, wenns ohne problemlos geht, dann is der fall ja wohl klar, warum eigentlich ein 5m kabel? stell doch die kiste näher zu dir.
     
  13. #12 dennis_, 04.07.2006
    Zuletzt bearbeitet: 04.07.2006
    dennis_

    dennis_ Jungspund

    Dabei seit:
    04.07.2006
    Beiträge:
    17
    Zustimmungen:
    0
    mein pc steht im keller, ich habe 2dvi, usb, 2firewire und 2optische fuer ton und diverse netzwerkkabel von unten<->oben verlegt .. keine waerme und absolute ruhe (bis auf das leise surren vom tft)

    unter windows habe ich mit dem selben kabel KEINE problem
    unter linux habe ich mit dem selben kabel probleme
    daher wird es nicht am kabel liegen sondern am linux

    :edit
    muesste das repeater kabel welches ja ein kleines stueck elektronik besitzt nicht im lsusb aufgelistet werden?
     
  14. #13 Nemesis, 04.07.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    warum sollte es? so wie du beschreibst verstärkt es ja nur das signal. du brauchst ja auch keine treiber dafür.
    wenn es unter win tadellos funktioniert, dann hast du was nicht richtig eingestellt.
    schau mal was xev ausgibt.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 dennis_, 04.07.2006
    dennis_

    dennis_ Jungspund

    Dabei seit:
    04.07.2006
    Beiträge:
    17
    Zustimmungen:
    0
    aber was, was habe ich nicht richtig eingestellt .. ich habe sozusagen garnichts eingestellt weil ich von ausgehe und irgendwie auch erwarte das eine usb tastatur aufanhieb richtig funktioniert

    Code:
    xev
    Outer window is 0x3600001, inner window is 0x3600002
    
    PropertyNotify event, serial 8, synthetic NO, window 0x3600001,
        atom 0x27 (WM_NAME), time 983004403, state PropertyNewValue
    
    PropertyNotify event, serial 9, synthetic NO, window 0x3600001,
        atom 0x22 (WM_COMMAND), time 983004403, state PropertyNewValue
    
    PropertyNotify event, serial 10, synthetic NO, window 0x3600001,
        atom 0x28 (WM_NORMAL_HINTS), time 983004403, state PropertyNewValue
    
    CreateNotify event, serial 11, synthetic NO, window 0x3600001,
        parent 0x3600001, window 0x3600002, (10,10), width 50, height 50
    border_width 4, override NO
    
    MapNotify event, serial 12, synthetic NO, window 0x3600001,
        event 0x3600001, window 0x3600002, override NO
    
    PropertyNotify event, serial 15, synthetic NO, window 0x3600001,
        atom 0x164 (_KDE_NET_WM_USER_CREATION_TIME), time 983004403, state PropertyNewValue
    
    ConfigureNotify event, serial 15, synthetic NO, window 0x3600001,
        event 0x3600001, window 0x3600001, (0,0), width 178, height 178,
        border_width 0, above 0x1601a1e, override NO
    
    ReparentNotify event, serial 15, synthetic NO, window 0x3600001,
        event 0x3600001, window 0x3600001, parent 0x100b9cc,
        (0,0), override NO
    
    PropertyNotify event, serial 15, synthetic NO, window 0x3600001,
        atom 0x139 (_NET_WM_DESKTOP), time 983004407, state PropertyNewValue
    
    PropertyNotify event, serial 15, synthetic NO, window 0x3600001,
        atom 0x141 (_NET_FRAME_EXTENTS), time 983004408, state PropertyNewValue
    
    PropertyNotify event, serial 15, synthetic NO, window 0x3600001,
        atom 0xe9 (_KDE_NET_WM_FRAME_STRUT), time 983004408, state PropertyNewValue
    
    PropertyNotify event, serial 15, synthetic NO, window 0x3600001,
        atom 0x13f (_NET_WM_ALLOWED_ACTIONS), time 983004408, state PropertyNewValue
    
    PropertyNotify event, serial 15, synthetic NO, window 0x3600001,
        atom 0xe0 (_NET_WM_STATE), time 983004408, state PropertyNewValue
    
    PropertyNotify event, serial 15, synthetic NO, window 0x3600001,
        atom 0xea (WM_STATE), time 983004408, state PropertyNewValue
    
    ConfigureNotify event, serial 15, synthetic YES, window 0x3600001,
        event 0x3600001, window 0x3600001, (4,20), width 178, height 178,
        border_width 0, above 0x0, override NO
    
    MapNotify event, serial 15, synthetic NO, window 0x3600001,
        event 0x3600001, window 0x3600001, override NO
    
    VisibilityNotify event, serial 15, synthetic NO, window 0x3600001,
        state VisibilityFullyObscured
    
    FocusIn event, serial 15, synthetic NO, window 0x3600001,
        mode NotifyNormal, detail NotifyNonlinear
    
    KeymapNotify event, serial 15, synthetic NO, window 0x0,
        keys:  0   0   0   0   16  0   0   0   0   0   0   0   0   0   0   0
               0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
    
    VisibilityNotify event, serial 15, synthetic NO, window 0x3600001,
        state VisibilityUnobscured
    
    Expose event, serial 15, synthetic NO, window 0x3600001,
        (0,0), width 178, height 10, count 3
    
    Expose event, serial 15, synthetic NO, window 0x3600001,
        (0,10), width 10, height 58, count 2
    
    Expose event, serial 15, synthetic NO, window 0x3600001,
        (68,10), width 110, height 58, count 1
    
    Expose event, serial 15, synthetic NO, window 0x3600001,
        (0,68), width 178, height 110, count 0
    
    KeyRelease event, serial 27, synthetic NO, window 0x3600001,
        root 0x63, subw 0x0, time 983004462, (492,630), root:(496,650),
        state 0x10, keycode 36 (keysym 0xff0d, Return), same_screen YES,
    "   XLookupString gives 1 bytes: (0d) "
    
    PropertyNotify event, serial 30, synthetic NO, window 0x3600001,
        atom 0x13c (_NET_WM_ICON_GEOMETRY), time 983004647, state PropertyNewValue
    
    FocusOut event, serial 31, synthetic NO, window 0x3600001,
        mode NotifyNormal, detail NotifyNonlinear
    
    
    
     
  17. #15 Nemesis, 04.07.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    hm, der ausgabe zufolge hast du keine taste gedrückt, normal sieht die ausgabe einer taste so aus:
    Code:
    KeyPress event, serial 29, synthetic NO, window 0x3000001,
        root 0x5b, subw 0x0, time 983941703, (48,339), root:(66,429),
        state 0x10, keycode 28 (keysym 0x74, t), same_screen YES,
        XLookupString gives 1 bytes: (74) "t"
        XmbLookupString gives 1 bytes: (74) "t"
        XFilterEvent returns: False
    
    KeyRelease event, serial 29, synthetic NO, window 0x3000001,
        root 0x5b, subw 0x0, time 983941784, (48,339), root:(66,429),
        state 0x10, keycode 28 (keysym 0x74, t), same_screen YES,
        XLookupString gives 1 bytes: (74) "t"
     
Thema:

usb probleme...

Die Seite wird geladen...

usb probleme... - Ähnliche Themen

  1. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  2. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  3. Forscher analysieren Durchsatzprobleme im Linux-Scheduler

    Forscher analysieren Durchsatzprobleme im Linux-Scheduler: Eine Gruppe von Forschern hat Fälle identifiziert, in denen der Scheduler im Linux-Kernel falsche Entscheidungen trifft und die CPUs nicht so gut...
  4. München: LiMux als Sündenbock für IT-Probleme?

    München: LiMux als Sündenbock für IT-Probleme?: Im Münchner Stadtrat soll später in diesem Jahr erneut über den Einsatz von Linux in der Stadtverwaltung diskutiert werden. Die Grünen vermuten,...
  5. BSI-Audit findet keine akuten Probleme in OpenSSL

    BSI-Audit findet keine akuten Probleme in OpenSSL: Das Bundesamt für Sicherheit in der Informationstechnik hat OpenSSL auf seine Sicherheit untersuchen lassen. Die Analyse zeigt vor allem, dass die...