USB-Platte in /etc/fstab laden lassen

Dieses Thema im Forum "Installation & Basiskonfiguration" wurde erstellt von bsdfreak, 28.05.2006.

  1. #1 bsdfreak, 28.05.2006
    bsdfreak

    bsdfreak Mit Glied

    Dabei seit:
    09.05.2006
    Beiträge:
    51
    Zustimmungen:
    0
    Moin,

    ich versuche mich testweise an Linux. Leider nicht besonders erfolgreich. Ich möchte in /etc/fstag eine USB-Platte (vfat) mounten lassen.

    Frage Nr.1: Wie kriege ich es bewerkstelligt, dass die enthaltenen Dateien (vfat kennt das Unix-Rechtesystem ja bekanntermaßen nicht) meinem Stammuser (bsdfreak) gehören. Momentan steht hier alles auf root:root (wenn ich z.B. (vgl. Frage Nr. 2) über /etc/rc.local) manuell nachmounte.

    Frage Nr.2: Beim Bootprozeß bekomme ich "special device /dev/sdc1 does not exist". Die Platte ist zwar im Bios schon zu sehen, Linux kennt sie zu dem Zeitpunkt des Moutens scheinbar noch nicht. Ein manueller Mount klappt - dann mit "users" in /etc/fstag auch als User. Ich möchte das aber halt automatisieren.

    Ich verwende Archlinux 0.7.2 (Gimmick) mit einem selbstgebackenen 2.6.15er Kernel. Unter FreeBSD gibt es keine Probleme, dort mounted das System local devices erst, nachdem alle Platten bekannt sind. Wie kann ich das Problem umgehen, kann mir jemand weiterhelfen?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. x0r

    x0r Bitschubser

    Dabei seit:
    20.12.2005
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Berlin
    Vielleicht verhällt es sich ja mit 'Archlinux' anders als mit den meisten anderen Dists aber mit einem eintrag in: /etc/fstab. Wie Du es bereits angedeutet hast, ist es nicht moeglich Daten eines vfat-FS einer UUID zu zuordnen.
    Du koenntest nat. mal so etwas versuchen:

    Code:
    $sudo chown -vR bsdfreak:user /mnt/MyVFAT ; sudo chmod -vR 0755 /mnt/MyFAT
    Allerdings wird das meiner Meinung nach nur zu einem Fehler führen ('Operation not permitted' oder so was).
    Was das automat. mounten zum boot betr. sollte dieser Aufruf sein Übriges tun:

    Code:
    $su  -c "echo  \"/dev/sdX /mnt/vfatMEINE_PLADDE vfat rwx,auto,users 0 0\" >> /etc/fstab"
    Danach mal mit:
    Code:
    $sudo mount -a
    testweise einhaengen, wenn das LW unter dem angegebenen Mountpunkt verfuegbar ist, sollte es auch nach dem Neustart funktionieren...

    MfG

    Wenn nicht probier doch mal nach dem anstoepseln der Platte mit:

    Code:
    $dmesg | tail
    heraus zu finden wo genau das Problem liegt...

    MfG
     
Thema:

USB-Platte in /etc/fstab laden lassen

Die Seite wird geladen...

USB-Platte in /etc/fstab laden lassen - Ähnliche Themen

  1. Ubuntu - USB-Platte wird nicht erkannt

    Ubuntu - USB-Platte wird nicht erkannt: Hi miteinander, ich habe das Problem, dass meine neue 1,5 TB/USB/Platte nicht erkannt wird, die Platte ist noch nicht formatiert. In...
  2. USB-Platte defekt oder kann ich sie noch nutzen?

    USB-Platte defekt oder kann ich sie noch nutzen?: Hi, seit einiger Zeit macht mein Mybook 500GB einige Problem und ich verstehe nicht was los ist. Ein check mit fsck und den Parameter -c -v -y...
  3. USB-Platte

    USB-Platte: Hallo, wie kann ich erreichen, daß eine USB-Platte und ein USB-Stick immer auf bestimmten dev's gemountet werden? (Wir gehen mal davon aus,...
  4. USB-Platte dreht Nummerierung

    USB-Platte dreht Nummerierung: Hallo zusammen, ich hab mir mal eine USB-Platte 500GB geleistet um hier auch mal die ein oder andere Linux-Distri zu testen. Nun habe ich...
  5. Wieso mounted Kubuntu USB-Platten nicht automatisch?

    Wieso mounted Kubuntu USB-Platten nicht automatisch?: Hallo, bis vor kurzem nutzte ich noch Ubuntu 7.04 mit Gnome (so eine Art Probelauf für Linux 8) ). Beim Anstöpseln meiner externen USB-Platte...