Usb 2.0 :(

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von fudda, 21.09.2008.

  1. fudda

    fudda Grünschnabel

    Dabei seit:
    21.09.2008
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo erst mal an alle, denn ich bin neu hier. ;)

    Habe folgendes Problem:

    Windows XP Pro und Linux Mint Elyssa (quasi Ubuntu 2.6.xx Kernel) sind als Dualboot auf meinem Desktop PC installiert. Biostar TP35D2-A7 mit P35/ICH9 Chipsatz einem e8400 2GB PC800 DDR2 und einer GeForce 8600GT. Festplatte sind 80GB partitioniert in 20GB Windows 8GB Mint 2GB Sawp 50GB NTFS Shared für Daten.

    Nachdem ich Windows installiert hatte legte ich die Live CD ein und bootete. Boot screen von Mint läuft an aber bricht irgendwann ab und mündet in der BusyBox mit failre to load some devices. Kenne mich mit der BusyBox nicht aus und weiss selbst nich wie und welche Module ich nachladen soll.

    Also ausporbieren an welcher device es liegen kann. Onboard sound ausgemacht, versucht, dann IDE, dann dies und jenes und schliesslich als USB2.0 auf dem Mainboard aus war ging es. War in der Live CD drin habe installiert wie oben beschreiben und dachte mir, mit ein paar packages nachladen oder so sollte das behoben sein. (Musste natürlich PS2 Eingabegeräte verwenden) Pusteblume! Nachdem USB 2.0 wieder aktiviert war das selbe Spiel wie mit der Live CD. Wenn ich im recovery mode starte ohne splash hakts auch jedes mal bei den USB Hid treibern.

    Komischerweise wenn ich im Windoof die USB host controller deinstalliere und dann Rechner neu starte bootet Linux ganz ohne zu klagen. Kann meine schöne beleuchtete Tastatur und Lasermaus benutzen und alles ist top. Bis ich wieder ins Windows gehe und es nach dem Start automatisch die USB controller wieder installiert. Was auch gut ist, denn ich will ja meine Eingabegeräte und USB Speicher zB. benutzen. Danach startet Linux wieder nicht, erst wenn ich im Windows wieder alles runterschmeisse. Bei 10 USB Ports ist das ein ordentliches geklicke.

    Jetzt habe ich eine Idee. Kann ich nicht den Linux USB 2.0 treiber blacklisten? Immerhin musste ich das bei meinem Lappi mit dem Broadcom WLAN Treiber auch machen damit dieser nicht schon beim booten geladen wird, sondern erst nachdem Linux und ndiswrapper komplett geladen wurden. Wenn dies möglich ist, wie genau ist das zu bewerkstelligen?

    Oder gibt es eine elegantere Art das Problem zu umgehen oder gar gänzlich zu beheben?

    Habe das übrigens auch mit Daryna, Ubuntu Gutsy/Hardy und Debian...

    Bin für jede Hilfe dankbar da ich es schon gerne habe, wenn alles glatt läuft. Vielen Dank schonmal im Vorraus.

    fudda
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    du könntest einfach mal als kernel boot option "nousb" nehmen

    z.B.
    ansonsten ... die module heissen ohci_hcd (usb1.1) und ehci_hcd (eventuell auch uhci_hcd wenn du nen via oder intel chipset hast für usb2.0)

    wo man die bei ubuntu/debian blacklisted weiss ich allerdings nicht.

    zu dem generellen problem würde ich, wie es aussieht, fast eher das microsoft support center nerven ;)

    aber andere wissen da bestimmt was, habe hier auf jedenfall schon mal was ähnliches gelesen (das windows was aus/an schaltet und linux nicht damit klar kommt)
     
  4. #3 slackfan, 21.09.2008
    slackfan

    slackfan König

    Dabei seit:
    18.04.2006
    Beiträge:
    809
    Zustimmungen:
    0
    Ort:
    Bonn
  5. #4 Gast1, 21.09.2008
    Zuletzt von einem Moderator bearbeitet: 21.09.2008
    Gast1

    Gast1 Guest

    Na sowas:

    http://www.linuxmint.com/forum/viewtopic.php?f=46&t=17045

    Hat da jemand Langeweile oder nur ein schlechtes Gedächtnis?
     
  6. #5 fudda, 22.09.2008
    Zuletzt bearbeitet: 22.09.2008
    fudda

    fudda Grünschnabel

    Dabei seit:
    21.09.2008
    Beiträge:
    2
    Zustimmungen:
    0
    Sorry dachte crossposting wär nur blöd wenn man's innerhalb eines Forums macht. ^^

    Im mint bekomm ich keine Antwort. Bei launchpad: go away! und bei anderen auch nix bisher. Von daher schonmal danke für die Antworten. :)

    Nein nix mit Langeweile. Dachte damit das Problem behoben zu haben. Wenn du allerdings meinen ersten Post hier genauer durchliest dann wirst du er kennen das damit das Problem bis zu dem Punkt behoben ist, bis ich wieder Windoof boote. Danach gehts wieder nicht.

    Habe jetzt mal versucht ohne splash normal zu booten also kein recovery mode. Da hörts schon auf mit IRQ 19 : nobody cared (try boot with irqpoll option)

    irqpoll funktioniert aber auch nur dann wenn windows nicht installiert bzw. festplatte angesteckt ist von LIVE CD und auch nur nach einem BIOS reset wenn zwischen durch mal Windoof geladen war.

    habe usbhid schon geblacklisted. Hat auch nichts gebracht. Wenn ich ohne usb2.0 boote wie oben beschrieben habe ich aber auch nach dem boot kein usb 2.0 oder? Das wird wohl dazu führen das Mouse und Tasta nicht angesprochen werden.

    Es ist zum verzweifeln :(
     
Thema:

Usb 2.0 :(