Upgrade auf GCC-4.1.1 & probleme mit KDE

Dieses Thema im Forum "Gentoo" wurde erstellt von Edward Nigma, 07.10.2006.

  1. #1 Edward Nigma, 07.10.2006
    Edward Nigma

    Edward Nigma Back again!

    Dabei seit:
    30.08.2003
    Beiträge:
    1.193
    Zustimmungen:
    1
    Ort:
    Erde
    Oh man ich bin so langsam echt am verzweifeln.
    Letztes Wochenende habe ich auf GCC 4.1.1 umgestellt und seit dem geht an meinem PC so gut wie nichts mehr.
    Ich habe mich bei der Umstellung an den GCC upgrade Guide gehalten, und auch alles genaustens befolgt.
    Doch jetzt läuft so gut wie kein KDE-Programm mehr.
    Folgende Fehlermeldung erscheint immer wenn ich z.B. Kmail, Kopete oder Kcontrol starten will:
    Folgendes habe ich bereits unternommen um das Problem zu beheben.
    1. Gemäß Upgrade Guide neuen GCC installiert
    2. fix_libtool_files.sh 3.4.4 emerge -e system && emerge -e world durchlaufen, lassen was auch ohne Zwichenfälle durch lief.
    3. revdep-rebuild --library libstdc++.so.6 hat aber auch nix gebracht.
    4. wieder emerge -e system && emerge -e world lief auch durch
    5. kurz davor die Kiste aus dem Fenster zu werfen. ;)

    emerge --info:
    Normalerweise habe ich meine Probleme immer recht schnell in den Griff bekommen, aber hier bin ich jetzt echt am Ende meines Lateins. :think:
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Keruskerfürst, 07.10.2006
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    War ccache während der Umstellung auf den neuen Compiler aktiv?
     
  4. #3 Edward Nigma, 07.10.2006
    Edward Nigma

    Edward Nigma Back again!

    Dabei seit:
    30.08.2003
    Beiträge:
    1.193
    Zustimmungen:
    1
    Ort:
    Erde
    Ja, CCache aktiv. Muß aber auch dazu sagen, daß ich damit noch nie Probleme hatte.
     
  5. #4 Keruskerfürst, 07.10.2006
    Zuletzt bearbeitet: 07.10.2006
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Bei einem Upgrade des Compilers muß ccache deaktiviert sein.
    Den Cache selbst auch leeren.

    Dann sollten die Probleme auch behoben sein.
     
  6. #5 Edward Nigma, 07.10.2006
    Edward Nigma

    Edward Nigma Back again!

    Dabei seit:
    30.08.2003
    Beiträge:
    1.193
    Zustimmungen:
    1
    Ort:
    Erde
    Einen Versuch ist es Wert. :)
     
  7. #6 Edward Nigma, 08.10.2006
    Edward Nigma

    Edward Nigma Back again!

    Dabei seit:
    30.08.2003
    Beiträge:
    1.193
    Zustimmungen:
    1
    Ort:
    Erde
    So, habe das Problem lösen können, und es war mal wieder echt so einfach, daß es schon wieder kompliziert war.
    Erst den alten GCC löschen (bei mir GCC-3.4.4) und dann emerge -e system && emerge -e world und alles rennt einwandfrei.
    Da muß man erst mal drauf kommen. zumal man doch immer noch ne Weile den alten GCC installiert lassen sollte falls es zu Problemen mit dem neuen kommt. :)
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Upgrade auf GCC-4.1.1 & probleme mit KDE

Die Seite wird geladen...

Upgrade auf GCC-4.1.1 & probleme mit KDE - Ähnliche Themen

  1. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  2. Problem bei apt-get upgrade (Kali 2.0)

    Problem bei apt-get upgrade (Kali 2.0): Hi, seit paar Tagen habe ich einige Probs. Dachte es sei mal an der Zeit für ein Update und nun tauchen da einige Fehler auf: Es müssen noch 0 B...
  3. CentOS 6 to 7 Upgrade

    CentOS 6 to 7 Upgrade: Hi, hat jemand diesbezüglich Erfahrungen gemacht? Ich habe jedesmal das Problem, dass ich mir 'yum' wegschiesse. 'No module named yum...
  4. purge: nach dist-upgrade

    purge: nach dist-upgrade: Hallo, ich habe vor einiger Zeit Debian "upgegradet". Nu ist aber noch der ganze alte Müll drauf, dh. alter Kernel und sonstige Pakete. Wie kann...
  5. Motherboard (ASRock P55 Pro) upgrade.

    Motherboard (ASRock P55 Pro) upgrade.: Hallo! Ich denke über eine Aufrüstung bzw. Umrüstung meines Rechners nach, da er doch schon in die Jahre gekommen ist. Die CPU (i5 760...