Updateprobleme mir Yum

Dieses Thema im Forum "RedHat,Fedora & CentOS" wurde erstellt von Edward Nigma, 01.12.2003.

  1. #1 Edward Nigma, 01.12.2003
    Edward Nigma

    Edward Nigma Back again!

    Dabei seit:
    30.08.2003
    Beiträge:
    1.193
    Zustimmungen:
    1
    Ort:
    Erde
    Hallo :)

    Ich hab da ein kleines Problem wenn ich updates mit yum machen will. Er installiert mir glut 3.7-12.lvn.1.1.i386 nicht und bricht ab. Angeblich fehlen GPG Keys die ich aber nicht finden kann. Weiß einer ne Lösung???

    Hier noch ein Auszug:

    [root@localhost edward]# yum update
    Gathering header information file(s) from server(s)
    Server: dagRPMS Fedora Core 1
    Server: FreshRPMS Fedora Core 1
    Server: Fedora Core 1 - i386 - Base
    Server: Fedora Supplemental Packages (Stable)
    Server: Livna.org Fedora Compatible Packages (stable)
    Server: NewRPMS.sunsite.dk Fedora Core 1
    Server: Fedora Core 1 - i386 - Released Updates
    Server: Fedora Core 1 ( xcyborg / stable )
    Finding updated packages
    Downloading needed headers
    Resolving dependencies
    Dependencies resolved
    I will do the following:
    [update: mozilla-nspr 38:1.5-1.rhfc1.dag.i386]
    [update: mozilla-nss 38:1.5-1.rhfc1.dag.i386]
    [update: glut 3.7-12.lvn.1.1.i386]
    [update: mozilla-mail 38:1.5-1.rhfc1.dag.i386]
    [update: mozilla 38:1.5-1.rhfc1.dag.i386]
    [update: xchat 1:2.0.6-0.2.i386]
    Is this ok [y/N]: y
    Getting mozilla-nspr-1.5-1.rhfc1.dag.i386.rpm
    mozilla-nspr-1.5-1.rhfc1. 100% |=========================| 124 kB 00:01
    Getting mozilla-nss-1.5-1.rhfc1.dag.i386.rpm
    mozilla-nss-1.5-1.rhfc1.d 100% |=========================| 652 kB 00:11
    Getting glut-3.7-12.lvn.1.1.i386.rpm
    glut-3.7-12.lvn.1.1.i386. 100% |=========================| 81 kB 00:01
    warning: rpmts_HdrFromFdno: V3 DSA signature: NOKEY, key ID a109b1ec
    Error: Could not find the GPG Key necessary to validate pkg /var/cache/yum/livna-stable/packages/glut-3.7-12.lvn.1.1.i386.rpm
    Error: You may want to run yum clean or remove the file:
    /var/cache/yum/livna-stable/packages/glut-3.7-12.lvn.1.1.i386.rpm
    Error: You may also check that you have the correct GPG keys installed

    Ich weiß einfach nich welche Keys ich brauche oder warum yum die nicht selber sucht um die abhängigkeit aufzulösen.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. barny

    barny user

    Dabei seit:
    25.12.2002
    Beiträge:
    37
    Zustimmungen:
    0
    Hallo
    -> Error: Could not find the GPG Key necessary to validate pkg /var/cache/yum/livna-stable/packages/glut-3.7-12.lvn.1.1.i386.rpm<-Holl dir mal den key von den Server und dann mach mal rpm --import RPM-GPG-KEY.lalala. Das ganze bitte mit alle Quellen die du eingetragen hast.
     
  4. #3 Edward Nigma, 01.12.2003
    Edward Nigma

    Edward Nigma Back again!

    Dabei seit:
    30.08.2003
    Beiträge:
    1.193
    Zustimmungen:
    1
    Ort:
    Erde
    Vielen dank Barny hat alles super funktioniert. :respekt:
     
  5. co2

    co2 Grünschnabel

    Dabei seit:
    30.03.2005
    Beiträge:
    1
    Zustimmungen:
    0
    wo finde ich denn gpg keys? muss es ein bestimmter sein, oder reicht es in google einfah gpg key einzugeben und dann den nächstbesten zu nehmen?
     
  6. #5 Edward Nigma, 30.03.2005
    Edward Nigma

    Edward Nigma Back again!

    Dabei seit:
    30.08.2003
    Beiträge:
    1.193
    Zustimmungen:
    1
    Ort:
    Erde
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. antoni

    antoni Grünschnabel

    Dabei seit:
    16.08.2005
    Beiträge:
    1
    Zustimmungen:
    0
    hallo, ich habe CentOS von RedHat und kann Yum nicht installieren. Immer wenn ich den Befehl: rpm --import http://mirror.centos.org/centos/RPM-GPG-KEY- eingebe passiert gar nichts. Kann mir jemand helfen?
     
  9. dmaphy

    dmaphy Routinier

    Dabei seit:
    16.04.2004
    Beiträge:
    482
    Zustimmungen:
    0
    Ort:
    Hamburg
    du müsstest zuerst mit dem browser auf die seite gehen und die gpg-datei herunterladen.
    dann wechselst du in das verzeichnis wo die datei liegt und machst das mit dem rpm --import ..
     
Thema:

Updateprobleme mir Yum