Und noch ein Nvidia Problem

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Emess, 28.12.2007.

  1. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Ich würde mir gerne den Nvidia-Treiber installieren. doch das Problem fängt schon damit an, dass ich für meinen 2.6.22-3-686 keinen passenden Nvidia-Kernel finde.
    Wie muss ich den jetzt vorgehen? Welche Pakete muss ich installieren? Was muss ich in der xorg-conf ändern?
    Helft dem alten Sack aus der Klemme! :oldman
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Always-Godlike, 28.12.2007
    Always-Godlike

    Always-Godlike Das Freak

    Dabei seit:
    31.12.2006
    Beiträge:
    939
    Zustimmungen:
    0
    Ort:
    Saarland
    Der fragt dich doch beim Installer, ob er den Kernel selber machen soll (ich glaube es gibt keine Kernel bei NVdidia, ich finde nie einen :P), dann baut er sich selber einen, vorrausgesetzt kernel-source und gcc sind installiert. Steht aber doch alles in der Meldung drinne.
     
  4. #3 Tomekk228, 28.12.2007
    Tomekk228

    Tomekk228 Lebende Foren Legende

    Dabei seit:
    14.08.2007
    Beiträge:
    2.417
    Zustimmungen:
    0
    Ort:
    /home/tomekk/
    Meinst du Kernel Modul?

    Wenn ja, bietet der Treiber bzw die Installation Routine keine möglichkeit an ein Modul für dein Kernel zu kompilieren? Wenn ja, dann brauchst du die Kernel sources.

    Edit: Mist, always-godlike war schneller :)
     
  5. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    gcc ist installiert! Welche Kernel-source meint ihr denn? Wenn ich Kpackage auf rufe gibt es einige Nvidia-Pakete zur auswahl. Ich weiß nur nicht welche ich brauch.
     
  6. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
  7. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
  8. #7 Goodspeed, 28.12.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Code:
    aptitude install module-assistant
    m-a update
    m-a prepare
    m-a a-i nvidia
    
    So?
    Ich kann mich dunkel erinnern, dass ich Dir das gleiche schon mal geschrieben habe ...

    Btw. ... in Testing gibt es noch keine Nvidia-Treiber ... da muss man sich halt mit Unstable zufrieden geben ...
     
  9. P17

    P17 Schandensbegrenzer

    Dabei seit:
    06.12.2007
    Beiträge:
    196
    Zustimmungen:
    0
    Ort:
    Germany
    Die zu deinem Kernel passt.

    Ausser die Kernelsourcen, gar keine. (nvidia-settings wäre aber emppfehlenswert)

    Machs am besten mit
    Code:
    dpkg-reconfigure xserver-xorg
     
  10. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Jetzt kommt es mir wieder dunkel. Doch zuerst muss doch der Treiber installiert werden und ich weiß nicht welches der vielen Nvdia pakete die ich im kpackage finde nehmen muss.
     
  11. #10 Goodspeed, 28.12.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    ?? Nix da ... das macht der Module-Assi ... sofern Du die von Debian angebotenen Nvidia-Treiber möchtest ...
    Für Testing/Unstable gibt es noch keine fertigen Nvidia-Module ...
     
  12. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Wenn du den *.sh treiber installierst, musst du keine nvidia Packete aus dem Manager installieren, steht doch aber auch im Link?

    Das versteh ich jetzt gerade nicht, ist ja nichts "undebianisches" beschrieben?
     
  13. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Ich hab das mal nach der Godspeed- Methode gemacht. Hat auch alles ganz gut geklappt. Nur jetzt komm ich nur noch auf die Konsole. Da konnt ich wenigtens Feststellen, dass ind der xorg.conf immer noch Standartgrafikkarte steht.
     
  14. #13 Goodspeed, 28.12.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Na als Treiber solltest Du da schon nvidia reintippen ... ?
    Btw. ... da oben gibts nen Button "Suchen" ... mit dem kann man genau das auch machen ...
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Ich habs geschafft, aber jetzt hab englische Tastatur seht euch mal die xorg.conf an

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Sat May 26 01:04:16 PDT 2007
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
        RgbPath         "/usr/X11R6/lib/X11/rgb"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       30.0 - 110.0
        VertRefresh     50.0 - 150.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        SubSection     "Display"
            Depth       24
            Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
    EndSection
    
    
     
  17. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    bei mir sieht die keyboardconfig so aus:

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "keyboard"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "de"
    Option "XkbVariant" "nodeadkeys"
    EndSection
     
Thema:

Und noch ein Nvidia Problem

Die Seite wird geladen...

Und noch ein Nvidia Problem - Ähnliche Themen

  1. Und noch ein NVIDIA-Prob. X-Absturz bei openGL

    Und noch ein NVIDIA-Prob. X-Absturz bei openGL: Seit ich die letzten Lenny Updates installiert habe, stürzt KDE bei openGL- Anwendungen ab. Hier ist mal ein Auszug der xorg.0.log. Falls ihr...
  2. nvidia treiber installiert - dennoch probleme

    nvidia treiber installiert - dennoch probleme: Ihr seht ja warum es geht, ich lasse wow über nun wine laufen... doch ruckelt es nur vor sich hin (wohl grtafik bedingt...) hatte den nvidia...
  3. Nvidia Treiber installiert - NUR noch als ROOT einlogbar

    Nvidia Treiber installiert - NUR noch als ROOT einlogbar: Hallo zusammen, ich habe den neuen Nvidia Treiber installiert, nun kann ich mich jedoch nur noch als ROOT einloggen. Bei jedem anderen Benutzer...
  4. suse 9 und immernoch nvidia probleme!

    suse 9 und immernoch nvidia probleme!: Habe suse9 drauf und nur probs mit meiner nVidia geforce2 (onboard): als erstes Schwarzer Bildschirm beim start vom xserver; das war grad noch zu...
  5. Firefox 44 bietet nochmals versteckte Option zum Laden nicht signierter Erweiterungen

    Firefox 44 bietet nochmals versteckte Option zum Laden nicht signierter Erweiterungen: Mozillas jetzt veröffentlichter Browser Firefox 44 verhindert das Laden von nicht signierten Erweiterungen. Entgegen dem ursprünglichen Plan gibt...