Umlaute falsch nach Abspeicherung des files

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von schelli2, 24.06.2007.

  1. #1 schelli2, 24.06.2007
    schelli2

    schelli2 Jungspund

    Dabei seit:
    28.05.2006
    Beiträge:
    12
    Zustimmungen:
    0
    Hallo

    ich habe ein Problem, dass ich leider auch nach intensiver Suche in google nicht lösen kann:

    Wenn ich deutschsprachigen Programmcode in der Lernsprache KTurtle mit Umlauten im Programmcode aus dem integrierten Editor von KTurtle abspeichere, ändern sich die Umlaute in diesem Moment in andere Zeichen, z.B. ä in ä, und die Befehle werden auch nicht mehr verstanden. Unter configure editor fand ich die folgende Information:

    kate: indent-mode none; encoding utf-8;

    Der gleiche Code in Kate abgespeichert blieb unverändert.

    Vielen Dank im Voraus Peter Schellenberg
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 gropiuskalle, 24.06.2007
    Zuletzt bearbeitet: 24.06.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Genau das müsstest Du auch in Deinem KTurtle-Editor eintragen.

    Edit: Ist die Befehlssprache denn auch auf Deutsch gestellt?
     
  4. #3 schelli2, 24.06.2007
    schelli2

    schelli2 Jungspund

    Dabei seit:
    28.05.2006
    Beiträge:
    12
    Zustimmungen:
    0
    vielen Dank für die schnelle Antwort.

    Ich dachte das ist es: Unter Settings -> Advanced Settings -> Configure Editor -> Filetypes ist unter Variables eingetragen:

    kate: indent-mode none; encoding utf-8;

    Die Bedeutung der Zeile vor allem im Hinblick auf Kate ist mir nicht klar, aber ich habe auch keine andere Stelle gefunden wo ich utf-8 eintragen könnte.

    Ja, der Programmcode wird auch korrekt ausgeführt, bis man den Code abspeichert.
     
  5. #4 gropiuskalle, 24.06.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Mich wundert das hier ein wenig:

    Das ist bei zwar auch bei mir so, aber es sieht so aus, als würdest Du in einer englisch lokalisierten Systemumgebung arbeiten. Nur mal so in's Blaue getippt (weil ich ansonsten auch nicht weiter weiß), könnte es sein, dass sich dahingehend etwas verhakelt und KTurtle gar nicht das Problem ist, sondern die Lokalisierung von (vermutlich) KDE?
     
  6. #5 Wolfgang, 24.06.2007
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Hallo
    Alternativ kannst du natürlich auch die Dateien mit kate in iso8859-15 abspeichern.
    Damit sollte dann auch dein Turtle-Editor klar kommen.
    BTW UTF-8 solltest du nur dann verwenden, wenn sicher ist, dass das Zielsystem dafür auch ausgelegt ist.

    Gruß Wolfgang
     
  7. #6 schelli2, 24.06.2007
    schelli2

    schelli2 Jungspund

    Dabei seit:
    28.05.2006
    Beiträge:
    12
    Zustimmungen:
    0
    umlaute

    Hallo vielen Dank für die Ratschläge, ich habe alles probiert, lokalisation mit Yast und KDE -Controlcenter auf Deutsch umgestelllt, ISO 8859-15 statt UTF-8 usw. Der Effekt bleibt der gleiche.

    Die Lösung: man muss ISO 8859-1 einstellen, alle anderen funktionieren nicht auch nicht 8859-15
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Umlaute falsch nach Abspeicherung des files

Die Seite wird geladen...

Umlaute falsch nach Abspeicherung des files - Ähnliche Themen

  1. Umlaute (ö,ä,ü) trotz UTF-8 falsch dargestellt auf Red Hat 6.3 Santiago

    Umlaute (ö,ä,ü) trotz UTF-8 falsch dargestellt auf Red Hat 6.3 Santiago: Hallo zusammen:-) Ich lese mit einem PERL-Script auf einem Linux Redhat 6.3 Server Informationen aus einem Exchange-Kalender aus. Dies...
  2. Keine Umlaute und falsche Farbe in Konsole

    Keine Umlaute und falsche Farbe in Konsole: Guten Morgen, wir haben mehrere Centos Server im Einsatz. Ich bin aber leider nicht so der Crack darin. Ich habe ein System CentOS 5.3 Final...
  3. Umlaute Filtern

    Umlaute Filtern: Hi zusammen, bin recht neu was UNIX Skripten angeht und hänge gerade bei etwas fest. Ich möchte eine Datei erstellen in welche ein Befehl kommt....
  4. Umlaute mit Grafiktool

    Umlaute mit Grafiktool: Halli, ich moechte gern ein Tool bzw eine Anwendung, mit der ich die Umlaute mit Klicks einfuegen kann. Distribution ist Knoppix.
  5. OpenSuse 12.1 KDE 4.7.2 keine Umlaute mehr

    OpenSuse 12.1 KDE 4.7.2 keine Umlaute mehr: Hallo zusammen. Ich weiß, dass dieses Thema schon oft diskutiert wurde. Allerdings verstehe ich die Problematik nicht wirklich. Seit einem Update...