UDMA Raid Controller unter SUSE 9.0

Dieses Thema im Forum "Laufwerke / Speichermedien" wurde erstellt von Preacherman, 25.12.2003.

  1. #1 Preacherman, 25.12.2003
    Preacherman

    Preacherman Grünschnabel

    Dabei seit:
    25.12.2003
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo!

    Seit einiger Zeit versuche ich (zuerst unter Suse 8.3, jetzt 9.0), einen UDMA RAID-Controller zum laufen zu kriegen. RAID ist an sich ar net wichtig, brauch nur nen externen Controller, da der onboard-Controller die Platte nicht voll erkennt (180GB).

    Bisher habe ich 2 Controller mit SIL0680 Chipsatz probiert, beide ohne Erfolg. Der Controller wird von SUSE bei der Installation nicht erkannt, manuelles Laden des Moduls SILRAID schlägt fehl (IDERAID lädt, SILRAID bricht mit Fehlermeldung ab).

    Hat jemand nen Tip, was ich falsch mache?? Oder ne Idee für einen erschwinglichen (!) Controller, der unter SUSE läuft?
    Oder mach ich eh alles falsch (jaa, ich weiß, ich hab XP auf der Platte... *g*)?

    Danke schon mal im Voraus!

    Thomas
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    gib mir mal die fehlermeldung beim laden des silraid moduls
     
  4. #3 Preacherman, 26.12.2003
    Preacherman

    Preacherman Grünschnabel

    Dabei seit:
    25.12.2003
    Beiträge:
    3
    Zustimmungen:
    0
    Die Fehlermeldung beim laden von silraid lautet schlicht: 'Failed to load module "silraid"!'
    Auf Konsole 3 zusätzlich:
    insmod silraid
    Using /modules/silraid.o
    /modules/silraid.o: init_module: No such device


    Zum Hintergrund: der primary channel des onboard-controllers ist deaktiviert, am secondary händen ein dvd und ein CD-RW. Die Platte hängt am primary master der controler card.
    Beim Booten meldet sich der controller auch und findet die platte.

    Thomas
     
  5. MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    1. versuch nocheinmal das modul zu laden und gib dann dmesg ein. dort sollte dann als letztes die entsprechende Fehlermeldung kommen, vielleicht gibt die mehr Auffschluss

    2. Ich hab ne ziemliche komische Erklärung für die ganze Sache gefunden (ich habe sie nicht kontrolliert, also unbestätigt meinerseits *g*):
    Dieser Sil680 Chipsatz ist kein "wirklicher" hardware raid chipsatz, stattdessen informiert sein bios das OS nur über das entsprechende array, so dass dieses dann per software gesteuert werden kann ...
    --> Stichwort softwareraid !?!

    3. Ich hab noch was merkwürdigeres gefunden ... ne mögliche Lösung

    "In my case, i am not even trying to use the raid function, only as a straight IDE controller... further inspection of dmesg output indicated that when the kernel tried to load the drivers for the sil680, an error to the effect of "MMIO already in use" was generated. I searched for that error on Google and discovered one other instance reported for this error with this card, and it was related to an ATI Radeon graphics card and what mode the ATI card was in when the sil680 drivers were loaded [ http://www.cs.helsinki.fi/linux/linux-kernel/2003-10/1415.html ] Since I have an ATI AIW Radeon 8500DV, I decided to re-start the install, and this time chodse the text-based install instead of the graphical modes.

    Everything went perfectly - the drivers were loaded, disks were seen, and I now have a MDK 9.1 system on my desk. I am able to use any mode I need for the display card, so it seems to only matter when the drivers are being loaded. Probably the sil680 is not smart enough to know what to do when its memory space has been pre-empted by another device, and the ATI card is... anyway, hopefully that will help some others that have this problem, but i am not sure it will for yours, since you are trying to use the raid.... good luck!"
    [from http://www.linuxquestions.org]

    also ... vielleicht kannst du ja damit was anfangen
    Viel Glück
     
  6. #5 Preacherman, 29.12.2003
    Preacherman

    Preacherman Grünschnabel

    Dabei seit:
    25.12.2003
    Beiträge:
    3
    Zustimmungen:
    0
    Danke für die Tips, werd mich gleich mal dran machen!

    Thomas
     
  7. #6 Viets, 29.12.2003
    Zuletzt bearbeitet: 29.12.2003
    Viets

    Viets Grünschnabel

    Dabei seit:
    17.11.2003
    Beiträge:
    6
    Zustimmungen:
    0
    Hi,

    Ich hab auch den RAID-Controller und auch ein Problem, darauf Linux zu installieren, bei mir ist es aber Debian nicht SUSE. Am besten du installierst SUSE erstmal auf einer Platte die nicht am Controller hängt, und kopierst das dann auf das RAID, dann funzt es, weil Linux zum Lesen des RAIDs zu bringen ist kein Problem, ich weiss nur noch nicht wie man lilo konfigurieren muss, damit ich vom RAID booten kann.

    @MTS:

    Das ist richtig, das das nur ein Software RAID Controller ist, das ist aber nicht das Problem, Software RAID heisst nur, das der Prozessor alles berechnen muss und es keinen eigenen Prozessor auf dem Controller gibt, man kauft sich aber so ein Software RAID-Controller, damit man ein plattformunäbhägiges Software RAID hat. Denn wenn ich eine Platte unter Linux mit Software RAID ausstatte, kann ich sie unter Windows nicht lesen und wenn ichs umgekehrt machen, kann ich die Platte unter Linux nicht lesen. Dafür hab ich mir den RAID-Controller gekauft.

    Mfg
    Viets
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

UDMA Raid Controller unter SUSE 9.0

Die Seite wird geladen...

UDMA Raid Controller unter SUSE 9.0 - Ähnliche Themen

  1. SATA II Platte udma mode verstellen

    SATA II Platte udma mode verstellen: Hallo! Ich habe versucht mit hdparm das acoustic und das power management und den spin down bei meiner Samsung Festplatten einzustellen und...
  2. UDMA Fehler? Bootet nicht mehr (SUSE 10.3)

    UDMA Fehler? Bootet nicht mehr (SUSE 10.3): Hallo! Ich habe gerade mein kernel auf 2.6.22.19 geupdated und jetzt hängt er sich jedes mal, wenn ich boote mit: ---------- SCSI subsystem...
  3. SATA max UDMA/133

    SATA max UDMA/133: Hallo, habe soeben CentOS5 + updates installiert. Frage: 1. Warum zeigt er mir während des Startvorganges SATA max UDMA/133 an, obwohl ich...
  4. »Tomb Raider« für Linux veröffentlicht

    »Tomb Raider« für Linux veröffentlicht: Knapp drei Jahre nach der initialen Vorstellung steht das Abenteuerspiel »Tomb Raider« auch allen Linux- und SteamOS-Spielern zur Verfügung. Tomb...
  5. RAID-fähiges Cubieboard5 rechnet mit Achtkern-CPU

    RAID-fähiges Cubieboard5 rechnet mit Achtkern-CPU: Die Cubitech Limited, ein chinesischer Mini-PC-Hersteller, hat mit dem Cubieboard5 seine Produktpalette um einen weiteren Platinenrechner...