udev rule will nicht so richtig!

Dieses Thema im Forum "Eingabegeräte" wurde erstellt von Phill, 19.12.2009.

  1. Phill

    Phill Jungspund

    Dabei seit:
    17.01.2008
    Beiträge:
    16
    Zustimmungen:
    0
    Hallo,

    Meine USB-Fernbedienung bringt mich echt noch zum verzweifeln.
    Sie hat zwei input events ( oder wie man das auch immer nennt )

    cat /proc/bus/input/devices: sagt jedenfalls folgendes dazu.

    Code:
    I: Bus=0003 Vendor=0766 Product=0204 Version=0100
    N: Name="TopSeed Tech Corp. USB IR Combo Device "
    P: Phys=usb-0000:00:04.0-1/input0
    S: Sysfs=/devices/pci0000:00/0000:00:04.0/usb2/2-1/2-1:1.0/input/input3
    U: Uniq=
    H: Handlers=kbd event3
    B: EV=120013
    B: KEY=10000 7 ff9f207a c14057ff febeffdf ffefffff ffffffff fffffffe
    B: MSC=10
    B: LED=1f
    
    I: Bus=0003 Vendor=0766 Product=0204 Version=0100
    N: Name="TopSeed Tech Corp. USB IR Combo Device "
    P: Phys=usb-0000:00:04.0-1/input1
    S: Sysfs=/devices/pci0000:00/0000:00:04.0/usb2/2-1/2-1:1.1/input/input4
    U: Uniq=
    H: Handlers=kbd mouse1 event4
    B: EV=17
    B: KEY=fc112 20d0c00 0 0 70000 0 18000 21f8 d001d804 9e0040 0 0 0
    B: REL=103
    B: MSC=10
    
    Man beachte, Handlers von input1 hat ein mouse1 und ein event4...
    Jetzt hätte ich gerne in /dev/input/ zwei symlinks einer auf (in diesem fall) event3 und einer auf event4.
    Hier meine /etc/udev/rules.d/10-lirc.rules:
    Code:
    KERNELS=="input*", ATTRS{name}=="TopSeed Tech Corp. USB IR Combo Device*", ATTRS{phys}=="usb-0000:00:04.0-*/input0", SYMLINK+="input/TS_kbd"
    KERNELS=="input*", ATTRS{name}=="TopSeed Tech Corp. USB IR Combo Device*", ATTRS{phys}=="usb-0000:00:04.0-*/input1", SYMLINK+="input/TS_mouse"
    Alles so weit wunderbar. Funktioniert auch, aber nur manchmal.
    Wenn ich udevadm trigger eingebe, liegt der link TS_mouse manchmal auf event4 und manchmal auf mouse1.
    Kann mir einer sagen welchen zusatz ich in die udev rule hinzufügen muss damit der symlink eindeutig zugeordnet werden kann!
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 slackfan, 19.12.2009
    Zuletzt bearbeitet: 19.12.2009
    slackfan

    slackfan König

    Dabei seit:
    18.04.2006
    Beiträge:
    809
    Zustimmungen:
    0
    Ort:
    Bonn
    Hallo,


    ich bin mir nicht sicher, ob das funktioniert, aber was bringt denn das Folgende?
    Code:
    KERNEL=="event[0-9]*", SUBSYSTEM=="input", \
      ATTRS{name}=="TopSeed Tech Corp. USB IR Combo Device*", \
      ATTRS{phys}=="usb-0000:00:04.0-*/input0", \
      SYMLINK+="input/TS_kbd"
    
    KERNEL=="event[0-9]*", SUBSYSTEM=="input", \
      ATTRS{name}=="TopSeed Tech Corp. USB IR Combo Device*", \
      ATTRS{phys}=="usb-0000:00:04.0-*/input1", \
      SYMLINK+="input/TS_mouse"
    
    Für zusätzliche Informationen nützlich wäre die Ausgabe von
    Code:
    udevadm info --attribute-walk --name /dev/pfad/zum/inputX
    udevadm info --attribute-walk --name /dev/pfad/zum/eventX
    
    cu
     
  4. Phill

    Phill Jungspund

    Dabei seit:
    17.01.2008
    Beiträge:
    16
    Zustimmungen:
    0
    Vielen Dank. Hat funktioniert.
     
  5. Adriel

    Adriel Grünschnabel

    Dabei seit:
    11.03.2010
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo,
    iich die Bank-Programm mit Moneyplex. Seit dem Umstieg auf Suse 11.2 (64) wird das Programm minimiert zu starten. D. h. Klicken Sie das Symbol auf dem Plasma-Bildschirm (Version 4.00.00 (bis 05.09.2009)), wird das Startfenster von Moneyplex kurz und wird dann in die Taskleiste minimiert. Um das Fenster von dort nach einem weiteren Klick öffnen erforderlich ist.
    Gibt es eine Option, um das Programm zu starten in der Regel (dh nicht minimiert) an?


    Moneyplex.desktop:

    [Desktop Entry]
    Name = Moneyplex
    Kommentar Moneyplex =
    Exec = / home / jens / Moneyplex / Moneyplex
    Icon = / home/jens/moneyplex/mpx48.png
    Terminal = 0
    Type = Application
    Categories = Application;
    Danke
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

udev rule will nicht so richtig!

Die Seite wird geladen...

udev rule will nicht so richtig! - Ähnliche Themen

  1. UDEV rules - How ?

    UDEV rules - How ?: Hallo zusammen, ich bin schon ne ganze weil am googlen, finde aber nicht die Loesung daher mal mein Post. Ich habe gerade mit OpenSuse udev...
  2. i2c udev rules

    i2c udev rules: Hallo Ich benutzt conky. Allerdings werden im fast täglichem Wechsel die i2c dev als i2c 1-0073 temp 1 bzw. i2c 0-0073 temp 1, i2c 1-0073 fan 2...
  3. eigene 10-udev rules

    eigene 10-udev rules: Hallo Ich habe nach geraumer Zeit ein neues Gentoo System aufgesetzt. Ich hatte mir die alten Configs (etc komplett) gesichert. Allerdings ist...
  4. usb Maus über udev konfigurieren

    usb Maus über udev konfigurieren: Hallo, meine usb Maus wird als drei dev angelegt.flammenflitzer olaf # lsusb Bus 002 Device 002: ID 09da:9090 A4 Tech Co., Ltd...
  5. xorg-server update: umstieg von hal auf udev -> probleme mit tastatur & maus

    xorg-server update: umstieg von hal auf udev -> probleme mit tastatur & maus: Hi also der Betreff sagt schon des meiste. Hab mein Gentoo-System seit längerer Zeit mal wieder aktualisiert, was 2 größere Änderungen mit sich...