Ubuntu Treiber für UMTS onboard

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von c4r1, 01.06.2008.

  1. c4r1

    c4r1 Grünschnabel

    Dabei seit:
    01.06.2008
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo, ich habe einen 1,5 Jahre alten Acer Travelmate 4283 Wlmi Schlepptop mit intern (SIM unterm Akku) verbauter UMTS Karte von Option Globetrotter, für die es die Originaltreiber unter ftp://ftp.work.acer-euro.com/notebook/3g/ gibt, und möchte aber dieser Hardware mit der aktuellen Version von Ubuntu (vor einigen Tagen installiert) nutzen. Ich habe schon vieles selber probiert und auch mit Erfolgt Einiges an Hardware geschafft zusätzlich zu installieren (internes WLAN zB), doch hier bin ich ratlos. HAT JEMAND EINEN TIPP, WO MAN NACH EINEM LINUXTREIBER HIERFÜR SUCHEN KÖNNTE UND WIE ICH VORGEHEN SOLLTE, DIESE UMTS KARTE ÜBERHAUPT IRGENDWO UNTER UBUNTU ZU SEHEN UND EINE DFÜ-VERBINDUNG ZU IHR HERZUSTELLEN? In der Windoof Hardware steht zu diesem Modul unter "Modems" als Bezeichnung: "GlobeTrotter Module 3G+ Modem", am Ort: "GlobeTrotter Module 3G+ Flip-Flop Bus" und als Geräteinstanzkennung: "OPTIONBUS\GTM_FF_SER\7&10386969&0&". Ich wäre für einen Tipp überaus dankbar. Aber vielleicht ist das auch einfach nicht möglich unter Linux. Ubuntu ist aber sonst so cool, wäre schade. Vielen Dank nochmal! C4R1
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 01.06.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Soweit ich weiss, benötigst du die Nozomi-Treiber, damit der Adapter mit Ubuntu läuft.

    Code:
    bitmuncher@admin-laptop:~$ apt-cache search nozomi
    nozomi-source - source for GlobeTrotter HSDPA kernel driver
    
    Da es die nur als Source gibt, wirst du deinen Kernel damit selbst patchen müssen.
     
  4. c4r1

    c4r1 Grünschnabel

    Dabei seit:
    01.06.2008
    Beiträge:
    8
    Zustimmungen:
    0
    umts ü. gnome ppp verbunden, aber ist das richtig?

    lb. bitmuncher, danke für den Post! Ich konnte über Gnome PPP eine Verbindung herstellen mit folgendem Protokoll (kompletter Mittschnitt):

    --> Ignoring malformed input line: ";Do NOT edit this file by hand!"
    --> WvDial: Internet dialer version 1.60
    --> Cannot get information for serial port.
    --> Initializing modem.
    --> Sending: ATZ
    ATZ
    OK
    --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    OK
    --> Modem initialized.
    --> Sending: ATM0L0DT*99#
    --> Waiting for carrier.
    ATM0L0DT*99#
    CONNECT 1800000
    --> Carrier detected. Waiting for prompt.
    --> Don't know what to do! Starting pppd and hoping for the best.
    --> Starting pppd at Wed Jun 4 23:13:45 2008
    --> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
    --> --> PAP (Password Authentication Protocol) may be flaky.
    --> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
    --> --> CHAP (Challenge Handshake) may be flaky.
    --> Pid of pppd: 6200
    --> Using interface ppp0
    --> local IP address 88.128.5.157
    --> remote IP address 10.64.64.64
    --> primary DNS address 193.254.160.1
    --> secondary DNS address 193.254.160.130

    Sollte ich denn versuchen, dies besser oder anders hinzukriegen?
    --- --- ---
    apt-cache search nozomi zeigt mir dann an:

    nozomi-source - source for GlobeTrotter HSDPA kernel driver
    --- --- ---
    c4r1@c4r1-laptop:~$ lsusb zeigt komplett an:
    Bus 005 Device 001: ID 0000:0000
    Bus 004 Device 002: ID 0af0:6500 Option
    Bus 004 Device 001: ID 0000:0000
    Bus 003 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    Bus 001 Device 001: ID 0000:0000
    -----------------------------------------------------------------------------------------------------------------------
    c4r1@c4r1-laptop:~$ lspci zeigt u. a. an:
    00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
    00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
    00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
    00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
    00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
    (...)
    -----------------------------------------------------------------------------------------------------------------------
    c4r1@c4r1-laptop:~$ dmesg zeigt u. a. an:
    (...)
    [ 35.622108] /build/buildd/linux-2.6.24/drivers/usb/serial/usb-serial.c: USB Serial support registered for GSM modem (1-port)
    [ 35.622150] option 4-2:1.0: GSM modem (1-port) converter detected
    [ 35.622321] usb 4-2: GSM modem (1-port) converter now attached to ttyUSB0
    [ 35.622336] option 4-2:1.1: GSM modem (1-port) converter detected
    [ 35.622438] usb 4-2: GSM modem (1-port) converter now attached to ttyUSB1
    [ 35.622452] option 4-2:1.2: GSM modem (1-port) converter detected
    [ 35.622554] usb 4-2: GSM modem (1-port) converter now attached to ttyUSB2
    [ 35.622570] usbcore: registered new interface driver option
    [ 35.622574] /build/buildd/linux-2.6.24/drivers/usb/serial/option.c: USB Driver for GSM modems: v0.7.1
    (...)
    [ 104.031948] PPP generic driver version 2.4.2
    [ 104.167128] PPP BSD Compression module registered
    [ 104.233210] PPP Deflate Compression module registered
    (...)
    --- --- ---
    Verwende ich nun falsche Kanäle (UMTS-Internetverbindung steht aber) oder eine nicht optimale Verbindungsmodamiltät, oder hab ich mein Ziel bestmöglich erreicht? Nochmal herzlichen Dank, C4R1
     
  5. #4 bitmuncher, 05.06.2008
    Zuletzt bearbeitet: 05.06.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Also offenbar wurde der Treiber korrekt geladen, fraglich ist nur, ob die Karte mit dem Standard-Treiber klarkommt, der ja offenbar verwendet wird. Das Verbindungsprotokoll sieht allerdings gut aus, bis auf die Meldung 'Could not modify /etc/ppp/chap-secrets: Permission denied', die darauf hinweist, dass du für den Verbindungsaufbau keine root-Rechte angenommen hast.

    Edit: Und ich sehe gerade, dass offenbar nicht das ttyUSB als Interface benutzt wird. Richtig konfigurieren musst du also schon noch.
     
  6. c4r1

    c4r1 Grünschnabel

    Dabei seit:
    01.06.2008
    Beiträge:
    8
    Zustimmungen:
    0
    ttyusb?

    lb. bitmuncher!
    danke dir herzlichst. meintest du folgende konfiguration? ich habe dieses echo im terminal gesendet (keine explizite antwort):
    --- --- ---
    c4r1@c4r1-laptop:~$ echo -ne 'at+cgdcont=1,"IP","internet.t-mobile","",0,0\r\n' > /dev/ttyUSB0
    c4r1@c4r1-laptop:~$
    --- --- ---
    danke schön, und für die geduld für ggf. dämliche newbie fragen (bin erst dabei, terminalbefehle zu lernen ).
    c4r1
     
  7. #6 bitmuncher, 05.06.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    'internet.t-mobile' wird sicherlich nicht antworten. Da dürfte ein .de fehlen, vermute ich mal. Ich mache der Einfachheit halber die Einwahl immer mittels wvdial. Ein entsprechender Abschnitt für Vodafone in der wvdial.conf sieht dann z.B. so aus:

    Code:
    [Dialer umts]
    Modem = /dev/ttyUSB0
    Baud = 1800000
    Username = ppp
    Password = ppp
    Phone = *99***1#
    Stupid Mode = 1
    Init1 = AT+CGDCONT=1,"IP","web.vodafone.de"
    Dial Attempts = 3
    
    Das lässt sich dann einfach mittels eines 'wvdial umts' (als root) starten. Ich weiss nicht, wie T-Mobile das gelöst hat, aber ich muss vorher die PIN für die Karte setzen:

    Code:
    #!/usr/bin/perl
    
    use strict;
    use warnings;
    
    my $modem = "/dev/ttyUSB0";
    
    my $pin = "1234"; # hier PIN eintragen
    
    $SIG{ALRM} = sub {
            die("timeout: no response from modem $modem\n");
    };
    
    open(MODEM, "+<", $modem) or die("can't open modem $modem");
    alarm(10);
    print(MODEM "AT+CPIN=\"$pin\"\n\r");
    while (<MODEM>) {
            if (m/OK/) {
                    close(MODEM);
                    print("PIN accepted\n");
                    exit(0);
            }
            if (m/ERROR/) {
                    close(MODEM);
                    print("PIN rejected\n");
                    exit(1);
            }
    }
    
     
  8. c4r1

    c4r1 Grünschnabel

    Dabei seit:
    01.06.2008
    Beiträge:
    8
    Zustimmungen:
    0
    haarerauff

    hi,
    bei t-mobile ist das so blöd ohne de, tatsächlich "internet.t-mobile" ;-) passwordabfrage hatte ich von vorn herein auf der SIM-Karte ausgeschaltet. Nun kommt bei wvdial umts der Hammer:
    --- --- ---
    root@c4r1-laptop:/home/c4r1# wvdial umts
    --> WvDial: Internet dialer version 1.60
    --> Warning: section [Dialer umts] does not exist in wvdial.conf.
    --> Cannot open /dev/modem: No such file or directory
    --> Cannot open /dev/modem: No such file or directory
    --> Cannot open /dev/modem: No such file or directory
    root@c4r1-laptop:/home/c4r1#
    --- --- ---
    und perl gibt's bei mir im 'bin' nicht drinnen *haarerauf*
    ich hab den eindruck, dass ich mich da über GNOME PPP völlig falscheinwähle und die Verbindung nur zustande kommt, weil Linux/Ubuntu ne schlaue Type ist, Herz für Hirnlose hat und sich intuitiv Kanäle nach draussen sucht, weil es merkt, dass ich einfach ins Netz will. Vielleicht muss ich irgenwie andere Controller dem GNOME PPP zuweisen (aber wo gibts dazu ne Anleitung?) oder überhaupt nicht GNOME benutzen sondern was anderes...
    Hilfe... Ich gehe ein :-S Trotzdem vielen Dank... Ich probiere weiter und belaste das Traffic aller Foren aufs Unanständigste. C4R1
     
  9. #8 bitmuncher, 05.06.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    /dev/modem dürfte auch nicht korrekt sein. Wie sieht deine wvdial.conf aus?
     
  10. #9 c4r1, 05.06.2008
    Zuletzt bearbeitet: 05.06.2008
    c4r1

    c4r1 Grünschnabel

    Dabei seit:
    01.06.2008
    Beiträge:
    8
    Zustimmungen:
    0
    ich mag dir das gar nicht sagen, hab locate gemacht um wvdial füt kwrite zu finden, kate war gar nicht installiert. nun sieht das so aus:
    ... bin ich jetzt wenigstens auf dem richtigen Weg? Ich glaub langsam brauch ich Deine Schweizer Kontonummer ;-) Grüße C4R1
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    ... dev/modem/ existiert gar nicht. nur so:

    oder sind mit Modem ttyUSB.. usw gemeint ?
     
  11. #10 bitmuncher, 05.06.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    ttyUSB0 dürfte dein Modem-Device sein. Und das obere ist die Datei /etc/wvdial.conf? Kann ich mir nicht vorstellen. Die ist nämlich kein Shell-Skript.
     
  12. c4r1

    c4r1 Grünschnabel

    Dabei seit:
    01.06.2008
    Beiträge:
    8
    Zustimmungen:
    0
    hi,
    nein, aber ich hab nur in der form
    --- --- ---
    /usr/share/man/man1/wvdialconf.1.gz
    /usr/share/man/man5/wvdial.conf.5.gz
    /var/lib/dpkg/info/wvdial.conffiles
    /var/lib/dpkg/info/wvdial.config
    --- --- ---
    mit einfachen conf nur mit . davor und wenn ich dann:
    --- --- ---
    root@c4r1-laptop:/home/c4r1# kwrite /.wvdial.conf
    kbuildsycoca running...
    Reusing existing ksycoca
    DCOP Cleaning up dead connections.
    --- --- ---
    dann ist das Editorfenster leer. pppconfig findet mein 'Option Modem', welches ich klar nur im lsusb finde (Bus 004 Device 002: ID 0af0:6500 Option) nicht und fragt nach tty oder so. ich krief n fön. Ich versuche echt alles. Aber es muss doch auch richtig gehen, wenn Ubuntu über die lahme Intuitivmethode sich verbindet, oder?
    Grüße, C4R1
     
  13. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  14. #12 bitmuncher, 05.06.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Dann solltest du mal die Manpage zu wvdial.conf lesen und dir einfach eine /etc/wvdial.conf (als root) erstellen. Eine Beispiel-Konfiguration hatte ich ja bereits gepostet.
     
  15. c4r1

    c4r1 Grünschnabel

    Dabei seit:
    01.06.2008
    Beiträge:
    8
    Zustimmungen:
    0
    ja, das werd ich. ich danke dir! also '/dev/ttyUSB0' ist definitiv das Option-UMTS-Modem, weil ich das nun noch einmal über kppp Statistics ausprobiert hab (also eine neue Einwahl da eingerichtet und über kppp wähle ich mich wesentlich schneller ein als gnome ppp). habe vorher noch über pppconfig das modem eingerichtet und auch dieses device angegeben, aber ich weiss immer noch nicht was das gebraucht hat auser in /etc/ppp/peers/ herumzustehen. also danke ich dir für die viele arbeit, vielleicht wurde schon eine lösung gefunden , nur ichmerk es nicht ;-) ich lese das jetzt und will danach schlauer werden, nochmal viel dank!
    c4r1
     
Thema:

Ubuntu Treiber für UMTS onboard

Die Seite wird geladen...

Ubuntu Treiber für UMTS onboard - Ähnliche Themen

  1. wlan Treiber (RTL8111/8168) unter Ubuntu

    wlan Treiber (RTL8111/8168) unter Ubuntu: Hallo Community, versuche verzweifelt, mein WLAN (HP Laptop) unter Ubuntu 10.04 LTS zum Laufen zu bringen. lspci gibt mir folgendes bekannt:...
  2. Ubuntu Intel GMA HD GPU - Probleme mit Grafiktreiber

    Ubuntu Intel GMA HD GPU - Probleme mit Grafiktreiber: Hallo. Ich hatte vor nem halben Jahr auf meinem Tecra A11-127 Ubuntu installiert. Da ist eine Intel GMA HD Grafik eingebaut. Die Auflösung des...
  3. Seit upadet auf ubuntu 9.04 öffnet hardware treiber einstellungen nicht mehr...

    Seit upadet auf ubuntu 9.04 öffnet hardware treiber einstellungen nicht mehr...: ich habe gestern von 8.10 auf 9.04 Ubuntu geupdatet und nun öffnet hardware treiber einstellungen nicht mehr und ich kann keine effekte mehr...
  4. Neuer Grafiktreiber Nvidia Ubuntu8.10?

    Neuer Grafiktreiber Nvidia Ubuntu8.10?: Hi Leute Ich selber habe mit dem aktuellen Grafiktreiber von Nvidia bei Ubuntu 8.04 probleme mit manchen Spielen. Aber irgendwie laden die...
  5. NVIDIA Treiber und Ubuntu 8.04 = Problem

    NVIDIA Treiber und Ubuntu 8.04 = Problem: Hallo zusammen, also ich hab hier ein Notebook(Acer Aspire 5610) auf dem ich Ubuntu installiert habe, was vom USB-Stick auch ohne Probleme...