Ubuntu dist-upgrade: Zurückgehaltene Pakete installieren

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von cuddlytux, 01.01.2007.

  1. #1 cuddlytux, 01.01.2007
    cuddlytux

    cuddlytux Alles außer unix ist sc..

    Dabei seit:
    25.11.2005
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Rheinhessen
    Laut man-page müsste das eigentlich mit der Option --ignore-hold funktionieren:

    klausi3:/home/jan# apt-get --ignore-hold dist-upgrade
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Berechne Upgrade...Fertig
    Die folgenden Pakete sind zurückgehalten worden:
    ace-of-penguins achilles adonthell amsn anjuta audacity autopsy briquolo
    bugsquish bzflag caca-utils cdtool celestia-glut compiz dia dopewars dosbox
    dsniff dvdbackup ethereal ethereal-common ettercap ettercap-common evince
    foomatic-db-gutenprint g++-4.0 galeon gdesklets gdk-imlib11 gdm gftp
    gftp-text gimp-python gnome-system-tools gnupg gok gpm grip
    gstreamer0.10-ffmpeg gstreamer0.10-gl gstreamer0.10-plugins-bad
    gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly
    gstreamer0.10-plugins-ugly-multiverse gtk-gnutella gtk2-engines-clearlooks
    gtk2-engines-crux gtk2-engines-highcontrast gtk2-engines-industrial
    gtk2-engines-lighthouseblue gtk2-engines-mist gtk2-engines-pixbuf
    gtk2-engines-redmond95 gtk2-engines-smooth gtk2-engines-thinice
    ia32-libs-gtk ia32-libs-openoffice.org ijsgutenprint imagemagick imlib11
    info kate kcontrol kdebase-bin kdirstat kicker kid3 kmldonkey kmobiletools
    lesstif2 liba52-0.7.4 libart2 libavahi-client3 libavahi-common3
    libavahi-glib1 libavahi-qt3-1 libcompfaceg1 libcrypto++5.2c2a libdvbpsi4
    libdvdread3 libfame-0.9 libggi2 libgimp2.0 libgnomeprintui2.2-0
    libgnomeprintui2.2-common libgnomevfs2-0 libgnomevfs2-bin
    libgnomevfs2-common libgnomevfs2-extra libgnorbagtk0 libgnutls12
    libgpewidget1 libgtk-perl libgtk2.0-0 libgtk2.0-bin libimlib2
    libjack0.100.0-0 libkonq4 liblame0 libmagick9 libmjpegtools0c2a libmms0
    libnetcdf3 libpng12-0 libpq4 librpm4 libruby1.8 libsdl-net1.2 libssl0.9.7
    libstdc++6-4.0-dev libswfdec0.3 libtasn1-2 libvcdinfo0 libwxgtk2.4-1
    libwxgtk2.6-0 libxine-extracodecs libxine-main1 libxosd2 libxvidcore4
    linux-amd64-generic lvm2 mc mdadm mjpegtools mozilla mozilla-browser
    mozilla-mailnews mozilla-psm mp3blaster mplayer music123 nvidia-glx
    nvidia-kernel-common openoffice.org openoffice.org-base openoffice.org-calc
    openoffice.org-common openoffice.org-core openoffice.org-draw
    openoffice.org-gnome openoffice.org-gtk openoffice.org-impress
    openoffice.org-math openoffice.org-writer p7zip prelink privoxy
    python-gadfly python-gtk-1.2 python-htmltmpl python-kjbuckets python-netcdf
    python-parted python-pgsql python-soappy python-stats python-syck ripperx
    rpm ruby1.8 screen shfs-utils sleuthkit sql-editor sshfs tar tcltls teleport
    tor unrar vcdimager vino vlc xcruise xdialog xmms-cdread xosview
    xserver-xorg-driver-all xutils
    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 179 nicht aktualisiert.

    Was muss ich sonst für eine Option nehmen, damit mir die Pakete wieder installiert werden?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Nemesis, 01.01.2007
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    hi,
    bitte verwendet
    Code:
    -tags.
    
    wenn ich richtig in deer annahme gehe, dass du bestimmte packete zurückhalten willst, dann versuchs mal mittels: 
    [code]echo "packet hold" | dpkg --set-selections
     
  4. #3 cuddlytux, 01.01.2007
    cuddlytux

    cuddlytux Alles außer unix ist sc..

    Dabei seit:
    25.11.2005
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Rheinhessen
    Nein, ich möchte Pakete, die apt seit dem ersten dist-upgrade zurückhält installieren (siehe Thema) ;-)

    Code:
     mag ich nicht, weil diese Box keinen Zeilenumbruch am ende der seite macht, sondern einen Scrollbalken aktiviert hat.
     
  5. #4 Goodspeed, 01.01.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Ich glaub, da gibt es irgendwelche nicht auflösbare Konflikte ...
    Was passiert denn z.B. wenn Du nur
    Code:
    apt-cache policy lvm2
    apt-get install lvm2
    
    versuchst?
     
  6. #5 cuddlytux, 01.01.2007
    cuddlytux

    cuddlytux Alles außer unix ist sc..

    Dabei seit:
    25.11.2005
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Rheinhessen
    Code:
    klausi3:/home/jan# apt-cache policy xutils
    xutils:
      Installiert:7.0.0-0ubuntu45
      Mögliche Pakete:1:7.1.1ubuntu6.2
      Versions-Tabelle:
         1:7.1.1ubuntu6.2 0
            500 http://de.archive.ubuntu.com edgy-updates/main Packages
     *** 7.0.0-0ubuntu45 0
            100 /var/lib/dpkg/status
    klausi3:/home/jan# apt-get install xutils
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
    Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
    instabile Distribution verwenden, einige erforderliche Pakete noch nicht
    kreiert oder aus Incoming herausbewegt wurden.
    
    Da Sie nur eine einzige Operation angefordert haben ist es sehr wahrscheinlich,
    dass das Paket einfach nicht installierbar ist und eine Fehlermeldung über
    dieses Paket erfolgen sollte.
    Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
    
    Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
      xutils: Hängt ab: xutils-dev ist aber nicht installierbar
    E: Kaputte Pakete
    
    Warum ist das Paket xutils-dev nicht in den Repositories, wenn es für xutils benötigt wird? Ich bin irgendwie ein wenig ratlos...
    Und wie kann ich kaputte Pakete suchen und ersetzen?
     
  7. #6 Nemesis, 01.01.2007
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    wie sieht deine sources.list aus?
     
  8. #7 cuddlytux, 01.01.2007
    cuddlytux

    cuddlytux Alles außer unix ist sc..

    Dabei seit:
    25.11.2005
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Rheinhessen
    Code:
    deb http://de.archive.ubuntu.com/ubuntu/ edgy restricted
    deb-src http://de.archive.ubuntu.com/ubuntu/ edgy main restricted
    
    ## Major bug fix updates produced after the final release of the
    ## distribution.
    deb http://de.archive.ubuntu.com/ubuntu/ edgy-updates main restricted
    deb-src http://de.archive.ubuntu.com/ubuntu/ edgy-updates main restricted
    
    ## Uncomment the following two lines to add software from the 'universe'
    ## repository.
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team, and may not be under a free licence. Please satisfy yourself as to
    ## your rights to use the software. Also, please note that software in
    ## universe WILL NOT receive any review or updates from the Ubuntu security
    ## team.
    
    deb http://de.archive.ubuntu.com/ubuntu/ edgy multiverse
    deb-src http://de.archive.ubuntu.com/ubuntu/ edgy multiverse
    
    deb http://de.archive.ubuntu.com/ubuntu/ edgy universe
    deb-src http://de.archive.ubuntu.com/ubuntu/ edgy universe
    
    ## Uncomment the following two lines to add software from the 'backports'
    ## repository.
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    deb http://de.archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
    deb-src http://de.archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
    
    deb http://security.ubuntu.com/ubuntu edgy-security main restricted
    deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted
    deb http://security.ubuntu.com/ubuntu edgy-security universe
    deb-src http://security.ubuntu.com/ubuntu edgy-security universe
    
    # Compiz und Xgl
    
    deb http://www.beerorkid.com/compiz dapper main main-amd64
    deb http://media.blutkind.org/xgl/ dapper main main-amd64
    
     
  9. #8 Goodspeed, 01.01.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Fehlt da irgendwie sowas:
    Code:
    deb http://de.archive.ubuntu.com/ubuntu/ edgy main
    
    Und ich glaube auch bei Ubuntu sollte man nicht unbedignt Edgy mit Dapper mischen ... oder?
    Ansonsten kannste ja mal schauen, warum er "xutils-dev" nicht installieren kann ...
     
  10. #9 cuddlytux, 01.01.2007
    cuddlytux

    cuddlytux Alles außer unix ist sc..

    Dabei seit:
    25.11.2005
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Rheinhessen
    Danke, irgendwie ist mir das überhauptnicht aufgefallen...
    Ich denke, das mit xutils-dev hat sich dann auch erledigt, da das ja warscheinlich dann in main drin war.
    Code:
    deb http://www.beerorkid.com/compiz dapper main main-amd64
    deb http://media.blutkind.org/xgl/ dapper main main-amd64
    
    Das steht drin, weil ich mir von dort aus compiz bzw. Xgl installiert habe. Allerdings sind diese Repositories veraltet und bieten keine Pakete für Edgy. Aber ich denke das wird schon klappen.
     
  11. #10 kbdcalls, 01.01.2007
    Zuletzt bearbeitet: 01.01.2007
    kbdcalls

    kbdcalls Master of Universe

    Dabei seit:
    16.10.2006
    Beiträge:
    518
    Zustimmungen:
    0
    Ich würde erstmal das Towubahohu aufräumen


    Vor allem was willst du mit den Dapper Paketen ? Das dann auch gleich rausschmeißen. Bzw da müßte dann auch edgy hin.
     
  12. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  13. seim

    seim seim oder nicht seim?

    Dabei seit:
    08.09.2006
    Beiträge:
    909
    Zustimmungen:
    0
    Ort:
    /mnt/reallife
    Offtopic:

    was bewirkt dieser
    Code:
     | 
    strich und dieses
    Code:
     & 
    "und" in der shell?
     
  14. #12 cuddlytux, 02.01.2007
    Zuletzt bearbeitet: 02.01.2007
    cuddlytux

    cuddlytux Alles außer unix ist sc..

    Dabei seit:
    25.11.2005
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Rheinhessen
    Code:
    dmesg | grep sda
    Ausgabe (stdout) von dmesg wird eingabe (stdin) von grep.

    Code:
    firefox &
    Ein Programm blockiert nicht weitere Eingaben in die bash.

    Genaueres:
    Code:
    info bash
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Danke fürs aufräumen ;-)
    Das war halt noch das Ubuntu Original der sources.list, bis auf einige Veränderungen. Ich werde sowieso bald wieder vom Ubuntu-Zug abspringen. Das war nur eine Zwischenlösung, weil mir Sarge zu alt für den Desktop-Gebrauch war und Etch noch zu unstable.
    Aber zurück zum Thema.
    Die compiz und Xgl-Repositories werde ich sowieso jetz rausschmeißen, weil ja der X.org 7.1 dabei ist und ich gerade Beryl auf meinem Labtop ausprobiert habe.
     
Thema: Ubuntu dist-upgrade: Zurückgehaltene Pakete installieren
Besucher kamen mit folgenden Suchen
  1. ubuntu ff kaputte installation

    ,
  2. ubuntu folgende pakete sind zurückgehalten

    ,
  3. folgende pakete sind zurückgehalten worden: bash

    ,
  4. ubuntu zurückgehaltene updates installieren,
  5. 3 pakete werden zurückgehalten
Die Seite wird geladen...

Ubuntu dist-upgrade: Zurückgehaltene Pakete installieren - Ähnliche Themen

  1. Ubuntu Dist-Upgrade? Gefahrlos?

    Ubuntu Dist-Upgrade? Gefahrlos?: Hi leute ich bins mal wieder und habe wieder mal eine brandheisse Frage :think: Ich habe hier bei mir einen Rechner mit ubuntu-Server 7.04...
  2. Canonical definiert Ziele für Ubuntu 16.10 »Yakkety Yak«

    Canonical definiert Ziele für Ubuntu 16.10 »Yakkety Yak«: Auf dem derzeit stattfindenden Ubuntu Online Summit (UOS) zur Entwicklung von Ubuntu 16.10 »Yakkety Yak« wurden in der Eröffnungssitzung einige...
  3. Artikel: Ubuntu und Kubuntu 16.04 LTS

    Artikel: Ubuntu und Kubuntu 16.04 LTS: Dieser Artikel beleuchtet die Neuerungen von Ubuntu 16.04 LTS »Xenial Xerus« vor allem in den beiden wichtigsten Desktop-Ausgaben, Unity und KDE....
  4. Ubuntu LTS: Viele Sicherheitslücken ungepatcht

    Ubuntu LTS: Viele Sicherheitslücken ungepatcht: Einem Bericht des Computer-Magazins »ct« zufolge kann die von »Ubuntu LTS« versprochene Langzeitpflege nicht das halten, was sie verspricht. Viele...
  5. Ubuntu loggt sich aus nach aktualisierung auf 16.04

    Ubuntu loggt sich aus nach aktualisierung auf 16.04: Während dem Update auf Ubuntu 16.04 hat sich Ubuntu aufgehängt. Nach 6 Stunden habe ich es abgebrochen. Nach einem Neustart konnte ich mich nicht...