[TV-Karte] WinTV NOVA-SE2 läuft nicht

Dieses Thema im Forum "Grafik / Video" wurde erstellt von namespace, 02.01.2006.

  1. #1 namespace, 02.01.2006
    namespace

    namespace Mitglied

    Dabei seit:
    03.04.2004
    Beiträge:
    44
    Zustimmungen:
    0
    Frohes neues Jahr euch allen,

    ich habe mir eine WinTV NOVA-SE2 von Hauppauge gekauft und verzweifele nun schone mehrere Tage daran.

    Hier fand ich ein Tutorial für das digitale TV (etwas nach unten scrollen) doch schon bei den ersten Schritten gibt es bei mir abweichungen.

    Code:
    user$ dmesg | grep dvb
    
    sollte ja den Kartennamen ausgeben oder zumindest das, was zu tun sei...
    Ich bekomme jedoch garnichts.

    Kernel habe ich schon den 2.6.13 installiert und auch die entsprechenden dvb module aktiviert.

    Ich weiß nicht mehr weiter...

    Ubuntu 5.10
    Kernel 2.6.13
    WinTV Nova-SE2 dvb-s

    Danke schonmal...
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Cappy

    Cappy Eroberer

    Dabei seit:
    13.06.2005
    Beiträge:
    73
    Zustimmungen:
    0
    WinTv Nova

    Hallo!

    Ich habe bei mir die WinTv Nova s unter SuSE 10 am Laufen.
    Die Karte läuft mit dem Budget treiber.
    Schau mal mit lsmod ob der Treiber bei dir aktiv ist.
    TV geht am besten mit dem aktuellen Kaffeine Player,
    der hat ein DVB modul.
    Wichtig ist, das die Karte eine IP- Adresse bekommt (zumindest ist das bei meiner so).

    Gruß cappy
     
  4. Cappy

    Cappy Eroberer

    Dabei seit:
    13.06.2005
    Beiträge:
    73
    Zustimmungen:
    0
    winTv Nova S

    Hallo!

    Hattest du mir am Wochenende eine Mail zu dem Thema WinTv unter SuSe geschickt?

    Mir ist am Sonntag die Platte abgeraucht, aufgrund dessen war
    die Mail auch weg.
    Ich muß mein Sys jetzt eh neu Installieren. wenn ich fertig bin, schicke ich dir ne Mail mit der genauen Anleitung!!

    Gruß Cappy!
     
  5. .lukas

    .lukas .mesa Developer

    Dabei seit:
    22.02.2006
    Beiträge:
    17
    Zustimmungen:
    0
    Hallo!

    Ich versuche nun schon einige Zeit meine Nova-SE unter Kubuntu 5.10 (mit 2.6.12-SMP Kernel) zum Laufen zu bekommen, aber bis lang ohne Erfolg. Ich habe mich wie namespace an das Ubuntu-Tutorial gehalten, und das gleiche Problem entdeckt. Hat irgendjemand schon seine Nova-SE unter Linux zum Laufen gebracht? Wie und mit welchen Treibern und Firmware? Kann es sein, dass der Kernel 2.6.12 mit dem Laden der Firmware Probleme hat? Wäre für jeden Tipp/Links oder Vorschlag dankbar!

    Gruß Lukas
     
  6. Cappy

    Cappy Eroberer

    Dabei seit:
    13.06.2005
    Beiträge:
    73
    Zustimmungen:
    0
    Nova s und Suse

    Hallole!
    Ich habe bei mir ne Nova S unter SuSE 10.0 am Laufen.
    Wichtig war bei mir erst mal die Xine- Lib 1.1, und dann
    die Win32 codecs.
    Ne gute Anleitung gibt's unter
    www.linuxtv.org oder hier: www.aumund.org/index.php?p=531

    Gruß Cappy
     
  7. .lukas

    .lukas .mesa Developer

    Dabei seit:
    22.02.2006
    Beiträge:
    17
    Zustimmungen:
    0
    Hallo!

    Ich habe versucht die Anleitung durchzuspielen, leider ist der Link zur Firmware tot. Gibts noch andere Quellen für die Windows Firmware (Kann man ja auch irgendwie aus den Treibern der Windows CD extrahieren. Nur welche Datei?) Auf jeden Fall müsste ich unter dmesg zumindest eine Meldung für die nichtgefunde Firmware bekommen, oder täusch ich mich? Das einzige das unter dmesg auf die Nova Karte hinweist sind einige Video4Linux2 Einträge:

    Code:
    [4294704.847000] cx2388x v4l2 driver version 0.0.4 loaded
    [4294704.852000] cx88[0]: subsystem: 0070:9200, board: UNKNOWN/GENERIC [card=0,autodetected]
    [4294705.058000] cx88[0]/0: found at 0000:02:03.0, rev: 5, irq: 19, latency: 64, mmio: 0xfb000000
    [4294705.062000] cx88[0]/0: registered device video1 [v4l2]
    [4294705.063000] cx88[0]/0: registered device vbi1
    [4294705.169000] cx2388x dvb driver version 0.0.4 loaded
    [4294705.204000] cx2388x blackbird driver version 0.0.4 loaded
    
    Das Device /dev/video1 (Video1 deshalb weil auf Video0 bereits eine bttv Karte liegt, die auch hervorragend funktioniert *g*!) existiert auch, aber soweit ich das verstanden habe fehlt mir trotzdem noch das Frontend der Karte zum tunen zwischen Kanälen!? Zumindest lässt sich ja nicht mit scan und szap arbeiten, da meine DVB Devices nicht da sind!

    :think: Langsam frage ich mich, was konkret für die WinTV Nova S benötigt wird (welche Module welche Firmware und was sonst noch so anfällt). Auf einigen Seiten wird auch behauptet, dass dafür gar keine zusätzliche Firmware nötig ist.

    Gruß Lukas
     
  8. Cappy

    Cappy Eroberer

    Dabei seit:
    13.06.2005
    Beiträge:
    73
    Zustimmungen:
    0
    Firmware

    Hallo .lukas!

    Die firmware kann ich dir per Mail schicken, wenn du
    mir deine Addy zukommen lässt.
    Die Anleitung ist doch schon ein bisschen Alt......

    Aber nach der Anleitung hab' ich meine Karte zum laufen bekommen.
    Du solltest nur noch das Kaffeine - Modul Kaffeine-dvb installieren.
    Oder du versuchst es mit klear.
    Gruß Cappy.
     
  9. #8 .lukas, 27.02.2006
    Zuletzt bearbeitet: 28.02.2006
    .lukas

    .lukas .mesa Developer

    Dabei seit:
    22.02.2006
    Beiträge:
    17
    Zustimmungen:
    0
    Hallo allerseits!

    PROBLEM GELÖST: Meine Hauppauge WinTV Nova SE2 funktioniert perfekt! (Sogar mit HDTV - was mich ein wenig verwundert)

    Wenn jemand an der Problemlösung interessiert ist:

    1. Neueste dvb-ttpci-01.fw Firmware von http://www.linuxtv.org/downloads/firmware/ downloaden und in den Ordner /usr/lib/hotplug/firmware/ verschieben. Die Datei umbenennen in dvb-ttpci-01.fw!

    2. Neustes v4l-dvb installieren! Die Karte wird nämlich erst seit Dezember 2005 unterstützt! Ein aktuelle Snapshot ist unter http://www.linuxtv.org/download/dvb/snapshots/ zu finden. Ich habe 20060115 verwendet. Die übliche Prozedur: Entpacken, make, make install

    3. Neustarten und voila -> Die Nova SE2 wird automatisch erkannt.

    4. Mit Kaffeine kommt man am Anfang ganz gut aus. Wichtig ist nur dass die richtige Engine eingestellt ist: Einstellungen -> Spieler-Engine -> Kaffeine oder xine!

    Ich hoffe ich konnte jemanden mit dieser Anleitung helfen! Diese Erkenntnisse haben mir einige zeit geraubt, die ich allen mit einer Nova SE2 gerne ersparen würde. Falls noch was unklar ist, weiter oben im Thread finden sich noch einige nützliche Hinweise von Cappy. Ein großes Dankeschön auch an Cappy!

    Ich wünsch allen noch viel Spaß mit der Karte DVB-S Karte!
    Lukas
     
  10. corny

    corny Grünschnabel

    Dabei seit:
    07.03.2006
    Beiträge:
    5
    Zustimmungen:
    0
    Hi,

    ich hab gerade versucht nach dieser Anleitung meine NOVE-SE2 zu installieren (Debian Sarge, Kernel 2.6.15.6).
    Wenn ich "make install" im v4l ausführe bekomme ich einen Fehler:

    Install: cannot stat 'pvrusb2.ko' : No such file or directory

    Beim booten wird die Karte auch nicht erkannt.

    Welchen Kernel hast du genommen, und wie schaut bei dir dir v4l-config des kernels aus? Muß man irgend etwas besonderes auswählen (abweichend von der std-conf)

    danke,
    Corny
     
  11. .lukas

    .lukas .mesa Developer

    Dabei seit:
    22.02.2006
    Beiträge:
    17
    Zustimmungen:
    0
    Hi,

    Also ich habe mit den obigen Schritten nicht nur die Nova-SE2 sondern auch die Nova-S-Plus und die WinTV DVB-C zum Laufen gebracht. Und dass ganze auch noch unter zwei Distributionen: Kubunut mit 2.6.12-SMP Kernel und Knoppix 4.0.2 mit 2.6.12 Kernel. An den Configs musste ich bei beiden Kernel nichts verändern (Muss jetzt aber nichts heißen, da ich nicht weiß wie dein Kernel konfiguriert ist).

    Kompiliert hat er aber alle Module ohne Fehler? Blöde Frage, aber "make install" hast du als root ausgeführt? Probier mal v4l per Paketsystem zu installieren, und dann die Module nochmals zu kompilieren&installieren.

    Gruß
    Lukas
     
  12. corny

    corny Grünschnabel

    Dabei seit:
    07.03.2006
    Beiträge:
    5
    Zustimmungen:
    0
    Danke erstmal.

    Hab jetzt grad 5 Stunden dran rum probiert. Mehrere Kernels mit verschiedenen configs durchprobiert. Aber ohne Erfolg.
    Hab dann einen Kernel (2.6.12) nach diser Anleitung http://www.vdr-wiki.de/wiki/index.php/DVB_Installation_v4l-dvb (Variante B) compiliert und v4l-dvb compiliert und geladen. Beim Laden sagt er zu jedem Modul einen Error mit "-1 File exists".
    Nach make install und reboot habe ich folgendes in dmesg:

    Ich versteh auch nicht ganz, woher er überhaupt noch die alte Version (0.0.4) hat. Ich dachte die hätte ich gar nicht mehr installiert...

    Hat jemand eine Idee?

    Danke, Corny
     
  13. HGW

    HGW Grünschnabel

    Dabei seit:
    14.03.2006
    Beiträge:
    5
    Zustimmungen:
    0
    Es sind noch ein paar Fragen offen geblieben.
    Ich versuche auch gerade die WinTV Nova SE2 zum laufen zu bekommen!

    OK. Download funktioniert. Eine andere Dokumentation mein, es könnte auch das /lib/firmware Verzeichnis sein. Wie kann ich überprüfen, ob auch tatsächlich diese Firmware gefunden wird und ob sie im richtigen Pfad liegt?

    Das wird mit der Meldung "module not supportet by Novell, setting U taint flag." quittiert. Abhilfe schafft hier ein vollständig neu kompilierter Kernel (der wieder die gleiche Liste zur Auswahl bring wie der alte Kernel ohne neuen v4l-Treiber).

    Genau das ist jetzt bei mir nicht der Fall und ich hab schön langsam keine Vorstellung mehr, woran das liegt!

    Danke erst mal für die Hinweise (auch wenn Sie noch nichts geholfen haben)
    Welche Distribution setzt Du ein? Unter SuSE 10 scheine ich relativ Chancenlos zu sein?

    Kannst Du mir vielleicht verraten, welche Ausgabe "dmesg | grep -i dvb" bei Dir bringt (oder Besser die ganzen zeilen wo die Videotreiber geladen werden)?

    Danke!
     
  14. #13 corny, 14.03.2006
    Zuletzt bearbeitet: 14.03.2006
    corny

    corny Grünschnabel

    Dabei seit:
    07.03.2006
    Beiträge:
    5
    Zustimmungen:
    0
    Ich weiß grad auch nicht wirklich weiter.

    Hab jetzt den neuesten Kernel (2.6.15.6) genommen und danzu noch die neueste Version des v4l-dvb aus dem Repository installiert.
    Die Karte wird trotzdem nicht erkannt. Bei ein paar Sachen von cx88-blackbird und cx88_dvb "unknown symbol"
    Wieso kann das nicht einfach funktionieren?
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. .lukas

    .lukas .mesa Developer

    Dabei seit:
    22.02.2006
    Beiträge:
    17
    Zustimmungen:
    0
    Hi!

    @HGW: In manchen Foren liest man, dass die Firmware für die Nova-SE2 nicht benötig wird. Ich musste die Firmware downloaden, weil ich sie für die Hauppauge WinTV DVB-C verwende. Also sollte die Firmware für dich nicht ausschlaggebend sein!

    Das mit dem Kernel hört sich nach einem SuSE/Novell Problem aus. Da kann ich dir leider nicht weiterhelfen, da ich seit dem Zusammenschluss mit Novell nicht mehr von SuSE begeistert bin. Hast du Sourcen von www.kernel.org verwendet, oder die von SuSE? Ich bin immer noch der Meinung, was auf einem Linux-System läuft, kann auf (fast *g*) allen anderen auch zum Laufen gebracht werden.

    Hier mein dmesg Output:

    Code:
    Linux video capture interface: v1.00
    cx2388x dvb driver version 0.0.5 loaded
    cx2388x: snapshot date 2006-01-15
    CORE cx88[0]: subsystem: 0070:9200, board: Hauppauge Nova-SE2 DVB-S [card=38,autodetected]
    TV tuner 4 at 0x1fe, Radio tuner -1 at 0x1fe
    tveeprom 0-0050: Hauppauge model 92500, rev B1B1, serial# 250614
    tveeprom 0-0050: MAC address is 00-0D-FE-03-D2-F6
    tveeprom 0-0050: tuner model is Conexant_CX24109 (idx 111, type 4)
    tveeprom 0-0050: TV standards ATSC/DVB Digital (eeprom 0x80)
    tveeprom 0-0050: audio processor is CX883 (idx 32)
    tveeprom 0-0050: decoder processor is CX883 (idx 22)
    tveeprom 0-0050: has no radio, has no IR remote
    cx88[0]: warning: unknown hauppauge model #92500
    cx88[0]: hauppauge eeprom: model=92500
    ACPI: PCI Interrupt 0000:00:0c.2[A] -> GSI 16 (level, low) -> IRQ 16
    cx88[0]/2: found at 0000:00:0c.2, rev: 5, irq: 16, latency: 64, mmio: 0xde000000
    cx88[0]/2: cx2388x based dvb card
    DVB: registering new adapter (cx88[0]).
    DVB: registering frontend 0 (Conexant CX24123/CX24109)...
    saa7146: register extension 'hexium HV-PCI6/Orion'.
    ACPI: PCI Interrupt 0000:00:0d.0[A] -> GSI 17 (level, low) -> IRQ 17
    3c59x: Donald Becker and others. www.scyld.com/network/vortex.html
    0000:00:0d.0: 3Com PCI 3c905C Tornado at 0xcc00. Vers LK1.1.19
    Via 686a/8233/8235 audio driver 1.9.1-ac4-2.5
    ACPI: PCI Interrupt 0000:00:07.5[C] -> GSI 10 (level, low) -> IRQ 10
    PCI: Setting latency timer of device 0000:00:07.5 to 64
    ac97_codec: AC97 Audio codec, id: ALG16 (ALC200/200P)
    via82cxxx: board #1 at 0xDC00, IRQ 10
    cx2388x v4l2 driver version 0.0.5 loaded
    cx2388x: snapshot date 2006-01-15
    ACPI: PCI Interrupt 0000:00:0c.0[A] -> GSI 16 (level, low) -> IRQ 16
    cx88[0]/0: found at 0000:00:0c.0, rev: 5, irq: 16, latency: 64, mmio: 0xdd000000
    cx88[0]/0: registered device video0 [v4l2]
    cx88[0]/0: registered device vbi0
    
    Der Output ist unverändert. Dazwischen befinden sich einige Zeilen, die sicher nicht relevant sind.

    Mein System sieht so aus (Output stammt von diesem System):
    Hauppauge WinTV DVB-C
    Hauppauge WinTV Nova-SE2
    (beide laufen ohne Probleme mit dem v4l-dvb Snapshot 2006-01-15)
    Verwende meine eigene Live-Distribution die auf Knoppix 4.02 basiert
    Mein Kernel: Linux Knoppix 2.6.12 #2 SMP Tue Aug 9 23:20:52 CEST 2005 i686 GNU/Linux


    Auf einem zweiten Rechner läuft:
    Hauppauge WinTV Nova S Plus
    Kubuntu 5.10 mit Kernel 2.6.12 (Ubuntu Standard Kernel mit SMP Unterstützung)

    Gruß
    Lukas
     
  17. #15 HGW, 16.03.2006
    Zuletzt bearbeitet: 18.03.2006
    HGW

    HGW Grünschnabel

    Dabei seit:
    14.03.2006
    Beiträge:
    5
    Zustimmungen:
    0
    Danke erstmal. Ich glaub ich hab endlich die Ursache des Problemes. Es wird einfach nach wie vor das alte Modul geladen!

    Die beiden Zeilen
    Code:
    cx2388x: snapshot date 2006-01-15
    CORE cx88[0]: subsystem: 0070:9200, board: Hauppauge Nova-SE2 DVB-S [card=38,autodetected]
    erscheinen bei mir nämlich überhaupt nicht.
    Auch mit dem ganze neuen Kernel von kernel.org hatte ich lediglich 36 Karten zur Auswahl und die Nova-SE2 DVB-S ist anscheinend Nr. 38. Ich werd mich gleich an noch einen Versuch machen!


    Update: 18.03.2006

    Dank dem Hinweis läuft die Karte jetzt!
     
Thema:

[TV-Karte] WinTV NOVA-SE2 läuft nicht

Die Seite wird geladen...

[TV-Karte] WinTV NOVA-SE2 läuft nicht - Ähnliche Themen

  1. WinTV-PVR USB2 personal video recorder unter ubuntu 11.04

    WinTV-PVR USB2 personal video recorder unter ubuntu 11.04: Ich würde gerne meine alten Videos digitalisieren und habe dazu ein WinTV-PVR USB2 personal video recorder als Gerät zur Verfügung. Leider bekomme...
  2. lirc vs. Hauppauge WinTV-Nova-S-plus

    lirc vs. Hauppauge WinTV-Nova-S-plus: Hallo zusammen, ich versuche nun schon seit ein paar Tagen meine Fernbedienung in mein System (Kubuntu 7.10) einzubinden. Nach dem Herunterladen...
  3. WinTV Nova-s Plus unter Ubunu 7.10

    WinTV Nova-s Plus unter Ubunu 7.10: Hallo zusammen, ich habe eine Hauppauge WinTV NOVA-S-Plus, funktioniert auch noch perfekt unter Windows. Nein will Windows nicht loben, nur sagen...
  4. WinTV HVR 1300 geht nur manchmal!

    WinTV HVR 1300 geht nur manchmal!: Hallo ich habe folgende Probleme: 1. Ich habe eine Hauppauge WinTV HVR 1300 unter openSuSE 10.3 laufen, jedoch gehd diese nur manchmal (also...
  5. WinTV PVR350

    WinTV PVR350: Weiß jemand, ob diese Karte unter Linux funktioniert?