Treiber laden

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von mekönig, 13.01.2007.

  1. #1 mekönig, 13.01.2007
    mekönig

    mekönig Grünschnabel

    Dabei seit:
    13.01.2007
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo Linux user,
    es geht um folgendes Problem!
    Ich habe ein Laptop Acer Aspire 3022 WLMI und schaffte es, mit viel Knobelei,
    das w-lan (auf Suse 10.2) zu aktivieren. Leider ist es sehr umständlich.
    Auf der Konsole gebe ich als root folgende Anweisungen ein:
    modprobe acerhk
    echo 1 > /proc/driver/acerhk/wirelessled
    rmmod bcmxx
    modprobe ndiswrapper
    Jetzt zur Sache, wie kann ich es einrichten das die Anweisungen, beim hochfahren automatisch gestartet werden.
    Zum Beispiel das der Treiber bcmxx gar nicht erst geladen wird und ndiswrapper
    statt dessen den Treiber läd.

    Mit freundlichen Grüßen
    Manne
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Keruskerfürst, 13.01.2007
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Indem man sich ein kleines Script schreibt:
    ---------------------------------------------
    #!/bin/bash
    modprobe acerhk
    echo 1> /proc/driver/acerhk/wirelessled
    rmmod bcmxx
    modprobe ndiswrapper
    echo "Treiber für WLAN geladen"
    --------------------------------------------

    Dieses Script mit chmod +x ausführbar machen und nach /etc/init.d versichieben.
    Dann mit Yast2 zum Runlevel 5 hinzufügen oder per hand einen Link anlegen (ln -s ....).
     
  4. #3 mekönig, 14.01.2007
    mekönig

    mekönig Grünschnabel

    Dabei seit:
    13.01.2007
    Beiträge:
    2
    Zustimmungen:
    0
    Es funktioniert!

    Hallo Keruskerfürst,
    vielen Dank für den Tip !
    Das WLan wird beim Systemstart gestartet und funktioniert so wie gewünscht.
    Gruss Manne
     
  5. #4 linuxundjetzt, 14.02.2007
    linuxundjetzt

    linuxundjetzt Grünschnabel

    Dabei seit:
    10.02.2007
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo Mekönig,
    wie hast du denn den Acerhk eingebunden? Ich habe genau das selbe Problem und das soll mit dem Treiber behoben sein. Nur leider bekomme ich den nicht installiert.
    Kannst du mir mal eine Step bei Steb Beschreibung zukommen lassen mit Angabe der Quelle wo du den Treiber her hast?
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Treiber laden

Die Seite wird geladen...

Treiber laden - Ähnliche Themen

  1. Treibermodule mit DKMS laden - Probleme

    Treibermodule mit DKMS laden - Probleme: Hallo, ich habe ich momentan ein Problem mit meinem SLES 10 SP3 auf einem Dell R310. linux-blqj:~ # uname -a Linux linux-blqj...
  2. Lantreiber trotz Blacklist geladen?

    Lantreiber trotz Blacklist geladen?: Hi, ich habe bei meinem Laptop (Vostro 1510 von Dell) das Problem, das das Lan eher sporadisch als zuverlässig arbeitet. Der Chip ist ein...
  3. ISDN-Karten treiber nicht geladen?

    ISDN-Karten treiber nicht geladen?: Hi Leute, also ich bin gerade verzweifelt an nem Asterisk-server dran :> isntalliert ist soweit alles. Nur ich bekomme meine ISDN-Karte nicht in...
  4. Soundtreiber können nicht geladen werden

    Soundtreiber können nicht geladen werden: Hi, also hier schon mal vorab eine Auflistung einiger relevanter Befehle... > cat /proc/asound/cards 0 [ICH6 ]: ICH4 - Intel ICH6...
  5. Falscher Grafiktreiber geladen

    Falscher Grafiktreiber geladen: Hallo! Ich habe vor kurzem OpenSuse 11.0 installiert und auch einen neuen ATI-Treiber für meine Radeon 9600 installiert (X11-video-fglrxG01),...