Treiber guer Grafikkarte wird nicht erkannt :think:

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Solar-Zelle, 15.10.2008.

  1. #1 Solar-Zelle, 15.10.2008
    Solar-Zelle

    Solar-Zelle Grünschnabel

    Dabei seit:
    14.10.2008
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo zusammen,

    Zuerst einmal: ich bin totaler neuling bei linux und habe bei einigem, was ich so lese ein entsprechend grosses fragezeichen ueberm kopf :D . daher bitte nicht boese sein, wenn ich auch die einfachsten dinge nicht wirklich hinkriege bzw. verstehe :)

    also zu meinem Problem:
    Wie der Titel schon vermuten laesst, habe ich da ein Problemchen mit meinem Grafikkartentreiber.
    Ich habe unter http://de.opensuse.org/Proprietäre_NVIDIA-Grafiktreiber per 1-Klick-Installation den Standardtreiber installiert, vorher natuerlich auch brav in der Liste geguckt, dass der Treiber auch fuer meine Grafikkarte passt (bzw passen sollte).
    Die 1-Klick-Installation lief wunderbar ab, nach ner gute halben Stunde (ja, langsame internetverbindung :D) auf Beenden geklickt und neugestartet. Laut Anleitung sollte das schon alles gewesen sein und der Treiber laufen. Pustekuchen, unter Arbeitsplatz steht bei "Graphikkarte" immernoch "Treiber: Unbekannt". Ich also nochmal in die Anleitung geschaut und die Anweisungen unter "Installationserfolg prüfen" durchgefuert. heraus kam folgende (fehler)meldung

    Code:
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Error: couldn't find RGB GLX visual
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    
    , und nicht, wie normalerweise, die entsprechenden Informationen.

    Jedoch wird mir angezeigt, wenn ich ueber Yast-Kontrollzentrum den treiber suchen bzw. intallieren moechte,dass dieser bereits installiert ist.
    Wenn ich die 1-Klick-Installation erneut starte, ist diese aus dem selben Grund nach ca 2 sek. fertig.
    Ich denke mal, dass dieses Problem schon oefter aufgetaucht ist, jedoch haben meine (google)suchergebnisse nicht weitergeholfen oder ich habe sie schlicht und ergreifend nicht verstanden ^^

    ach genau, noch eine daten zum computer:
    System: openSUSE 11.0 (x86_64)
    KDE: 3.5.9 "release 49.1"
    Grafikkarte: GeForce 7600 GS

    schonmal Danke im voraus, auch allein schon fuer das durchlesen von dem roman :D

    mfg, Joshua
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Gast1

    Gast1 Guest

    Ohne genaue Dateinamen der installierten Pakete und des installierten Kernels kann man hier erst mal gar nichts sagen, also z.B. in YaST nachsehen, was da installiert wurde.
     
  4. #3 Solar-Zelle, 15.10.2008
    Solar-Zelle

    Solar-Zelle Grünschnabel

    Dabei seit:
    14.10.2008
    Beiträge:
    7
    Zustimmungen:
    0
    ah sorry, hab ich wohl eben vergessen :D

    Kernel 2.6.25.16-0.1-default (tty2).

    und installiert wurden die pakete:

     
  5. Gast1

    Gast1 Guest

    Code:
    lsmod |grep nvidia
    
    su -c "grep -E 'WW|EE' /var/log/Xorg.0.log"
    
    glxinfo |grep rendering
    
    grep -E 'Driver|Load' /etc/X11/xorg.conf
    sagen?
     
  6. #5 bitmuncher, 15.10.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Ist in der Datei /etc/X11/xorg.conf die Zeile

    Code:
    Load            "glx"
    
    in der Section "Module" eingetragen?
     
  7. #6 Solar-Zelle, 15.10.2008
    Solar-Zelle

    Solar-Zelle Grünschnabel

    Dabei seit:
    14.10.2008
    Beiträge:
    7
    Zustimmungen:
    0
    @Rain_Maker
    die sagen
    Code:
    linux-0c9v:/etc/X11 # lsmod |grep nvidia
    nvidia               8165472  0
    i2c_core               45344  2 i2c_viapro,nvidia
    linux-0c9v:/etc/X11 # su -c "grep -E 'WW|EE' /var/log/Xorg.0.log"
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (WW) The directory "/usr/share/fonts/local" does not exist.
    (WW) The directory "/usr/share/fonts/PEX" does not exist.
    (WW) The directory "/usr/share/fonts/latin2/misc" does not exist.
    (WW) The directory "/usr/share/fonts/latin2/75dpi" does not exist.
    (WW) The directory "/usr/share/fonts/latin2/100dpi" does not exist.
    (WW) The directory "/usr/share/fonts/latin2/Type1" does not exist.
    (WW) The directory "/usr/share/fonts/latin7/75dpi" does not exist.
    (WW) The directory "/usr/share/fonts/baekmuk" does not exist.
    (WW) The directory "/usr/share/fonts/japanese" does not exist.
    (WW) The directory "/usr/share/fonts/kwintv" does not exist.
    (WW) The directory "/usr/share/fonts/uni" does not exist.
    (WW) The directory "/usr/share/fonts/CID" does not exist.
    (WW) The directory "/usr/share/fonts/ucs/misc" does not exist.
    (WW) The directory "/usr/share/fonts/ucs/75dpi" does not exist.
    (WW) The directory "/usr/share/fonts/ucs/100dpi" does not exist.
    (WW) The directory "/usr/share/fonts/hellas/misc" does not exist.
    (WW) The directory "/usr/share/fonts/hellas/75dpi" does not exist.
    (WW) The directory "/usr/share/fonts/hellas/100dpi" does not exist.
    (WW) The directory "/usr/share/fonts/hellas/Type1" does not exist.
    (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    (WW) The directory "/usr/share/fonts/xtest" does not exist.
    (II) Loading extension MIT-SCREEN-SAVER
    (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
    linux-0c9v:/etc/X11 # glxinfo |grep rendering
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Error: couldn't find RGB GLX visual
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    linux-0c9v:/etc/X11 # grep -E 'Driver|Load' /etc/X11/xorg.conf
      Load         "glx"
      Load         "type1"
      Load         "extmod"
      Load         "dbe"
      Load         "freetype"
      Driver       "kbd"
      Driver       "mouse"
      Driver       "fbdev"
    
    @bitmuncher: ja ist eingetragen
     
  8. Gast1

    Gast1 Guest

    Ohne den Treiber auch mittels sax2 "scharf" zu schalten, funktioniert es auch nicht.

    Code:
      Driver       "kbd"
      Driver       "mouse"
    [B]  Driver       "fbdev"[/B]
    Siehe die von Dir verlinkte Anleitung.
     
  9. #8 Solar-Zelle, 15.10.2008
    Solar-Zelle

    Solar-Zelle Grünschnabel

    Dabei seit:
    14.10.2008
    Beiträge:
    7
    Zustimmungen:
    0
    danke fuer die vielen schnellen antworten, hat mir sehr geholfen :)
    das problem war, wie du wohl meintest, dass in der datei /etc/X11/xorg.conf in Section "Device" die Zeile
    fehlte.

    soweit ich das sehe gehts jetzt, danke nochmal :))
     
  10. #9 gropiuskalle, 15.10.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    @R_M: Bin mir jetzt nicht sicher, aber Du beziehst Dich, glaube ich, auf einen Schritt, der im HowTo bezüglich der "händischen" Installation vorgschlagen wird (weswegen Solar-Zelle das evtl. nicht findet), also:

    1. X-Server beenden

    2.

    Code:
    init 3
    3.

    Code:
    sax2 -r -m 0=nvidia
    4.

    Code:
    init 5
    ...sollte in diesem Fall aber auch hinhauen.

    Edit: ups, es funktioniert jetzt? Sicher?

    Code:
    glxinfo | grep direct
     
  11. Gast1

    Gast1 Guest

    Nein, eigentlich beziehe ich mich auch auf die Anleitung via 1-Klick bzw. Einbinden der Repos, da steht auch:

    So lange da wirklich noch "fbdev" als Treiber steht, wage ich zu bezweifeln, daß das mit 3D klappt, sollte das sax2 -r nicht genügen (weil aus irgendwelchen Gründen nicht automatisch nvidia als Treiber gesetzt wird), dann muss man ihm wie oben gezeigt die Option wirklich mitgeben.
     
  12. #11 gropiuskalle, 15.10.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Ah okay. Jedenfalls ist da wohl wirklich noch nicht alles notwendige getan.
     
  13. #12 Solar-Zelle, 15.10.2008
    Solar-Zelle

    Solar-Zelle Grünschnabel

    Dabei seit:
    14.10.2008
    Beiträge:
    7
    Zustimmungen:
    0
    sax2 -r hatte ich schon mal gemacht (2 mal sogar, glaub ich), hat aber, soweit ich das beurteilen kann, nichts nuetzliches getan bzw angezeigt.
    auch wurde mir dann immer angezeigt, dass (kein?) x-server aktiv ist bzw. laeuft. daher hab ich das uebersprungen - wie das bei DAUs halt is, "versteh ich nich, lassen wir das halt aus, wird schon nciht wichtig sein" xD
    jedenfalls bin ich mir jetzt ziemlich sicher, dass der treiber geht, nachdem ich wie oben beschreiben eine zeile ergaenzt habe.

    danke nochmal fuer eure hilfe, jetzt verhaelt sich die grafik so, wie sie es mit treiber normalerweise tuen sollte :D
     
  14. #13 gropiuskalle, 15.10.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Huhu! "Ziemlich sicher" reicht nicht aus, insbesondere wenn alles darauf hindeutet, dass der Treiber nicht aktiviert ist. Nochmal:

    Code:
    glxinfo | grep direct
    ...damit prüfst Du, ob Du recht hast oder wir.

    Ich wette die Hälfte meiner Microsoft-Anteile, dass da noch kein 3D ist.

    Edit: Post #9 von gropiuskalle würde ich mir nochmal ansehen. Da steht irgendwas von "X-Server beenden". Da könnte man doch ins Grübeln kommen, oder?
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Solar-Zelle, 15.10.2008
    Solar-Zelle

    Solar-Zelle Grünschnabel

    Dabei seit:
    14.10.2008
    Beiträge:
    7
    Zustimmungen:
    0
    so wie ich das verstehe, ist das gut was der da anzeigt

    Code:
    joshua@linux-0c9v:~> glxinfo | grep direct
    direct rendering: Yes
    joshua@linux-0c9v:~> glxinfo | grep vendor
    server glx vendor string: NVIDIA Corporation
    client glx vendor string: NVIDIA Corporation
    OpenGL vendor string: NVIDIA Corporation
    joshua@linux-0c9v:~> glxinfo | grep version
    server glx version string: 1.4
    client glx version string: 1.4
    OpenGL version string: 2.1.2 NVIDIA 173.14.12
    glu version: 1.3
    
     
  17. #15 gropiuskalle, 15.10.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Mist, die schönen MS-Aktien... da hast Du aber Ausgaben gepostet, die dann schon nicht mehr aktuell waren.

    Okay, hier noch ein Bonus, weil Du das mit der Wette mal ganz schnell wieder vergisst:

    Als root (brauchst dafür nicht den Desktop verlassen oder so):

    Code:
    nvidia-xconfig --composite
    nvidia-xconfig --allow-glx-with-composite
    nvidia-xconfig --render-accel
    nvidia-xconfig --add-argb-glx-visuals -d 24
    ...aktiviert nv-glx (bessere performance), Composite und setzt die Farbtiefe auf 24bit. Das ganze wird nach dem nächsten X-Server Neustart (z.B. reboot) aktiviert.
     
Thema:

Treiber guer Grafikkarte wird nicht erkannt :think:

Die Seite wird geladen...

Treiber guer Grafikkarte wird nicht erkannt :think: - Ähnliche Themen

  1. Grafiktreiber von Nvidia und AMD mit Vulkan-Unterstützung

    Grafiktreiber von Nvidia und AMD mit Vulkan-Unterstützung: Nvidia und AMD haben Betaversionen ihrer Linux-Grafiktreiber herausgegeben, die erstmals die neue 3D-Schnittstelle Vulkan unterstützen. Aber auch...
  2. Grafiktreiber von Nvidia und AMD mit Vulkan-Unterstützung

    Grafiktreiber von Nvidia und AMD mit Vulkan-Unterstützung: Nvidia und AMD haben Betaversionen ihrer Linux-Grafiktreiber herausgegeben, die erstmals die neue 3D-Schnittstelle Vulkan unterstützen. Aber auch...
  3. Nvidia aktualisiert Vulkan-Treiber

    Nvidia aktualisiert Vulkan-Treiber: Eine Woche nach der Freigabe der ersten Version von Vulkan hat der US-amerikanische Hersteller Nvidia seine Treiber einem Update unterzogen. Auch...
  4. WinBtrfs: Btrfs-Treiber für Windows-Systeme

    WinBtrfs: Btrfs-Treiber für Windows-Systeme: Unter dem Namen WinBtrfs hat ein Entwickler eine erste Testversion eines Windows-Treibers veröffentlicht, der den Zugriff auf das neue...
  5. Oculus Rift: Linux-Treiber weiter ungewiss

    Oculus Rift: Linux-Treiber weiter ungewiss: Auch nach der Freigabe von Oculus Rift ist die Zukunft der VR-Hardware unter Linux ungewiss. Zwar versprach das Unternehmen, auch das freie...