Tomcat6 startet nicht

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von realheat, 12.10.2009.

  1. #1 realheat, 12.10.2009
    Zuletzt bearbeitet: 12.10.2009
    realheat

    realheat Jungspund

    Dabei seit:
    19.01.2007
    Beiträge:
    15
    Zustimmungen:
    0
    Tomcat6 startet nicht [meldung: java.lang.ClassNotFoundException]

    hallo erstmal,

    ich habe eigentlich erfolgreich einen Tomcat6 Server aufgesetzt, nun wollte ich den mod_jk konfigurieren. Leider startet Tomcat6 nicht mehr. Im log von Tomcat steht die Fehlermeldung drinnen:
    Code:
    WARNING: Catalina.start using conf/server.xml: 
    java.lang.ClassNotFoundException: org.apache.catalina.storeconfig.StoreConfigLifecycleListener
    
    meine server.xml habe ich soweit eingerichtet:
    Code:
    <Server port="8005" shutdown="SHUTDOWN">
     
      <Listener className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener" />
      <Listener className="org.apache.catalina.storeconfig.StoreConfigLifecycleListener"/>
      <Listener className="org.apache.jk.config.ApacheConfig" modJk="/usr/lib/apache2/modules/mod_jk.so" workersConfig="/etc/apache2/workers.properties" />
     
      <!-- Global JNDI resources -->
      <GlobalNamingResources>
     
        <!-- Test entry for demonstration purposes -->
        <Environment name="simpleValue" type="java.lang.Integer" value="30"/>
     
        <!-- Editable user database that can also be used by
             UserDatabaseRealm to authenticate users -->
        <Resource name="UserDatabase" auth="Container"
                  type="org.apache.catalina.UserDatabase"
           description="User database that can be updated and saved"
               factory="org.apache.catalina.users.MemoryUserDatabaseFactory"
              pathname="conf/tomcat-users.xml" />
     
      </GlobalNamingResources>
     
     
      <!-- Define the Tomcat Stand-Alone Service -->
      <Service name="Catalina">
     
        <!-- A "Connector" represents an endpoint by which requests are received
             and responses are returned.  Each Connector passes requests on to the
             associated "Container" (normally an Engine) for processing.
        -->
     
        <!-- Define a non-SSL HTTP/1.1 Connector on port 2117 (default 8080) -->
        <Connector port="2117" maxHttpHeaderSize="8192"
                   maxThreads="150" minSpareThreads="5" maxSpareThreads="75"
                   enableLookups="false" redirectPort="8443" acceptCount="100"
                   connectionTimeout="20000" disableUploadTimeout="true" />
     
     
        <!-- Define an AJP 1.3 Connector on port 8009 -->
        <Connector port="8009"
                   enableLookups="false" redirectPort="8443" protocol="AJP/1.3" />
     
        <!-- Define a Proxied HTTP/1.1 Connector on port 8082 -->
        <!-- See proxy documentation for more information about using this. -->
        <!--
        <Connector port="8082"
                   maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
                   enableLookups="false" acceptCount="100" connectionTimeout="20000"
                   proxyPort="80" disableUploadTimeout="true" />
        -->
     
        <!-- An Engine represents the entry point (within Catalina) that processes
             every request.  The Engine implementation for Tomcat stand alone
             analyzes the HTTP headers included with the request, and passes them
             on to the appropriate Host (virtual host). -->
          
        <!-- Define the top level container in our container hierarchy -->
        <Engine name="Catalina" defaultHost="localhost">
     
          <Realm className="org.apache.catalina.realm.UserDatabaseRealm"
                 resourceName="UserDatabase"/>
     
          <!-- Define the default virtual host -->
     
          <Host name="localhost" appBase="webapps"
           unpackWARs="true" autoDeploy="true"
           xmlValidation="false" xmlNamespaceAware="false">
     
            <Valve className="org.apache.catalina.valves.AccessLogValve"
                     directory="logs"  prefix="localhost_access_log." suffix=".txt"
                     pattern="common" resolveHosts="false"/>
          </Host>
     
          <!-- www.domain1.com -->
          <Host name="www.domain1.com" appBase="/home/www/web1/web"
            unpackWARs="true" autoDeploy="true">
     
            <Context path="" docBase="jsp-examples" debug="0" reloadable="true"/>
     
            <Valve className="org.apache.catalina.valves.AccessLogValve"
                     directory="logs"  prefix="web1_access_log." suffix=".txt"
                     pattern="common" resolveHosts="false"/>
          </Host>
     
          <Listener className="org.apache.jk.config.ApacheConfig"
                     modJk="/usr/lib/apache2/modules/mod_jk.so"
                     workersConfig="/etc/apache2/workers.properties"/>
     
        </Engine>
     
      </Service>
     
    </Server>
    
    Ich benutze Ubuntu 8.04 LTS server. Die Fehlermeldung sagt mir nur, dass er die Klasse nicht findet. Aber wie binde ich die Klasse ein? und wo findet er die?
    Ich hoffe ihr könnt mir helfen.

    Gruß
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 marce, 13.10.2009
    Zuletzt bearbeitet: 13.10.2009
    marce

    marce Kaiser

    Dabei seit:
    01.08.2007
    Beiträge:
    1.053
    Zustimmungen:
    8
  4. #3 realheat, 13.10.2009
    Zuletzt bearbeitet: 13.10.2009
    realheat

    realheat Jungspund

    Dabei seit:
    19.01.2007
    Beiträge:
    15
    Zustimmungen:
    0
    also an der falschen Stelle lag es nicht, der Fehler ist immer noch. Aber was für ein Connector benutzt Ihr denn?
     
  5. marce

    marce Kaiser

    Dabei seit:
    01.08.2007
    Beiträge:
    1.053
    Zustimmungen:
    8
    TomCat direkt - gar kein Apache vornedran :-)
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Tomcat6 startet nicht

Die Seite wird geladen...

Tomcat6 startet nicht - Ähnliche Themen

  1. Tomcat6/GWT auf 1und1 virtual Server

    Tomcat6/GWT auf 1und1 virtual Server: hallo, sobald ich mein GWT Projekt hochlade und es ausführe, dann stoppt capalist. In der Log Datei steht keine Fehlermeldung sondern nur eine...
  2. LEDE: Fork von OpenWRT gestartet

    LEDE: Fork von OpenWRT gestartet: Unter dem Namen LEDE haben einzelne OpenWRT-Entwickler ein neues Projekt gestartet. Ziel des neuen Projektes ist es, eine gemeinschaftszentrierte...
  3. X startet nichtmehr

    X startet nichtmehr: Hallo, ich habe versucht CUDA und OPENCL mit meiner Graka zum laufen zu bekommen ... nun hängt er aber schon beim Booten bei "started Update UTMP...
  4. Humble Devolver Bundle gestartet

    Humble Devolver Bundle gestartet: Mit dem »Humble Devolver Bundle« sind nun ein weiteres Mal zahlreiche Independent-Spiele zu einem selbst wählbaren Preis für Linux, Mac OS X und...
  5. Linux Foundation startet Projekt für zivile Infrastruktur

    Linux Foundation startet Projekt für zivile Infrastruktur: Strom, Öl, Gas, Wasser, Gesundheitswesen, Kommunikationsverbindungen, Verkehrswege und anderes mehr benötigen immer komplexere...