SuSE+nVidia+Scripts

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von LinuxSchwedy, 19.08.2003.

  1. #1 LinuxSchwedy, 19.08.2003
    LinuxSchwedy

    LinuxSchwedy ehem. Mod

    Dabei seit:
    12.12.2002
    Beiträge:
    1.797
    Zustimmungen:
    0
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    jo update für Nvidia treiber im YOU !

    DRIVER="http://download.nvidia.com/XFree86/Linux-x86/1.0-4496/NVIDIA-Linux-x86-1.0-4496-pkg2.run"

    kannste auch selber runterladen und per "sh NVIDIA-Linux-x86-1.0-4496-pkg2.run" starten :)
     
  4. #3 LinuxSchwedy, 19.08.2003
    LinuxSchwedy

    LinuxSchwedy ehem. Mod

    Dabei seit:
    12.12.2002
    Beiträge:
    1.797
    Zustimmungen:
    0
    Ne, kann ich nämlich nicht - fehlen kernel-headers und ich finde diese nicht auf den CDs ...

    PS: ich weiß - das Thema hatten wir schon hier oft ...
     
  5. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    wir reden von suse oder ?

    such mal im yast nach KERNEL ... da werden dir u.a. dein installierter kernel + sourcen angezeigt ..
     
  6. #5 LinuxSchwedy, 19.08.2003
    LinuxSchwedy

    LinuxSchwedy ehem. Mod

    Dabei seit:
    12.12.2002
    Beiträge:
    1.797
    Zustimmungen:
    0
    Danke.

    Die Sourcen habe ich nachinstalliert. Jetzt probiere ich es nochmal mit den nVidia-Treibern.

    Die 3D-Unterstützung hat bis heute gefunzt. Ich habe nur mein System und u.a. den Kernel aktualisiert und jetzt musste ich die Treiber neu installieren, weil YaST keine anderen Möglichkeiten angezeigt hatte.
     
  7. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    ja das kenn ich, hab ich beim kunden auch per hand installiert, klappte prima !

    nach der install mußte in der konsole in "init 3" wechseln und dann "sax2" aufrufen ... und dort deine settings überprüfen und 3D aktivieren ..

    fertig
     
  8. #7 nob62, 21.08.2003
    Zuletzt bearbeitet: 21.08.2003
    nob62

    nob62 Jungspund

    Dabei seit:
    26.01.2003
    Beiträge:
    14
    Zustimmungen:
    0
    @LinuxSchwedy,

    welchen kernel hast Du denn jetzt? Ich habe das gleiche Problem, nachdem ich
    per You auf den 2.4.20-100_k-athlon aktualisiert hatte, ließ sich der Nvidia-Treiber nicht mehr installieren, im Installer:
    NVIDIA-Linux-x86-1.0-4496-pkg2.run ist nur ein sogenanntes precompiled
    Kernel-Modul von bis kernel 2.4.20-98 drin, bisher gibt es noch keine neuen
    Updates, ich schaue jeden Tag erwartungsvoll auf den FTP-Server von
    Nvidia
    , bisher leider nichts Neues drauf, letztes Update ist vom 27.07.2003.
    Inzwischen habe ich auf den 2.4.21-4 aktualisiert, da werde ich wohl noch etwas warten müssen. :rolleyes:
     
  9. #8 LinuxSchwedy, 21.08.2003
    LinuxSchwedy

    LinuxSchwedy ehem. Mod

    Dabei seit:
    12.12.2002
    Beiträge:
    1.797
    Zustimmungen:
    0
    Jau nob62,

    habe jetzt auch den 2.4.20-100 (K-Athlon). Leider ...:( Mit den Treibern klappt es bei mir auch nicht....

    Möchte momentan aber nicht auf den 2.4.21 umsteigen. :rolleyes:
     
  10. #9 shellmaster, 21.08.2003
    shellmaster

    shellmaster Doppel-As

    Dabei seit:
    21.08.2003
    Beiträge:
    122
    Zustimmungen:
    0
    hi leuts,

    um die nvidia treiber für einen selbstkompilierten kernel zu installieren machst du am besten folgendes:

    lade dir von der nvidia homepage die treiber bzw. die datei "NVIDIA-Linux-x86-1.0-4496-pkg2.run" runter.
    nun muss man die datei entpacken mit "sh NVIDIA-Linux-x86-1.0-4496-pkg2.run --extract-only", nun sollte ein verzeichniss da sein ("NVIDIA-Linux-x86-1.0-4496-pkg2" oder so ähnlich). am besten wechselst du nun in init 3 um kdm oder xdm zu beenden. in dem verzeichniss führst du nun "./nvidia-installer --no-precompiled-interface" aus und befolgst die anweisungen.
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. nob62

    nob62 Jungspund

    Dabei seit:
    26.01.2003
    Beiträge:
    14
    Zustimmungen:
    0
    @shellmaster,
    danke für den Tip, das geht aber leider auch nicht:

    Error: "Unable to build the NVIDIA kernle module" 8o
     
  13. #11 damager, 27.08.2003
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    das problem hatte ich auch aber google hilft da gerne weiter :]

    folgender link hilft:
    ftp://ftp.suse.com/pub/suse/i386/supplementary/X/XFree86/nvidia-installer-HOWTO.html

    hier der auszug:
    II. SuSE Linux Desktop (SLD)
    SuSE Linux 8.2 with update kernel or self-compiled kernel
    -------------------------------------------------------------

    1) Kernel sources must be installed and configured. Usually this means
    installing the 'kernel-source' RPM with YaST2 and configure it then
    with the following commands:

    cp /boot/vmlinuz.config /usr/src/linux/.config
    cp /boot/vmlinuz.version.h /usr/src/linux/include/linux
    cp /boot/vmlinuz.autoconf.h /usr/src/linux/include/linux
    cd /usr/src/linux
    make cloneconfig dep

    2) Use the nvidia installer.

    export IGNORE_CC_MISMATCH=yes
    sh NVIDIA-Linux-x86-1.0-4363.run

    3) Enable 3D support with SaX2.

    Quelle: ftp://ftp.suse.com/pub/suse/i386/supplementary/X/XFree86/nvidia-installer-HOWTO.html


    bei mir futzt es!

    Gruß
    Damager 8)
     
Thema:

SuSE+nVidia+Scripts