SuSE 9.2 Pro - Probleme mit Internet/Namensauflösung/Ping nach IFDOWN/IFUP

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von axel1973, 24.03.2005.

  1. #1 axel1973, 24.03.2005
    axel1973

    axel1973 Grünschnabel

    Dabei seit:
    24.03.2005
    Beiträge:
    1
    Zustimmungen:
    0
    Ort:
    Freiburg
    Hallo Allerseits!

    Ich hab neulich SuSE 9.2 Pro installiert und möchte es u.a. als DSL Router fürs lokale LAN nutzen. Früher war bei mir 9.0 im Einsatz und hat prima geklappt. Die neue 9.2 macht hier nun Prrobleme und ich weis nich warum und wieso.

    Folgendes habe ich festgestellt: (IF == Interface)

    1. MAschine frisch rebootet: alles OK!

    2. inet verb. Besteht, pings funktionieren

    3. IFDOWN DSL0 - IF DSL0 geht weg

    4. IFUP DSL0 - DSL0 kommt NICHT wieder!!! Siehe hier

    ##############################################
    linux:~ # ifdown dsl0
    dsl0
    interface dsl0 is down
    linux:~ # ifup dsl0
    dsl0
    interface dsl0 is up
    linux:~ # ifconfig
    eth0 Link encap:Ethernet HWaddr 00:11:D8:3A:2A:3F
    inet addr:192.168.1.69 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::211:d8ff:fe3a:2a3f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:588 errors:0 dropped:0 overruns:0 frame:0
    TX packets:682 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:151902 (148.3 Kb) TX bytes:156838 (153.1 Kb)
    Base address:0xbc00 Memory:fc8e0000-fc900000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:4 errors:0 dropped:0 overruns:0 frame:0
    TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:200 (200.0 b) TX bytes:200 (200.0 b)

    linux:~ #
    #####################################################

    5. nochmal IFUP DSL0 eingeben >> DSL0 wieder da mit pseudo IP wie gewollt.

    ###########################################################
    linux:~ # ifup dsl0
    dsl0
    interface dsl0 is up
    linux:~ # ifconfig
    eth0 Link encap:Ethernet HWaddr 00:11:D8:3A:2A:3F
    inet addr:192.168.1.69 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::211:d8ff:fe3a:2a3f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:588 errors:0 dropped:0 overruns:0 frame:0
    TX packets:682 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:151902 (148.3 Kb) TX bytes:156838 (153.1 Kb)
    Base address:0xbc00 Memory:fc8e0000-fc900000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:4 errors:0 dropped:0 overruns:0 frame:0
    TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:200 (200.0 b) TX bytes:200 (200.0 b)

    linux:~ # ifup dsl0
    dsl0
    interface dsl0 is up
    linux:~ # ifconfig
    dsl0 Link encap:Point-to-Point Protocol
    inet addr:192.168.99.1 P-t-P:192.168.99.99 Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    eth0 Link encap:Ethernet HWaddr 00:11:D8:3A:2A:3F
    inet addr:192.168.1.69 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::211:d8ff:fe3a:2a3f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:656 errors:0 dropped:0 overruns:0 frame:0
    TX packets:767 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:158861 (155.1 Kb) TX bytes:167449 (163.5 Kb)
    Base address:0xbc00 Memory:fc8e0000-fc900000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:4 errors:0 dropped:0 overruns:0 frame:0
    TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:200 (200.0 b) TX bytes:200 (200.0 b)

    linux:~ #
    ##########################################################################


    6. Verbindung starten mit "ping -c3 www.hallo.de" >> IF DSL0 erhält neue IP Adresse. Er erscheinen aber auch dubiose Meldungen. siehe hier:

    ######################################

    linux:~ # ping -c3 www.hallo.de
    PING wielin3.hallo.de (80.121.157.11) 56(84) bytes of data.
    ping: sendmsg: Operation not permitted
    ping: sendmsg: Operation not permitted

    --- wielin3.hallo.de ping statistics ---
    3 packets transmitted, 0 received, 100% packet loss, time 1999ms

    linux:~ # ifconfig
    dsl0 Link encap:Point-to-Point Protocol
    inet addr:80.131.224.47 P-t-P:217.5.98.41 Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    RX packets:9 errors:0 dropped:0 overruns:0 frame:0
    TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:591 (591.0 b) TX bytes:789 (789.0 b)

    ######################################


    7. nochmaliger Ping versuch einige Sekunden später ergibt:


    ######################################


    linux:~ # ping -c3 www.hallo.de
    PING wielin3.hallo.de (80.121.157.11) 56(84) bytes of data.
    64 bytes from 80.121.157.11: icmp_seq=1 ttl=249 time=62.7 ms
    64 bytes from 80.121.157.11: icmp_seq=2 ttl=249 time=62.5 ms
    64 bytes from 80.121.157.11: icmp_seq=3 ttl=249 time=62.2 ms

    --- wielin3.hallo.de ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2003ms rtt min/avg/max/mdev = 62.241/62.515/62.780/0.363 ms linux:~ #

    ######################################

    Was läuft hier falsch?!?


    Aber es geht noch weiter!

    8. ein ping auf eine andere Adresse z.b. ping www.heute.de klappt dann immernoch nicht. Fehlermeldung wie bereits oben. Hostnot found oder ähnliches. Es scheint als könne er bei bekannten IP Adressen noch sauber pingen. Bei neuen Hostnamen jedoch schlägt es wohl fehl.


    Ich kanns mir echt nicht mehr erklären!!! Hat einer von euch nen Tipp oder kennt gar da Problem???


    btw:
    NEtzkonfig sieht bei mir so aus:
    1. Linux box mit IP x.x.x.69 ist ROUTER/Gateway
    2. Windows Server mit IP x.x.x..95 ist DNS/Nameserver u.a. wg ADS
    3. der DNS auf der Windows box enthält forwarder welche auf gültige NS der Telekom zeigen (TDSL)

    Zu guter letzt: Wenn ich die Linux Box per "reboot" neu starte funktioniert alles perfekt bis zum nächsten "ifdown/ifup" :(( Das nachträgliche aufrufen von SuSEFirewall2 und/oder "rcnetwork restart" brachte ebenfalls nichts.


    HILFÄÄÄÄÄÄ!!!!!

    MFG
    Axel
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    HINWEIS : Doppelpostings werden normalerweise umgehend gelöscht !
     
Thema:

SuSE 9.2 Pro - Probleme mit Internet/Namensauflösung/Ping nach IFDOWN/IFUP

Die Seite wird geladen...

SuSE 9.2 Pro - Probleme mit Internet/Namensauflösung/Ping nach IFDOWN/IFUP - Ähnliche Themen

  1. Netzwerk Probleme mit Opensuse 12.3

    Netzwerk Probleme mit Opensuse 12.3: Hallo, ich habe einen alten Rechner den ich für mich als Server benutze. Es ist als CPU ein Intel Celeron 2.00 GHz mit 2 GB Arbeitsspeicher....
  2. Suse 12.3 Probleme mit HP Elite und Metzwerk

    Suse 12.3 Probleme mit HP Elite und Metzwerk: Hallo, ich versuche gerade, und das schon ziemlich lange, Suse vernünftig auf einem HP-Desktop (Elite) zum Laufen zu bekommen. Das Problem ist...
  3. Probleme nach Update auf Suse 12.1

    Probleme nach Update auf Suse 12.1: Hallo Leute, Ich habe heute per Netzwerk-CD mein Sytem von 11.4 auf 12.1 upgegradet. Die Installtion ging ohne Fehlermeldungen von statten....
  4. OpenSuse 11.3 RTL8185L W-Lan und nur Probleme.

    OpenSuse 11.3 RTL8185L W-Lan und nur Probleme.: Moin Moin, So ich bin leider im besitz einer W-Lan Karte mit dem RTL 8185L Chip der (nicht nur unter Suse) nichts als ärger macht bzw das...
  5. OpenSuse 11.2 UMTS Probleme Huawei E220

    OpenSuse 11.2 UMTS Probleme Huawei E220: Hallo Leute, hab seit einer Woche von OpenSuse 10.3 auf 11.2 gewechselt. Wollte mit UMTSMON eine Verbindung mit dem Huawei Technologies Co.,...