Suse 10: Grafikmodus beim Booten funktioniert nicht

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Heinz, 14.02.2006.

  1. Heinz

    Heinz Grünschnabel

    Dabei seit:
    14.02.2006
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo,

    ich habe bei SUSE 10.0 ein Online-Update gemacht, bei dem er auch das Kernel upgedated hat und nach dem Reboot konnte er nur noch den Textmodus verwenden. Ich konnte dann zwar über sax2 die Grafikparameter wieder so einstellen, dass er jetzt wieder normal die KDE starten kann, aber der ganze Bootvorgang, der früher grafisch erfolgte, ist jetzt im Text-Modus, so wie bei den ganz alten Linux-Versionen. Bei der 10-er Version konnte man mit <ESC> ja auch auf die Meldungsausgabe umschalten, aber in dem Modus hatte er unten immer noch diesen blauen Balken mit den weissen Kreischen als Fortschrittsanzeige. Bei mir ist jetzt aber wirklich nur der reine Textmode beim Booten und runter fahren. Hat irgendjemand eine Ahnung, wie ich wieder den "normalen" grafischen Bootmodus vom 10er aktivieren kann??
    Als Bootloader habe ich GRUB und in der sysconfig habe ich kontrolliert, dass SPLASH=yes und SuSE als Theme eingetragen ist :hilfe2: . Daran kann es also nicht liegen. Falls irgendjemand eine Idee hat, woran es liegen könnte wäre es super! :)

    vielen Dank
    Heinz
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Ritschie, 14.02.2006
    Ritschie

    Ritschie SuSE-User

    Dabei seit:
    10.09.2003
    Beiträge:
    1.216
    Zustimmungen:
    0
    Ort:
    D-Bayreuth
    Schau mal in die /boot/grub/menu.lst und überprüfe, ob dort splash=silent eingetragen ist. Wenn nicht, ändern.

    Ich hoffe, das war´s.

    Gruß,
    Ritschie
     
  4. Heinz

    Heinz Grünschnabel

    Dabei seit:
    14.02.2006
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo Ritschie,

    vielen Dank für Deine Hilfe! In der menu. lst steht splash=silent showopts. Das heisst von dem her wäre es eigentlich schon OK, oder? Das Eigenartige ist auch, dass das System nicht wirklich im silent mode bootet, weil selbst im silent Mode hat es in der 10er Version diesen blauen Balken am unteren Bildschirmrand. Bei mir hat er den Bootmanager und den Login zwar im Grafik-Modus, aber für alles dazwischen wechselt er in den Textmodus seit diesem Updateproblem.
    Nach dem Update hatte er völligen Blödsinn bei den Monitor und Grafikkarteneinstellungen drin. Das Korrigieren der Einstellungen mit Sax2 war scheinbar ausreichend, damit alles ab dem Login wieder im Grafikmodus ist, aber scheinbar muss es noch irgendwo separate Einstellungen geben, die er für die Zeit zwischen Bootmanager und Login verwendet (und die leider durch Sax2 nicht korrigiert wurden :( ). Ich habe aber keine Ahnung was dafür zuständig sein könnte, respektive wonach ich suchen soll.

    Gruß,
    Heinz
     
  5. #4 Ritschie, 14.02.2006
    Zuletzt bearbeitet: 14.02.2006
    Ritschie

    Ritschie SuSE-User

    Dabei seit:
    10.09.2003
    Beiträge:
    1.216
    Zustimmungen:
    0
    Ort:
    D-Bayreuth
    Hm,

    schau Dir mal im Ordner /etc/sysconfig/ die Datei bootsplash an. Bei mir (allerdings SuSE 9.3) sieht sie folgendermaßen aus:

    It should be based in # /etc/bootsplash/themes/
    zeigt Dir also an, wo das Theme SuSE zu finden sein sollte. Schau mal nach, ob es da ist. Darin müssen sich auch die images befinden.

    Wenn dann noch THEME="SuSE" und SPLASH="yes" eingetragen ist, fällt mir langsam auch nix mehr ein.

    Schau auch mal in der menu.lst, was bei vga=xxxxx eingetragen ist. Bei mir ( 1024x768 ) steht vga=0x317

    Gruß,
    Ritschie
     
  6. Heinz

    Heinz Grünschnabel

    Dabei seit:
    14.02.2006
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo Ritschie,

    vielen Dank für Deine tolle Hilfe! Leider scheinen die Einstellungen korrekt zu sein (die bootsplash ist identisch und die anderen Einstellungen/Pfade würden eigentlich auch passen). Ich habe jetzt gesehen, dass noch ein paar andere Sachen (USB-Sticks, Filezugriffe,...) seit dem Update ziemlich suboptimal funktionieren.
    Ich schätze ich werde am Abend das System nocheinmmal neu drauf spielen. Nochmals aber ganz herzlichen Dank für Deine großartige Hilfe!

    Danke
    Heinz


    P.S.: Wenn Du jetzt die 9.3 drauf hast, würde ich mit der 10-er noch etwas warten - die aktuelle Version ist im Moment noch VIEL instabiler als es die 9.3 war.
     
  7. #6 Ritschie, 14.02.2006
    Ritschie

    Ritschie SuSE-User

    Dabei seit:
    10.09.2003
    Beiträge:
    1.216
    Zustimmungen:
    0
    Ort:
    D-Bayreuth
    Ich hab gerne versucht zu helfen. Leider hat´s ja nicht viel gebracht. Wegen der anderen Punkte, die nicht richtig wollen, würde ich dann auch mal zu ner Neuinstallation tendieren (obwohl das ja bei Linux nicht sein sollte :( ). Aber interessieren würd mich jetzt trotzdem, wo das Problem liegt ;)

    Bei der 9.3 werd ich auf jeden fall noch ne Zeit bleiben - vielleicht sogar bis zur Einstellung des Support - da ich mit ihr sehr zufrieden bin.

    Gruß,
    Ritschie
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Suse 10: Grafikmodus beim Booten funktioniert nicht

Die Seite wird geladen...

Suse 10: Grafikmodus beim Booten funktioniert nicht - Ähnliche Themen

  1. SUSE 13.2 Bumblebee dual monitor

    SUSE 13.2 Bumblebee dual monitor: Folgendes Problem: weder am VGA noch HDMI-Ausgang ist ein Signal für den Beamer vorhanden. Rechner: Lenovo Z70 SUSE 13.2 Kernel...
  2. Suse: Tomas Di Giacomo wird neuer CTO

    Suse: Tomas Di Giacomo wird neuer CTO: Suse hat seinen Vorstand um Dr. Tomas Di Giacomo erweitert, der als Chief Technology Officer ab sofort dem Unternehmen angehört. In der neu...
  3. OpenSuse Conference vom 22. bis 26. Juni in Nürnberg

    OpenSuse Conference vom 22. bis 26. Juni in Nürnberg: Zum mittlerweile achten Mal findet die OpenSuse Conference statt. In diesem Jahr wird sie vom 22. bis 26. Juni in Nürnberg abgehalten. Der Call...
  4. OpenSuse Conference vom 22. bis 26. Juni in Nürnberg

    OpenSuse Conference vom 22. bis 26. Juni in Nürnberg: Zum mittlerweile achten Mal findet die OpenSuse Conference statt. In diesem Jahr wird sie vom 22. bis 26. Juni in Nürnberg abgehalten. Der Call...
  5. Suse veröffentlicht OpenStack Cloud 6

    Suse veröffentlicht OpenStack Cloud 6: Mit Suse OpenStack Cloud 6 können Unternehmen private Clouds mit geringem Aufwand aufsetzen. Die Distribution beruht auf Suse Enterprise Linux und...