Startscript unter SuSE 10.1

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von mkl, 22.09.2006.

  1. mkl

    mkl Grünschnabel

    Dabei seit:
    22.09.2006
    Beiträge:
    2
    Zustimmungen:
    0
    Ich möchte beim OS-Start ein Script ausführen lassen. Hierzu habe ich ein Script unter /etc/init.d algelebt (unter Beachtung der üblichen gegebenheiten, wie rc_status, oder start-/stop-Sections). dieses Script habe ich nach rc3.d und rc5.d als letztes Script (S20...) verlinkt - und ebenfalls einen Stoplink.
    Wenn ich dieses Script nun mit S20... start aufrufe, wird dieses ausgeführt, tut was es soll und meldet ein "Done" zurück. Alles super soweit. Auch im Yast erscheint das Script und läßt sich sauber starten und dem Anschein nach auch konfigurieren.
    Mein Problem liegt nun darin, daß es beim Booten nicht ausgeführt wird. Es steht nichts bei den Bootmeldungen (auch keine Fehlermeldung) und nichts in den Logfiles. Ich habe leider keine Stelle gefunden, an der ich irgendetwas konfigurieren könnte, damit das Script nun wirklich beim Booten auch ausgeführt wird. :(
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 22.09.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Hmm,

    was macht denn das script?

    Desweiteren erscheint mir S20 etwas niedrig angesetzt, was ist denn wenn du das in S99 änderst?
     
  4. mkl

    mkl Grünschnabel

    Dabei seit:
    22.09.2006
    Beiträge:
    2
    Zustimmungen:
    0
    Es startet bonding für zwei Netzwerkkarten.
    Ich habe S20 gewählt, da die höchste systemseitig vergebene Startnummer S12 lautet. An dieser Stelle habe ich ein bißchen Platz gelassen, aber nicht soweit nach "oben" gehen wollen.
     
Thema:

Startscript unter SuSE 10.1

Die Seite wird geladen...

Startscript unter SuSE 10.1 - Ähnliche Themen

  1. Runlevel+Startscript unter Ubuntu 10.04 Server x64

    Runlevel+Startscript unter Ubuntu 10.04 Server x64: Hallo Community, wie sich schon aus dem Titel unschwer erkennen lässt, habe ich ein Problem / eine Verständnisfrage bezüglich der Runlevel in...
  2. Startscript als User nicht als root ausführen

    Startscript als User nicht als root ausführen: Hallo Zusammen, wie es der Titel bereits andeutet, möchte ich ein Script als User und nicht als root starten. Leider funktioniert es nur als...
  3. Startscript in init.d scheitert an - " -

    Startscript in init.d scheitert an - " -: Hallo ich schon wieder ;) Ich starte in Debian lenny auf der Console den mjpg_streamer problemlos: /usr/bin/mjpg_streamer -b -i "input_uvc.so -d...
  4. Minecraft Startscript

    Minecraft Startscript: Ich finde den Fehler nicht. Als Fehler kommt: ./startserver: 73: [[: not foundUnd hier der Quellcode: #!/bin/sh DIR="/home/marok" DAEMON="java"...
  5. respawn aus Startscript in /etc/init.d/

    respawn aus Startscript in /etc/init.d/: Hallo zusammen Habe soeben ein init Script in /etc/init.d geschrieben damit mein Programm als Daemon startet. Nun sollte sich dieses...