SSH Zugriff dauert lange

Dieses Thema im Forum "Security Talk" wurde erstellt von campylobacter, 10.08.2006.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. #1 campylobacter, 10.08.2006
    campylobacter

    campylobacter Tripel-As

    Dabei seit:
    26.10.2003
    Beiträge:
    194
    Zustimmungen:
    0
    Hallo,

    Ich habe ein sehr nerviges Problem.
    Unter VMWARE-Server läuft Archlinux mit SSH. Wenn ich mich jetzt verbinden möchte, dauert es immer exakt 20 Sekunden, bis die Aufforderung zur Passworteingabe kommt. Egal ob jetzt per Konsole oder sftp. Auf dauer nervt das natürlich, weil es ja nicht notwendig und auch nicht nachvollziehbar ist.

    Die Frage ist nur, woran kann es liegen? Bei den SSH Einstellungen konnte ich nichts finden. Kann es sein, das VMWARE so lange braucht? Vielleicht habt ihr da Erfahrungen gemacht.

    Vielen Dank!
    mfg campy
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. grey

    grey -=[GHOST]=-

    Dabei seit:
    28.07.2006
    Beiträge:
    303
    Zustimmungen:
    0
    Existiert in deinem Netz ein DNS-Server oder hast du ersatzweise die Systeme in die /etc/hosts eingetragen?
    Bei mir hat sich dieses Problem gelöst, nachdem die System-Namen aufgelöst werden konnten.
     
  4. mcas

    mcas Routinier

    Dabei seit:
    29.12.2005
    Beiträge:
    398
    Zustimmungen:
    0
    Ich hatte da mal so ein Problem, dass er versucht hat den Namen des Clients aufzulösen. Das hat nicht geklappt und dann hat es gedauert. Könnte das bei dir auch sein? Das es an VMWare liegt glaube ich eher nicht, hatte da noch nie Probleme.
    EDIT: Mal wieder zu langsam ;-)
     
  5. rocko

    rocko Grünschnabel

    Dabei seit:
    30.06.2005
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo,
    normal liegt daran, dass der sshd ein reverse dns lookup auf die interne IP Adresse macht und das timeout abwartet.
    In der sshd config (z.b. /etc/ssh/sshd_config unter debian/SARGE) kann man den Parameter
    UseDNS no
    setzten.
    Könnte/sollte helfen.
    R.
     
  6. #5 campylobacter, 10.08.2006
    Zuletzt bearbeitet: 10.08.2006
    campylobacter

    campylobacter Tripel-As

    Dabei seit:
    26.10.2003
    Beiträge:
    194
    Zustimmungen:
    0
    So, jetzt hab ich ein Problem ;)
    Also es geht, ich weiß aber nicht wieso. Hab nur bei vmware ein paar Sachen umgestellt; Bridged auf NAT und dann wieder zurück,.. komisch

    Edit:

    Nach einem Reboot ging es dann doch wieder nicht. Das "UseDNS no" sieht aber sehr gut aus; Danke!
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 aspire_5652, 03.01.2008
    aspire_5652

    aspire_5652 Tripel-As

    Dabei seit:
    02.01.2008
    Beiträge:
    198
    Zustimmungen:
    0
    ich habe fast das gleiche Problem.
    Ich habe auf einem Kubuntu 7.04 vmware-server installiert.
    Die installierte vmware ist ein OpenSuSE 10.3.
    Eingestellt ist der bridged Netzwerk Modus, Kubuntu und OpenSuSE haben beide jeweils eine unterschiedliche IP vom DHCP zugewiesen bekommen.
    Versuche ich nun von meinem Gastgebersystem (Kubuntu) auf die vmware (Suse) mit ssh zu verbinden scheitert es:

    #ssh -v user@vmware
    Code:
    OpenSSH_4.3p2 Debian-8ubuntu1, OpenSSL 0.9.8c 05 Sep 2006
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to <VMWARE_IP> [<VMWARE_IP>] port 22.
    debug1: Connection established.
    debug1: identity file ~/.ssh/identity type -1
    debug1: identity file ~/.ssh/id_rsa type -1
    debug1: identity file ~/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_4.6
    debug1: match: OpenSSH_4.6 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_4.3p2 Debian-8ubuntu1
    debug1: Miscellaneous failure
    No credentials cache found
    
    debug1: Miscellaneous failure
    No credentials cache found
    
    debug1: SSH2_MSG_KEXINIT sent
    Alle anderen Rechner im Netzwerk können sich verbinden, nur ich nicht auf meine eigene VMware. Weiß jemand Rat?
     
  9. tr0nix

    tr0nix der-mit-dem-tux-tanzt

    Dabei seit:
    11.07.2003
    Beiträge:
    1.585
    Zustimmungen:
    0
    Ort:
    Schweiz, Opfikon/Glattbrugg
    Bitte eroeffne einen neuen Thread, das Problem ist offensichtlich nicht fast dasselbe :).
     
Thema:

SSH Zugriff dauert lange

Die Seite wird geladen...

SSH Zugriff dauert lange - Ähnliche Themen

  1. Problem mit Win-Zugriff auf SAMBA

    Problem mit Win-Zugriff auf SAMBA: Hallo rundherum, vielleicht hat jemand eine Idee... Habe jetzt schon 1 1/2 Tage damit verbraten und den Fehler nicht gefunden. Problem:...
  2. Nach Update debian 8 ist der Zugriff auf samba4 nicht möglich

    Nach Update debian 8 ist der Zugriff auf samba4 nicht möglich: Gerade habe ich debian mit dem Befehl "apt-get ugrade" aktualisiert. Es gab zahlreiche neue Daten unteranderen samba files. Nach neuem Start kann...
  3. Hackerzugriff auf Mozilla-Bugtracker

    Hackerzugriff auf Mozilla-Bugtracker: Ein Hacker hatte mindestens ein Jahr, möglicherweise sogar zwei Jahre Zugriff auf den nicht öffentlichen Teil von Bugzilla, der...
  4. Dateizugriffsrechte

    Dateizugriffsrechte: Hey, wenn ich eine Datei habe und einem Nutzer Ausührrechte (x) gebe aber keine Lesrechte (r)? Was passiert dann? Kann er die Datei normal...
  5. Ubuntu 14.4: Samba v3 => v4, Kein Zugriff

    Ubuntu 14.4: Samba v3 => v4, Kein Zugriff: Hallo, letzte Woche habe ich auf Ubuntu 14.04 LTS aktualisiert. Dabei wurde Samba von v3 auf v4 aktualisiert. Nachdem vorher alles mit der...
Status des Themas:
Es sind keine weiteren Antworten möglich.