ssh logins nicht loggen

Dieses Thema im Forum "Security Talk" wurde erstellt von simonwiese, 29.09.2009.

  1. #1 simonwiese, 29.09.2009
    simonwiese

    simonwiese Grünschnabel

    Dabei seit:
    20.11.2008
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo zusammen!

    Vielleicht eine ungewöhnliche Frage aber wie kann ich sshd da zubringen keine Informationen mit zu loggen? Also weder in /var/log/auth.log noch wtmp btmp bzw. lastlog....?

    Danke für eure Hilfe,
    Simon
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 29.09.2009
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Indem du deinen Syslog-Daemon entsprechend einstellst.
     
  4. #3 freak_out, 29.09.2009
    freak_out

    freak_out Cookie

    Dabei seit:
    01.12.2007
    Beiträge:
    234
    Zustimmungen:
    0
    Ort:
    Nachbar von Tux (Aufn Mars)
    Einfach in der /etc/ssh/sshd_config folgendes auskommentieren:

    Code:
    # Logging
    SyslogFacility AUTH
    LogLevel INFO
    
    Also:

    Code:
    # Logging
    #SyslogFacility AUTH
    #LogLevel INFO
    Denkmal dann sollte es gehen!

    Zumindestens sollte es gehen laut google :D
     
  5. #4 simonwiese, 29.09.2009
    simonwiese

    simonwiese Grünschnabel

    Dabei seit:
    20.11.2008
    Beiträge:
    5
    Zustimmungen:
    0
    Danke für die schnellen antworten!

    @freak_out:
    hab ich natürlich auch schon versucht - tut aber nicht...

    @bitmuncher:
    mit syslog kann ich doch nur die auth.log "steuern" aber nicht btmp, wtmp und lastlog - oder überseh ich was?!


    Grüße,
    Simon
     
  6. Gast1

    Gast1 Guest

    Wie wäre es mit RTFM?

     
  7. #6 simonwiese, 29.09.2009
    simonwiese

    simonwiese Grünschnabel

    Dabei seit:
    20.11.2008
    Beiträge:
    5
    Zustimmungen:
    0
    IRTFM!

    weder QUIET noch FATAL unterdrücken die Eintragungen in btmp, wtmp oder lastlog

    Trotzdem danke!
     
  8. Gast1

    Gast1 Guest

    Macht ja auch Sinn, weil die letzteren unabhängig davon sein sollten, wie sich der entsprechende User eingeloggt hat (zumindest bei lastlog bin ich mir 100%ig sicher).

    Mit QUIET, FATAL oder ERROR werden keinerlei Logins in den "human readable" Logs angezeigt (bei mir ist das sshd/sshd.log, mein syslog ist etwas "modifiziert"), die anderen Dateien lastlog, wmtp&co sind ja "binär" angelegt.

    Ob das überhaupt geht _alles_ abzuschalten wage ich zu bezweifeln, wenn es ginge wäre es auf jeden Fall wenig sinnvoll.

    Kannst ja versuchen Dein eigenes rootkit zusammen zu stöpseln, die können so etwas.

    :-)
     
  9. Jabo

    Jabo Aufgabe ohne Minister

    Dabei seit:
    12.10.2006
    Beiträge:
    1.322
    Zustimmungen:
    0
    Ort:
    Hamburg
    eben.

    es soll eine secureshell sein, weshalb der Admin wenigstens wissen möchte, wer zu Besuch war. Das ist doch das Minimum, daß man wissen möchte, wenn man überhaupt SSH-Logins hat
     
  10. #9 simonwiese, 29.09.2009
    simonwiese

    simonwiese Grünschnabel

    Dabei seit:
    20.11.2008
    Beiträge:
    5
    Zustimmungen:
    0
    jap ich denk auch des es dafür keinen schalter gibt der einem sowas macht.

    Mal schauen wie ich das Regel...


    Trotzdem allen vielen dank!
     
  11. Shorti

    Shorti Routinier

    Dabei seit:
    08.04.2007
    Beiträge:
    271
    Zustimmungen:
    0
    Loesch einfach die Logs regelmaessig (Per cronjob zB alle 5min)
    Wenn du nicht die gesammten logs loeschen willst, dann loesch nur die sshd-Zeilen.
     
  12. Jabo

    Jabo Aufgabe ohne Minister

    Dabei seit:
    12.10.2006
    Beiträge:
    1.322
    Zustimmungen:
    0
    Ort:
    Hamburg
    dennoch widerspricht das aber grundsätzlich der Idee von syslog und auch der von ssh, oder?
     
  13. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  14. #12 saeckereier, 30.09.2009
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Jetzt bin ich interessiert: Wozu das ganze?
     
  15. T-One

    T-One Routinier

    Dabei seit:
    14.10.2008
    Beiträge:
    478
    Zustimmungen:
    3
    Ort:
    Österreich
    starte den sshd als

    sshd -e 2>/dev/null somit gehen alle sshd ausgaben an stderr die du wiederrum an /dev/null schickst.

    du kannst auch versuchen sshd mit option -q zu starten, dann sollte er sich ebenfalls ganz ruhig verhalten, bis auf wirkliche fehlermeldungen. Punkt 1 macht das alles aus.

    PS: ich hab das eigentlich immer nur auf servern gebraucht auf denne ich nix verloren hab :)
     
Thema:

ssh logins nicht loggen

Die Seite wird geladen...

ssh logins nicht loggen - Ähnliche Themen

  1. Logins funktionieren nicht

    Logins funktionieren nicht: Hallo, auf meinem Lanserver funktioniert der Login auf dem Tracker nicht-Man wird statt eingeloggt zu sien einfach auf die Hauptseite des...
  2. Samba PDC (Ubuntu Feisty) lässt keine Logins zu und zeigt Netbios Namen nicht an

    Samba PDC (Ubuntu Feisty) lässt keine Logins zu und zeigt Netbios Namen nicht an: Hallo, ich habe seit 30 Stunden ein nettes Problem dem ich nicht mehr Herr werde und mir sind langsam komplett die Ideen ausgegangen. Ich...
  3. who zeigt nicht alle Benutzer von ssh logins

    who zeigt nicht alle Benutzer von ssh logins: Hallo, hab hier bei uns in der Firma auf einem Rechner (Debian etch) openssh-server laufen. Wenn Wartungsarbeiten durchzuführen sind, möchte...
  4. Online Logins unter Linux

    Online Logins unter Linux: nAbend, Es fallen doch heutzutage Online Logins / Passwörter ohne ende an. Diverse Online Shops, verschiedene Foren, Mail Accounts und mehr....
  5. LoginScreen Komisch versaut

    LoginScreen Komisch versaut: Hi Leute hab ein Ubuntu Upgrade auf Hardy gemacht. Beim Laptop hatte ich keien probelme. Beim Desktop hats mir irgendwie den LoginScreen...