SSH Login - lahm

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von lordlamer, 20.04.2006.

  1. #1 lordlamer, 20.04.2006
    lordlamer

    lordlamer Haudegen

    Dabei seit:
    15.05.2003
    Beiträge:
    703
    Zustimmungen:
    0
    Ort:
    hamburg
    Hi,

    wir setzen hier auf Arbeit Suse Linux Enterprise Server 9 ein. Dabei haben wir eigentlich immer folgendes Problem. Wenn man sich per SSH auf den Server connecten will dauert es ewig bis er nach dem Passwort fragt. Ewig sind so ca 20 bis 30 Sekunden. Mit Debian hab ich das zb nicht. Wodurch kommt das? Der scheiss IpV6 in Suse oder woran liegts?

    Mfg Frank
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Dauert es auch so lange, wenn Du statt des Namens die IP-Adresse des Servers angibst? Wenn nicht, dann liegt es wohl am nameserver. Hatten wir auch lange Zeit. Ist irgendwann weggegangen und ich weiss nicht, wieso (obwohl ich fuer das Netz verantwortlich bin...). Habe eine Weile damit rumgespielt, sowohl mit /etc/resolv.conf auf den einzelnen Rechnern als auch mit dem nameserver setup.
     
  4. #3 slasher, 20.04.2006
    slasher

    slasher König

    Dabei seit:
    22.03.2006
    Beiträge:
    827
    Zustimmungen:
    0
    vergleich bitte deinen lokalen Hostname mit den Mappings in der "/etc/hosts". Wenn dein lokaler Hostname dort nicht auftaucht, trage ihn ein :). Mit "ping $deinHostname" kannst du testen, ob es geklappt hat. Danach sollte der Login ruckizucki gehen.
     
  5. #4 lordlamer, 20.04.2006
    lordlamer

    lordlamer Haudegen

    Dabei seit:
    15.05.2003
    Beiträge:
    703
    Zustimmungen:
    0
    Ort:
    hamburg
    oki das mit dem hostnamen klinkt ja irgendwie schon logisch. aber wieso ist das unter debian so nicht? kann man das in ssh abschalten?

    also den aufruf zum server mache ich direkt über ip und nicht über einen hostnamen bzw eine domain.

    mfg frank
     
  6. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Wenn Du die IP eingibst, hat es nichts mit den hostnamen zu tun.
    Vielleicht unterscheiden sich die beiden Distributionen darin, welche protokolle beim Handshake ausgefuehrt werden und/oder welche timeouts dafuer gesetzt sind. Allerdings kann ich Dir auch nicht sagen, wie man das einstellt.
     
  7. #6 StyleWarZ, 22.05.2006
    StyleWarZ

    StyleWarZ Profi Daten Verschieber

    Dabei seit:
    05.03.2004
    Beiträge:
    1.929
    Zustimmungen:
    0
    Ich habe dies Gestern gemerkt als ich mein Server beim Kollegen hatte und per Putty connecten wollte. FreeBSD 6 hatte eine Ewigkeit bis er das Passwort abfragt. Wenn ich aber mit meinem OpenSUSE10.1 per ssh drauf geh flutscht es wie geschmiert. Jemand schon eine Lösung?
     
  8. #7 lordlamer, 22.05.2006
    lordlamer

    lordlamer Haudegen

    Dabei seit:
    15.05.2003
    Beiträge:
    703
    Zustimmungen:
    0
    Ort:
    hamburg
    jap es liegt am reversedns- ssh versucht deine ip aufzulösen. trage am besten im dnsserver oder direkt in die hosts auf dem sshserver die ip des clients mit dem rechenrnamen des clients ein.

    dann sollte es funktionieren.

    frank
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 damager, 22.05.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    hmmm hast du eine option:
    NoDelay in der sshd_condfig?

    evtl. hilft das was.
    evtl mit im VerboseMode nach evtl. auffäligkeiten auf den server suchen...
     
  11. #9 StyleWarZ, 22.05.2006
    StyleWarZ

    StyleWarZ Profi Daten Verschieber

    Dabei seit:
    05.03.2004
    Beiträge:
    1.929
    Zustimmungen:
    0
    Werde heute Abend den Server abholen (100gb mp3 kopieren ging etwas lange um daneben zu sitzen). Werde dann mal in die configs gucken. Ach ja. Beim Kollegen war das ganze mit statischen IP's und gekreuztem Kabel zusammengeschlossen.
     
Thema:

SSH Login - lahm

Die Seite wird geladen...

SSH Login - lahm - Ähnliche Themen

  1. Solaris Login mit Active Directory User

    Solaris Login mit Active Directory User: Hallo zusammen, Ich arbeite daran unsere Solaris Systeme ans AD anzubinden. Teilweise ist mir das schon gelungen, teilweise stehe ich aber auch...
  2. Frage zu QNX - habe login nie gefunden

    Frage zu QNX - habe login nie gefunden: ′
  3. SSH Login nur mit einer bestimmten IP die in einer Textdatei gespeichert wird

    SSH Login nur mit einer bestimmten IP die in einer Textdatei gespeichert wird: Hallo Ich bin andauernd Opfer einer Brute Force Attacke. Die IPs die fehlerhafte Logins produzieren werden nach dem 3ten Versuch gesperrt. Aber...
  4. Root Login nach installation ohne Desktop Environment

    Root Login nach installation ohne Desktop Environment: Hey, Ich habe mir gerade Linux Debian 8 auf meinen alten PC gezogen und bei Desktop Environment das Sternchen rausgenommen, da das ja bei nem...
  5. Auto-Login auf Slackware

    Auto-Login auf Slackware: Hi, Ist gegen ein Auto-login auf einem nur privat zugänglichem Rechner (SL-13.37) grundsätzlich etwas einzuwenden? Und (falls nicht), wie am...