Squid proxy für rpc over https

Dieses Thema im Forum "Security Talk" wurde erstellt von Kodiax, 28.02.2012.

  1. Kodiax

    Kodiax Eroberer

    Dabei seit:
    29.06.2006
    Beiträge:
    50
    Zustimmungen:
    0
    Hallo,

    ich versuche einen Squid für meinen Test-Exchange für owa und active sync Einzurichten.
    dabei Laufe ich immer wieder in eine Fehlermeldung.

    Exchange version ist 2010 sp2
    Debian inklusive aller aktueller Updates.

    Code:
    # Publish the RPCoHTTP service via SSL
    https_port 192.168.1.20:443  accel cert=/etc/squid3/cert/test_root.crt defaultsite=mail.meinedomain.de
    
    cache_peer 192.168.1.1 parent 443 0 no-query originserver login=PASS ssl sslcert=/etc/squid3/cert/test.crt name=exchangeServer
    
    acl EXCH dstdomain exchange.testdomain.de./
    
    cache_peer_access exchangeServer allow EXCH
    cache_peer_access exchangeServer deny all
    never_direct allow EXCH
    
    Dabei bekomme ich immer folgende Fehlermeldung.
    Code:
    root@proxy2:~# /etc/init.d/squid3 restart
    Restarting Squid HTTP Proxy 3.x: squid3Creating Squid HTTP Proxy 3.x cache structure ... (warning).
    2012/02/28 18:29:22| cache_cf.cc(363) parseOneConfigFile: squid.conf:2 unrecognized: 'https_port'
    2012/02/28 18:29:22| parse_peer: token='ssl'
    FATAL: Bungled squid.conf line 5: 192.168.1.1 parent 443 0 no-query originserver login=PASS ssl sslcert=/etc/squid3/cert/test.crt name=exchangeServer
    Squid Cache (Version 3.1.6): Terminated abnormally.
    CPU Usage: 0.008 seconds = 0.000 user + 0.008 sys
    Maximum Resident Size: 15888 KB
    Page faults with physical i/o: 0
    2012/02/28 18:29:22| cache_cf.cc(363) parseOneConfigFile: squid.conf:2 unrecognized: 'https_port'
    2012/02/28 18:29:22| parse_peer: token='ssl'
    FATAL: Bungled squid.conf line 5: 192.168.1.1 parent 443 0 no-query originserver login=PASS ssl sslcert=/etc/squid3/cert/test.crt name=exchangeServer
    Squid Cache (Version 3.1.6): Terminated abnormally.
    CPU Usage: 0.008 seconds = 0.000 user + 0.008 sys
    Maximum Resident Size: 15904 KB
    Page faults with physical i/o: 0
    
    Ich hoffe mir kann jemand auf die Sprünge helfen woran es liegen könnte.

    Danke im voraus.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. foexle

    foexle Kaiser

    Dabei seit:
    02.05.2007
    Beiträge:
    1.104
    Zustimmungen:
    0
    Ort:
    Saarbrücken
    Hiho Kodiax,

    als erstes würde ich prüfen ob beide Sever (Squid und Exchange) auch wirklich auf port 443 lauschen.
    Du hast scheinbar einen Fehler in der Squid-Config:
    2012/02/28 18:29:22| cache_cf.cc(363) parseOneConfigFile: squid.conf:2 unrecognized: 'https_port'
    Code:
    acl EXCH dstdomain exchange.testdomain.de./
    
    cache_peer_access exchangeServer allow EXCH
    cache_peer_access exchangeServer deny all
    never_direct allow EXCH
    
    hast du hier EXCH auch definiert irgendwo ? Also den "hostname" der muss in der /etc/hosts oder dem pondont in windows


    Poste mal deine squid.conf von zeile 1-10
    Bungled squid.conf line 5: 192.168.1.1 parent 443 0 no-query originserver login=PASS ssl sslcert=/etc/squid3/cert/test.crt name=exchangeServer

    Grüße
     
  4. #3 Kodiax, 23.05.2012
    Zuletzt bearbeitet: 24.05.2012
    Kodiax

    Kodiax Eroberer

    Dabei seit:
    29.06.2006
    Beiträge:
    50
    Zustimmungen:
    0
    Erst einmal Danke :)

    Ich habe mir nun zwei tage lang gezwungener maßen die Zeit genommen mich dahingehend weiter ein zu Arbeiten.
    Eine funktionierende Lösung habe ich noch immer nicht, aber diverse Fehler behoben.

    1. Für Squid mit SSL Support muss man es unter Debian und Ubuntu Selbst "Angepasst" Kompilieren, sonst läuft man in diesen Fehler den ich hatte.

    2. mein .PEM Zertifikat war absolut nicht Brauchbar habe es von Hand neu erstellt. (Erst Private key dann Zertifikat in eine leere Datei Kopiert)

    3. Diverse fehlerchen den Paralellaufenden Apach2 betreffend... Mod ssl deaktiviert "a2dismod ssl"

    Aktuelle, Kommentierte config Poste ich Morgen. (Diese geht zwar imer noch nicht aber Squid 3 startet ohne Fehler)
     
  5. #4 Kodiax, 24.05.2012
    Zuletzt bearbeitet: 24.05.2012
    Kodiax

    Kodiax Eroberer

    Dabei seit:
    29.06.2006
    Beiträge:
    50
    Zustimmungen:
    0
    Hier die nun Funktionsfähige config, ich suche nun nur noch einen redirect bei Nicht freigegbener URL auf die Standard owa URL.
    Code:
    # Publish the RPCoHTTP service via SSL
    https_port Proxy_IP:443  accel cert=/etc/squid3/cert/zertifikat.pem defaultsite=exchange.domain.de
    cache_peer Exchange_IP parent 443 0 no-query originserver login=PASS ssl sslflags=DONT_VERIFY_PEER ssl sslcert=/etc/squid3/cert/Zertifikat.pem  name=exchangeServer
    #cache_peer Exchange_IP parent 80 0 no-query originserver login=PASS front-end-https=on name=exchangeServer
    
    acl localhost src 127.0.0.1/255.255.255.255
    acl local src Netzwerk/255.255.255.0
    acl to_localhost dst 127.0.0.0/8
    
    #zugriff auf folgende URLs Erlauben, EXCH dient nur als frei wählbarer Parameter
    acl EXCH url_regex -i ^https://exchange.domain.de/rpc/rpcproxy.dll.*$
    acl EXCH url_regex -i ^https://exchange.domain.de/exchange.*$
    acl EXCH url_regex -i ^https://exchange.domain.de/exchweb.*$
    acl EXCH url_regex -i ^https://exchange.domain.de/owa.*$
    acl EXCH url_regex -i ^https://exchange.domain.de/Microsoft-Server-ActiveSync.*$
    acl EXCH url_regex -i ^https://exchange.domain.de/ecp.*$
    acl EXCH url_regex -i ^https://exchange.domain.de/public.*$
    acl EXCH url_regex -i ^https://exchange.domain.de/cert.*$
    
    cache_peer_access exchangeServer allow EXCH
    cache_peer_access exchangeServer deny all
    never_direct allow EXCH
    
    # Zugriffe für Parameter EXCH
    http_access allow EXCH
    http_access deny all
    miss_access allow EXCH
    miss_access deny all
    
    #erweitertes Logging
    debug_options ALL,1 33,2
    
    
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema: Squid proxy für rpc over https
Besucher kamen mit folgenden Suchen
  1. squid3 owa ausnahme

Die Seite wird geladen...

Squid proxy für rpc over https - Ähnliche Themen

  1. Squid3 als Reverse Proxy

    Squid3 als Reverse Proxy: Hallo zusammen Ich hoffe, ihr könnt mir hier weiterhelfen, stehe irgendwie was Squid angeht mächtig auf dem Schlauch. Ich möchte Squid3 als...
  2. Squid als RPCoHTTPS Proxy für Outlook Anywhere

    Squid als RPCoHTTPS Proxy für Outlook Anywhere: Hallo Community, ich habe bereits versucht in einem anderen Forum Hilfe zu finden leider ohne Erfolg, darum versuche ich nochmal hier mein...
  3. McAfee Web Gateway And Squid Proxy 3.1.19 Bypass

    McAfee Web Gateway And Squid Proxy 3.1.19 Bypass: McAfee Web Gateway and Squid Proxy version 3.1.19 suffers from a bypass vulnerability due to putting trust in Host headers. Proof of concept tool...
  4. Proxyserver Squid: "Normalmode" + transparent auf Port 80 kombinieren möglich?

    Proxyserver Squid: "Normalmode" + transparent auf Port 80 kombinieren möglich?: Hi. Ist es möglich, bei einem Squid Proxyserver eine "normale" Installation zu machen, wo man im Browser die Proxy Zugangsadten machen muss. Und...
  5. Problem mit Squid-Proxy Transparent + ASA 5505

    Problem mit Squid-Proxy Transparent + ASA 5505: Erst einmal vorab viele Grüße an alle hier im Board ! Ich bin dabei einen Squid Proxy Version 2.7.Stable7 transparent zu betreiben. Dieser...