Soundblaster AWE 64 tut nicht (Suse 10.2)

Dieses Thema im Forum "Sound" wurde erstellt von gochx, 09.01.2007.

  1. gochx

    gochx Grünschnabel

    Dabei seit:
    09.01.2007
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo,

    ich habe probleme dabei meine soundkarte (soundblaster awe64) unter suse 10.2 einzurichten.

    sowohl alsa als auch yast können den treiber dabei anscheinend nicht laden.l
    alsa läuft perfekt durch bis dann die meldung kommt:
    error inserting snd_sbawe

    yast schreibt: das kernelmodul snd-sbawe für die soundunterstützung konnte nicht geladen werden.

    bin absoluter linux anfänger und hab keine ahnung wo ich anfangen muss!

    Danke
    gochx
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 09.01.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Ist denn das Modul überhaupt auf dem System vorhanden?

    Was ist die Ausgabe von

    ?
     
  4. gochx

    gochx Grünschnabel

    Dabei seit:
    09.01.2007
    Beiträge:
    3
    Zustimmungen:
    0
    findet die datei nicht.

    heißt das ich muss die nachinstallieren? muss ich dafür das komplette alsa paket installieren oder wie geht des? bzw. warum gibts dazu nix im yast?
     
  5. gochx

    gochx Grünschnabel

    Dabei seit:
    09.01.2007
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo nochmal,

    also nachdem das alles nix geholfen hat, hab ich jetzt versucht das ganze mal wie auf der alsa homepage beschrieben selbst zu installieren. schon beim compilieren vom alsa-driver-*** wir auf
    http://www.alsa-project.org/alsa-do...ter+64+Value.&chip=sb16,+emu8000&module=sbawe
    beschrieben tritt aber so weit ich das sehe ein fehler auf. Fehlt mit da noch irgendein modul?

    Hier ist die Ausgabe (bzw. der letzte teil davon) :

    config.status: include/autoconf-extra.h is unchanged
    Hacking autoconf.h...
    make[1]: Entering directory `/home/falko/Documents/alsa/alsa-driver-1.0.9b/acore'
    gcc -D__KERNEL__ -DMODULE=1 -I/home/falko/Documents/alsa/alsa-driver-1.0.9b/include -I/lib/modules/2.6.18.2-34-default/build/include -I/lib/modules/2.6.18.2-34-default/build/include2 -I/lib/modules/2.6.18.2-34-default/source/include -I/lib/modules/2.6.18.2-34-default/source/include/asm-i386/mach-default -O2 -mpreferred-stack-boundary=2 -march=i586 -D__SMP__ -DCONFIG_SMP -DLINUX -Wall -Wstrict-prototypes -fomit-frame-pointer -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -pipe -DALSA_BUILD -nostdinc -iwithprefix include -DMODVERSIONS -include /lib/modules/2.6.18.2-34-default/source/include/linux/modversions.h -DKBUILD_BASENAME=hpetimer -c -o hpetimer.o hpetimer.c
    cc1: error: /lib/modules/2.6.18.2-34-default/source/include/linux/modversions.h: Datei oder Verzeichnis nicht gefunden
    In file included from /lib/modules/2.6.18.2-34-default/source/include/linux/rwsem.h:24,
    from /lib/modules/2.6.18.2-34-default/build/include2/asm/semaphore.h:42,
    from /lib/modules/2.6.18.2-34-default/source/include/linux/sched.h:57,
    from /lib/modules/2.6.18.2-34-default/source/include/linux/module.h:9,
    from /home/falko/Documents/alsa/alsa-driver-1.0.9b/include/adriver.h:45,
    from /home/falko/Documents/alsa/alsa-driver-1.0.9b/include/sound/driver.h:42,
    from hpetimer.c:22:
    /lib/modules/2.6.18.2-34-default/build/include2/asm/rwsem.h: In function ‘__down_read’:
    /lib/modules/2.6.18.2-34-default/build/include2/asm/rwsem.h:104: error: expected ‘:’ or ‘)’ before ‘hpetimer’
    /lib/modules/2.6.18.2-34-default/build/include2/asm/rwsem.h: In function ‘__down_write_nested’:
    /lib/modules/2.6.18.2-34-default/build/include2/asm/rwsem.h:156: error: expected ‘:’ or ‘)’ before ‘hpetimer’
    /lib/modules/2.6.18.2-34-default/build/include2/asm/rwsem.h: In function ‘__up_read’:
    /lib/modules/2.6.18.2-34-default/build/include2/asm/rwsem.h:198: error: expected ‘:’ or ‘)’ before ‘hpetimer’
    /lib/modules/2.6.18.2-34-default/build/include2/asm/rwsem.h:192: warning: unused variable ‘tmp’
    /lib/modules/2.6.18.2-34-default/build/include2/asm/rwsem.h: In function ‘__up_write’:
    /lib/modules/2.6.18.2-34-default/build/include2/asm/rwsem.h:224: error: expected ‘:’ or ‘)’ before ‘hpetimer’
    /lib/modules/2.6.18.2-34-default/build/include2/asm/rwsem.h: In function ‘__downgrade_write’:
    /lib/modules/2.6.18.2-34-default/build/include2/asm/rwsem.h:249: error: expected ‘:’ or ‘)’ before ‘hpetimer’
    In file included from /lib/modules/2.6.18.2-34-default/source/include/linux/sched.h:57,
    from /lib/modules/2.6.18.2-34-default/source/include/linux/module.h:9,
    from /home/falko/Documents/alsa/alsa-driver-1.0.9b/include/adriver.h:45,
    from /home/falko/Documents/alsa/alsa-driver-1.0.9b/include/sound/driver.h:42,
    from hpetimer.c:22:
    /lib/modules/2.6.18.2-34-default/build/include2/asm/semaphore.h: In function ‘down’:
    /lib/modules/2.6.18.2-34-default/build/include2/asm/semaphore.h:105: error: expected ‘:’ or ‘)’ before ‘hpetimer’
    /lib/modules/2.6.18.2-34-default/build/include2/asm/semaphore.h: In function ‘down_interruptible’:
    /lib/modules/2.6.18.2-34-default/build/include2/asm/semaphore.h:130: error: expected ‘:’ or ‘)’ before ‘hpetimer’
    /lib/modules/2.6.18.2-34-default/build/include2/asm/semaphore.h: In function ‘down_trylock’:
    /lib/modules/2.6.18.2-34-default/build/include2/asm/semaphore.h:155: error: expected ‘:’ or ‘)’ before ‘hpetimer’
    /lib/modules/2.6.18.2-34-default/build/include2/asm/semaphore.h: In function ‘up’:
    /lib/modules/2.6.18.2-34-default/build/include2/asm/semaphore.h:179: error: expected ‘:’ or ‘)’ before ‘hpetimer’
    In file included from /home/falko/Documents/alsa/alsa-driver-1.0.9b/include/adriver.h:677,
    from /home/falko/Documents/alsa/alsa-driver-1.0.9b/include/sound/driver.h:42,
    from hpetimer.c:22:
    /lib/modules/2.6.18.2-34-default/source/include/linux/pci.h: At top level:
    /lib/modules/2.6.18.2-34-default/source/include/linux/pci.h:500: error: expected identifier or ‘(’ before numeric constant
    make[1]: *** [hpetimer.o] Fehler 1
    make[1]: Leaving directory `/home/falko/Documents/alsa/alsa-driver-1.0.9b/acore'
    make: *** [compile] Fehler 1
    rm -f /lib/modules/0.0.0/misc/snd*.*o /lib/modules/0.0.0/misc/persist.o /lib/modules/0.0.0/misc/isapnp.o
    make[1]: Entering directory `/home/falko/Documents/alsa/alsa-driver-1.0.9b/acore'
    mkdir -p /lib/modules/0.0.0/misc
    cp snd-hpet.o snd-hwdep.o snd-page-alloc.o snd-pcm.o snd-rawmidi.o snd-timer.o snd.o /lib/modules/0.0.0/misc
    cp: Aufruf von stat für „snd-hpet.o“ nicht möglich: Datei oder Verzeichnis nicht gefunden
    cp: Aufruf von stat für „snd-hwdep.o“ nicht möglich: Datei oder Verzeichnis nicht gefunden
    cp: Aufruf von stat für „snd-page-alloc.o“ nicht möglich: Datei oder Verzeichnis nicht gefunden
    cp: Aufruf von stat für „snd-pcm.o“ nicht möglich: Datei oder Verzeichnis nicht gefunden
    cp: Aufruf von stat für „snd-rawmidi.o“ nicht möglich: Datei oder Verzeichnis nicht gefunden
    cp: Aufruf von stat für „snd-timer.o“ nicht möglich: Datei oder Verzeichnis nicht gefunden
    cp: Aufruf von stat für „snd.o“ nicht möglich: Datei oder Verzeichnis nicht gefunden
    make[1]: *** [_modinst__] Fehler 1
    make[1]: Leaving directory `/home/falko/Documents/alsa/alsa-driver-1.0.9b/acore'
    make: *** [install-modules] Fehler 1
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Soundblaster AWE 64 tut nicht (Suse 10.2)

Die Seite wird geladen...

Soundblaster AWE 64 tut nicht (Suse 10.2) - Ähnliche Themen

  1. Creative Soundblaster läuft nicht!

    Creative Soundblaster läuft nicht!: Hallo Leute! Da ich seit einem halben Jahr sehr sehr zufriedener Ubuntu nutzer auf meinem Laptop bin dachte ich mich neulich, dass ich es auf...
  2. Creative SoundBlaster Audigy SE funktioniert nicht / sehr eingeschränkt

    Creative SoundBlaster Audigy SE funktioniert nicht / sehr eingeschränkt: Heyho, ich hab heute ne SoundBlaster Audigy SE soundkarte von Creative bekommen und die eingebaut, laut erfahrungsberichten sollte die eigentlich...
  3. Soundblaster Live 5.1 läuft nicht unter Suse 9.1

    Soundblaster Live 5.1 läuft nicht unter Suse 9.1: Hallo, ich habe schon stundenlang gegoogelt, leider finde ich keine Treiber für meine Soundblaster Live 5.1! Hat jemand ein Tipp für mich wie ich...
  4. Creative Labs SoundBlaster Audigy 2 ZS unter Debian / Kernel 3.16

    Creative Labs SoundBlaster Audigy 2 ZS unter Debian / Kernel 3.16: Hallo zusammen Beim verwendeten Gerät handelt es sich um eine Sun Ultra 45, also SPARC-Plattform. Die Karte wird angezeigt bei den...
  5. Problem mit Soundblaster 128 (CT4810)

    Problem mit Soundblaster 128 (CT4810): Hallo ! Ich habe heute eine Soundblaster 128 eingebaut (in der Hoffnung das dann Hardwaremixing funktioniert). Dann hab ich alsaconf...