SD-Speicher wirde nicht angezeigt

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Emess, 25.09.2009.

  1. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Habe ein Samsung U900 Soul und wenn ich unter Lenny das USB-Kabel anstecke und mit dem PC verbinde wird auch gleich der Inhalt der Karte angezeigt

    Code:
    enny:/home/michael# fdisk -l
    
    Disk /dev/hda: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x388a3889
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/hda1   *           1        1912    15358108+   7  HPFS/NTFS
    /dev/hda2            1913       19457   140930212+   f  W95 Ext'd (LBA)
    /dev/hda5            1913        5099    25599546    7  HPFS/NTFS
    /dev/hda6            5100        8138    24410736   83  Linux
    /dev/hda7            8139       12393    34178256   83  Linux
    /dev/hda8           12394       12502      875511   82  Linux swap / Solaris
    /dev/hda9           12503       14204    13671283+  83  Linux
    /dev/hda10          14205       19189    40041981   83  Linux
    /dev/hda11          19190       19457     2152678+  82  Linux swap / Solaris
    
    Disk /dev/sda: 1030 MB, 1030225920 bytes
    4 heads, 3 sectors/track, 167680 cylinders
    Units = cylinders of 12 * 512 = 6144 bytes
    Disk identifier: 0x00000000
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1              21      167680     1005958+   6  FAT16
    
    Unter Squezze passiert garnix, obwohl ich schwören könnte, dass es mal funktionierte.
    Wer kann ir auf die Sprünge helfen.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Jabo

    Jabo Aufgabe ohne Minister

    Dabei seit:
    12.10.2006
    Beiträge:
    1.322
    Zustimmungen:
    0
    Ort:
    Hamburg
    ich war neulich bei einem Bekannten, der ein neues Samsung-Handy hatt. Da taucht das Teil unter XP im Arbeitsplatz nicht mehr als Laufwerk auf. Man muß eine spezielle Windows-Software installieren, in der wiederum ein eigener Arbeitsplatz ist, der dann sowohl die Festplatte als auch das Handy anzeigen kann. Die Software bringt einen eigenen USB-Treiber mit.

    Das Gerät hängt also zwar am USB, meldet sich aber nicht standardkonform an, sonst sähe XP es ja. Sondern es schickt irgend was über den Bus, das nur dieser Treiber versteht und nur für die hauseigene Software übersetzt.

    Schade, kein Widows. Wenn das bei dir auch so ist, gute Nacht.
     
  4. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Wie schon gesagt, unter XP und Lenny geht es ja auch.
     
  5. #4 slackfan, 25.09.2009
    slackfan

    slackfan König

    Dabei seit:
    18.04.2006
    Beiträge:
    809
    Zustimmungen:
    0
    Ort:
    Bonn
    Hallo,

    du könntest mal
    Code:
    root@host[~] udevadm monitor
    ausführen und anschließend das Handy anschleißen, um zu schauen, ob das System das Handy überhaupt erkennt und was dann passiert.

    cu
     
  6. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Code:
    squeeze:/home/michael# udevadm monitor
    monitor will print the received events for:
    UDEV - the event which udev sends out after rule processing
    KERNEL - the kernel uevent
    
    KERNEL[1253912435.284266] add      /devices/pci0000:00/0000:00:1d.1/usb3/3-1 (usb)
    KERNEL[1253912435.287159] add      /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0 (usb)
    KERNEL[1253912435.287194] add      /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0/usb_endpoint/usbdev3.2_ep84 (usb_endpoint)
    KERNEL[1253912435.287217] add      /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0/usb_endpoint/usbdev3.2_ep05 (usb_endpoint)
    KERNEL[1253912435.287239] add      /devices/pci0000:00/0000:00:1d.1/usb3/3-1/usb_device/usbdev3.2 (usb_device)
    KERNEL[1253912435.287261] add      /devices/pci0000:00/0000:00:1d.1/usb3/3-1/usb_endpoint/usbdev3.2_ep00 (usb_endpoint)
    UDEV  [1253912435.354300] add      /devices/pci0000:00/0000:00:1d.1/usb3/3-1 (usb)
    UDEV  [1253912435.361453] add      /devices/pci0000:00/0000:00:1d.1/usb3/3-1/usb_endpoint/usbdev3.2_ep00 (usb_endpoint)
    UDEV  [1253912435.362722] add      /devices/pci0000:00/0000:00:1d.1/usb3/3-1/usb_device/usbdev3.2 (usb_device)
    KERNEL[1253912435.539597] add      /module/usb_storage (module)
    UDEV  [1253912435.563617] add      /module/usb_storage (module)
    KERNEL[1253912435.569279] add      /bus/usb/drivers/usb-storage (drivers)
    UDEV  [1253912435.572564] add      /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0 (usb)
    UDEV  [1253912435.595297] add      /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0/usb_endpoint/usbdev3.2_ep84 (usb_endpoint)
    UDEV  [1253912435.596967] add      /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0/usb_endpoint/usbdev3.2_ep05 (usb_endpoint)
    UDEV  [1253912435.598254] add      /bus/usb/drivers/usb-storage (drivers)
    
    das ist passiert
     
  7. #6 slackfan, 25.09.2009
    slackfan

    slackfan König

    Dabei seit:
    18.04.2006
    Beiträge:
    809
    Zustimmungen:
    0
    Ort:
    Bonn
    Also das sieht bei meinen Nokias definitiv anders aus. Bei dir fehlen z.B. die Zeilen, die bekunden, dass das Blockdevice angelegt wird. Sieht die Ausgabe auf deinem Lenny genauso aus? Das sind in meinen Augen entweder verkrüppelte Udev-Regeln oder der Kernel (ein anderer als bei deinem Lenny?) kommt mit dem Handy/Datenkabel nicht klar. Das wiederum kenne ich von älteren Nokias, die sich nicht immer standardkonform verhielten.

    cu
     
  8. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Das ist der log unter Lenny

    Code:
    lenny:/home/michael# udevadm monitor
    udevmonitor will print the received events for:
    UDEV the event which udev sends out after rule processing
    UEVENT the kernel uevent
    
    UDEV  [1253908606.363605] add      /devices/pci0000:00/0000:00:1d.1/usb2/2-1 (usb)
    UEVENT[1253908606.390973] add      /devices/pci0000:00/0000:00:1d.1/usb2/2-1/2-1:1.0 (usb)
    UEVENT[1253908606.391010] add      /class/usb_endpoint/usbdev2.2_ep84 (usb_endpoint)
    UEVENT[1253908606.391020] add      /class/usb_endpoint/usbdev2.2_ep05 (usb_endpoint)
    UEVENT[1253908606.391030] add      /class/usb_device/usbdev2.2 (usb_device)
    UEVENT[1253908606.391040] add      /class/usb_endpoint/usbdev2.2_ep00 (usb_endpoint)
    UEVENT[1253908606.461438] add      /module/usb_storage (module)
    UDEV  [1253908606.462724] add      /module/usb_storage (module)
    UEVENT[1253908606.463500] add      /class/scsi_host/host0 (scsi_host)
    UDEV  [1253908606.466265] add      /bus/usb/drivers/usb-storage (drivers)
    UDEV  [1253908606.471484] add      /devices/pci0000:00/0000:00:1d.1/usb2/2-1/2-1:1.0 (usb)
    UDEV  [1253908606.471524] add      /class/usb_endpoint/usbdev2.2_ep84 (usb_endpoint)
    UDEV  [1253908606.473614] add      /class/usb_endpoint/usbdev2.2_ep05 (usb_endpoint)
    UDEV  [1253908606.492401] add      /class/usb_endpoint/usbdev2.2_ep00 (usb_endpoint)
    UDEV  [1253908606.495385] add      /class/scsi_host/host0 (scsi_host)
    UDEV  [1253908606.522084] add      /class/usb_device/usbdev2.2 (usb_device)
    UEVENT[1253908611.551211] add      /devices/pci0000:00/0000:00:1d.1/usb2/2-1/2-1:1.0/host0/target0:0:0/0:0:0:0 (scsi)
    UEVENT[1253908611.551412] add      /class/scsi_device/0:0:0:0 (scsi_device)
    UEVENT[1253908611.551486] add      /class/scsi_generic/sg0 (scsi_generic)
    UEVENT[1253908611.551552] add      /class/bsg/0:0:0:0 (bsg)
    UDEV  [1253908611.615630] add      /module/sd_mod (module)
    UDEV  [1253908611.615822] add      /class/scsi_disk (class)
    UEVENT[1253908611.615897] add      /class/scsi_disk/0:0:0:0 (scsi_disk)
    UEVENT[1253908611.645626] change   /devices/pci0000:00/0000:00:1d.1/usb2/2-1/2-1:1.0/host0/target0:0:0/0:0:0:0 (scsi)
    UDEV  [1253908611.680880] add      /devices/pci0000:00/0000:00:1d.1/usb2/2-1/2-1:1.0/host0/target0:0:0/0:0:0:0 (scsi)
    UEVENT[1253908611.680924] add      /block/sda/sda1 (block)
    UEVENT[1253908611.680935] add      /class/bdi/8:0 (bdi)
    UEVENT[1253908611.680944] add      /bus/scsi/drivers/sd (drivers)
    UDEV  [1253908611.709769] add      /class/scsi_generic/sg0 (scsi_generic)
    UDEV  [1253908611.710475] add      /class/scsi_device/0:0:0:0 (scsi_device)
    UDEV  [1253908611.713538] add      /class/bsg/0:0:0:0 (bsg)
    UDEV  [1253908611.715083] add      /class/scsi_disk/0:0:0:0 (scsi_disk)
    UDEV  [1253908611.716560] change   /devices/pci0000:00/0000:00:1d.1/usb2/2-1/2-1:1.0/host0/target0:0:0/0:0:0:0 (scsi)
    UDEV  [1253908611.720601] add      /class/bdi/8:0 (bdi)
    UDEV  [1253908611.723144] add      /bus/scsi/drivers/sd (drivers)
    UDEV  [1253908612.103701] add      /block/sda (block)
    UDEV  [1253908612.334931] add      /block/sda/sda1 (block)
    UDEV  [1253908615.487779] add      /module/nls_base (module)
    UEVENT[1253908615.557925] add      /module/fat (module)
    UDEV  [1253908615.558387] add      /module/fat (module)
    UEVENT[1253908615.678610] add      /module/vfat (module)
    UDEV  [1253908615.680779] add      /module/vfat (module)
    UEVENT[1253908615.714715] add      /module/nls_cp437 (module)
    UDEV  [1253908615.716233] add      /module/nls_cp437 (module)
    UEVENT[1253908615.727901] add      /module/nls_iso8859_1 (module)
    UDEV  [1253908615.729388] add      /module/nls_iso8859_1 (module)
                                                                                    
    das sieht ganz anders aus
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 slackfan, 25.09.2009
    Zuletzt bearbeitet: 25.09.2009
    slackfan

    slackfan König

    Dabei seit:
    18.04.2006
    Beiträge:
    809
    Zustimmungen:
    0
    Ort:
    Bonn
    Ja, das kommt mir vertrauter vor :)
    Vielleicht steht in den Log-Dateien noch etwas. Ansonsten hilft wohl nur die Udev-Regeln zu vergleichen und zu adaptieren und/oder eine andere Kernelversion zu probieren und/oder einen Bugreport zu schreiben. Andere wissen dazu sicherlich mehr...

    cu

    Edit: du könntest noch versuchen, das Blockdevice per Hand anzulegen mit mknod und zu mounten.
    Code:
    root@host[~] mknod /dev/sda b 8 0
    root@host[~] mknod /dev/sda1 b 8 1
    root@host[~] mount /dev/sda1 /mnt/memory
    
    Wenn das klappen sollte, kannst du wenigstens davon ausgehen, dass es nicht am Kernel liegt.
     
  11. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Code:
    squeeze:/home/michael# mknod /dev/sda b 8 0
    squeeze:/home/michael# mknod /dev/sda1 b 8 1
    squeeze:/home/michael# mount /dev/sda1 /mnt/sd-karte
    mount: /dev/sda1 is not a valid block device
    squeeze:/home/michael#
    
    Das hat leider keine Frucht getragen. Trotz deiner guten Idee
     
Thema:

SD-Speicher wirde nicht angezeigt

Die Seite wird geladen...

SD-Speicher wirde nicht angezeigt - Ähnliche Themen

  1. SD-Speicherkarte

    SD-Speicherkarte: also das mag jetzt eine komische frage sein aber wie formatiere ich das teil unter Linux ich hab es unter XP formatiert (FAT32) weil der...