SCSI Platten mounten

Dieses Thema im Forum "Linux OS" wurde erstellt von Biatch, 28.09.2006.

  1. Biatch

    Biatch Grünschnabel

    Dabei seit:
    28.09.2006
    Beiträge:
    6
    Zustimmungen:
    0
    Hi.
    Meine scsi Platten werden aus irgendeinem Grund nicht automatisch gemountet. Die Einträge in der fstab müssten stimmen. Wenn ich sie mittels mount -a mounte, geht dies aber ohne probleme. Hier zur verdeutlichung:

    debianServer:/var/squid/platte2# df
    Dateisystem 1K-Blöcke Benutzt Verfügbar Ben% Eingehängt auf
    /dev/hda1 918322 739208 130118 86% /
    tmpfs 128452 0 128452 0% /dev/shm
    /dev/hda5 1365392 85920 1279472 7% /var/squid/platte1
    debianServer:/var/squid/platte2# cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/hda1 / ext3 defaults,errors=remount-ro 0 1
    /dev/hda6 none swap sw 0 0
    /dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
    /dev/hda5 /var/squid/platte1 reiserfs auto,noatime,async,data=writeback 0 0
    /dev/sda1 /var/squid/platte2 reiserfs auto,noatime,async,data=writeback 0 0
    /dev/sdb1 /var/squid/platte3 reiserfs auto,noatime,async,data=writeback 0 0

    debianServer:/var/squid/platte2# mount -a
    debianServer:/var/squid/platte2# df
    Dateisystem 1K-Blöcke Benutzt Verfügbar Ben% Eingehängt auf
    /dev/hda1 918322 739211 130115 86% /
    tmpfs 128452 0 128452 0% /dev/shm
    /dev/hda5 1365392 85920 1279472 7% /var/squid/platte1
    /dev/sda1 3140572 44288 3096284 2% /var/squid/platte2
    /dev/sdb1 1244948 44288 1200660 4% /var/squid/platte3



    Wie man sieht, wird die hda5 trotz gleicher Parameter problemlos gemountet. Die sd* platten aber nicht.
    Hoffe Ihr könnt mir helfen.
    PS: Mein deutsch ist nach 10 std. fummelei nicht mehr das beste :))
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Lumpi

    Lumpi Haudegen

    Dabei seit:
    14.06.2006
    Beiträge:
    663
    Zustimmungen:
    0
    Ort:
    Dessau
    Hallo

    Zu erst, ich habe keine Ahnung von Debian :)
    dennoch:
    mount -a wird bei Start ausgeführt und die fstab "geladen"
    IMHO legt Deb beim Start keine Logdatei an.
    Trage mal in die
    /etc/default/bootlogd
    an beliebiger Stelle ein
    Code:
    BOOTLOGD_ENABLE=Yes
    (Später kannst du diese Stelle wieder auskommentieren mit # )
    Damit wird beim nächsten Boot in die
    /var/log/boot geloggt.
    diese Datei wird beim nächsten Start überschrieben,
    und eine Sicherheitskopie /*/boot1 (später boot2, *3 usw) angelegt.
    Diese Datei kannst du nun auf Fehler prüfen.
    Nutze am Besten den Befehl
    cat /var/log/boot

    Gruß Lumpi

    PS: Falls du sie posten willst, nimm einen
    Code:
    -Block
     
  4. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Ich vermute mal, dass die SCSI-Treiber noch nicht geladen sind, wenn das System beim Start die fstab durchgeht. Packe einfach mal deine SCSI-Treiber mit in die initrd.
     
  5. Biatch

    Biatch Grünschnabel

    Dabei seit:
    28.09.2006
    Beiträge:
    6
    Zustimmungen:
    0
    So, erstmal danke für die Tips.
    Hab grade mal die kernel.log durchforstet (gibt es einen unterschied zwischen der kernel.log und der boot.log?). Dabei ist mir kein Fehler aufgefallen, außer das, wie theton schon vermutet hat, der SCSI-Controler erst ne ganze weile nachdem die hda5 gemountet wurde, ins System eingebunden wird.
    Ich werde wohl also entweder die SCSI-Teiber in die initrd schreiben, ein mount -a in das squid start-script schreiben oder den Treiber fest in der Kernel einkompilieren müssen. Falls jemand noch eine andere Idee hat, nur zu.
    Und da tut sich schon die nächste Frage auf:
    In der Kernel-config gibt es für die ACI7XXX Reihe zwei Treiber. Ein neuen mit U160 unterstützung (was ich nicht benötige) und einen alten. Weiß jemand ob es Geschwindigkeitsunterschiede zwischen den beiden Treibern gibt (ohne U160er Platten)?
     
  6. Lumpi

    Lumpi Haudegen

    Dabei seit:
    14.06.2006
    Beiträge:
    663
    Zustimmungen:
    0
    Ort:
    Dessau
    Hallo

    Wie die Namen es audrücken loggt die jeweilige *log-Datei nur infos,
    die das entsprechende "Programm" betreffen.

    Das Log vom Boot gibt dir alle Infos darüber,
    was dein System beim Starten macht oder auch nicht.
    Daher solltest du dir diese anschauen.

    Genau das musst du tun ;)
    Allerdings solltest du kein "script" verwenden.
    Aber die anderen Optionen klingen schonmal nicht schlecht :D

    Gruß Lumpi
     
  7. #6 Biatch, 29.09.2006
    Zuletzt bearbeitet: 29.09.2006
    Biatch

    Biatch Grünschnabel

    Dabei seit:
    28.09.2006
    Beiträge:
    6
    Zustimmungen:
    0
    Wie denn sonst? Bin linux Neuling :)

    Wie und wo sollte ich das mount -a eintragen (squid wird als letzter Prozess gestartet)
     
  8. Biatch

    Biatch Grünschnabel

    Dabei seit:
    28.09.2006
    Beiträge:
    6
    Zustimmungen:
    0
    Hab grade die Bootlog durchgesehen. Liegt definitiv am zu spät geladenen SCSI-Treiber.
    Hier ein Auszug:

    Code:
    Fri Sep 29 14:24:49 2006: bootlogd.
    Fri Sep 29 14:24:49 2006: Setting parameters of disc: (none).
    Fri Sep 29 14:24:49 2006: Activating swap.
    Fri Sep 29 14:24:49 2006: Checking root file system...
    Fri Sep 29 14:24:49 2006: fsck 1.37 (21-Mar-2005)
    Fri Sep 29 14:24:49 2006: /: clean, 65098/490560 files, 801207/979933 blocks (check in 3 mounts)
    Fri Sep 29 14:24:50 2006: System time was Fri Sep 29 12:24:49 UTC 2006.
    Fri Sep 29 14:24:50 2006: Setting the System Clock using the Hardware Clock as reference...
    Fri Sep 29 14:24:51 2006: System Clock set. System local time is now Fri Sep 29 14:24:51 CEST 2006.
    Fri Sep 29 14:24:51 2006: Cleaning up ifupdown...done.
    Fri Sep 29 14:24:51 2006: Calculating module dependencies... done.
    Fri Sep 29 14:24:52 2006: Loading modules...
    Fri Sep 29 14:24:52 2006:     ide-cd
    Fri Sep 29 14:24:52 2006:     ide-disk
    Fri Sep 29 14:24:52 2006: FATAL: Module ide_disk not found.
    Fri Sep 29 14:24:52 2006:     ide-generic
    Fri Sep 29 14:24:52 2006: FATAL: Module ide_generic not found.
    Fri Sep 29 14:24:52 2006:     psmouse
    Fri Sep 29 14:24:52 2006:     sd_mod
    Fri Sep 29 14:24:53 2006: All modules loaded.
    Fri Sep 29 14:24:53 2006: Checking all file systems...
    Fri Sep 29 14:24:53 2006: fsck 1.37 (21-Mar-2005)
    Fri Sep 29 14:24:53 2006: Setting kernel variables ...
    Fri Sep 29 14:24:53 2006: ... done.
    Fri Sep 29 14:24:53 2006: Mounting local filesystems...
    Fri Sep 29 14:24:53 2006: mount: /dev/sda1 is not a valid block device
    Fri Sep 29 14:24:53 2006: mount: /dev/sdb1 is not a valid block device
    Fri Sep 29 14:24:53 2006: /dev/hda5 on /var/squid/platte1 type reiserfs (rw,noatime,data=writeback)
    Fri Sep 29 14:24:53 2006: Cleaning /tmp /var/run /var/lock.
    Fri Sep 29 14:24:54 2006: Detecting hardware: agpgart parport_pc 8139too via82cxxx aic7xxx ide_scsi
    Fri Sep 29 14:24:55 2006: Loading agpgart module.
    Fri Sep 29 14:24:55 2006: Loading parport_pc module.
    Fri Sep 29 14:24:56 2006: Loading 8139too module.
    Fri Sep 29 14:24:57 2006: Loading via82cxxx module.
    Fri Sep 29 14:24:57 2006: Loading aic7xxx module. 
    Fri Sep 29 14:25:15 2006: Loading ide_scsi module.
    
    Alledings ist mir dabei ein anderer Fehler aufgefallen. Was soll das denn!?:

    Code:
    Fri Sep 29 14:24:52 2006: Loading modules...
    Fri Sep 29 14:24:52 2006:     ide-cd
    Fri Sep 29 14:24:52 2006:     ide-disk
    Fri Sep 29 14:24:52 2006: FATAL: Module ide_disk not found.
    Fri Sep 29 14:24:52 2006:     ide-generic
    Fri Sep 29 14:24:52 2006: FATAL: Module ide_generic not found.
    
    Hab den IDE Support fest in den Kernel eingebunden (funktioniert auch).

    Schon mal vielen Dank,
    Nils
     
  9. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Offenbar versucht dein System die IDE-Sachen noch als Modul zu laden. In welcher Datei das steht haengt von der verwendeten Distro ab. Meist aber in der /etc/modprobe.conf oder /etc/modules.conf.
     
  10. Biatch

    Biatch Grünschnabel

    Dabei seit:
    28.09.2006
    Beiträge:
    6
    Zustimmungen:
    0
    Hab grade versucht das Laden der Module über die discover.conf zu verhindern. Leider ohne Erfolg.

    Hab folgendes eingetragen:
    Code:
    skip ide_disk
    skip ide_generic
    
    Code:
    skip ide-disk
    skip ide-generic
    
    geht übrigens auch nicht.
     
  11. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Nimm sie doch einfach aus der Konfiguration raus, die dafuer verantwortlich ist, dass die geladen werden. Wenn du nicht findest wo das ist, kannst du ja einfach mal mit 'grep' rekursiv durch's /etc gehn. Da wird sich das schon finden.
     
  12. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  13. #11 nikster77, 29.09.2006
    nikster77

    nikster77 Routinier

    Dabei seit:
    15.03.2004
    Beiträge:
    307
    Zustimmungen:
    0
    Hi.
    nimm das einfach wieder raus, und trag die Modulnamen in /etc/modules ein.
    Das laedt die Treiber schon rechtzeitig.

    Warum moechtest du die Treiber unbedingt als Module?
    Wenn du Ssie fest einkompilierst tut's wahrscheinlich auf Anhieb, allerdings haettest du dann das Prob das du bei bestimmten Problemen die Module nicht einfach aus dem Kernel kicken und wieder neu laden kannst was IMHO bei einem Heimsystem das man einfach neustarten kann nicht wirklich schlimm ist.

    Gruss

    Niels
     
  14. Biatch

    Biatch Grünschnabel

    Dabei seit:
    28.09.2006
    Beiträge:
    6
    Zustimmungen:
    0
    So, habe die Probleme beheben können.
    Das eigentliche Problem (SCSI Platten wurden nicht beim booten eingehängt), indem die SCSI - Treiber fest in den Kernel einkompiliert wurden.
    Das zweite (FATAL: Module ide_disk not found usw.), in dem ich die /etc/modules editiert habe.
     
Thema:

SCSI Platten mounten

Die Seite wird geladen...

SCSI Platten mounten - Ähnliche Themen

  1. File server mit SCSI platten?

    File server mit SCSI platten?: Hi, ich hätte mal eine Fragen zu einem Fileserver. Ich habe 5 Server hier rumliegen (RICHTIGE server im 19" format) Ich will mir daraus jetzt...
  2. iscsi-dienst mit virtl. laufwerk unter solaris einrichten

    iscsi-dienst mit virtl. laufwerk unter solaris einrichten: hallo zusammen das habe ich versucht: sudo pkg install group/feature/storage-server sudo svcadm enable stmf sudo zfs create -V 1g...
  3. iscsi-target als sparse-file?

    iscsi-target als sparse-file?: hallo zusammen, habe gestern ein iscsi-target in der grösse von 750gb mithilfe von "dd if" angelegt. (bs=768k, count=1024000) nun ging das...
  4. SCSI page 83h VPD descriptor mit Linux SCSI target framework (tgt)

    SCSI page 83h VPD descriptor mit Linux SCSI target framework (tgt): Hallo, ich habe einen Linux Server (auf VMware Workstation Basis) der seine 3 Festplatten via iSCSI exportiert (Target). Auf einem Windows...
  5. SCSI to iSCSI - "Bruecke" irgendwie machbar?

    SCSI to iSCSI - "Bruecke" irgendwie machbar?: Hallo zusammen, bei folgender Frage bzw. Problemstellung waere ich ueber jede Anregung oder Information dankbar, da ich in Sachen SCSI gerade...