Schon wieder Probleme mit Kaffeine?!

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von thei, 25.09.2008.

  1. #1 thei, 25.09.2008
    Zuletzt bearbeitet: 25.09.2008
    thei

    thei Foren As

    Dabei seit:
    26.07.2007
    Beiträge:
    94
    Zustimmungen:
    0
    Ort:
    Oberfranken
    Hi,

    Hab schon wieder ein Problem mit Kaffeine! ;( Und zwar kann ich keine DVDs mehr abspielen! Jedes mal wenn ich es versuche bekomm ich die meldung das die Verwendete version von Xine nur eingeschränkten Support für DVDs bietet. Ich benutze die Xinelib von Packman (Libdvdcss ist auch installiert) MPlayer spielt die DVDs einwandfrei ab.

    System ist Suse 11.0
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Gast1

    Gast1 Guest

  4. thei

    thei Foren As

    Dabei seit:
    26.07.2007
    Beiträge:
    94
    Zustimmungen:
    0
    Ort:
    Oberfranken
    Nein, diesmal eben nicht! :( Hab alle Pakete von Packman genommen und nicht aus dem VLC Repo!
     
  5. Gast1

    Gast1 Guest

    Code:
    rpm -qa "*xine*"
    
    su -c "zypper se -s xine"
     
  6. thei

    thei Foren As

    Dabei seit:
    26.07.2007
    Beiträge:
    94
    Zustimmungen:
    0
    Ort:
    Oberfranken
    Code:
    thomas@linux-qtvu:~> rpm -qa "*xine*"
    
    
    
    amarok-xine-1.4.10-100.pm.1
    libxine1-codecs-1.1.15-44.pm.0
    libxine1-1.1.15-44.pm.0
    xinetd-2.3.14-115.1
    thomas@linux-qtvu:~>
    thomas@linux-qtvu:~> su -c "zypper se -s xine"
    Passwort:
    Lese installierte Pakete...
    
    S | Name                            | Typ        | Version                 | Architektur | Repository
    --+---------------------------------+------------+-------------------------+-------------+----------------------------------------
    i | amarok-xine                     | Paket      | 1.4.10-100.pm.1         | i586        | Packman Repository
    v | amarok-xine                     | Paket      | 1.4.9.1-39.2            | i586        | openSUSE BuildService - KDE:Backports
    v | amarok-xine                     | Paket      | 1.4.9.1-27.1            | i586        | openSUSE-11.0-Oss
      | gxine                           | Paket      | 0.5.903-0.pm.0          | i686        | Packman Repository
      | gxine                           | Paket      | 0.5.903-0.pm.0          | i586        | Packman Repository
      | gxine-browser-plugin            | Paket      | 0.5.903-0.pm.0          | i686        | Packman Repository
      | gxine-browser-plugin            | Paket      | 0.5.903-0.pm.0          | i586        | Packman Repository
      | gxine-debuginfo                 | Paket      | 0.5.903-0.pm.0          | i686        | Packman Repository
      | gxine-debuginfo                 | Paket      | 0.5.903-0.pm.0          | i586        | Packman Repository
      | gxine-debugsource               | Paket      | 0.5.903-0.pm.0          | i686        | Packman Repository
      | gxine-debugsource               | Paket      | 0.5.903-0.pm.0          | i586        | Packman Repository
      | jftpgw-xinetd                   | Paket      | 0.13.5-0.pm.2           | i586        | Packman Repository
      | kdemultimedia3-video-xine       | Paket      | 3.5.9-44.pm.1           | i586        | Packman Repository
      | kdemultimedia3-video-xine       | Paket      | 3.5.9-43.1              | i586        | openSUSE-11.0-Oss
      | kdemultimedia3-video-xine       | Paket      | 3.5.9-43.1              | i586        | openSUSE-DVD 11.0
      | libxine-devel                   | Paket      | 1.1.15-44.pm.0          | i686        | Packman Repository
      | libxine-devel                   | Paket      | 1.1.15-44.pm.0          | i586        | Packman Repository
    i | libxine1                        | Paket      | 1.1.15-44.pm.0          | i686        | Packman Repository
    v | libxine1                        | Paket      | 1.1.15-44.pm.0          | i586        | Packman Repository
      | libxine1-aa                     | Paket      | 1.1.15-44.pm.0          | i686        | Packman Repository
      | libxine1-aa                     | Paket      | 1.1.15-44.pm.0          | i586        | Packman Repository
      | libxine1-arts                   | Paket      | 1.1.15-44.pm.0          | i686        | Packman Repository
      | libxine1-arts                   | Paket      | 1.1.15-44.pm.0          | i586        | Packman Repository
    i | libxine1-codecs                 | Paket      | 1.1.15-44.pm.0          | i686        | Packman Repository
    v | libxine1-codecs                 | Paket      | 1.1.15-44.pm.0          | i586        | Packman Repository
      | libxine1-directfb               | Paket      | 1.1.15-44.pm.0          | i686        | Packman Repository
      | libxine1-directfb               | Paket      | 1.1.15-44.pm.0          | i586        | Packman Repository
      | libxine1-esd                    | Paket      | 1.1.15-44.pm.0          | i686        | Packman Repository
      | libxine1-esd                    | Paket      | 1.1.15-44.pm.0          | i586        | Packman Repository
      | libxine1-gnome-vfs              | Paket      | 1.1.15-44.pm.0          | i686        | Packman Repository
      | libxine1-gnome-vfs              | Paket      | 1.1.15-44.pm.0          | i586        | Packman Repository
      | libxine1-jack                   | Paket      | 1.1.15-44.pm.0          | i686        | Packman Repository
      | libxine1-jack                   | Paket      | 1.1.15-44.pm.0          | i586        | Packman Repository
      | libxine1-pulse                  | Paket      | 1.1.15-44.pm.0          | i686        | Packman Repository
      | libxine1-pulse                  | Paket      | 1.1.15-44.pm.0          | i586        | Packman Repository
      | libxine1-sdl                    | Paket      | 1.1.15-44.pm.0          | i686        | Packman Repository
      | libxine1-sdl                    | Paket      | 1.1.15-44.pm.0          | i586        | Packman Repository
      | totem-xine                      | Paket      | 2.22.2-10.2             | i586        | openSUSE BuildService - GNOME:Community
      | totem-xine-lang                 | Paket      | 2.22.2-10.2             | i586        | openSUSE BuildService - GNOME:Community
      | totem-xine-plugin               | Paket      | 2.22.2-10.2             | i586        | openSUSE BuildService - GNOME:Community
      | xine-browser-plugin             | Paket      | 1.0.2-0.pm.0            | i686        | Packman Repository
      | xine-browser-plugin             | Paket      | 1.0.2-0.pm.0            | i586        | Packman Repository
      | xine-browser-plugin-debuginfo   | Paket      | 1.0.2-0.pm.0            | i686        | Packman Repository
      | xine-browser-plugin-debuginfo   | Paket      | 1.0.2-0.pm.0            | i586        | Packman Repository
      | xine-browser-plugin-debugsource | Paket      | 1.0.2-0.pm.0            | i686        | Packman Repository
      | xine-browser-plugin-debugsource | Paket      | 1.0.2-0.pm.0            | i586        | Packman Repository
      | xine-devel                      | Paket      | 1.1.12-8.1              | i586        | openSUSE-11.0-Oss
      | xine-extra                      | Paket      | 1.1.12-8.1              | i586        | openSUSE-11.0-Oss
      | xine-lib                        | Quellpaket | 1.1.15-44.pm.0          | noarch      | Packman Repository
      | xine-lib                        | Quellpaket | 1.1.12-8.1              | noarch      | openSUSE-11.0-Oss
      | xine-lib                        | Quellpaket | 1.1.12-8.1              | noarch      | openSUSE-DVD 11.0
      | xine-lib-debuginfo              | Paket      | 1.1.15-44.pm.0          | i686        | Packman Repository
      | xine-lib-debuginfo              | Paket      | 1.1.15-44.pm.0          | i586        | Packman Repository
      | xine-lib-debugsource            | Paket      | 1.1.15-44.pm.0          | i686        | Packman Repository
      | xine-lib-debugsource            | Paket      | 1.1.15-44.pm.0          | i586        | Packman Repository
      | xine-skins                      | Paket      | 1.0.3-0.pm.0            | noarch      | Packman Repository
      | xine-ui                         | Paket      | 0.99.5cvs-20080426.pm.0 | i686        | Packman Repository
      | xine-ui                         | Paket      | 0.99.5cvs-20080426.pm.0 | i586        | Packman Repository
      | xine-ui                         | Paket      | 0.99.5-161.1            | i586        | openSUSE-11.0-Oss
      | xine-ui                         | Paket      | 0.99.5-161.1            | i586        | openSUSE-DVD 11.0
      | xine-ui-debuginfo               | Paket      | 0.99.5cvs-20080426.pm.0 | i686        | Packman Repository
      | xine-ui-debuginfo               | Paket      | 0.99.5cvs-20080426.pm.0 | i586        | Packman Repository
      | xine-ui-debugsource             | Paket      | 0.99.5cvs-20080426.pm.0 | i686        | Packman Repository
      | xine-ui-debugsource             | Paket      | 0.99.5cvs-20080426.pm.0 | i586        | Packman Repository
    i | xinetd                          | Paket      | 2.3.14-115.1            | i586        | openSUSE-11.0-Oss
    i | xinetd                          | Paket      | 2.3.14-115.1            | i586        | openSUSE-DVD 11.0
    
     
  7. #6 Gast1, 25.09.2008
    Zuletzt von einem Moderator bearbeitet: 25.09.2008
    Gast1

    Gast1 Guest

    Ich kann das Verhalten hier mit den selben Paketen reproduzieren.

    Schreib einen Bugreport (per Email) an den Paketmaintainer von libxine1, zu finden auf der Packman-Homepage.

    http://packman.links2linux.de/package/xine-lib

    //Nachtrag:

    Welche Version von Kaffeine ist installiert? Genauer Paketname und Herkunft? (siehe obige Zypper-Ausgabe analog angewandt).

    Möglicherweise ist das kein libxine-Problem.

    //Nachtrag2:

    Mit kaffeine von Packman funktioniert die Chose, komischerweise lief das aber vor ein paar Wochen mit der selben (sic!) Version aus den KDE-Repos, die jetzt Probleme bereitet.

    (Es ist allerdings eher verwunderlich, warum diese Version bis vor ein paar Tagen überhaupt das Abspielen von DVDs zugelassen hat, da die KDE-Backports eigentlich die selben SPECs wie die offiziellen und aus lizenzrechtlichen Gründen absichtlich "beschnittenen" Pakete verwenden.)

    Greetz,

    RM
     
  8. #7 gropiuskalle, 25.09.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Muss kein absolut gültiger bug sein, hab's gerade getestet und bei mir funktionieren DVDs einwandfrei.

    Code:
    kalle@hoppers:~> rpm -qa "*xine*"
    
    xine-skins-1.0.3-0.pm.0
    libxine1-jack-1.1.15-44.pm.0
    xinetd-2.3.14-77
    libxine-devel-1.1.15-44.pm.0
    xine-ui-0.99.5cvs-20080426.pm.0
    libxine1-1.1.15-44.pm.0
    amarok-xine-1.4.10-100.pm.1
    libxine1-codecs-1.1.15-44.pm.0
    libxine1-directfb-1.1.15-44.pm.0
     
  9. Gast1

    Gast1 Guest

    Kaffeine-Version?

    Wie gesagt, mit der Version aus OSS bzw. KDE-Backports funktioniert es zumindest hier nicht (mehr).

    Und die Version "0.8.7-2.1" lief vor ein paar Wochen noch.

    Greetz,

    RM
     
  10. #9 gropiuskalle, 25.09.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Für die 10.3 gibt es in KDE-Backports derzeit gar kein Kaffeine, sondern nur für die 11.0. Meine Version ist die 0.8.7-0.pm.1 von packman.

    Trotzdem wundert mich das angesichts der Fehlermeldung ein wenig, denn diese spricht ja von einer eingeschränkten Unterstützung durch xine. Wie sieht es denn mit anderen xine-Playern (z.B. Codeine) und DVDs aus?
     
  11. #10 Gast1, 25.09.2008
    Zuletzt von einem Moderator bearbeitet: 25.09.2008
    Gast1

    Gast1 Guest

    Also xine-ui funktioniert aus beiden (sic!) Quellen, sowohl von Packman als auch aus OSS, codeine gibt es nur bei Packman, also macht ein Vergleich da wenig Sinn.

    Das Seltsame ist ja, daß exakt die selbe kaffeine-Version (0.8.7-2.1) vor den letzten Updates ebenfalls funktionierte.

    Irgendeine seltsame "Wechselwirkung" muss da vorliegen, der Patch, welcher die zitierte Meldung auslöst, ist schon seit Ewigkeiten in kaffeine drin, daran kann es also eigentlich nicht liegen.

    //Edit:

    Jetzt brat' mir einer einen Storch, ein direktes

    Code:
    kaffeine dvd://
    funktioniert ohne Meldung auch über die Version 0.8.7-2.1, nur über den Dateidialog gibt es die obige Meldung.

    Betätigt man anschliessend (nachdem man die "Fehlermeldung" weggeklickt hat) ganz "frech" den Play-Button, so läuft die DVD ganz normal los.

    Ob da kaffeine die neue Version von libxine1 (denn die wurde vor kurzem upgedatet) beim Start zunächst "falsch" erkennt?

    Greetz,

    RM
     
  12. thei

    thei Foren As

    Dabei seit:
    26.07.2007
    Beiträge:
    94
    Zustimmungen:
    0
    Ort:
    Oberfranken
    Also ich hab die version 0.8.7-2.1 aus'n KDE-Backport

    und der konsolen aufruf (kaffeine dvd://) funktioniert bei mir auch...
     
  13. #12 gropiuskalle, 25.09.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Diese 'libxine1-codecs' sind doch auch noch ziemlich neu, vielleicht trägt das zur von Dir gemutmaßten Fehlzuordnung bei?
     
  14. Gast1

    Gast1 Guest

    Die Lösung steht oben und trifft auf das zu, was ich schon im letzten Thread und auch in meiner ersten Antwort gesagt habe.

    Greetz,

    RM
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 saeckereier, 26.09.2008
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Dann zahl ihn mal aus :-)
     
  17. #15 Gast1, 26.09.2008
    Zuletzt von einem Moderator bearbeitet: 26.09.2008
    Gast1

    Gast1 Guest

    Wieso?

    Mit dem kaffeine von Packman funktioniert es und rate mal woher die libxine kommt.

    :-)

    (OK, ich habe als einziges nicht explizit geschrieben, daß ich zuerst kaffeine von KDE-Backports installieren musste um den Fehler zu reproduzieren, aber ein Blick auf den letzten Thread des TE zu dem Thema legte das nahe. Der Auslöser ist also genau der von mir genannte, auch wenn der Grund für den Fehler bisher unklar bleibt.)
     
Thema:

Schon wieder Probleme mit Kaffeine?!

Die Seite wird geladen...

Schon wieder Probleme mit Kaffeine?! - Ähnliche Themen

  1. XFCE schon wieder zerstört erbitte Hilfe

    XFCE schon wieder zerstört erbitte Hilfe: Schon wieder mal habe ich irgendwie xfce kaputt gemacht. 3 Stunden klicken und suchen im www jetzt geht es wieder einigermassen. Wie kann...
  2. Text ersetzen - (schon wieder - ich weiß)

    Text ersetzen - (schon wieder - ich weiß): Moin Forum, ich muss in einer Datei wenn Bedingung A und B erfüllt ist, einen Wert in einer bestimmten Spalte ändern. Genauer: Wenn in der 1....
  3. Schon wieder der DAU aus Stuttgart...

    Schon wieder der DAU aus Stuttgart...: Hallo ihr Lieben! Jetzt habt ihr mir ganz ausführlich erklärt, dass man Gnome und KDE locker parallel installiert haben und dann auch...
  4. Was denn jetzt schon wieder kapput? (fehler bei startx)

    Was denn jetzt schon wieder kapput? (fehler bei startx): nach >> startx (EE) Failed to load module "bitmap" (module does not exist,0) (EE) Failed to load module "pcidata" (module does not exist,0)...
  5. Schon wieder= Wlan geht nicht

    Schon wieder= Wlan geht nicht: schon wieder ein tread das wlan karte nich funzt... ich hab mir schon viele Treads durchgelesen und hab es mit ndiswrapper unter Suse 10.1 mit...