Scanner nur mit root-rechten

Dieses Thema im Forum "Drucker / Scanner" wurde erstellt von muellermichi, 28.04.2007.

  1. #1 muellermichi, 28.04.2007
    muellermichi

    muellermichi Grünschnabel

    Dabei seit:
    28.03.2007
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo, habe für meinen Scanner (Epson Stylus DX4000) nach langer suche Treiber gefunden (iscan-free-2.3.0.1-15.1.i586.rpm).
    Habe auf meinem Laptop ubuntu 7.04.
    Habe dann die rpm-datei mit alien zu einer deb. gemacht und installiert.
    Bei eingabe von sudo xsane bekomme ich den Scanner zum laufen, aber nur so.
    Wie bekomme ich es hin , dass er mir mit normalen userrechten scannt?

    Dank im voraus
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. mali

    mali noob @ linux

    Dabei seit:
    22.12.2006
    Beiträge:
    306
    Zustimmungen:
    0
    Ort:
    Leverkusen
    Dann füge doch mal deinen USER in der Benutzerverwaltung zu der Gruppe Scanner oder so ähnlich sollte die heißen.
     
  4. #3 muellermichi, 28.04.2007
    muellermichi

    muellermichi Grünschnabel

    Dabei seit:
    28.03.2007
    Beiträge:
    8
    Zustimmungen:
    0
    Unter System-Administration-Benutzer und Gruppen bin ich Mitglied in der Gruppeneinstellung scanner.
    Trotzdem habe ich keine Möglichkeit als normaler Benutzer zuzugreifen.
     
  5. mali

    mali noob @ linux

    Dabei seit:
    22.12.2006
    Beiträge:
    306
    Zustimmungen:
    0
    Ort:
    Leverkusen
    hmm, evtl. muss du die Rechte von "xsane" ändern, so dass der User auch Zugriff hat; z.B.:
    Code:
    chmod 777 /usr/local/bin/xsane (
    (Pfad musst du natürlich anpassen) oder
    Code:
    chmod -R 777 /blablabla/xsane
    (Wenn es sich um ein Verzeichnis mit Unterverzeichnissen handelt).

    Dann hat dein User quasi root-rechte bzw. Vollzugriff auf die Datei oder das Verzeichnis
     
  6. #5 muellermichi, 28.04.2007
    muellermichi

    muellermichi Grünschnabel

    Dabei seit:
    28.03.2007
    Beiträge:
    8
    Zustimmungen:
    0
    Habe chmod 777 /usr/bin/xsane probiert, hat aber leider nicht gefunzt.
    Auch sudo chmod 777 /usr/bin/xsane ging nicht.
    dabei hat sich auch an der Datei wohl nichts geändert.
    wenn die Datei in Nautilus ansehe ist nach wie vor nur root Eigentümer und berechtigt. auch manuelles ändern der Datei als sudo Nautilus und dann die Änderung der Dateiberechtigung bringt keinen Erfolg.
    Steht dann zwar ein anderer Eigentümer bzw. Berechtigter, aber geht trotzdem nicht.
     
  7. #6 mali, 28.04.2007
    Zuletzt bearbeitet: 28.04.2007
    mali

    mali noob @ linux

    Dabei seit:
    22.12.2006
    Beiträge:
    306
    Zustimmungen:
    0
    Ort:
    Leverkusen
    Haste auch wirklich den ganzen xsane-ordner mit allen Unterordnern bearbeitet, mit "chmod -R 777 ..."?

    Falls ja, dann bin ich am Ende mit meinem Latein.
    Jetzt müssen mal die Leute mit nem Scanner an linux ran.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 muellermichi, 29.04.2007
    Zuletzt bearbeitet: 29.04.2007
    muellermichi

    muellermichi Grünschnabel

    Dabei seit:
    28.03.2007
    Beiträge:
    8
    Zustimmungen:
    0
    -rwxrwxrwx 1 root root 602636 2006-10-05 16:41 xsane
    ist das ergebnis meiner /usr/bin/xsane.
    drwxrwxrwx 4 ubuntu ubuntu 4096 2007-04-28 17:58 .sane
    drwxrwxrwx 3 ubuntu ubuntu 4096 2007-04-28 14:40 xsane
    ist das ergebnis von /home/ubuntu/.sane bzw. /home/ubuntu/.sane/xsane
    wenn ich über sudo xsane in /usr/bin/ oder xsane als sudo nautilus mit verzeichnis /usr/bin/ starte geht es.
    aber leider nur so.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Achja, bei meinem anderen Rechner OpenSuse 10.2 hat er alles automatisch erkannt und installiert. Ohne Probleme.
    Auf meinem Läppi habe ich halt Ubuntu 7.04 drauf und es ist wirklich gut.
    Brauche den Laptop/Scanner wegen Mobilität.
     
  10. zeael

    zeael Routinier

    Dabei seit:
    29.12.2006
    Beiträge:
    261
    Zustimmungen:
    0
    Ich hatte genau das gleiche Problem, und meinen Namen in die Gruppe reinzuschreiben hat geholfen (hab ich bei der Installation vergessen....und ich hab gedacht, ich wäre routiniert^^). Bist du dir sicher, dass du nichts falsch gemacht hast? Bearbeite die /etc/groups doch mal von Hand.
     
Thema:

Scanner nur mit root-rechten

Die Seite wird geladen...

Scanner nur mit root-rechten - Ähnliche Themen

  1. ClamAV 0.99 mit besserem Echtzeitscanner

    ClamAV 0.99 mit besserem Echtzeitscanner: Die Entwickler der freien Antivirus-Software ClamAV haben eine neue Hauptversion der Lösung veröffentlicht. ClamAV 0.99 folgt, von wenigen...
  2. CoreOS stellt Sicherheitsscanner Clair für Container vor

    CoreOS stellt Sicherheitsscanner Clair für Container vor: CoreOS hat das Projekt Clair unter einer freien Lizenz veröffentlicht. Clair analysiert die Paketliste von Containern, um vor Sicherheitsproblemen...
  3. Canon PIXMA MG5250 Scanner und Drucker einrichten

    Canon PIXMA MG5250 Scanner und Drucker einrichten: Hallo, ich bin gerade auf Open Suse 12.2 umgestiegen. Bin absolut nicht sattelfest was die Verwendung der Konsole angeht. Würde jetzt gerne mein...
  4. Netzwerkscanner Nmap 6.40 erschienen

    Netzwerkscanner Nmap 6.40 erschienen: Der freie Netzwerkscanner Nmap ist in der Version 6.40 erschienen. Laut Nmap-Entwickler Fyodor sind in dieser Version 14 neue NSE-Scripte,...
  5. OCS Cisco Scanner 0.2

    OCS Cisco Scanner 0.2: Compact mass scanner for Cisco routers with default telnet/enable passwords. Weiterlesen...