samba4 & Netzwerkeeinstellung, dns konfiguration

Dieses Thema im Forum "Samba" wurde erstellt von drown, 27.01.2014.

  1. drown

    drown Jungspund

    Dabei seit:
    11.12.2007
    Beiträge:
    23
    Zustimmungen:
    0
    Ich habe endlich fast zum Ziel (installation und konfiguration von samba4 als AD DC & Filesever) gekommen. gefolgt hab ich die seite "http://www.youtube.com/watch?v=5WKMtFyyxGI".
    Jetzt habe folgendes Problem:
    wenn ich die private dns ip wie 192.168.xxx.xxx an windows 7 machine eingebe, klappt die Verbindung zum sambaserver & funktioniert die authentifizierung. Dafür bricht aber die Internetverbindung bei Klientmaschine (windows 7).
    andererzeits die benutzung von private ip-adresse 192.168.xxx.xxx. an samba4-server ermöglicht die LAN verbindung. Aber hier auch ist es nicht möglich zum Internt. außerdem bekomme ich bei dem Befehl: $host -t A samba.xxxx. die folgende meldung: "host samba.xxx not found. 3(NXDOMAIN).
    wo habe ein fehler gemacht?
    wie konnte die lösung ausschauen?
    danke im voraus.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 28.01.2014
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Die Namensauflösung funktioniert nur, wenn ein entsprechender Dienst im Netzwerk verfügbar ist, der diese übernimmt. Das kann ein DNS-Server sein oder auch WINS.

    Warum allerdings die Internet-Verbindungen wegbrechen, wenn du den Samba ansprichst, ist mir etwas rätselhaft. Sind die Routen auf den Clients denn korrekt gesetzt?
     
  4. nighT

    nighT Guest

    Kann es sein, dass du mit den IP's etwas durcheinander bringst?

    Oben schreibst du von 192.168.xxx.xxx; die normale Netzmaske ist aber 255.255.255.0, wodurch das Netz z.B. 192.168.178.xxx oder 192.168.2.xxx oder ähnlich sein sollte.

    Kannst du uns die genauen IP Adressen der einzelnen Hosts geben? Also von Router, Client und von dem Samba-Server.
    Brauchst du auch nicht zu zensieren, da es sich um private Adressen handelt und diese keine Rückschlüsse auf deine öffentliche IP zulassen...
     
  5. drown

    drown Jungspund

    Dabei seit:
    11.12.2007
    Beiträge:
    23
    Zustimmungen:
    0
    Weitere Information
    Bei der provision habe ich DNS backend SAMBA_INTERNAL genommen. Daher habe ich wie es empfohlen wurde bind9 dienste deaktiviert.
    Die IP Konfiguration.
    Die Router DHCP IP-Vergabebereich: 192.168.0.10/200
    Konfiguration /etc/network/interfaces:
    static ip 192.168.0.210
    net mask 255.255.255.0
    gateway 192.168.0.1
    dns-nameserver 192.168.0.210
    dns-search mydomain
    mit dieser Konfiguration kann ich mit der samba-maschine nicht zum Internet kommen wohl aber die LAN-Verbindung
    win 7 Client-machine:
    Netzkonfiguration:
    ip-vergabe: dhcp öfter mit ip 192.168.0.17
    dns- 192.168.0.210
    mit dieser Konfiguration kann ich wieder nicht zum Internet wohl aber Verbindung mit Samba-server
    wenn dns automatisch beziechen wird dann ist gleich im Interent aber kann keine Verbindung mit samba-server gebaut werden.
     
  6. nighT

    nighT Guest

    Da stimmt auch definitiv was mit dem DNS nicht.
    Wenn du bind9 deaktivierst und unter Linux und Windows als DNS-Server dann den Linux-Host verwendest, ist klar, warum du keine Verbindung bekommst.

    Konfiguriere bei beiden Maschinen entweder per DHCP bzw. den Router als DNS.

    Anschließend testest du, ob du von Windows aus den Linux-Server nur über den Hostname nicht erreichen kannst oder auch die IP nicht pingbar ist.

    Sprich einmal:
    Code:
    ping <hostname>
    und einmal:
    Code:
    ping 192.168.0.210
    Wenn beides funktioniert, dann liegt das Problem wo anders. Nutzt du das binding von Samba an ein spezielles Interface (sprich interfaces in der smb.conf)?
     
  7. rene29

    rene29 Grünschnabel

    Dabei seit:
    05.03.2014
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo,

    Das ist auch meine Vermutung - allerdings hat es nicht unbedingt etwas mit dem deaktivierten Bind-DNS zu tun, da Samba4 einen internen DNS-Server mitbringt, den du bei dei Installation ja auch als DNS angegeben hast. Meine Erfahrungen dazu sind allerdings folgende:

    Samba4 richtet über den Internen DNS nur eine Forward-Zone ein, keine Reverse. Somit funktioniert die Auflösung nur bedingt in eine Richtung, was für die Gesamtfunktionalität problematisch ist. Da eine Windows7-Machine vorhanden ist, hier die Windows RSAT-Tools installieren, und über die DNS-Console auf den Server zugreifen und die Reverse-Lookup-Zone erstellen. Wenn möglich vorher den Client in die Domäne einbinden und als Administrator an der Domäne anmelden. Dann sollte das DNS schonmal vernünfig laufen.

    Gruß René
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

samba4 & Netzwerkeeinstellung, dns konfiguration

Die Seite wird geladen...

samba4 & Netzwerkeeinstellung, dns konfiguration - Ähnliche Themen

  1. Samba4 AD DC

    Samba4 AD DC: Hey Forum, das ist mein erster Post ich hoffe ich bin in der Richtigen section [IMG] Ich habe mit OpenSuSe 42.1 probiert einen Samba4 AD DC...
  2. Samba4 AD DC über VPN

    Samba4 AD DC über VPN: Ich verwende momentan einen Debian 8 root Server bei strato. Ein VPN i(l2tp/ipsec) ist installiert und der interfacename für die Verbindung ist...
  3. Nach Update debian 8 ist der Zugriff auf samba4 nicht möglich

    Nach Update debian 8 ist der Zugriff auf samba4 nicht möglich: Gerade habe ich debian mit dem Befehl "apt-get ugrade" aktualisiert. Es gab zahlreiche neue Daten unteranderen samba files. Nach neuem Start kann...
  4. Anmeldung auf Samba4 Server

    Anmeldung auf Samba4 Server: Ein debian 8 server mit samba4 als pdc und file server installiert. Alle Konfigurationen sind gut gelaufen und samba4 hat bis jetzt einwandfrei...
  5. samba4 und bind9 auf raspbian - bind stürzt ständig ab

    samba4 und bind9 auf raspbian - bind stürzt ständig ab: Hallo zusammen, Hallo zusammen, ich habe seit Mai auf meinen Raspberry samba4 mit bind9 als Backend laufen (incl. Kerberos). Seit...