Samba-User schreibt als root

Dieses Thema im Forum "Samba" wurde erstellt von whity, 04.11.2006.

  1. whity

    whity Grünschnabel

    Dabei seit:
    04.11.2006
    Beiträge:
    5
    Zustimmungen:
    0
    Hi,

    hab mein Problem so im Forum nicht gefunden, deswegen stelle ich es mal in den Raum:

    Mehrere Windows-Clients nutzen in einem kleinen Netz Samba-Freigaben auf einem Linux-Server. Läuft alles prima, bis auf einen User: Legt dieser in der Freigabe ein Verzeichnis oder eine Datei an, gehört diese(s) dem Benutzer und der Gruppe root. Hat den Effekt, daß kein anderer User diese Dateien ändern kann. Der User hat die gleiche Gruppenzugehörigkeit wie die anderen 0815-User, was ihn aber nicht davon abhält, als root zu schreiben.
    Wenn ich einen neuen User anlege und ihn der entsprechenden Gruppe zuordne ist alles i.O. Also habe ich mir gedacht, den Stör-User einfach zu löschen und einen neuen mit diesem Namen anzulegen. Gesagt, getan: User gelöscht, per useradd und smbpasswd neu angelegt und in der /etc/groups noch der passenden Gruppe zugeordnet. Ergebnis: Der neue "alte" User legt nach wie vor Dateien an, die root gehören. :think:

    Wenn jemand eine Idee hat, wie sich das Problem lösen läßt oder wo mein Denkfehler liegt, wäre ich dafür dankbar.

    Grüße
    Whity
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Lumpi

    Lumpi Haudegen

    Dabei seit:
    14.06.2006
    Beiträge:
    663
    Zustimmungen:
    0
    Ort:
    Dessau
    Hallo

    Tritt das Problem mit diesem USER nur an einem Client auf
    oder auch an Anderen?
    Schreibt USER in jeder Freigabe als "root" ?
    poste mal deine [global] der smb.conf
    Auch eine "Problem"-Freigabe wäre nett...

    Gruß Lumpi
     
  4. whity

    whity Grünschnabel

    Dabei seit:
    04.11.2006
    Beiträge:
    5
    Zustimmungen:
    0
    Hmmm, an einem anderen Client hab ich's mit diesem User noch nicht probiert. Bzw. mit einem anderen User an diesem Client. Muß ich mal testen. Komme leider erst nächste Woche dazu. Dann kann ich auch die Einträge aus der smb.conf posten.

    Gruß
    Whity
     
  5. #4 pitschi5, 04.11.2006
    pitschi5

    pitschi5 ***BOFH

    Dabei seit:
    30.04.2005
    Beiträge:
    81
    Zustimmungen:
    0
    Ort:
    Wasserliesch, Germany
    hi,
    ein post deiner smb.conf wäre nicht verkehrt.

    hast du in der sharing die optionen

    Code:
    create mask = 0777
    directory mask = 0777
    
    drin. Nur so ne Idee vielleicht könnte es daran liegen?
    Aber ohne config-files lässt sich da nix genaues sagen

    so long...
     
  6. whity

    whity Grünschnabel

    Dabei seit:
    04.11.2006
    Beiträge:
    5
    Zustimmungen:
    0
    So, hier ist also der Auszug aus der smb.conf:

    [global]
    workgroup = TEST2000
    encrypt passwords = Yes
    log level = 1
    syslog = 0
    unix extensions = Yes
    socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
    printcap name = CUPS
    character set = ISO8859-15
    os level = 65
    create mask = 0774
    directory mask = 0775
    printing = cups
    veto files = /*.eml/*.nws/riched20.dll/*.{*}/

    [DAT]
    comment = DAT
    path = /DATEN/DAT
    read only = No

    [DAT2]
    comment = DAT2
    path = /DATEN/DAT2
    read only = No

    Der Problem-User schreibt unabhängig vom Client (und auf beiden Freigaben) als root - umgekehrt arbeiten andere User am problematischen Client normal. Also muß das Problem am Linux-Server liegen.
    Was würden diese Einstellungen denn bewirken?
    create mask = 0777
    directory mask = 0777
    Da die Freigabeeinstellungen scheinbar bei allen anderen Usern funktionieren, habe ich diese Werte vorerst nicht gesetzt.

    Gruß
    Whity
     
  7. Lumpi

    Lumpi Haudegen

    Dabei seit:
    14.06.2006
    Beiträge:
    663
    Zustimmungen:
    0
    Ort:
    Dessau
    Hallo nimm mal als [global] folgende Einstellung:
    Code:
            workgroup = TEST2000
            security = user
            log level = 1
            syslog = 0
            socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
            printcap name = CUPS
            os level = 65
            create mask = 0774
            directory mask = 0775
            veto files = /*.eml/*.nws/riched20.dll/*.{*}/
    Was die einzelnen Parameter bewirken, kannst du hier lesen
    Ansonsten scheint eher ein Problem beim User vorzuliegen..

    Gruß Lumpi
     
  8. #7 pitschi5, 07.11.2006
    Zuletzt bearbeitet: 07.11.2006
    pitschi5

    pitschi5 ***BOFH

    Dabei seit:
    30.04.2005
    Beiträge:
    81
    Zustimmungen:
    0
    Ort:
    Wasserliesch, Germany
    hi,

    versuch mal die zugriffrechte im sharing zu setzen, zusätzlich dazu
    geh auf datei-ebene und lege für jedes sharing eine gruppe an, die schreibzugriff auf dieses sharing hat.
    dann änderst du den besitzer des ordners in root:gruppe.
    anschließend gibst du folgdes in der smb.conf an:


    Code:
    [sharing-name]
    valid user = @gruppe
    create mask = 0770
    directory mask = 0770
    inherit acl = yes

    inherit acl = yes, bewirkt dass die rechte von neuen ordnern vom parent übernommen werden.
    vergiss nicht rcsmb reload/restart und dich auf der wks einmal aus und wieder einzuloggen. jetzt sollten die user als samba-user schreiben.

    edit:
    SAMBA 3 für Unix/Linux-Administratoren von Volker Lendecke, Karolin Seeger, ..... dpunkt.verlag, iX-Press
    kann ich dir empfehlen bevor du an ner SAMBA-config rumschraubst.....

    so long...
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. whity

    whity Grünschnabel

    Dabei seit:
    04.11.2006
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo,

    danke für eure Anhaltspunkte. Werd ich so bald wie möglich ausprobieren. Auch wenn's diese Woche bestimmt nicht mehr wird, werde ich das Ergebnis hier posten.

    Grüße
    Whity
     
  11. whity

    whity Grünschnabel

    Dabei seit:
    04.11.2006
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo nochmal,

    danke für alle Tips - auch wenn das Problem dadurch nicht gelöst wurde. Ich habe deshalb den User neu angelegt (mit abgeändertem Namen) und wie zu erwarten hat das funktioniert. Zwar mußte ich dann auch noch das Profil am Client neu erstellen; ist aber im Endeffekt wahrscheinlich schneller, als den verkorksten Eintrag in wer-weiß-welcher config-Datei zu suchen.

    Grüße
    Whity
     
Thema:

Samba-User schreibt als root

Die Seite wird geladen...

Samba-User schreibt als root - Ähnliche Themen

  1. OSB Alliance schreibt Innovationspreis aus

    OSB Alliance schreibt Innovationspreis aus: Der Open Source Business Award - der OSBAR - ist der neue Innovationspreis der OSB Alliance. Damit will der Open Source Verband Projekte,...
  2. Handbuch der britischen Regierung für Entscheider in der ICT schreibt Open-Source vor

    Handbuch der britischen Regierung für Entscheider in der ICT schreibt Open-Source vor: Ein neues Handbuch der britischen Regierung empfiehlt die Verwendung von Open-Source-Software bei Informations- und Kommunikationstechnologien...
  3. Red Hat schreibt Fedora Stipendium 2012 aus

    Red Hat schreibt Fedora Stipendium 2012 aus: Der Open-Source-Lösungs-Anbieter Red Hat hat bekannt gegeben, dass er ab sofort Bewerbungen für das Fedora-Stipendien-Programm entgegen nimmt. An...
  4. printf Formatierung: echo schreibt bei Ausgabeumleitung auf File nichts. Wieso?

    printf Formatierung: echo schreibt bei Ausgabeumleitung auf File nichts. Wieso?: #!/bin/sh ZAHL="372" FARBE="gelb" printf "%s%06d%s" "Bearbeitungsnummer 888" $ZAHL ", Farbe: $FARBE" echo printf "%s%06d%s" "Bearbeitungsnummer...
  5. openldap schreibt massig archivelogs

    openldap schreibt massig archivelogs: Unter Redhat wird ein openLDAP-Server betrieben. Dieser fängt manchmal an, alle drei Minuten eine Archivelog zu schreiben und somit das Filesystem...