Samba und Win XP recht langsam

Dieses Thema im Forum "Samba" wurde erstellt von Swargon, 09.01.2005.

  1. #1 Swargon, 09.01.2005
    Swargon

    Swargon Grünschnabel

    Dabei seit:
    09.01.2005
    Beiträge:
    2
    Zustimmungen:
    0
    Hi!

    Ich habe folgendes Problem:
    Ich habe einen Fileserver unter Linux (Suse 9.0 Pro). Inzwischen habe ich ihn auf Samba 3 geupdated. Es handelt sich dabei um einen 1200er Duron mit 100 MBit Netzwerkkarte und ca. 300 MB ram.
    Mein Client ist ein 2100+ Athlon XP mit über 700 MB ram auf dem Windows XP läuft.
    Nachdem ich vor etwa einer Woche meinen Server von Windows XP Pro auf Linux umgestellt habe, war ich erstmal begeistert. Linux ist echt cool. Allerdings hatte ich früher eine Netzlaufwerkverbindung zum Server, die unter Linux mit Samba nicht so richtig funktioniert.
    Wenn ich eine Datei neu öffne, z.B. ein Video, dann dauert es öfter mal bis zu einer Minute (!) bevor sich was tut. Ähnlich ist es beim Ausführen von .exe-Dateien.
    Es wirkt so als würde es immer dann Probleme geben, wenn verschiedne Informationen an verschiedenen Stellen einer Datei aus dem Netzwerk gelesen werden. Zum Beispiel beim Entpacken, oder wenn Windows die Informationen aus einer Videodatei holt.
    Ich habe schon mal gehört, das Samba 3 teilweise schneller ist als Windwos 2003 Server, also hoffe ich einfach mal das ich da irgendwas falsch konfiguriert habe. Währe cool, wenn mir jemand weiterhelfen könnte!

    Hier nochmal meine smb.conf:
    [global]
    workgroup = SPACE2001
    os level = 2
    time server = Yes
    unix extensions = Yes
    encrypt passwords = yes
    map to guest = Bad User
    printing = CUPS
    printcap name = CUPS
    socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY SO_RCVBUF=8192 SO_SN
    DBUF=8192
    change notify timeout = 120
    paranoid server security = No
    read size = 32768
    wins support = No
    veto files = /*.eml/*.nws/riched20.dll/*.{*}/
    server string = Fileserver und Gateway
    add user script =
    domain master = false
    domain logons = no
    local master = no
    log level = 4
    preferred master = auto
    ;; ldap server = 127.0.0.1
    [hypernova] ;Das ist das share für das Netzwerklaufwerk (Z: unter WinXP)
    path = /mnt/hypernova
    comment = Alte Datenfestplatte
    valid users = swargon
    browseable = yes
    read only = No
    create mask = 0640
    directory mask = 0750
    guest ok = no
    printable = no

    Bitte bitte helft mir ich will nicht zurück zu Windows!!! ;(
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 h2owasser, 10.01.2005
    h2owasser

    h2owasser Sxe Power User

    Dabei seit:
    07.12.2002
    Beiträge:
    491
    Zustimmungen:
    0
    Hi!

    Unter Samba richtest du ein logon-Share ein. Auf diesem liegt dann in aller Regel eine .bat - Datei, die dann wiederum auf dem Clientsystem gestartet wird und mit dem net-Befehl die entsprechenen Shares "mountet" bzw. mapped.

    Oje... Das ist ein harter Brocken. :think: Kannst du mir verraten, welches Filesystem (Ich vermute ReiserFS) du verwendest und ob der DMA Modus der Festplatte angeschaltet ist.
     
  4. #3 hamilcar, 10.01.2005
    hamilcar

    hamilcar Grünschnabel

    Dabei seit:
    31.05.2004
    Beiträge:
    4
    Zustimmungen:
    0
    vielleicht liegts am DNS

    Hallo.

    Ich hatte bis vor kurzem auch erhebliche Probleme mit Samba 3 und konnte mir das ganze einfach nicht erklären. Beim erstenmal zugreifen auf eine Share nach dem hochfahren dauerte es ewig bis ich Zugriff auf die Freigabe hatte. Außerdem kamen ständig Fehlermeldungen in der "log.smbd"

    Die Lösung meines Problems war dann das ich die Namensauflösung repariert habe. Bei mir läuft auch BIND9 auf dem Server und die Konfiguration war total falsch.

    Was ich dir raten würde ist die "/etc/hosts" anzuschauen und möglichst vollständig und korrekt deine Rechner dort einzutragen. Vielleicht hilfts...

    Wenn das auch nicht klappt dann poste mal was aus deiner "log.smbd"

    J.G.
     
  5. #4 Swargon, 14.01.2005
    Swargon

    Swargon Grünschnabel

    Dabei seit:
    09.01.2005
    Beiträge:
    2
    Zustimmungen:
    0
    Hier ist meine log.smbd
    Code:
    [2005/01/14 20:40:23, 3] smbd/process.c:process_smb(1091)
      Transaction 1962336 of length 63
    [2005/01/14 20:40:23, 3] smbd/process.c:switch_message(886)
      switch message SMBreadX (pid 7663) conn 0x83c8a30
    [2005/01/14 20:40:23, 3] smbd/reply.c:send_file_readX(2154)
      send_file_readX fnum=8270 max=8 nread=8
    [2005/01/14 20:40:23, 3] smbd/process.c:process_smb(1091)
      Transaction 1962337 of length 63
    [2005/01/14 20:40:23, 3] smbd/process.c:switch_message(886)
      switch message SMBreadX (pid 7663) conn 0x83c8a30
    [2005/01/14 20:40:23, 3] smbd/reply.c:send_file_readX(2154)
      send_file_readX fnum=8270 max=8 nread=8
    [2005/01/14 20:40:23, 3] smbd/process.c:process_smb(1091)
      Transaction 1962338 of length 63
    [2005/01/14 20:40:23, 3] smbd/process.c:switch_message(886)
      switch message SMBreadX (pid 7663) conn 0x83c8a30
    [2005/01/14 20:40:23, 3] smbd/reply.c:send_file_readX(2154)
      send_file_readX fnum=8270 max=8 nread=8
    [2005/01/14 20:40:23, 3] smbd/process.c:process_smb(1091)
      Transaction 1962339 of length 63
    [2005/01/14 20:40:23, 3] smbd/process.c:switch_message(886)
      switch message SMBreadX (pid 7663) conn 0x83c8a30
    [2005/01/14 20:40:23, 3] smbd/reply.c:send_file_readX(2154)
      send_file_readX fnum=8270 max=8 nread=8
    
    Das passiert gerade. Ich war eben dabei The Cell via Netzlaufwerk anzusehen. - Ich warte jetzt schon seit ca. 5-10 Minuten und der RealPlayer hängt immer noch... X(
    Die paar Zeilen in der Logdatei wiederholen sich ständig. Wenn ich mehr posten soll gebt mir bitte bescheid.

    Mein Nameserver läuft auch noch nicht richtig, aber zumindest die /etc/hosts hat jetzt alle rechner im Netz korrekt drin. - Hat nur leider auch nicht viel gebracht... :(

    Ja, mein Filesystem ist ReiserFS. Leider hab ich keine Ahnung, wie man überprüft, ob der DMA Modus an ist!

    Bin für jeden Vorschlag dankbar! :))
     
  6. #5 h2owasser, 16.01.2005
    h2owasser

    h2owasser Sxe Power User

    Dabei seit:
    07.12.2002
    Beiträge:
    491
    Zustimmungen:
    0
    "hdparm -tT /dev/hda" als root gibt dir die Lesegeschwindigkeit deiner ersten Festplatte an. Sollte man aber auch sonst im normalen Betrieb merken, wenn was mit der Festplatte net stimmt. Sonst nimm' mal die Optionen SO_RCVBUF und DBUF raus. Zuletzt versuch mal die vorgeschlagenen Optionen von
    http://www.rootboard.de/vb3/showthread.php?t=11498.
    Sonst kann ich dir nurnoch raten, die allerneuste Sambaversion einzuspielen oder weitergooglen.
     
Thema:

Samba und Win XP recht langsam

Die Seite wird geladen...

Samba und Win XP recht langsam - Ähnliche Themen

  1. Samba und Ordnerberechtigungen für windows

    Samba und Ordnerberechtigungen für windows: Hallo ich hab ein kleines problem das ich nicht gelöst bekomme , ich bin mir auch nicht sicher ob das überhaupt mit samba geht also folgendes...
  2. Samba-Dateiserver, Zugriffsrechte für Netzlaufwerke

    Samba-Dateiserver, Zugriffsrechte für Netzlaufwerke: Hallo liebe Community Ich bin ein absoluter Samba-Anfänger, habe also kein technisches Hintergrundwissen in Sachen Samba. Meine Frage zu...
  3. Falsche Rechte gesetzt beim Anlegen von Ordnern via Samba-Client

    Falsche Rechte gesetzt beim Anlegen von Ordnern via Samba-Client: Hallo, ich habe eine Bitte: Kann jemand der Ahnung von der Konfiguration eines Samba-Servers hat, mal meine smb.conf kritisch duchgehen? Ich...
  4. Samba u. AD - Berechtigungsgruppen greifen nicht

    Samba u. AD - Berechtigungsgruppen greifen nicht: Hallo, ich habe auf einem Serer Samba 3.5.6 installiert. Die Berechtigungen für die Shares sollen hierzu aus dem AD kommen. Das funktioniert...
  5. Rechte beim Anlegen von Dateien via Samba-Client nicht korrekt gesetzt

    Rechte beim Anlegen von Dateien via Samba-Client nicht korrekt gesetzt: Hallo, ich habe einen Samba-Server aufgesetzt und die beiden im Folgenden beschriebenen Freigaben in der smb.conf definiert. Neu angelegte...