Samba Share Name ist nach Samba 2 zu Samba 3 Umstellung case sensitive

Dieses Thema im Forum "Samba" wurde erstellt von AndiS, 25.02.2008.

  1. AndiS

    AndiS Grünschnabel

    Dabei seit:
    25.02.2008
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo!

    Wir haben vor kurzem unsere Samba-Server von Samba 2 auf Samba 3 migriert.

    Seitdem haben wir das Problem, dass der Sharename z.B. blub bei \\server\blub case senstive ist.

    Die Ordner und Dateien im share selbst bleiben case insensitive.

    Wenn ich auf den Share

    \\server\BLUB zugreifen will, wird dieser nicht erkannt. Bei
    \\server\blub wird dieser allerdings gefunden.

    Bisher konnte ich keine Lösung finden!

    Weiß jemand von euch woran das liegt?

    Schöne Grüße,

    AndiS
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 serverzeit.de, 25.02.2008
    serverzeit.de

    serverzeit.de Netzwerkarchäologe

    Dabei seit:
    24.05.2007
    Beiträge:
    227
    Zustimmungen:
    0
    Kannst du mal deine smb.conf hier reinstellen?

    Ich habe Samba 3 auch im Einsatz und bei mir ist nix case sensitive.
     
  4. AndiS

    AndiS Grünschnabel

    Dabei seit:
    25.02.2008
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo!

    ich konnte das Problem weiter einschränken!

    Es tritt nur bei shares die von der [home]-section generiert werden auf.

    Meine [home]-section auf dem server:

    [homes]
    comment = UNIX Home Directory for %S
    valid users = %S
    writeable = yes
    browseable = no

    An der Config wurde seit Samba 3 Migration nichts geändert. Das könnte eine Implementierungssache des Samba 3 Server sein.


    Schöne Grüße,

    AndiS
     
  5. #4 serverzeit.de, 26.02.2008
    serverzeit.de

    serverzeit.de Netzwerkarchäologe

    Dabei seit:
    24.05.2007
    Beiträge:
    227
    Zustimmungen:
    0
    Füg doch mal das bei den Shares, speziell [homes] mit ein:

    case sensitive = no

    Vielleicht hilfts.
     
  6. AndiS

    AndiS Grünschnabel

    Dabei seit:
    25.02.2008
    Beiträge:
    7
    Zustimmungen:
    0
    Hi!

    Nein das setzen der Option und restart von samba hat an dem Problem nichts verändert.
     
  7. #6 serverzeit.de, 26.02.2008
    serverzeit.de

    serverzeit.de Netzwerkarchäologe

    Dabei seit:
    24.05.2007
    Beiträge:
    227
    Zustimmungen:
    0
    Hast du Windows-Clients?

    Für gemischte Netzwerke solltest du das setzen:

    default case = lower
    case sensitive = no
    preserve case = no

    Für jede Share übrigens. Hast du mal in die Logs geschaut was er dann sagt?
     
  8. AndiS

    AndiS Grünschnabel

    Dabei seit:
    25.02.2008
    Beiträge:
    7
    Zustimmungen:
    0
    Nein, das hilft leider auch nichts!

    Ja ich hab logs. Hab den Fehler in den Logs isoliert:

    Benutzer ist: "john" auf dem Server "testserver". Ich habe versucht anstatt

    \\testserver\john
    \\testserver\JOHN einzugeben

    Code:
    [2008/02/26 10:23:28, 3] smbd/reply.c:reply_tcon_and_X(574)
      tconX service=IPC$ 
    [2008/02/26 10:23:28, 3] smbd/process.c:process_smb(1068)
      Transaction 4 of length 106
    [2008/02/26 10:23:28, 3] smbd/process.c:switch_message(926)
      switch message SMBtrans2 (pid 1677) conn 0x1005b9410
    [2008/02/26 10:23:28, 3] smbd/sec_ctx.c:set_sec_ctx(241)
      setting sec ctx (60001, 60001) - sec_ctx_stack_ndx = 0
    [2008/02/26 10:23:28, 3] smbd/service.c:find_service(286)
      checking for home directory JOHN gave /home/john
    [2008/02/26 10:23:28, 3] param/loadparm.c:lp_add_home(2660)
      adding home's share [JOHN] for user 'JOHN' at '/home/john'
    [2008/02/26 10:23:28, 3] smbd/msdfs.c:get_referred_path(624)
      get_referred_path: |JOHN| in dfs path \testserver\JOHN is not a dfs root.
    [2008/02/26 10:23:28, 3] smbd/error.c:error_packet_set(106)
      error packet at smbd/trans2.c(6184) cmd=50 (SMBtrans2) NT_STATUS_NOT_FOUND
    [2008/02/26 10:23:28, 3] smbd/process.c:process_smb(1068)
      Transaction 5 of length 240
    [2008/02/26 10:23:28, 3] smbd/process.c:switch_message(926)
      switch message SMBsesssetupX (pid 1677) conn 0x0
    [2008/02/26 10:23:28, 3] smbd/sec_ctx.c:set_sec_ctx(241)
      setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
     
  9. #8 serverzeit.de, 26.02.2008
    Zuletzt bearbeitet: 26.02.2008
    serverzeit.de

    serverzeit.de Netzwerkarchäologe

    Dabei seit:
    24.05.2007
    Beiträge:
    227
    Zustimmungen:
    0
    msdfs root = yes im [homes]-Bereich. Bringt das was?

    Ist dein oben dargestellter [homes] Bereich vollständig? Was steht unter GLOBAL?

    P.S: Nach dieser Änderung den Client einmal neustarten...
     
  10. AndiS

    AndiS Grünschnabel

    Dabei seit:
    25.02.2008
    Beiträge:
    7
    Zustimmungen:
    0
    WOW!!! Du bist der Mann des Tages!

    msdfs root = yes

    brachte die Lösung!! Tausend dank, woher hast du das gewusst?

    Aus der samba doku:

    msdfs root (S)
    If set to yes, Samba treats the share as a Dfs root and allows clients to browse the distributed file system tree rooted at the share directory. Dfs links are specified in the share directory by symbolic links of the form msdfs:serverA\\shareA,serverB\\shareB and so on. For more information on setting up a Dfs tree on Samba, refer to the MSDFS chapter in the Samba3-HOWTO book.

    Default: msdfs root = no
     
  11. #10 serverzeit.de, 26.02.2008
    serverzeit.de

    serverzeit.de Netzwerkarchäologe

    Dabei seit:
    24.05.2007
    Beiträge:
    227
    Zustimmungen:
    0
    Ich hatte mal ein ähnliches Problem bei einem Kunden, war mir aber nicht mehr sicher welche der genannten Optionen das Problem behob. Daher war es mit etwas Raten verbunden.

    Schön dass es jetzt funktioniert.
    Schönen Tag.
     
  12. AndiS

    AndiS Grünschnabel

    Dabei seit:
    25.02.2008
    Beiträge:
    7
    Zustimmungen:
    0
    Hi!

    Die Freude war nur von kurzer Dauer!
    msdfs root = yes behebt das Problem nur im Windows-Explorer.

    Wenn ich versuche das share (share-name in Großbuchstaben geschrieben) mit "net use" oder in VBS mit "WshNetwork.MapNetworkDrive" zu mounten (also in Windows XP) dann tritt trotzdem der Fehler auf, sprich share kann nicht eingebunden werden.

    Folgendes erscheint in der log:
    Es ist zum verzweifeln...

    Schöne Grüße,

    AndiS
     
  13. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  14. #12 serverzeit.de, 27.02.2008
    serverzeit.de

    serverzeit.de Netzwerkarchäologe

    Dabei seit:
    24.05.2007
    Beiträge:
    227
    Zustimmungen:
    0
    Argh. Kannst du das LogLevel mal auf 2 oder 3 setzen und es nochmal versuchen ob er vielleicht genauer ausspuckt wo das Problem liegt?

    Mich würde zudem interessieren, was dich daran hindert überall Kleinbuchstaben zu verwenden. Sicherlich nicht die Lösung des Problems aber ein "Workaround", wie man es so schön nennt?

    Ich weiß langsam auch nicht mehr weiter, vorallem da ich es nicht nachvollziehen kann. Bei mir funktioniert "net use \\192.168.0.1\FILES" und "net use \\192.168.0.1\files" gleichermaßen. Liegt es vielleicht an deinen Berechtigungen oder so?

    Sehr seltsam. Kannst du mal deine komplette smb.conf hier abbilden?
     
  15. AndiS

    AndiS Grünschnabel

    Dabei seit:
    25.02.2008
    Beiträge:
    7
    Zustimmungen:
    0
    Hi!

    Den Auszug den du oben siehst ist Log Level 3.
    net use \\192.168.0.1\FILES oder net use \\192.168.0.1\files ist auch kein Problem, da dieses Problem nur bei Homeshares also [homes]-section auftritt. Andere [xyz]-share sections haben dieses Problem nicht, sprich ob groß oder klein ist egal.

    Generell ist das kein Problem. Nur für unsere User ist es ein Problem, weil die Jungs und Mädels sich groß/klein anmelden wie sie lustig sind. Genau dieser Windows-Anmeldename wird dann verwendet um sich an die samba-server anzumelden.

    Wir haben das jetzt anders gelöst. Unser login-script wird angepasst und der Windows-Login-Name wird in kompletter Kleinschreibung konvertiert egal, wie es der User anmeldet.

    Ich danke dir auf alle Fälle für deine Hilfestellung.

    Schöne Grüße,

    AndiS
     
Thema:

Samba Share Name ist nach Samba 2 zu Samba 3 Umstellung case sensitive

Die Seite wird geladen...

Samba Share Name ist nach Samba 2 zu Samba 3 Umstellung case sensitive - Ähnliche Themen

  1. mv auf Samba-Share mit 'preserving permissions'

    mv auf Samba-Share mit 'preserving permissions': Hallo, ich verschieben gerade einige *.rar-Dateien von meinem Downloadserver mit Raspbian (Raspberry Pi) auf meine per Samba gemountete...
  2. CTDB Samba Cluster als Shared Storage für MS SQl Server

    CTDB Samba Cluster als Shared Storage für MS SQl Server: Hallo Zusammen, ich habe eine etwas abenteuerliche Konfiguration vor. Ich möchte zwei SQL Server 2008 R2 Ent. Edt. quais parallel laufen lassen....
  3. SAMBA shares mit Windows/7 Home Premium

    SAMBA shares mit Windows/7 Home Premium: Ich betreibe einen LAMP-server unter Debian-Squeeze mit den entsprechenden Software-Paketen auf dem neuesten Stand. Ich kann von Debian-clients...
  4. Sambashare ist Readonly

    Sambashare ist Readonly: Hallo zusammen, seit Tagen quäle ich mich mit meinem Samba Fileserver rum. Ich kann meine Sambashares nur Readonly einbinden. smb.conf...
  5. Samba Share auf DFS Link - Probleme

    Samba Share auf DFS Link - Probleme: Wir haben einen Win2008 R2 SP1 Server am laufen auf dem ein Verzeichnis z.B. F:\Austausch als Netzwerkshare freigegeben haben, in diesem...