Samba-Mount??

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von TomZ, 28.01.2006.

  1. TomZ

    TomZ Grünschnabel

    Dabei seit:
    28.01.2006
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo,

    ich bin noch neu mit Ubuntu und hab jetzt folgendes Problem: Ich kann als Root-User einwandfrei ein bestimmtes SMB-Share von einem anderen Windows-Rechner mounten. Und dann auch da rein schreiben, klappt perfekt - aber nur als User root. Als normaler User "ubuntu" kann ich in das Share nicht schreiben. Ich hab das Teil so gemountet:

    mount -t smbfs //meister/freigabe /home/meister

    Any ideas? Und dann nochwas: Kann ich dieses SMB-Share dann irgendwie zum Home-Verzeichnis für den User ubuntu machen???

    Danke Euch!
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Bâshgob, 28.01.2006
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    1. Frage
    Entweder mit smbmount ( der Aufruf mount -t smbfs ruft in Wahrheit smbmount auf) als normaler User mounten und/oder mit den Optionen experimentieren (fmask/dmask/uid/gid usw.) Siehe man 8 smbmount.

    2. Frage
    Ohne es getestet zu haben würde ich sagen ja. Einfach über einen entsprechenden Eintrag nebst passenden Optionen in der fstab.
     
  4. #3 Nemesis, 28.01.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    wie sieht denn deine samba config aus?

    hast du schonmal webmin pobiert?
     
  5. #4 Bâshgob, 28.01.2006
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    Das Share liegt laut OP auf einer Windozebüchse. Demnach ist da nix mit smb.conf. Nur mal so am Rande ;-)
     
  6. #5 Nemesis, 28.01.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    ohje, ups, jetzt hab ichs falsch verstanden, ich dachte gerade andersrum.

    sry ^^
     
  7. jonbob

    jonbob Grünschnabel

    Dabei seit:
    17.01.2007
    Beiträge:
    4
    Zustimmungen:
    0
    hallo leute

    ich versuche einen normalen mount befehl auf samba aus zuführen bekomme jedoch immer diese fehlermeldung :think: :

    root@pc-78:~# mount -t smbfs //linux/max /home/test
    mount: wrong fs type, bad option, bad superblock on //linux/max,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so


    mfg jonbob
     
  8. #7 supersucker, 12.02.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Probier mal cifs anstatt smbfs:

    Code:
    mount -t cifs //linux/max /home/test
     
  9. jonbob

    jonbob Grünschnabel

    Dabei seit:
    17.01.2007
    Beiträge:
    4
    Zustimmungen:
    0
    ne gleicher fehler ?(
     
  10. #9 Goodspeed, 13.02.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Was gibt den
    Code:
    smbclient -L linux
    
    Alternativ kannste es ja auch mal mit der IP anstatt dem Namen versuchen ...
     
  11. #10 TAXI, 11.05.2009
    Zuletzt bearbeitet: 11.05.2009
    TAXI

    TAXI Grünschnabel

    Dabei seit:
    24.07.2004
    Beiträge:
    2
    Zustimmungen:
    0
    bin grad zufällig via google über diesen thread gestolpert ;)
    und was sagt dmesg (das tail kannste weglassen, zu 80% ist/sind die letze(n) zeile(n) aus dmesg nach dem mount aufruf wichtig ;))

    P.S: (sry, komm grad vom feiern, nich übel nehmen ;)) wow... mein 2ter beitrag hier? aber seit 5 jahren angemeldet? o.O

    //EDIT: sry fürs zu spät kommen ;) hab nur beim letzten beitrag "Today" gelesen... wieso? weil ich nicht eingeloggt war und es ein werbebeitrag war ^^
     
  12. #11 Bâshgob, 11.05.2009
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    Das Taxi kommt gepflegte 2 Jahre zu spät. OP geglückt, Patient tot.
     
  13. #12 sarpedon, 02.06.2009
    sarpedon

    sarpedon Grünschnabel

    Dabei seit:
    30.11.2008
    Beiträge:
    1
    Zustimmungen:
    0
    Du musst smbfs nachinstallieren

    Unter debian/ubuntu sudo apt-get install smbfs

    sarpedon
     
  14. seim

    seim seim oder nicht seim?

    Dabei seit:
    08.09.2006
    Beiträge:
    909
    Zustimmungen:
    0
    Ort:
    /mnt/reallife
    Weil dieser Thread wohl erstes Suchergebnis bei Google ist: "Samba mount"

    --------

    Um als User eine Sambafreigabe zu mounten kommt man nicht um sudo oder das UserID Bit herum (wird per chmod gesetzt - folglich wird diese Datei immer mit root rechten aufgerufen).

    Es gibt nun zwei Möglichkeiten:

    Code:
    mount -t smbfs //192.168.13.37/freigabename /mnt/sambafreigabe01 -o username=user,password=geheim,uid=root,rw
    Code:
    smbmount //192.168.13.37/freigabename /mnt/sambafreigabe01 -o username=user,password=geheim,uid=root,rw
    Das hat natürlich den ultimativen Nachteil, dass sich heuer Loginpasswort in der History der Shell verewigt und ihr jederzeit per "Pfeil nach oben" euer PW nochmal anschauen könnt - wie man das unterbindet habe ich noch nicht rausbekommen.

    Mit der UID=root Option setzt ihr den User dem der mount gehören soll, der der Owner von allen Dateien und Verzeichnissen der Freigabe werden wird nachdem sie gemountet ist.
    Statt dem "rw" (read,write) kann man auch "ro" (read only) hinschreiben - was das bewirkt habe ich noch nicht rausbekommen können :))
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. daboss

    daboss Keine Macht für niemand!

    Dabei seit:
    05.01.2007
    Beiträge:
    1.294
    Zustimmungen:
    0
    Ort:
    sydney.australia.world
    Es reicht die UID des Benutzers, der das share einbindet, bzw. auf den die Freigabe "zugelassen" ist.

    Aber jetzt ist langsam genug zerfleddert :D (Kommt aber irgendwie schon recht häufig vor, in letzter Zeit, hab ich das Gefühl...)
     
  17. seim

    seim seim oder nicht seim?

    Dabei seit:
    08.09.2006
    Beiträge:
    909
    Zustimmungen:
    0
    Ort:
    /mnt/reallife
    Weil's bei Google nich steht :P

    Die Sache wie ich mein Passwort nicht in der Shell eintippen muss wäre aber schon ne schöne Sache :D
     
Thema:

Samba-Mount??