[SAMBA] Lange Zugriffszeiten auf Share von XP aus

Dieses Thema im Forum "Samba" wurde erstellt von benwei, 11.07.2007.

  1. #1 benwei, 11.07.2007
    Zuletzt bearbeitet: 11.07.2007
    benwei

    benwei Grünschnabel

    Dabei seit:
    10.07.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo zusammen,

    erster Beitrag, gleich mal großes Problem...

    Ich habe auf der Arbeit einen Samba-Server (3.0.24-r3, gentoo), der Homes für Benutzer in die Windows-Welt (XP, einige wenige 2000) bereitstellt. Der Connect zu diesen Netzlaufwerken ist extrem langsam (vom Absetzen der Verbindungsaufforderung bis zur Verbindung zwischen 10 und 30 Sekunden). Sobald die Verbindung aufgebaut ist, kann man da auch normal mit arbeiten, solange mal keine große Idle-Time aufkommen lässt. Lasse ich das Laufwerk im Hintergrund liegen, auch ohne geöffneten Explorer, so legt sich beim Wiederaufruf des Laufwerks unter Windows selbiger lahm (für ebenfalls 10 - 30 Sekunden). Dieser Effekt tritt unterschiedlich auf, mal sofort nach Herstellen der Verbindung, manchmal erst nach mehreren Minuten. Im entsprechenden Logfile kann man sehen, dass nach einem undefinierten Zeitpunkt X die Verbindung abgebaut und dann bei Wiederaufruf eine neue Passwortabfrage gestartet wird.
    Die Authentifizierung läuft über Passwortserver der Windowsdomäne (Benutzer sind unter Linux identisch zu Windows), ebenso ist da ein WINS im Einsatz.

    Kann mir jemand helfen, das Problem in den Griff zu kriegen? Es ist zeitweise unmöglich, mit den Shares zu arbeiten, da der Explorer totliegt. Das Problem tritt auch mit dem Samba 3.0.20 unseres SLES9 auf, das Samba 2.2.0/2.2.1 der älteren SuSEs funktioniert hingegen einwandfrei. Netzwerklatenzen sind auch ok.

    smb.conf und ggf. Logfiles kann ich morgen posten.

    Hinzu kommt noch, dass im SWAT smbd und nmbd als inaktiv angezeigt werden, im System aber laufen.


    Bin über jeden Tip dankbar, da mir Google bisher nicht wirklich weiterhelfen konnte. Besten Dank schonmal! :hilfe2:

    EDIT:

    Hier die versprochene smb.conf...

    Code:
    # Samba config file created using SWAT
    # from 127.0.0.1 (127.0.0.1)
    # Date: 2007/07/10 18:51:38
    
    [global]
            workgroup = ARBEITSGRUPPE
            netbios name =
            server string = <hier steht der Rechnername>
            interfaces = eth3
            bind interfaces only = Yes
            security = SERVER
            map to guest = Bad User
            password server = <hier stehen drei Server-IPs>
            ntlm auth = No
            client NTLMv2 auth = Yes
            client lanman auth = No
            client plaintext auth = No
            log level = 3
            log file = /var/log/samba-log.%m
            defer sharing violations = No
            name resolve order = host lmhosts wins bcast
            use spnego = No
            load printers = No
            local master = No
            domain master = No
            wins server = <hier stehen drei Server-IPs>
            kernel oplocks = No
            ldap suffix = dc=example,dc=com
            ldap ssl = no
            winbind offline logon = Yes
            hosts allow = <hier steht ein Netzbereich>
    
    [homes]
            comment = Heimatverzeichnis
            read only = No
            create mask = 0640
            browseable = No
    
    
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Buchi

    Buchi Routinier

    Dabei seit:
    25.05.2006
    Beiträge:
    375
    Zustimmungen:
    0
    Ort:
    Wien
    Hi,
    Vl. liegt es einfach an eurem Netzwerk. Könnte ja sein´, dass das langsaam läuft.
    Oder hast du es unter nem Windowsrechner auch schon getestet?

    MfG,
    Buchi
     
  4. MrBoe

    MrBoe Routinier

    Dabei seit:
    13.06.2006
    Beiträge:
    399
    Zustimmungen:
    0
    Ort:
    braunschweig/nds/de/world
    Ich habe negative Erfahrungen gemacht mit der Sicherheits Option von Windows "Daten des sicheren Kanals verschlüsseln".
    Findest du unter Verwaltung-> lokale Sicherheitsrichtlinien -> Sicherheitsoptionen (so ähnlich, aus dem Kopf)
    Dort einfach die obige Option mit dem Wert "immer" deaktivieren.

    Probier das mal.
     
  5. NoXqs

    NoXqs Routinier

    Dabei seit:
    07.05.2007
    Beiträge:
    420
    Zustimmungen:
    0
    Ort:
    Bremen
    Versuche mal die workgroup des smb-servers an die des Passwort-Servers anzupassen, falls es geht.
    Wir hatten hier das selbe Problem und das war die Lösung.

    Code:
    workgroup = PC-Domain
    security = server
    
     
  6. #5 benwei, 11.07.2007
    Zuletzt bearbeitet: 11.07.2007
    benwei

    benwei Grünschnabel

    Dabei seit:
    10.07.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo und Danke für die Antworten.


    - Am Netzwerk liegt es augenscheinlich nicht, da es mit Samba 2.2.x einwandfrei funktioniert

    - Die Änderung der Windows-Einstellung hat keinen Effekt gehabt, zumindest ist mir keine Veränderung aufgefallen.

    - Auch die Änderung der Arbeitsgruppe bringt keinen Unterschied.

    Offensichtlich liegt das Problem aber nun doch beim Client, wenn man dem Logfile glauben darf:

    Code:
    
    [2007/07/11 11:05:28, 3] smbd/process.c:timeout_processing(1359)
      timeout_processing: End of file from client (client has disconnected).
    [2007/07/11 11:05:28, 3] smbd/sec_ctx.c:set_sec_ctx(241)
      setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
    [2007/07/11 11:05:28, 3] smbd/connection.c:yield_connection(69)
      Yielding connection to
    [2007/07/11 11:05:28, 3] smbd/server.c:exit_server_common(675)
      Server exit (normal exit)
    
    
     
  7. benwei

    benwei Grünschnabel

    Dabei seit:
    10.07.2007
    Beiträge:
    6
    Zustimmungen:
    0
    hmmmmm...

    das Ändern irgendeiner Option hat das Problem gelöst... ich weiß nur noch nicht, von welcher...

    Wenn ich es herausgefunden habe, teile ich Euch das mit. Vielen Dank für die Hilfe!
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

[SAMBA] Lange Zugriffszeiten auf Share von XP aus

Die Seite wird geladen...

[SAMBA] Lange Zugriffszeiten auf Share von XP aus - Ähnliche Themen

  1. [Samba] Probleme mit SymLinks und Mount

    [Samba] Probleme mit SymLinks und Mount: Hallo, ich bin gerade noch beim Neu Aufsetzen von meinem Homeserver (Arch Linux). Folgende Situation: Samba hab ich installiert und konfiguriert,...
  2. Unix Shell echo/ausgabe solange Bedingung ...

    Unix Shell echo/ausgabe solange Bedingung ...: Hallo liebe Unix User, da ich relativ neu bin, was Linux / Unix angeht stehe ich gerade komplett auf dem Schlauch! Problem: Aus mehreren...
  3. OpenVMS lebt länger

    OpenVMS lebt länger: Entgegen der ursprünglichen Befürchtung wird Hewlett-Packard (HP) das Betriebssystem OpenVMS noch eine Weile unterstützen. Allerdings nicht...
  4. Debian plant verlängerte Unterstützung

    Debian plant verlängerte Unterstützung: Das Debian-Sicherheitsteam traf sich jüngst im Linux-Hotel in Essen, um organisatorische Dinge zu klären. Dabei stand auch eine LTS-Version zur...
  5. Windows clients können nicht mehr auf lange laufendes System zugreifen

    Windows clients können nicht mehr auf lange laufendes System zugreifen: Dies ist mehr oder weniger eine Panik-Mail. Ein wenig ausführlicher, da ich nicht sicher bin, wo es schief gelaufen ist. Ich arbeite derzeit in...