Samba 3.0 (Ldap, Bind) - Leere Netzwekumgebung

Dieses Thema im Forum "Samba" wurde erstellt von emile8, 27.10.2008.

  1. emile8

    emile8 Grünschnabel

    Dabei seit:
    27.10.2008
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo Zusammen,

    ich habe von SuSE 9.3 auf SuSE Enterprise Server 10 SP2 updaten wollen, wobei die Konfigurationsdatei von Samba, Ldap und Bind teilweise übernommen wurden. Der Samba agiert wie bisher als PDC im intranet und als wins server. Die Samba-Authentikation erfolgt über Ldap. Der Name services (DNS) bzw. hosts (PCs, Servers) sind auch in ldap gepflegt.

    Es sieht aus, dass alles funktioniert :
    + Benutzer können sich an Domain an melden.
    + Alle Shares und Rechte funktioniert
    + nslookup laüft.
    + Alle PCs im Netz sind erreichbar über Netbios und ping

    Mit der Befehlt "getent passwd" und "getent group" sind alle Benutzer, Maschinenname und Gruppen sind verfügbar

    Nur unter Windows XP - Netzwerkumgebung sind keine nur der Domainname angezeigt, sonst keine PCs und Samba server.

    Mit dem Tool nbtstat -a pdc-server sind Netbios-Namentabelle korrekt aufgelistet.

    Auf dem Samba server der Befehl : "smbclient -L pdc-server -U%" liefert nur die shares, aber kein Server , Workgroup und Master.

    Ich habe die wins.dat und browse.dat (/var/log/samba/locks) gepfüft, alle vorhandende PCs und Server sind eingetragen.

    Im /etc/nsswitch.conf sind folgendes eingetragen:

    passwd: compat
    group: compat
    passwd_compat: ldap
    group_compat: ldap
    hosts: files dns
    networks: files dns
    ...

    In ldap-log und log.smbd, log.nmbd sind keine Fehlermeldungen vorhanden. (samba hat log level 3 und ldap -1 für debug).

    Benutzer- und Maschinen-Aufnehmen über smbldap-tools funktioniert einwandfrei.

    Ich habe meine Konfigurationsdateien geprüft, mit Hilfe der Doku "Samba in 21 Tagen" (http://www.64-bit.de/dokumentationen/netzwerk/b/001/25741-22.htm#TopOfPage). Es hat nichts geholfen. (auch mit offiizieller Doku)

    Im Google fand ich Hinweis über den Eintrag SETUPDUMMYDEV in rc.config (SUSE). Sein Wert soll auf NO gesetzt werden. Da SLES 10 solche Datei nicht hat, weiß ich nicht mehr wie es weiter geht. Seit über 10 Tage versuche ich das Problem zu lösen, aber kein Licht im Tunnel.

    Hat jemand Erfahrungen mit SLES bzw. mit solchen Problem gehabt ?

    Vielen Dank für euere Hilfe und Antwort

    Emile8
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 renderling, 27.10.2008
    renderling

    renderling Grünschnabel

    Dabei seit:
    27.10.2008
    Beiträge:
    2
    Zustimmungen:
    0
    spontan würde mich die Ausgabe von ipconfig /all Deines Windows Clients interessieren. ist sichergestellt das auf den clients keine firewall läuft?
    wins server manuell auf den clients in der tcp/ip konfig angeben ? welches Betriebssystem haben die clients ?
    vom Server aus zu den Clients ? Funktioniert das auch von Client zu Client? und von Client zu pdc? ist da ein Win2k.X Server im Lan ?
     
  4. emile8

    emile8 Grünschnabel

    Dabei seit:
    27.10.2008
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo

    hier ist die Ausgabe von ipconfig /all von XP-Client

    Windows-IP-Konfiguration

    Hostname. . . . . . . . . . . . . : fenja
    Primäres DNS-Suffix . . . . . . . : mydomain.com
    Knotentyp . . . . . . . . . . . . : Unbekannt
    IP-Routing aktiviert. . . . . . . : Nein
    WINS-Proxy aktiviert. . . . . . . : Nein
    DNS-Suffixsuchliste . . . . . . . : mydomain.com

    Ethernetadapter LAN-Verbindung:

    Verbindungsspezifisches DNS-Suffix:
    Beschreibung. . . . . . . . . . . : 3Com EtherLink XL 10/100 PCI für vol
    lständige PC-Verwaltung-NIC (3C905C-TX)
    Physikalische Adresse . . . . . . : 00-04-75-AC-57-F4
    DHCP aktiviert. . . . . . . . . . : Nein
    IP-Adresse. . . . . . . . . . . . : 194.195.223.62
    Subnetzmaske. . . . . . . . . . . : 255.255.255.0
    Standardgateway . . . . . . . . . :
    DNS-Server. . . . . . . . . . . . : 194.195.223.42

    Alle Clients sind XP-PCs.
    Auf Clients und dem Samba Server sind Firewalls abgeschaltet.
    Der Ping zwischen PCs und PCs zum Server funktioniert.
    Im Netz steht kein Windows 2000 server, sondern nur der Samba Server als PDC.

    Ich habe den Verdacht, daß bei SLES10 SP2 (=^ OpenSuSE 10.1) Samba die Netzwerkumgebung nicht bietet (Bug!). Da ich heute die Samba kurz ohne ldap, ohne DNS getestet habe, liefert Samba auch keine Netzwerkumgebung !

    Gruß
    Emile
     
Thema:

Samba 3.0 (Ldap, Bind) - Leere Netzwekumgebung

Die Seite wird geladen...

Samba 3.0 (Ldap, Bind) - Leere Netzwekumgebung - Ähnliche Themen

  1. Samba ActivDirectory (LDAP)

    Samba ActivDirectory (LDAP): Hallo alle zusammen, ich hoffe mal das es hier jemanden gibt der mir helfen kann :headup: Mein Problem ist folgendes: Ich möchte meine Anmeldung...
  2. Samba4 AD DC

    Samba4 AD DC: Hey Forum, das ist mein erster Post ich hoffe ich bin in der Richtigen section [IMG] Ich habe mit OpenSuSe 42.1 probiert einen Samba4 AD DC...
  3. Samba Active Directory SUBDOMAIN

    Samba Active Directory SUBDOMAIN: Hi, ich habe eine Samba Domäne ESC.LAN mit Samba 4.5 aufgebaut. Jetzt würde ich gern einen neuen Domänen AD im Tree MUNICH.ESC.LAN also eine...
  4. Wiederherstellen von überschriebenen Dokumenten auf debian samba

    Wiederherstellen von überschriebenen Dokumenten auf debian samba: Ich habe ein Problem. Vor Kurzem hat der Trojaner cryptologer einen Schaden eingerichtet. Glücklicherweise gab es eine Sicherung auf...
  5. SAMBA für Windows10 Domäne einrichten

    SAMBA für Windows10 Domäne einrichten: Hallo, ich habe letztes Wochenende verzweifelt versucht, Samba auf meinem Server einzurichten, daher versuche ich aktuell meinen Fehler zu...