Samba 2.x auf 3.x, mdb-Datenbank-Zugriff um Faktor 7 langsamer

Dieses Thema im Forum "Samba" wurde erstellt von hugossa, 04.06.2007.

  1. #1 hugossa, 04.06.2007
    hugossa

    hugossa Grünschnabel

    Dabei seit:
    04.06.2007
    Beiträge:
    2
    Zustimmungen:
    0
    Hi,
    Server von Samba 2.08a auf Samba 3.024 (jetzt Ubuntu 7.04) umgestellt.
    So bald ein zweiter WinXP-Client auf die mdb-Datenbank zugreift, erhöht sich die Zugriffszeit um Faktor 7.
    Vermutung Probleme mit Oplocks (ein/aus), hat sich nicht bestätigt. In WinXP ("OpLocksDisabled"=dword:00000001 ...) und in Samba Oplocks abgeschaltet. -> smb.conf mit den Parametern getestet. [lokal_Freigabe] "oplocks = no" und "level2 oplocks = no", haben keine Auswirkung auf die Zugriffszeit.
    Wer hat eine Idee?

    hugossa
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 hugossa, 08.06.2007
    hugossa

    hugossa Grünschnabel

    Dabei seit:
    04.06.2007
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo,
    das Problem konnte gelöst :)
    Verwendet Version Ubuntu 7.10, Samba 3.0.24:

    folgenden Wert setzen:
    [global]
    defer sharing violations = no

    Beschreibung:
    Windows erlaubt die Spezifizierung, wie eine Datei mit anderen Prozessen geteilt werden soll, wenn diese geöffnet ist. Sharing violations treten auf, wenn eine Datei von einem unterschiedlichen Prozeß mit Optionen geöffnet wurde, die die spezifizierten share-Einstellungen eines anderen Prozesses verletzen. Dieser Parameter veranlaßt smbd, sich wie ein Windows Server zu verhalten, und hält die sharing violation Fehlermeldung für eine Sekunde zurück, um dem Client in der Zwischenzeit die Möglichkeit zu geben, die Datei, die die Verletzung ausgelöst hat, zu schließen.

    Vorhanden ab Version 3.0.6

    Gruss hugossa
     
  4. BenjiX

    BenjiX Eroberer

    Dabei seit:
    13.04.2004
    Beiträge:
    55
    Zustimmungen:
    0
    Hi,
    ich hab ein ähnliches Problem,
    wenn ich eine Datei von meinem Samba-Server runterkopiere habe ich ca. 10 MB/s, wenn ich aber auf einen MDB zugreife maximal 5 MB/s.

    Hab auch schon die Option "defer sharing violations = no" gesetzt hat aber nichts gebracht!

    Habt ihr sonst noch ideen an was das liegen kann?

    Habe nen Samba 3.0.28a auf ner Ubuntu 8.04 Server Installation laufen.

    mfg Stefan
     
Thema:

Samba 2.x auf 3.x, mdb-Datenbank-Zugriff um Faktor 7 langsamer

Die Seite wird geladen...

Samba 2.x auf 3.x, mdb-Datenbank-Zugriff um Faktor 7 langsamer - Ähnliche Themen

  1. Samba4 AD DC

    Samba4 AD DC: Hey Forum, das ist mein erster Post ich hoffe ich bin in der Richtigen section [IMG] Ich habe mit OpenSuSe 42.1 probiert einen Samba4 AD DC...
  2. Samba Active Directory SUBDOMAIN

    Samba Active Directory SUBDOMAIN: Hi, ich habe eine Samba Domäne ESC.LAN mit Samba 4.5 aufgebaut. Jetzt würde ich gern einen neuen Domänen AD im Tree MUNICH.ESC.LAN also eine...
  3. Wiederherstellen von überschriebenen Dokumenten auf debian samba

    Wiederherstellen von überschriebenen Dokumenten auf debian samba: Ich habe ein Problem. Vor Kurzem hat der Trojaner cryptologer einen Schaden eingerichtet. Glücklicherweise gab es eine Sicherung auf...
  4. SAMBA für Windows10 Domäne einrichten

    SAMBA für Windows10 Domäne einrichten: Hallo, ich habe letztes Wochenende verzweifelt versucht, Samba auf meinem Server einzurichten, daher versuche ich aktuell meinen Fehler zu...
  5. Problem mit Win-Zugriff auf SAMBA

    Problem mit Win-Zugriff auf SAMBA: Hallo rundherum, vielleicht hat jemand eine Idee... Habe jetzt schon 1 1/2 Tage damit verbraten und den Fehler nicht gefunden. Problem:...